Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Na sua regra de content está assim: X-Cache: HIT ?

  2. Acho que vc esqueceu de configurar corretamente a guia advanced. É necessário que na célula CONTENT, vc coloque o seguinte:X-Cache: HIT. Se isso não for colocado lá, sua marcação do mangle não vai ter eficácia.

    Espero ter ajudado



  3. Verifique se em IP - DNS ta cadastrado os DNSs...

  4. Citação Postado originalmente por Andr0x Ver Post
    O NAT como está configurado. Já tentei marcar a caixa do LINK para ficar com a (!) ao lado, como o post do amigo datalinenet mostra, mas nada de funcionar.
    http://img363.imageshack.us/img363/1261/natas8.jpg

    Aqui como está configurado o MANGLE como mostra o video do amigo alexandrecorrea. Segui passo-a-passo, rigorosamente esse video q já me ajudou bastante nos outros servidores. Porém, aqui nao funciona. Note que abaixo fica DISABLED e nao consigo fazer como q ele fique Enabled. Nao sei se é bug ou estou fazendo algo de muito errado...
    http://img169.imageshack.us/img169/2441/mangletv0.jpg

    Nessa foto mostra algumas pessoas conectadas no Hotspot e abaixo a não comunicação com o Mangle.
    http://img169.imageshack.us/img169/4...tmangleko8.jpg





    Abaixo, segue a última...

    COLOCA ESSAS 2 REGRAS NO NAT QUE FUNCIONA .

    add chain=pre-hotspot in-interface=LINK protocol=tcp dst-port=80 hotspot=auth \
    action=redirect to-ports=3128 comment="Hots" disabled=no
    add chain=pre-hotspot in-interface=LOCAL src-address=192.168.102.0/24 \
    protocol=tcp dst-port=80 hotspot=auth action=redirect to-ports=3128 \
    comment="PROXY FULL" disabled=no

    E ESSAS DUAS NO QUEUE TREE

    add name="Squid-out" parent=global-out packet-mark=squid-hit limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="Squid-in" parent=global-in packet-mark=squid-hit-in limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no

    POSTA SE DEU CERTO FLW.



  5. Olha amigo,
    Crie as regras:

    /ip firewall nat
    add chain=dstnat action=redirect to-ports=3128 in-interface=!wan dst-port=80 protocol=tcp

    /ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=caching passthrough=yes out-interface=lan src-port=3128 protocol=tcp content=X-Cache: HIT

    add chain=output action=mark-packet new-packet-mark=cache passthrough=yes connection-mark=caching

    Dae é só criar a regra no /queue tree

    Deixe a opção do profile dos users do hotspot, Transparent Proxy, desmarcada, assim as regras dinamicas do hotspot não irão interferir no redir para o proxy.






Tópicos Similares

  1. Respostas: 9
    Último Post: 05-11-2010, 18:45
  2. Problema com cache full no mikrotik
    Por adenilso no fórum Redes
    Respostas: 6
    Último Post: 27-07-2009, 17:09
  3. Problemas com Hotspot + Web proxy com cache full
    Por Deltadigo no fórum Redes
    Respostas: 5
    Último Post: 16-06-2009, 00:29
  4. Ajuda com Cache Full MK em Cascata com Linux
    Por fnandoicatel no fórum Redes
    Respostas: 1
    Último Post: 18-02-2009, 17:36
  5. Problema com Cache Full (squid fora do mikrotik)
    Por tacianopinheiro no fórum Redes
    Respostas: 2
    Último Post: 07-07-2008, 19:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L