+ Responder ao Tópico



  1. #1

    Padrão [AJUDA]Problemas com cache full - Fotos postadas!!!

    Bem galera, a versao do meu ML é 2.9.27. O rádio é um Zinwell e está ligado a um Switch e este ligado a uma das placas do PC (3com) em que o MK está instalado. A outra placa, tb da marca 3com, está ligada diretamente ao modem que está em bridge. O MK disca a conexao e se conecta automaticamente. O servidor funciona no modo HOTSPOT.

    Seguindo os passos do video do alexandrecorrea, eu já fiz 3 servidores funcionar. Porém, com o mesmo problema. De tanto fazer e refazer o cache full, finalmente eu conseguia (isso nos OUTROS servidores anteriores a esse). Portanto, nesse novo servidor eu nao consegui de modo algum. Gostaria de saber o q estou fazendo de errado e sei que vcs entendem muito e poderao me ajudar.

    Obs.: o PC é um AMD athlon 2.6ghz com 1gb de ram e HD IDE 80gb.

    Abaixo seguem todas as fotos das configs do MK:

    Aqui está a INTERFACE
    http://img169.imageshack.us/img169/6...terfaceca9.jpg

    Aqui os IPs como estao configurados:
    http://img397.imageshack.us/img397/2...esslistne7.jpg

    Aqui o Web-Proxy rodando direitinho:
    http://img169.imageshack.us/img169/3430/webproxypg9.jpg



    Agradeço MUITO a vcs que me ajudam a desvendar esse "mistério". Minha opinião é que isso é um BUG da versao ou nao estou vendo o q faço de errado.

    Abraço, caro amigos.


    Abaixo seguem as outras figuras, pois nao consegui anexar todas no mesmo post

    http://img397.imageshack.us/my.php?i...esslistne7.jpg

  2. #2

    Padrão

    O NAT como está configurado. Já tentei marcar a caixa do LINK para ficar com a (!) ao lado, como o post do amigo datalinenet mostra, mas nada de funcionar.
    http://img363.imageshack.us/img363/1261/natas8.jpg

    Aqui como está configurado o MANGLE como mostra o video do amigo alexandrecorrea. Segui passo-a-passo, rigorosamente esse video q já me ajudou bastante nos outros servidores. Porém, aqui nao funciona. Note que abaixo fica DISABLED e nao consigo fazer como q ele fique Enabled. Nao sei se é bug ou estou fazendo algo de muito errado...
    http://img169.imageshack.us/img169/2441/mangletv0.jpg

    Nessa foto mostra algumas pessoas conectadas no Hotspot e abaixo a não comunicação com o Mangle.
    http://img169.imageshack.us/img169/4...tmangleko8.jpg





    Abaixo, segue a última...



  3. #3

    Padrão

    Aqui mostra a queue tree, essa regra eu deletei algumas vezes, pois sei q nao e necessario te-la para que o cache full funcione.
    http://img60.imageshack.us/img60/1575/queuetreehz8.jpg


    Obrigado, galera!!!

  4. #4



  5. #5

    Padrão

    Se você quizer posso ajudar. Estou no MSN [email protected]


    João Silva

  6. #6

    Padrão

    Na sua regra de content está assim: X-Cache: HIT ?



  7. #7

    Padrão

    Acho que vc esqueceu de configurar corretamente a guia advanced. É necessário que na célula CONTENT, vc coloque o seguinte:X-Cache: HIT. Se isso não for colocado lá, sua marcação do mangle não vai ter eficácia.

    Espero ter ajudado

  8. #8

    Padrão

    Verifique se em IP - DNS ta cadastrado os DNSs...



  9. #9

    Padrão

    Citação Postado originalmente por Andr0x Ver Post
    O NAT como está configurado. Já tentei marcar a caixa do LINK para ficar com a (!) ao lado, como o post do amigo datalinenet mostra, mas nada de funcionar.
    http://img363.imageshack.us/img363/1261/natas8.jpg

    Aqui como está configurado o MANGLE como mostra o video do amigo alexandrecorrea. Segui passo-a-passo, rigorosamente esse video q já me ajudou bastante nos outros servidores. Porém, aqui nao funciona. Note que abaixo fica DISABLED e nao consigo fazer como q ele fique Enabled. Nao sei se é bug ou estou fazendo algo de muito errado...
    http://img169.imageshack.us/img169/2441/mangletv0.jpg

    Nessa foto mostra algumas pessoas conectadas no Hotspot e abaixo a não comunicação com o Mangle.
    http://img169.imageshack.us/img169/4...tmangleko8.jpg





    Abaixo, segue a última...

    COLOCA ESSAS 2 REGRAS NO NAT QUE FUNCIONA .

    add chain=pre-hotspot in-interface=LINK protocol=tcp dst-port=80 hotspot=auth \
    action=redirect to-ports=3128 comment="Hots" disabled=no
    add chain=pre-hotspot in-interface=LOCAL src-address=192.168.102.0/24 \
    protocol=tcp dst-port=80 hotspot=auth action=redirect to-ports=3128 \
    comment="PROXY FULL" disabled=no

    E ESSAS DUAS NO QUEUE TREE

    add name="Squid-out" parent=global-out packet-mark=squid-hit limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="Squid-in" parent=global-in packet-mark=squid-hit-in limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no

    POSTA SE DEU CERTO FLW.

  10. #10

    Padrão

    Olha amigo,
    Crie as regras:

    /ip firewall nat
    add chain=dstnat action=redirect to-ports=3128 in-interface=!wan dst-port=80 protocol=tcp

    /ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=caching passthrough=yes out-interface=lan src-port=3128 protocol=tcp content=X-Cache: HIT

    add chain=output action=mark-packet new-packet-mark=cache passthrough=yes connection-mark=caching

    Dae é só criar a regra no /queue tree

    Deixe a opção do profile dos users do hotspot, Transparent Proxy, desmarcada, assim as regras dinamicas do hotspot não irão interferir no redir para o proxy.