+ Responder ao Tópico



  1. #1

    Padrão Como desconectar um cliente se a velocidade de conexão for baixa?

    Como fazer com que o mikrotik desconecte os clientes baseado na velocidade que ele está conectado no AP?

    Tenho feito testes usando usando a opção "data rates" mas ela só é válida para a velocidade de transmissão.

    Gostaria que desconectasse também caso a velocidade de recepção também esteja baixa.

    Dessa maneira o cliente seria desconectado e tentaria se conectar em outra antena com sinal mais forte.

    Obrigado!

  2. #2

    Padrão

    Kra tem isso no forum... só n me recordo onde !!
    mas tem tdo explicadim !!



  3. #3

    Padrão

    n sei se é bem isso que vc precisa vehuel, mas quando vc faz controle de acesso por mac é só ir na aba wireles > access list quando vc adiciona um novo mac, em signal strength vc pode definir o mínimo de sinal que o cliente necessita para se conectar ao seu MK ... aí vc ajusta de acordo com sua necessidade, creio que o ideal seria se todos clientes se conectassem pelo menos a -65dBm se estiver enganado me corrijam..

  4. #4

    Padrão

    Cara faz assim msm !!

    Mas tenho clientes com -80 funcionando perfeito, axo -65 complicado, pois eu tenho poucos clientes com este sinal...

    Axo um tanto bom e que o pessoal do forum recomenda setar em -75 dBm...

    Abraço !



  5. #5

    Padrão

    Tentei pela access list / connect list mas não obtive sucesso.

    Coloquei até ranges que o cliente não se enquadraria nunca e mesmo assim ele se conecta normalmente.

    Tentei por exemplo: 1..120 ou -120..-100

    Na verdade queria uma solução genérica. Qualquer cliente que tente se conectar e não esteja com sinal adequado teria o acesso negado mas se pela access list é a única solução eu usaria ela mesmo.

    Já vasculhei tudo aqui no forum e não encontrei nada que possa me ajudar.

    Uma dúvida, posso usar esse recurso com o meu ap configurado para o modo 'ap bridge'?

  6. #6

    Padrão

    Pelo que pesquisei a versão 2.9 não oferece esse recurso nativamente. Já a versão 3 oferece através da access list.

    Tentei pela access list e não obtive sucesso.

    Depois de revirar a internet de cabeça pra baixo achei o script disponível abaixo para a versão 2.9 e corrigi umas besteiras para funcionar na versão 3.

    No link tem as instruções de como utilizar, mas basicamente crie o script e um agende uma tarefa para ser executada em um intervalo de tempo determinado. Toda vez que o script for executado ele varre todos os clientes conectados e todos aqueles que tiverem com o sinal maior que o definido na variável wifithreshold serão adicionados na access list tendo sua permissão negada para acesso. Na próxima vez que o script for executado ele remove todos os banidos e scaneia novamente os conectados. Não é necessário usar o sinal de - (menos) ao informar o sinal.

    Versão 2.9.x: Disconnecting the users with bad signal [2.9.X] | human.network.web.id

    Versão 3:

    :log info "Monitor de Sinal. Iniciando..."
    :local wifithreshold 50
    :local aldisabled "no"
    :log info "Monitor de Sinal. Removendo clientes banidos";

    :foreach i in=[/interface wireless access-list find comment="Sinal fraco."] do={ /interface wireless access-list remove $i }

    :foreach i in=[/interface wireless registration-table find] do {

    :local csig [/interface wireless registration-table get $i signal-strength]

    :local cmac [/interface wireless registration-table get $i mac-address]

    :local cint [/interface wireless registration-table get $i interface]

    :local csigform [:pick $csig 1 3]

    :if ($csigform>$wifithreshold) do={

    /interface wireless access-list add mac-address=$cmac interface=$cint disabled=$aldisabled authentication="no" comment="Sinal fraco."

    }

    }
    Última edição por Vehuel; 12-09-2008 às 12:51.