Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por nexusbr Ver Post
    hum..
    entendi..

    agora eu tenho outra duvida..
    existe uma possibilidade de eu fazer um software para "liberar" acesso a um determinado ip.
    por exemplo, no software eu libero o ip 10.10.0.100 para acesso livre até as 14hs do dia 25/09, e quando da o tempo o programa bloqueia o ip novamente.

    tipo, todos os ips ficariam bloqueados, exceto os que eu liberar o acesso pelo software.
    é possível fazer isso com esse rb133?
    Você pode fazer isto no próprio mikrotik. Tecnologia: scripts; submenu: /system script e /system scheduler

    Veja o ex:
    Se você quer que o mac: 001122334455 de joao seje bloqueado as 8h da manhã e desbloqueado as 3h da tarde:

    Adicionar joao ao arp:
    /ip arp add address=192.168.0.2 mac-address=00:11:22:33:44:55 interface=clientes comment="joao"

    Criar o script para desativar o mac de joao:
    /system script add name="joao_desativar" policy=ftp,reboot,read,write,policy ,test,winbox source=/ip arp disable [/ip arp find comment="joao"]

    Criar o script para ativar o mac de joao:
    /system script add name="joao_ativar" policy=ftp,reboot,read,write,policy ,test,winbox source=/ip arp enable [/ip arp find comment="joao"]

    Criar o scheduler para o script ativar:
    /system scheduler add name="joao_ativar" on-event=joao_ativar start-date=jan/01/1970 start-time=15:00:00 interval=1d

    Criar o scheduler para o script desativar:
    /system scheduler add name="joao_desativa" on-event=joao_desativar start-date=jan/01/1970 start-time=08:00:00 interval=1d

    No caso ae, para desativar o mac de joão, foi usado o commentário "joao".

  2. Citação Postado originalmente por Mr. RG Ver Post
    Você pode fazer isto no próprio mikrotik. Tecnologia: scripts; submenu: /system script e /system scheduler

    Veja o ex:
    Se você quer que o mac: 001122334455 de joao seje bloqueado as 8h da manhã e desbloqueado as 3h da tarde:

    Adicionar joao ao arp:
    /ip arp add address=192.168.0.2 mac-address=00:11:22:33:44:55 interface=clientes comment="joao"

    Criar o script para desativar o mac de joao:
    /system script add name="joao_desativar" policy=ftp,reboot,read,write,policy ,test,winbox source=/ip arp disable [/ip arp find comment="joao"]

    Criar o script para ativar o mac de joao:
    /system script add name="joao_ativar" policy=ftp,reboot,read,write,policy ,test,winbox source=/ip arp enable [/ip arp find comment="joao"]

    Criar o scheduler para o script ativar:
    /system scheduler add name="joao_ativar" on-event=joao_ativar start-date=jan/01/1970 start-time=15:00:00 interval=1d

    Criar o scheduler para o script desativar:
    /system scheduler add name="joao_desativa" on-event=joao_desativar start-date=jan/01/1970 start-time=08:00:00 interval=1d

    No caso ae, para desativar o mac de joão, foi usado o commentário "joao".

    certo, assim é bem fácil, só que como vão ser os recepcionistas do hotel que vão liberar o "sinal", tem que ser algo mais simples, por isso eu mencionei fazer um software para realizar estas ações..
    pq ae o cara entra no software, vai em liberar acesso, e o sistema sozinho conecta la no mikrotik faz esses scripts, e retorna o número de ip válido para o dia em questão.

    talvez alguma coisa que conecte via ssh ou telnet..

    tipo, o administrador via windows dele (que esqueci o nome agora), é mais ou menos o que quero fazer, só que terá apenas uma função, ao invés de configurar todo o OS..



  3. Pode fazer com o delphi + telnet que é tranquilo.

  4. Só que para hotel, no teu caso, seria ideal usar o hotspot + user manager

    https://under-linux.org/forums/mikro...ot-artigo.html



  5. Sim consegue sim, tudo eh questão de configuração !






Tópicos Similares

  1. Duvida montando provedor
    Por marcosasjr no fórum Redes
    Respostas: 13
    Último Post: 16-06-2009, 11:51
  2. Duvida proxy provedor wireless
    Por fabianobazilio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 28-08-2008, 11:01
  3. Dúvidas Diversas Provedor
    Por srotaner no fórum Redes
    Respostas: 8
    Último Post: 12-12-2007, 14:20
  4. Dúvida: Projeto Provedor: kodama 2000 e myauth
    Por anarchist no fórum Redes
    Respostas: 3
    Último Post: 23-07-2007, 07:43
  5. Dúvida Sobre Provedor Internet, equipamento ISP normal e ISP
    Por glauberportella no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 13-08-2005, 03:16

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L