+ Responder ao Tópico



  1. #1
    eidt2008
    Visitante

    Padrão Mikrotik como AP bridge e servidor linux fazendo o proxy e cache

    Boa tarde, tenho a seguinte duvida:
    Tenho um mikrotik rodando como AP em bridge, ele tem uma placa de rede e uma wlan (d-link 520), e um servidor linux kurumin com squid fazendo o proxy transparente e o cache. A duvida é o seguinte, nos micros que tenho no escritorio que não passam pelo MK eu testei o cache fazendo o download de um arquivo e depois fiz o mesmo down em outro e foi rapidão. Mas ao fazer o mesmo down em uma maquina cliente que passa pelo MK ele baixa novamente o arquivo, isso quer dizer que não esta passando pelo proxy??.
    No servidor linux possuo duas palcas 3com, uma ligada ao modem (endereço do modem 10.1.1.1) como o endereço 10.1.1.2 e a outra com o ip da minha rede que é 192.168.0.1 fazendo o compartilhamento da internet para os clientes.
    No MK coloquei a ether e a wlan em bridge e setei o ip 192.168.0.3 e em firewal fiz o NAT, os clientes navegam, o controle de banda faço no MK mesmo com QUEUE simples, tudo funciona, mas o cache estou em duvidas, alguem pode me ajudar a esclarecer isso ou minha configuração esta errada. Agradeço desde já pela colaboração.

  2. #2

    Padrão

    O que está acontecendo é que o seu controle de banda que você está usando no MK está controlando até mesmo o conteúdo do cache squid, para resolver isso tem que usar um patch no Linux e usar o controle diretamente no Linux mesmo.



  3. #3
    eidt2008
    Visitante

    Padrão

    Como seria esse patch no linux, você se refere a usar um HTB ou um CBQ para controle de banda?

  4. #4

    Padrão

    Citação Postado originalmente por eidt2008 Ver Post
    Como seria esse patch no linux, você se refere a usar um HTB ou um CBQ para controle de banda?
    Isso mesmo, estou tentando usar aqui o patch, aqui eu já uso o HTB.



  5. #5

    Padrão

    Este patch que o amigo se refere é o ZPH (zero penality hit) no qual setando os valores adequados dos ToS, será possivel fazer o cache full usando o mikrotik + cache linux.

  6. #6

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Este patch que o amigo se refere é o ZPH (zero penality hit) no qual setando os valores adequados dos ToS, será possivel fazer o cache full usando o mikrotik + cache linux.
    Isso mesmo, estou brigando com ele aqui, ainda não tive sucesso.



  7. #7

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Isso mesmo, estou brigando com ele aqui, ainda não tive sucesso.
    Qual é a versão do mikrotik e do squid que você está usando?

  8. #8
    eidt2008
    Visitante

    Padrão

    Squid 2.6 e MK 2.927



  9. #9

    Padrão

    Use esta versão
    http://www.squid-cache.org/Versions/...TABLE16.tar.gz

    E baixe este patch

    squid-2.6.16-ToS_Hit_ToS_Preserve.patch

    No squid.conf use estas configs
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off
    zph_preserve_miss_tos on

    No mikrotik
    /ip firewall mangle add chain=postrouting tos=48 action=mark-packet new-packet-mark=proxy-hit passthrough=no

    /queue tree add name="pmark" parent=global-out packet-mark=proxy-hit limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

  10. #10

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Use esta versão
    http://www.squid-cache.org/Versions/...TABLE16.tar.gz

    E baixe este patch

    squid-2.6.16-ToS_Hit_ToS_Preserve.patch

    No squid.conf use estas configs
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off
    zph_preserve_miss_tos on

    No mikrotik
    /ip firewall mangle add chain=postrouting tos=48 action=mark-packet new-packet-mark=proxy-hit passthrough=no

    /queue tree add name="pmark" parent=global-out packet-mark=proxy-hit limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
    Você usou ai e deu certo, o que você achou? não força muito os radios?



  11. #11
    eidt2008
    Visitante

    Padrão

    Tem como eu aplicar o patch no squid que ja esta rodando e somente instalar o HTB, ou tenho mesmo que parar e remover esse que tenho e usar essa versão recomendada acima?

  12. #12

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Você usou ai e deu certo, o que você achou? não força muito os radios?
    Para você que está usanda a rede wireless, você deve setar o max-limit Para um valor adequado a sua estrutura.



  13. #13

    Padrão

    Citação Postado originalmente por eidt2008 Ver Post
    Tem como eu aplicar o patch no squid que ja esta rodando e somente instalar o HTB, ou tenho mesmo que parar e remover esse que tenho e usar essa versão recomendada acima?
    você pode usar outra versão (2.6) e outro patch também.

  14. #14
    eidt2008
    Visitante

    Padrão

    Não consegui aplicar o patch e nem instalar outra versão do squid no kurumin...pesquisei vario tutoriais, segui alguns mas porem sem exito algum, se alguem conseguiu instalar no kurumin e puder dar uma ajuda sera bem vindo.Obrigado



  15. #15

    Padrão

    Citação Postado originalmente por eidt2008 Ver Post
    Não consegui aplicar o patch e nem instalar outra versão do squid no kurumin...pesquisei vario tutoriais, segui alguns mas porem sem exito algum, se alguem conseguiu instalar no kurumin e puder dar uma ajuda sera bem vindo.Obrigado
    Use o debian amigo, instale os pacotes essenciais e instale o squid a partir da source.

  16. #16
    eidt2008
    Visitante

    Padrão

    Ok...irei instalar e depois posto os resultados...obrigado pela dica