+ Responder ao Tópico



  1. #1

    Padrão parent proxy e sarg

    pessoal to fazendo o parent proxy .. e no servidor de squid tenho sarg.
    como meu gtw é o mikrotik ele so aparece o ip do servidor mikrotik no caso 10.10.10.1.
    e meus clientes tao no ip 192.168.1.x
    teria como eu fazer chegar os ip dos clientes direto no squid ?

  2. #2

    Padrão

    Para que apareça o ip dos clientes, você precisa deixar o squid/linux como cliente mikrotik e usar um DNAT.



  3. #3

    Padrão

    certo no aso a mesma faixa de ip dos clientes..
    mas como ficaria esse dnat

  4. #4

    Padrão

    Isto você faz em /ip firewall nat

    Faça uma regra de accept vindo do endereço do squid/linux e outra redirecionando o tráfego da porta 80 para o squid/linux.

    Em firewall filter faça uma regra de accept para aceitar o redirecionamento.



  5. #5

    Padrão

    amigo disculpa mas fiquei zonzo..rsrs

    o esquema aki ta asim

    servidor mk 192.168.1.1
    servidor squid 192.168.1.200
    clientes 192.168.1.x

    meu nat para proxy
    chain=dstnat action=redirect to-ports=3126 protocol=tcp
    src-address=192.168.1.0/24 dst-address-list=!no-proxy
    in-interface=cliente dst-port=8

    meu proxy
    enabled: yes
    src-address: 0.0.0.0
    port: 3126
    parent-proxy: 192.168.1.200
    parent-proxy-port: 3128
    cache-drive: system
    cache-administrator: "jdprovedor"
    max-cache-size: none
    cache-on-disk: no
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 0s
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 0

    tem como se me da um exemplo das regras

  6. #6

    Padrão

    Da forma que estou falando não irá usar o proxy do mikrotik. Faça desta forma, pois irá redirecionar o tráfego da porta 80 e deixará passar o ip do linux:
    /ip firewall nat add chain=dstnat src-address=!192.168.1.200/32 protocol=tcp dst-port=80 in-interface=ether2 chain=dst-nat to-address=192.168.1.200 to-ports=3128

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 out-interface=ether2 action=src-nat to-addresses=192.168.0.1 to-port=0-65535

    /ip firewall filter add chain=forward src-address=192.168.1.0/24 dst-address=192.168.1.1 dst-port=3128 in-interface=ether2 out-interface=ether1 action=accept



  7. #7

    Padrão

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 out-interface=ether2 action=src-nat to-addresses=192.168.0.1 to-port=0-65535

    nun concigo fazer navegar. abre msn.. mas as paginas nao abre..
    o ethe2 pra vc é internet ou cliente ?

  8. #8
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Proxy Paralelo

    No meu apareceu Requisição Invalida



  9. #9

    Padrão

    Observem a configuração do squid. Mas como está a topologia da rede, placas no mikrotik, etc?

  10. #10

    Padrão

    no meu caso
    o router > mikrotik > squid e clientes
    a mesma placa que server os clientes esta o squid.



  11. #11

    Padrão

    Citação Postado originalmente por jdmano Ver Post
    no meu caso
    o router > mikrotik > squid e clientes
    a mesma placa que server os clientes esta o squid.
    Use apenas estas:

    /ip firewall nat add chain=dstnat src-address=!192.168.1.200/32 protocol=tcp dst-port=80 in-interface=ether2 chain=dst-nat to-address=192.168.1.200 to-ports=3128

    /ip firewall filter add chain=forward src-address=!192.168.1.200/32 dst-address=192.168.1.200 dst-port=3128 in-interface=ether2 out-interface=ether1 action=accept

  12. #12

    Padrão

    essas ether1 e o 2 qual seria a referencia ?

    eu anexei meu squid3.conf para vc ver.
    Arquivos Anexos Arquivos Anexos
    Última edição por jdmano; 08-10-2008 às 14:38.



  13. #13

    Padrão

    Citação Postado originalmente por jdmano Ver Post
    essas ether1 e o 2 qual seria a referencia ?

    eu anexei meu squid3.conf para vc ver.
    ether1 internet
    ether2 lan

  14. #14



  15. #15

    Padrão

    Citação Postado originalmente por minelli Ver Post
    No meu apareceu Requisição Invalida

    como vc resolveu... o meu deu requisição invalida tbm... fiz minhas conf baseadas nesse tudo
    http://www.vivaolinux.com.br/dica/Proxy-paralelo-MikroTik-com-ZPH

  16. #16

    Padrão

    vocês já liberaram os ip's no squid.conf ?

    Vejo que vocês estão usando mascara /30, na acl do squid não está liberado só um ip não ? Teria que liberar tudo, ou seja /24.

    Observem também a rota do servidor, use o comando ''router'' e veja as rotas como estão.

    Da uma olhada nesse site http://www.phpmania.org/modules.php?name=Guia_Foca_Debian_Basi_Inter&page=ch-rede.htm

    talvez ajude bastante.
    Última edição por Roberto21; 06-01-2009 às 12:57.



  17. #17