+ Responder ao Tópico



  1. #1

    Padrão Redirecionamento não está funcionando, me ajudem.

    Olá a todos os participantes ativos ou não.

    Segui as seguintes regras deste tópico que achei aqui mas não funciona de jeito nenhum.

    Meu servidor funciona assim:
    DSL => MK => APs => CLIENTES

    SENDO QUE O SERVIDOR DE HTTP ESTÁ COMPREENDIDO EM CLIENTES

    Visto desta forma vou mostrar o script

    / ip firewall address-list
    add list=bloqueio address=192.168.0.19 comment="" disabled=no
    / ip firewall nat
    add chain=srcnat out-interface=LINK action=masquerade comment="LIBERA O LINK" \
    disabled=no
    add chain=dstnat dst-address=!192.168.0.250 protocol=tcp dst-port=80 \
    src-address-list=bloqueio action=dst-nat to-addresses=192.168.0.250 \
    to-ports=81 comment="REDIRECIONA PARA CADASTRO" disabled=yes
    # oct/21/2008 12:13:09 by RouterOS 2.9.27
    # software id = J464-G1N
    #
    / ip firewall filter
    add chain=forward protocol=tcp dst-port=81 src-address-list=bloqueio \
    action=accept comment="" disabled=yes
    add chain=forward src-address-list=bloqueio action=drop comment="" \
    disabled=yes
    Mesmo assim não está redirecionando, o que pode estar errado??

    Fico grato a atenção de todos,
    Obrigado!!

  2. #2

    Padrão

    Dá uma estudada no firewall que vc vai ver que se vc ta passando o cliente pelo hotspot não adianta usar a tabela forward, pois com a instalação do hotspot ele cria e redireciona as tabelas padrões.
    Coloque all na visualização das tabelas que vc vai entender.
    Me corrijam os que sabem mais se eu estiver errado.



  3. #3

  4. #4

    Padrão

    eu não estou utilizando hotspot por enquanto, estou com dhcp.
    e MR. RG, desculpa, mas tb naum funfou o topico que vc me passou



  5. #5

    Padrão

    Está usando proxy? Se estiver observe se a regra está abaixo da regra de proxy.

  6. #6

    Padrão

    eu cheguei a tentar com proxy, mas nem com nem sem funcionoou
    nem acima nem abaixo da regra de proxy
    o que pode ser????



  7. #7

    Padrão

    Citação Postado originalmente por makkai Ver Post
    eu não estou utilizando hotspot por enquanto, estou com dhcp.
    e MR. RG, desculpa, mas tb naum funfou o topico que vc me passou
    o modem esta roteado ou bridge?
    tem q funcionar, nao tem o pq nao funcionar.

  8. #8

    Padrão

    Tente usar portas diferentes, tipo 8008, veja as regras de filter se não tem algo bloqueando.



  9. #9

  10. #10

    Padrão

    vou tentar ser mais especifico...

    | MODEM (BRIDGE)
    | PC MK 2.9.27 (1 ETHER = PPPOE PARA O MODEM / 2 ETHERS = BRIDGE)
    | SERVIDOR COM ROTEAMENTO + DHCP (SEM HOTSPOT E SEM PPPOE)

    ENLACE 5.8 PARA 4.3KM USANDO RB MK TODA EM BRIDGE
    | RB 433 MK 3.3
    | RB 133 MK 2.9.50

    | CLIENTES CABEADOS + SERVIDOR WEB (PORTA 81) - O SERVIDOR WEB FIKA DISTANTE DO SERVIDOR MK, PORÉM ESTA COMPREENDIDO NA REDE INTERNA.

    VOU DEIXAR AQUI OS DADOS DO MEU SERVIDOR PARA QUE ACESSEM E VISUALIZEM MELHOR O QUE EU NAO SOUBE EXPLICAR

    host: servidor.dyndns.pro
    login: demo
    senha: demo

    PS:
    CONSIGO COM A REGRA QUE DESCREVI NO INICIO DO POST APENAS DEIXAR O IP SEM NAVEGAÇÃO, MAS NADA ACONTECEU QUANTO AO REDIRECIONAMENTO
    Última edição por makkai; 25-10-2008 às 20:50.



  11. #11

    Padrão

    tire aquele ponto de interogação do dst host, pois ele significa "!not" não aplica a regra pro especificado.
    Outra coisa, não dst host, é src host que vc quer bloquear, são as chamadas syn que vc quer redirecionar.
    Ai vai funcionar blz.






    Citação Postado originalmente por makkai Ver Post
    vou tentar ser mais especifico...

    | MODEM (BRIDGE)
    | PC MK 2.9.27 (1 ETHER = PPPOE PARA O MODEM / 2 ETHERS = BRIDGE)
    | SERVIDOR COM ROTEAMENTO + DHCP (SEM HOTSPOT E SEM PPPOE)

    ENLACE 5.8 PARA 4.3KM USANDO RB MK TODA EM BRIDGE
    | RB 433 MK 3.3
    | RB 133 MK 2.9.50

    | CLIENTES CABEADOS + SERVIDOR WEB - O SERVIDOR WEB FIKA DISTANTE DO SERVIDOR MK, PORÉM ESTA COMPREENDIDO NA REDE INTERNA.

    VOU DEIXAR AQUI OS DADOS DO MEU SERVIDOR PARA QUE ACESSEM E VISUALIZEM MELHOR O QUE EU NAO SOUBE EXPLICAR

    host: servidor.dyndns.pro
    login: demo
    senha: demo

    PS:
    CONSIGO COM A REGRA QUE DESCREVI NO INICIO DO POST APENAS DEIXAR O IP SEM NAVEGAÇÃO, MAS NADA ACONTECEU QUANTO AO REDIRECIONAMENTO

  12. #12

    Padrão

    Desculpa, mas naum entendi, tentei aplicar com o pouco que havia entendido, mas deu no mesmo



  13. #13

    Padrão

    seguinte coloca o ip que vc quer bloquear, 192.200.210.201, no src address, não marca o ponto de interrogaçao.
    protocolo tcp, dst port 80. No action pode deixar como está. Outra coisa, arrasta a regra pra que ela fique primeiro que o o masquerade da rede.

  14. #14



  15. #15

    Padrão

    Faça com um jump:
    add chain=dstnat protocol=tcp dst-port=80 action=jump target=linux
    add chain=linux action=dst-nat to-address=ipdolinux to-ports=81

    Tente desta forma ae amigo.

  16. #16

    Padrão

    Me add no msn e conversamos a noite. [email protected].



    Citação Postado originalmente por makkai Ver Post
    infelizmente naum funcionou



  17. #17

    Padrão

    bom dia,
    tente mudar o MTU mais o MRU do ppoe para 1492,
    e tambem adicione esta regra no seu mangle, e ponha acima de todas...


    / ip firewall mangle
    add chain=forward out-interface=LINK protocol=tcp tcp-flags=syn \
    action=change-mss new-mss=1300 comment="msn, e navegaçao na Adsl" \
    disabled=no