Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por Raphael_suporte Ver Post
    pois é já estava estudando está alternativa...
    mudando o comando para

    tail arquivo > temp_file
    sleep xx
    grep 'log' temp_file

    acho que assim irá funcionar do jeito que preciso.

    na verdade estou usando uma maquina com o SUN_OS

    =================================================

    Bom funcionou bem do jeito que eu queria, muito obrigado pela atenção.
    Você pode combinar os dois comandos...
    tail arquivo | grep 'log'

  2. Obrigado pela intenção Magnun, mas no meu caso eu não posso usar juntos por causa do comando sleep entre os dois, eu sou obrigado a usar o sleep, para que dê tempo do log "pegar" o processo rodando...



  3. cara...

    se você explicar o que está tentando fazer talvez alguém consiga te ajudar, mas com informações limitadas você quer que as pessoas adivinhem?

  4. Citação Postado originalmente por Raphael_suporte Ver Post
    Obrigado pela intenção Magnun, mas no meu caso eu não posso usar juntos por causa do comando sleep entre os dois, eu sou obrigado a usar o sleep, para que dê tempo do log "pegar" o processo rodando...
    se o sleep é pra dar tempo do serviço subir o tail tem que estar depois do sleep...



  5. Luciano?? não entendi seu post, o problema já foi resolvido.. junto a solução que postei e Magnun é verdade no script está assim mesmo


    Código :
    Sleep 30
    tail arquivo > tempfile
    teste $(grep 'processo' tempfile)
    if [ -n $teste ]; then
        echo "$teste" 
    else
         echo "Não foi possivel iniciar o Serviço"
    fi
    read






Tópicos Similares

  1. script qmailstats do qmail
    Por marcelo0 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 25-08-2005, 09:35
  2. Menu Aplicações do Gnome sumiu depois do gdesklet
    Por esales no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-04-2005, 10:34
  3. Samba Pedindo senha mesmo depois do login
    Por Valterri no fórum Servidores de Rede
    Respostas: 4
    Último Post: 12-04-2005, 19:51
  4. KDE Trava Depois do Login
    Por black_burn no fórum Servidores de Rede
    Respostas: 9
    Último Post: 17-01-2005, 22:29
  5. Script depois do login
    Por osni_passos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-07-2003, 15:51

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L