+ Responder ao Tópico



  1. #1

    Padrão OpenDNS - promete deixar a internet mais rápida e segura

    Como podemos utilizar este serviço tão atrativo usando o MK.

    Teriamos que desativar o cache de dns no MK?
    Adicionar o dns deles 208.67.222.222 / 208.67.220.220?
    Como atualizar nosso ip no servico da opendns quando não temos ip fixo (adsl)?


    O OpenDNS é um DNS que promete deixar a internet mais rápida e segura. Quando abrimos uma página na internet, por exemplo, (www.exemplo.com.br) a internet reconhece a página como números (127.0.0.1) quando você digita o endereço da página no seu browser o computador chama automaticamente o DNS (Domain Name System) que procura pelo endereço da forma numérica e exibe a página que você está procurando. Imagine se nós tivéssemos que memorizar cada URL de forma numérica! O DNS nos poupa desse trabalho. O OpenDNS é mais seguro pois ele consegue identificar os sites que tentam fazer phish (sites falsos, que fazem uma cópia idêntica de sites de bancos, por exemplo, para roubarem número de contas, senhas e outras informações pessoais) informando ao usuário que a página não é confiável. O OpenDNS também corrige erros comuns de digitação do endereço da página. Ex: www.garotatpm.co Ops! Esqueci de digitar a letra “m”. Com o OpenDNS a página seria aberta sem nenhum problema, este erro é corrigido automaticamente. E se você tentar visitar um Web site que não carregue, em vez de ver a tela irritante do erro do browser, o OpenDNS te ajuda a achar o site que está procurando. OpenDNS não precisa ser instalado e é fácil de usar. E tudo isso Grátis!

    FONTE: Linkk - OpenDNS – Internet mais rápida
    Link's para leitura:

    OpenDNS, o DNS aberto
    Open DNS - aumenta velocidade Internet e protege contra Phishing - FórumGdH
    [Dicas-L] OpenDns
    OpenDNS - DNS gratuito e seguro! - Sedativo para a Mente..
    Acelerando sua conexão com Open DNS « Blog Etilico

  2. #2

    Padrão

    Amigo,

    Tanto no linux quanto no windows você pode forçar as maquinas para usarem o DNS que você quiser. Dessa forma sugiro você colocar no seu DHCP esses DNS's e depois para seus servidores nos arquivos de configuração você colocar esse DNS como padrão.

    abraços.



  3. #3

    Padrão

    E como faço para renovar automaticamente esta dns como faço no changeip.

  4. #4

    Padrão

    Olá!


    Não tem mistério, é só ir em IP-DNS-SETINGS e substituir os seus números DNS pelos números do openDNS.

    O DNS continuará funcionando do mesmo jeito, quando já tiver em cache ele solicita ao cache, quando não ao openDNS.



  5. #5

    Padrão

    E ai Dr. Roberto, tudo bom?


    Rapaz o que eu quero dizer é relacionado ao controle de navegacao que eles tem, onde voce adiciona seu ip e eles lhe ajudam com varias ferramentas:

    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         controle.JPG
Visualizações:	420
Tamanho: 	65,5 KB
ID:      	2958   Clique na imagem para uma versão maior

Nome:	         controle1.JPG
Visualizações:	277
Tamanho: 	19,1 KB
ID:      	2959  


  6. #6

    Padrão

    Olá!

    Pode retirar o DR., por que eu sou da ''galera''

    Rapaz, muito interessante isso, muito mesmo, vou avaliar agora a noite isso, por que em uma primeira olhada ví que ele faz o mesmo trabalho que o squid guard, ou bem parecido, você está certo, eu estou falando de outra coisa.

    Vou dar uma olhada, mas para quem ADSL precisaria de um scrip tipo ddns ou noip, vou dar uma lida hoje a noite e se eu achar alguma coisa de ''novo'' eu posto aqui pra gente.

    Vlw.



  7. #7

    Padrão

    Citação Postado originalmente por pitboyrn Ver Post
    Como podemos utilizar este serviço tão atrativo usando o MK.

    Teriamos que desativar o cache de dns no MK?
    Adicionar o dns deles 208.67.222.222 / 208.67.220.220?
    Como atualizar nosso ip no servico da opendns quando não temos ip fixo (adsl)?




    Link's para leitura:

    OpenDNS, o DNS aberto
    Open DNS - aumenta velocidade Internet e protege contra Phishing - FórumGdH
    [Dicas-L] OpenDns
    OpenDNS - DNS gratuito e seguro! - Sedativo para a Mente..
    Acelerando sua conexão com Open DNS « Blog Etilico
    Bom dia, amigo poderia me passar o endereço do topico do script para DNS dinamico para MK com ADSL?

    Ficarei grato pela ajuda.

  8. #8

    Padrão

    Citação Postado originalmente por gladstony Ver Post
    Bom dia, amigo poderia me passar o endereço do topico do script para DNS dinamico para MK com ADSL?

    Ficarei grato pela ajuda.
    BAIXE:
    script-pronto
    tutorial-ddns

    system - script-->

    NAME: IP
    POLYCE: Marque todas as opções

    Código HTML:
     
    SOURCE:
    :log info "DDNS: Begin"
    :global ddns-user "login (NOME DE USUARIO CADASTRADO NO CHANGEIP)"
    :global ddns-pass "senha DO USUARIO CADASTRADO NO CHANGEIP"
    :global ddns-host "NOME DO DOMINIO ESCOLHIDO NO CHANGEIP"
    :global ddns-interface "LINK DA INTERFACE PPOE DA DISCAGEM DO MIKROTIK ex:pppoe-out1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={ 
    :log info "DDNS: No change" 
    }
    }
    :log info "DDNS: End"
     
    "OK"

    Agora em

    system -scheduler-->

    NAME: IP
    START DATE: Jan/12/2007
    START TIME: 23:14:00
    INTERVAL: 00:01:00
    ON EVENT: /system script run IP
    COMMENT: RENOVA IP

    "OK"

    Agora esta programado para a cada 1 minuto sua dns seja renovada.


    by: Magrock



  9. #9

    Padrão

    Deveria haver diferença para melhor se cadastrar estes DNS?
    Eu estava usando outro dns e estava rápido. Quando coloquei 208.67.222.222 e 208.67.22.220 ficou muito lento.
    Ou este desempenho só vai aparecer quando usar o script?
    Voltei para o DNS antigo.

  10. #10

    Padrão

    Citação Postado originalmente por pitboyrn Ver Post
    BAIXE:
    script-pronto
    tutorial-ddns

    system - script-->

    NAME: IP
    POLYCE: Marque todas as opções

    Código HTML:
     
    SOURCE:
    :log info "DDNS: Begin"
    :global ddns-user "login (NOME DE USUARIO CADASTRADO NO CHANGEIP)"
    :global ddns-pass "senha DO USUARIO CADASTRADO NO CHANGEIP"
    :global ddns-host "NOME DO DOMINIO ESCOLHIDO NO CHANGEIP"
    :global ddns-interface "LINK DA INTERFACE PPOE DA DISCAGEM DO MIKROTIK ex:pppoe-out1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={ 
    :log info "DDNS: No change" 
    }
    }
    :log info "DDNS: End"
     
    "OK"

    Agora em

    system -scheduler-->

    NAME: IP
    START DATE: Jan/12/2007
    START TIME: 23:14:00
    INTERVAL: 00:01:00
    ON EVENT: /system script run IP
    COMMENT: RENOVA IP

    "OK"

    Agora esta programado para a cada 1 minuto sua dns seja renovada.


    by: Magrock

    Amigo, me diz uma coisa pra eu ficar aliviado, esse script caso eu tenha dificuldade em executar-lo ou mesmo executar de forma errada não terei problemas com meu server? Tipo ele esta redondo estavel, não ira deixar-lo com problemas e instabilidade?

    Abraço.



  11. #11

    Padrão

    Citação Postado originalmente por gladstony Ver Post
    Amigo, me diz uma coisa pra eu ficar aliviado, esse script caso eu tenha dificuldade em executar-lo ou mesmo executar de forma errada não terei problemas com meu server? Tipo ele esta redondo estavel, não ira deixar-lo com problemas e instabilidade?

    Abraço.

    Ta funcionando normal, sem nenhum problema.

  12. #12

    Padrão

    Olá!


    Andei pesquizando sobre o OPENDNS e ainda não existe um script para funcionar com o MK, pesquizei até no forum dos gringos, eles acham que a solução mais próxima é um redirecionamento do DDNS ou changeip para o openDNS.

    O serviço é realmente atraente, mas é necessário que se tenha ip fixo para usa-lo, no momento que tem ip dinâmico não dá pra usar não, ao menos com mikrotik, só da pra usar com o WINDOS SERVER, UNIX, MAC, e até com IPCOP, mas com o MK ainda não (com ip dinâmico).

    Mas por outro lado acho que é uma coisa que vai se resolver rapidinho, logo logo vai ter um script pronto para o MK trabalhar com OPENDNS.

    Agora, dá pra usar sim o DNS do openDNS, mas sem aproveitar completamentes os serviços agregados a ele.


    Espero ter ajudado.



  13. #13

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Olá!


    Agora, dá pra usar sim o DNS do openDNS, mas sem aproveitar completamentes os serviços agregados a ele.

    Espero ter ajudado.
    Tempos atrás eu usei e era muito rápido. Mas hoje não andou. Vou tentar outra hora.

  14. #14

    Padrão Dúvida na Configuração.

    Citação Postado originalmente por Roberto21 Ver Post
    Olá!


    Não tem mistério, é só ir em IP-DNS-SETINGS e substituir os seus números DNS pelos números do openDNS.

    O DNS continuará funcionando do mesmo jeito, quando já tiver em cache ele solicita ao cache, quando não ao openDNS.

    Roberto

    Boa Tarde!

    E quanto a:

    1. "Allow Remote Requestes" é para marca?

    2. Na aba Static tem tambem um sinal de + para adicionar o que?


    Abs

    Aprendiz!



  15. #15

    Padrão

    Alguem poderia me ajudar não conseguir de geito nenhum, aparece a seguinte mensagem:

    Could not fetch index from 189.81.221.226 (port 80): Not Found

    o status no site já está assim Account Status: Active

    Já tentei entrar até com meu IP válido e nao conseguir

    Assim que apertei em Run Script apareceu a hora em que cadastrei e nao apareceu nenhum erro
    e no Log apareceu:
    DDNS: Begin
    DDNS: No change
    DDNS: End

    Meu Mikrotik é a versão 2.9.27

    Script:

    :log info "DDNS: Begin"

    :global ddns-user "shark2net"
    :global ddns-pass "minha senha"
    :global ddns-host "shark2net.ServeUsers.com"
    :global ddns-interface "saida"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"