+ Responder ao Tópico



  1. olha so galera

    em outro topico conversando com o Raniel ele deu a seguinte dica:

    Citação:
    Postado Originalmente por Raniel https://under-linux.org/forums/image...s/viewpost.gif
    Para usar com o hotspot, faça o seguinte:
    Use regra de dnat (fiz um post no vivaolinux, mikrotik + squid 2.6).
    Não uso o Transparent proxy nos profiles dos users.
    Desta forma funciona tranquilamente.


    Raniel obrigado pela dica:

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    por favor esse ip 10.111.1.2 e o ip do debian ,modem ou dos clientes??

    minhas redes
    mk10.1.1.0/24
    debian 10.10.10.0/24
    modem 192.168.254.0/24


    resposta :

    Este ip 10.111.1.2, é do debian.
    A sua regra pode ficar assim:
    Código:
    /ip firewall nat add chain=dstnat action=dst-nat to-addresses=10.111.1.2 to-ports=3128 src-address=!10.111.1.2 dst-address=!10.111.1.2 dst-port=80 protocol=tcp

    no caso ficaria assim:

    /ip firewall nat add chain=dstnat src-address=10.10.10.11 dst-address=10.10.10.11 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=
    10.10.10.11 to-ports=3128

    aki olink para o viva o linux
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]

    aki so a parte da regra com o dnat

    Configurando o mikrotik

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    Configuração de firewall mangle:

    /ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT

    /ip firewall mangle chain=forward action=mark-packet new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits

    /ip firewall mangle chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes tos=48

    /ip firewall mangle chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits


    Queue tree:

    /queue tree add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=0 queue=default priority=8 max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s

    /queue tree add 27 name="cache" parent=global-out packet-mark=cache-hits limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    vamos testar

    vou postar os resultados assim q tiver um parecer

    abraços

  2. Citação Postado originalmente por ivovid Ver Post
    olha so galera

    em outro topico conversando com o Raniel ele deu a seguinte dica:

    Citação:
    Postado Originalmente por Raniel https://under-linux.org/forums/image...s/viewpost.gif
    Para usar com o hotspot, faça o seguinte:
    Use regra de dnat (fiz um post no vivaolinux, mikrotik + squid 2.6).
    Não uso o Transparent proxy nos profiles dos users.
    Desta forma funciona tranquilamente.


    Raniel obrigado pela dica:

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    por favor esse ip 10.111.1.2 e o ip do debian ,modem ou dos clientes??

    minhas redes
    mk10.1.1.0/24
    debian 10.10.10.0/24
    modem 192.168.254.0/24


    resposta :

    Este ip 10.111.1.2, é do debian.
    A sua regra pode ficar assim:
    Código:
    /ip firewall nat add chain=dstnat action=dst-nat to-addresses=10.111.1.2 to-ports=3128 src-address=!10.111.1.2 dst-address=!10.111.1.2 dst-port=80 protocol=tcp

    no caso ficaria assim:

    /ip firewall nat add chain=dstnat src-address=10.10.10.11 dst-address=10.10.10.11 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=
    10.10.10.11 to-ports=3128

    aki olink para o viva o linux
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]

    aki so a parte da regra com o dnat

    Configurando o mikrotik

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    Configuração de firewall mangle:

    /ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT

    /ip firewall mangle chain=forward action=mark-packet new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits

    /ip firewall mangle chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes tos=48

    /ip firewall mangle chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits


    Queue tree:

    /queue tree add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=0 queue=default priority=8 max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s

    /queue tree add 27 name="cache" parent=global-out packet-mark=cache-hits limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    vamos testar

    vou postar os resultados assim q tiver um parecer

    abraços

    pô naum deu certo

    as regras de nat deu certo porem as mangle e Queue tree naum deram

    qdo dou o comando pra executar da esse erro

    Terminal vt102 detected, using multiline input mode
    [admin@MikroTik] > ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passth
    rough=yes content=X-Cache: HIT
    no such command or directory (chain)
    [admin@MikroTik] >



  3. qual versao do mk vc esta usando
    dependendo muda o comando
    quando for assim vai fazendo pelo winbox
    e seguindo os passos
    ex:
    /ip firewall nat
    add
    chain=srcnat

    entendeu? so q vc vai pelo winbox vai achar td... as vezes a parte de TOS esta entre parenteses e a variavel esta com outro nome..

  4. Citação Postado originalmente por stevens144 Ver Post
    qual versao do mk vc esta usando
    dependendo muda o comando
    quando for assim vai fazendo pelo winbox
    e seguindo os passos
    ex:
    /ip firewall nat
    add
    chain=srcnat

    entendeu? so q vc vai pelo winbox vai achar td... as vezes a parte de TOS esta entre parenteses e a variavel esta com outro nome..

    valew a dica amigo + tentei via terminal depois via winbox mesmo assim
    + naum deu certo naum



  5. Citação Postado originalmente por wifiinternet Ver Post
    primero vc vai usar :

    1 Mikrotik (qualquer versão) funcionando 3 placas de redes (com a placa de rede que vai para a Debian (ip=192.168.10.1/30)
    1 Debian Com 1 placa de rede editado assim (ip=192.168.10.2/mask=255.255.255.255.252/gw q eo mikrotik=192.168.10.1)


    Essa regra e para o mikrotik conversar com a Debian

    Vá em Firewall, dentro da aba NAT, clique em + , na janela a seguir, na primeira aba chamada GENERAL, no campo CHAIN escolha a opção SRCNAT, na opção SRC. ADDRESS coloque 192.168.10.0/30, vá até a aba ACTION E selecione MASQUERADE.



    primeiro a rede vai ficar assim

    internet
    !
    Mikrotik------Debian
    !
    !
    clientes

    agora instale o squid3 e tbm se vc precisar ssh para acessar-lo na sua rede(preferencial)( #apt-get update ) eu uso o putty no windows
    (#apt-get install ssh )vou disponixar para download
    #apt-get update
    #apt-get install squid3

    der permissões as pastas do proxy

    #chmod 777 /var/spool/squid3
    #chmod 777 /var/log/squid3
    #chown proxy.proxy /var/spool/squid3
    #chown proxy.proxy /var/log/squid3


    agora vc tem que apagar seu squid.conf
    #rm -rf etc/squid3/squid.conf
    agora criar-lo
    #vi etc/squid3/squid.conf
    ou use o mcdit
    se tiver em modo grafico va em pelo gedit

    agora leia o squid.conf e altere de acordo com seus hardware e seus clientes e edite do sua preferencia


    #Squid.conf gerado por Adriano Soluções - Adriano Jorge Vitorino Melo Junior
    #Contato (82) 9909-3868
    #
    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128
    visible_hostname webproxy


    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid3/access.log

    #cache.log
    cache_log /var/log/squid3/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 80 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0

    #########################################################################################################
    qual quer duvida desse squid.conf pode falar .

    agora seu squid ta funcionado

    abra seu mikrotik vá em IP > WEB PROXY> SETTINGS

    port:3128
    parent proxy:192.168.10.2
    parent port proxy:5128
    cache driver:system
    cache adriministrador"sua preferencia"
    max. cache size:none
    max client conection :1000
    " server """""""" :1000

    Pronto, seu proxy tem comunicação com o mikrotik e está apto a atender clientes, vamos as configurações para que os clientes passem pelo proxy.

    Vamos supor que a rede que você tem configurada para seus clientes é 10.0.0.0/24 (cliente 1 = 10.0.0.2/24, cliente 2 =10.0.0.3/24 etc...), também vamos pegar o primeiro ip desta classe como o configurado em IP ADDRESS ou seja 10.0.0.1/24.

    Precisamos primeiro permitir que esta classe acesse o proxy:

    Vá em IP > WEB PROXY, na aba ACCESS clique em +, já janela seguinte adicione a classe 10.0.0.0/24 no campo SRC-ADDRESS, na opção action deixe em ALLOW.

    Agora vamos barrar qualquer outra classe para acesso ao proxy:

    Clique novamente no + e na deixe todos os campos como estão, somente altere a opção action para DENY.

    Precisamos agora direcionar todo o trafego da porta 80 para o proxy, vá em IP > FIREWALL > aba NAT clique em + e coloque exatamente como esta na imagem abaixo:
    http://www.vivaolinux.com.br/imagens...rect-proxy.JPG

    Nas imagens acima, na aba GENERAL temos um campo marcado com um [!] escrito IP VÁLIDO DO SEU SERVIDOR,no seu caso o ip daDebian 192.168.10.2 , troque esta mensagem pelo IP válido que você está utilizando nesta máquina e mantenha o [!], no campo interfaces, onde na imagem aparece REDE_8 troque pela interface que atende diretamente seus clientes (ex: ether3).

    Agora temos que bloquear o acesso externo ao proxy, esta regra é muito importante, clique na aba FILTER RULES e clique no +, coloque exatamente como na figura abaixo:http://www.vivaolinux.com.br/imagens...erno-proxy.JPG

    e esse vc estiver no mk 2.9.27 tem que clicar em !x!transparent proxy

    eu tenho 15 anos foi moleza fazer o proxy e pq começei um dias desses
    coloquei esse proxy em uma rede de 200 clientes com uns 100 clientes acessando simultaniamente

    qualquer duvida pode me adicionar (adrianobatalh@hotmail.com)

    qualquer duvida dou o suporte a todos do forum




    Bem bolado
    fiz aki com o debian
    depois coloquei o brazilfw 3.0
    nao notei diferença tao show de bola em paralelo

    uma dica No Maximum Object Size coloque 1
    pq assim ele nao vao fica gravando nada no hd do mikrotik
    o vem direto do squid achei mais rapido
    espero ter ajudado






Tópicos Similares

  1. Respostas: 12
    Último Post: 29-09-2012, 09:49
  2. Squid - lentidão em paralelo ao Mikrotik - direto ok
    Por rockeiromaiden no fórum Redes
    Respostas: 7
    Último Post: 29-10-2009, 19:16
  3. Respostas: 4
    Último Post: 14-07-2009, 08:37
  4. Respostas: 15
    Último Post: 07-05-2009, 10:29
  5. mikrotik + parent proxy squid
    Por jdmano no fórum Redes
    Respostas: 12
    Último Post: 08-04-2008, 20:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L