+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por brunocabrini Ver Post
    boa noite amigos, tenho uma pequena duvida.

    o link entra e sai do debian pela mesma placa de rede??

    sim e claro !!!!!

    e mt facio e so vc criar uma interface virtual tipo assim !!!

    eth0 a sua placa de rede normal esta assim correto ?

    pra vc add e mole mole

    e so vc fazer assim sua placa de rede e eth0 vc coloca : e o numero de rede virtual q vc quer fazer 1 ai eu vo criar uma assim

    ifconfig eth0:1 192.168.10.1 netmask 255.255.255.0 up

    entendeu ?

    ai vc crio uma interface virtual q vai sair pela msm placa de rede q entra o link da internet

    qual quer duvida posta ai !!!!!1





  2. #42

    Talking

    Amigo como eu faço para marcar os pacotes para o cache ficar full e repassar para os clientes como vc fez, qual é o procedimento? Se vc poder me explicar ficarei muito grato, estou começando agora nu lixux, squid, vlw irmão...



  3. #43

    Talking

    Amigo fiz tudo como vc explicou e funcionou blz, mas agora ele não acessa orkut, msn, e-mail e a pagina do globo.com fica sempre a primeira q eu acessei, como eu faço para corrigir isso? A eu ja coloquei as regras pra não fazer cache de paginas dinamicas e tal mas mesmo assim deu isso. valew pela ajuda irmão... Só não agradeço de novo pq o botão sumiu daki rsrsrsrs...

  4. #44

    Padrão

    Citação Postado originalmente por Rafael1929 Ver Post
    Amigo como eu faço para marcar os pacotes para o cache ficar full e repassar para os clientes como vc fez, qual é o procedimento? Se vc poder me explicar ficarei muito grato, estou começando agora nu lixux, squid, vlw irmão...

    Somos 3 ...... que esta começando no linux ... huahuahuahuahua

    mais vamos la vc quer marcar o pacotes que vem do cache ^^

    isso e mole

    primeiro vc esta squid em cascata com o Mk ?

    si for isso e so vc marcar o pacote da porta 80

    e outra qual versao de mk vc esta usando ?

    aki esta uma regrinha show

    / ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=superproxy passthrough=yes src-port=8080 protocol=tcp comment="SUPER-PROXY" disabled=no
    add chain=output action=mark-packet new-packet-mark=superproxy passthrough=yes connection-mark=superproxy comment="" disabled=no
    add chain=output action=return connection-mark=superproxy comment="" disabled=no

    8080 = essa e minha porta do squid mais vc pode usar qual vc preferir


    /queue simple
    add name="SUPER-PROXY" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=superproxy direction=both priority=3 \
    queue=default/default limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no


    / ip firewall nat
    add chain=dstnat dst-port=80 action=redirect to-ports=8080 comment="PROXY REDIRECTION" disabled=no

    qual quer coisa e so posta

    eu tenho outras aki show tbm ^^

    vlw abraços





    Última edição por cddteam; 06-01-2009 às 05:22.



  5. #45

    Padrão

    Citação Postado originalmente por Rafael1929 Ver Post
    Amigo fiz tudo como vc explicou e funcionou blz, mas agora ele não acessa orkut, msn, e-mail e a pagina do globo.com fica sempre a primeira q eu acessei, como eu faço para corrigir isso? A eu ja coloquei as regras pra não fazer cache de paginas dinamicas e tal mas mesmo assim deu isso. valew pela ajuda irmão... Só não agradeço de novo pq o botão sumiu daki rsrsrsrs...

    / ip firewall nat
    add chain=dstnat dst-address=207.46.0.0/16 protocol=tcp action=accept comment="regras estabiliza o MSN,Hotmail,Gmail e outros" disabled=no
    add chain=dstnat dst-address=64.4.0.0/16 protocol=tcp action=accept comment="" disabled=no
    add chain=dstnat dst-address=65.54.0.0/16 protocol=tcp action=accept comment="" disabled=no
    add chain=dstnat dst-address=207.68.128.0/18 action=accept comment="" disabled=no
    add chain=dstnat dst-address=64.4.0.0/18 action=accept comment="" disabled=no
    add chain=dstnat dst-address=213.199.144.0/20 action=accept comment="" disabled=no
    add chain=dstnat dst-address=65.52.0.0/14 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.208.0.0/20 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.249.150.0/26 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.167.67.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.179.42.29 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.249.84.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.201.173.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.201.174.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.220.254.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.217.233.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.172.181.0/24 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.141.204.0/24 action=accept comment="" disabled=no
    add chain=dstnat protocol=tcp dst-port=443 action=accept comment="ssl" disabled=no
    add chain=dstnat dst-address=200.201.0.0/16 action=accept comment="CEF" disabled=no
    add chain=dstnat src-address=200.155.0.0/16 action=accept comment="" disabled=no
    add chain=dstnat dst-address=200.141.204.0/24 action=accept comment="" disabled=no


    testa essas ai ve si funfa ^^

    vlw fui !!!



    Última edição por cddteam; 06-01-2009 às 05:20.

  6. #46

    Padrão

    Eu como sempre olhando a net axei perdido isso em um site

    -.-"

    e ai o site esplicando como vc visualiza o doc

    Abrindo arquivos docx no Internet Explorer
    Arquivos Anexos Arquivos Anexos
    Última edição por cddteam; 06-01-2009 às 21:16.



  7. #47

    Padrão duvida

    gente, to precisando de ajuda!!!

    Tenho um pequeno provedor e to precisando redirecionar as portas de 901 a 904, pois tenho um cliente que tem cameras de segurança no comercio dele, uso o mickrotik e gostaria da ajuda de alguem.

  8. #48

    Padrão topico errado amigo...

    Citação Postado originalmente por Elisio Ver Post
    gente, to precisando de ajuda!!!

    Tenho um pequeno provedor e to precisando redirecionar as portas de 901 a 904, pois tenho um cliente que tem cameras de segurança no comercio dele, uso o mickrotik e gostaria da ajuda de alguem.
    Voce postou no topico errado, mas é bem simpels veja:
    adicione em: ip firewall nat
    chain=dstnat protocol=tcp dst-port=901 action=dst-nat to-addresses=ip da maquina que esta com a camera to-ports=901

    chain=dstnat protocol=tcp dst-port=904 action=dst-nat to-addresses=ip da maquina que esta com a camera to-ports=904

    Esta liberando conexoes tcp, se for preciso faça as regras com o protocolo udp tambem

    chain=dstnat protocol=udp dst-port=901 action=dst-nat to-addresses=ip da maquina que esta com a camera to-ports=901

    chain=dstnat protocol=udp dst-port=904 action=dst-nat to-addresses=ip da maquina que esta com a camera to-ports=904

    Boa sorte.



  9. #49

    Padrão

    olá não entendi muito bem qual ip devo colocar em ! ip valido seria ex: 3º placa no mikritik 192.168.3.1 no debian 192.168.3.2 eu devo colocar o ip !192.168.3.2 seria isso essa parte ficou vago para mim ficarei grato com a ajuda dos caros colegas da under.

  10. #50

    Padrão sera q ta dando certo????

    seguinte ::

    fiz tudo como manda no tuto
    o debian ta instalado e o squid rodando

    as paginas tão sendo carregadas com mais rapidez

    baixei um aplicativo de 7Mb na minha maquina levou o tempo normal ( compativel com a velocidade)
    depois deletei o aplicativo dei um tempo e mandei baixar denovo qdo cliquei em salvar ele ja baixou no meu desktop, porem ,qdo vou em outra maquina e faço a mesma operação ele torna abaixar o arquivo da net

    sera q ta dando certo????

    tem como saber ????


    ps vou no MK e fico olhando o trafego das placas
    10.1.1.5 MK> dispara depois para
    10.1.1.6 minha placa > tempo todo ativa
    15.15.0.2 debian> dispara depois para



  11. #51

    Padrão

    Posta as configurações do seu squid e web-proxy para que possamos analisar. Esse aquivo de 7 mega que voce baixou se enquadra dentro do valor do maximum_object_size ? mostra mais detalhes, assim fica mais facil a galera ajudar.

  12. #52

    Padrão

    Citação Postado originalmente por Mirandapb Ver Post
    Posta as configurações do seu squid e web-proxy para que possamos analisar. Esse aquivo de 7 mega que voce baixou se enquadra dentro do valor do maximum_object_size ? mostra mais detalhes, assim fica mais facil a galera ajudar.

    desculpa mas naum estendi bem sua pergunta
    o .conf foi o q esta no tutorial e no mk foram as configuraçoes no NAT E FIREWALL

    no webproxy
    max-object-size=4096

    no squid
    cache_mem 32 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95


    desculpa



  13. #53

    Padrão

    Vou tentat ser mais claro, eu quiz dizer que se o tamanho de 7m fosse maior que o suportado(indicado) no cache do HD ae ele não iria mesmo pro cache, mas pelas conf do seu squid isto
    ja esta descartado pois voce setou em 512 m. Portanto voce deve continuar com a caça as bruxas. A proposito voce criou a pasta swap, com squid -z?

  14. #54

    Padrão

    Citação Postado originalmente por Mirandapb Ver Post
    Vou tentat ser mais claro, eu quiz dizer que se o tamanho de 7m fosse maior que o suportado(indicado) no cache do HD ae ele não iria mesmo pro cache, mas pelas conf do seu squid isto
    ja esta descartado pois voce setou em 512 m. Portanto voce deve continuar com a caça as bruxas. A proposito voce criou a pasta swap, com squid -z?

    webproxy:~# squid
    2009/02/04 07:45:44| Squid is already running! Process ID 2525
    webproxy:~# squid -z
    2009/02/04 07:46:01| Squid is already running! Process ID 2525

    webproxy:~#

    squid -z foi na instalação ( ne assim??)

    descula minha ignorancia ainda naum domino o debian mas vou fazer cursos esse ano espero aprender +
    Última edição por ivovid; 04-02-2009 às 12:20.



  15. #55

    Padrão

    Citação Postado originalmente por cddteam Ver Post
    Po eu esto entrandu agora no forum so novo no pedaço

    pow eu estava olhandu o topico esta maneiro show

    mais vcs estao e me deixandu loucos

    e tao facio kra

    eu fiz um bagulho doido aki um desenho xD

    e so vcs colocar um cabo crossover





    eu usei cabo direto mesmo... dependendo da plca de rede ela reconhece os dois modos de ligaçao sem problemas....

    fiquei 2 dias me matando aqui tentando fazer isso tudo funcionar, pois tava comentendo uns pequenos vacilos:
    1-o debian nao tava comunicando de jeito nenhum com mkt, reinstalei o debian umas 3 vezes, troquei placa de rede do mkt e nada, ate q resolvi testar a comunicaçao com outro pc e nada de pingar tb!! testei uma ponta crossover com imenda q tenho pra testes e nada! fui ver o cabo direito e tinha invertido o laranja e marron!!! eita vacilo meu!!!rs
    2-depois q consegui comunicar com o debian e instalei e configurei tudo o proxy nao tava passando de jeito nenhum, nada de trafego na interface do debiam.... revi as regras do web proxy varias vezes e reinstalei o squid dezena de vezes, e alterei todas as permissoes das pastas pra 777 e nada! fui rever a configuraçao no mk com calma e vi q tinha colocado pro proxy sair pela mesma porta de entrada, ao inves da interface dos clientes!!!! engraçado é q os clientes tavam navegando normal. santo vacilo!!!rs

    agora ta tudo de boa, funcionando 100%


    so to com umas duvidas:
    qdo desligo o debian, todos os clientes param, ate mesmo qdo vou no mk la no webproxy e mudo o estado de enable pra disable, os clientes nao navegam, porem todos pingam, como faço pra fazer os clientes voltarem a navegar qdo precisar desligar o debian? uma forma rapida, sem ter q desfazer todas as regras.

  16. #56

    Padrão

    Citação Postado originalmente por cddteam Ver Post
    Nao !!!!

    pra vc fazer ele ficar full e mole e so vc marcar os pacotes

    e repassar pros clientes a full !!!!

    eu pelo menos fiz isso aki



    ok abraços

    pode explicar isso melhor?
    queria q o cache saisse full, mas sai com o controle de banda do mkt q tenho para os clientes no queues com mk 2.9.27
    Última edição por lelyrock; 10-02-2009 às 12:10.



  17. #57

    Padrão

    Citação Postado originalmente por ivovid Ver Post
    seguinte ::

    fiz tudo como manda no tuto
    o debian ta instalado e o squid rodando

    as paginas tão sendo carregadas com mais rapidez

    baixei um aplicativo de 7Mb na minha maquina levou o tempo normal ( compativel com a velocidade)
    depois deletei o aplicativo dei um tempo e mandei baixar denovo qdo cliquei em salvar ele ja baixou no meu desktop, porem ,qdo vou em outra maquina e faço a mesma operação ele torna abaixar o arquivo da net

    sera q ta dando certo????

    tem como saber ????


    ps vou no MK e fico olhando o trafego das placas
    10.1.1.5 MK> dispara depois para
    10.1.1.6 minha placa > tempo todo ativa
    15.15.0.2 debian> dispara depois para

    pra testar se ta baixando a full vc tem q limpar o cache do IE ou do FIREFOX, se nao baixa a full mesmo, mas nao do cache do debiam, e sim do cache da propria maquina cliente

  18. #58

    Padrão

    Para os clientes voltarem a navegar quando vc desligar o debian é so desabilitar a regra de redirect do proxy na aba nat do mikrotik.

    Uma pergunta: vc colocou o sarg pra funcionar nesse debian que voce fez???


    Citação Postado originalmente por lelyrock Ver Post
    eu usei cabo direto mesmo... dependendo da plca de rede ela reconhece os dois modos de ligaçao sem problemas....

    fiquei 2 dias me matando aqui tentando fazer isso tudo funcionar, pois tava comentendo uns pequenos vacilos:
    1-o debian nao tava comunicando de jeito nenhum com mkt, reinstalei o debian umas 3 vezes, troquei placa de rede do mkt e nada, ate q resolvi testar a comunicaçao com outro pc e nada de pingar tb!! testei uma ponta crossover com imenda q tenho pra testes e nada! fui ver o cabo direito e tinha invertido o laranja e marron!!! eita vacilo meu!!!rs
    2-depois q consegui comunicar com o debian e instalei e configurei tudo o proxy nao tava passando de jeito nenhum, nada de trafego na interface do debiam.... revi as regras do web proxy varias vezes e reinstalei o squid dezena de vezes, e alterei todas as permissoes das pastas pra 777 e nada! fui rever a configuraçao no mk com calma e vi q tinha colocado pro proxy sair pela mesma porta de entrada, ao inves da interface dos clientes!!!! engraçado é q os clientes tavam navegando normal. santo vacilo!!!rs

    agora ta tudo de boa, funcionando 100%


    so to com umas duvidas:
    qdo desligo o debian, todos os clientes param, ate mesmo qdo vou no mk la no webproxy e mudo o estado de enable pra disable, os clientes nao navegam, porem todos pingam, como faço pra fazer os clientes voltarem a navegar qdo precisar desligar o debian? uma forma rapida, sem ter q desfazer todas as regras.



  19. #59

    Padrão

    Citação Postado originalmente por hideout Ver Post
    Para os clientes voltarem a navegar quando vc desligar o debian é so desabilitar a regra de redirect do proxy na aba nat do mikrotik.

    Uma pergunta: vc colocou o sarg pra funcionar nesse debian que voce fez???

    o sarg é pra ver o acesso q o squid ta tendo ne? ainda nao instalei nao, consegui colocar o squid pra funcionar ontem a noite (terça) e hj o dia foi bem corrido, nao deu pra ler direito sobre o sarg....
    procurei informaçoes sobre o uso do squid la no access.log mas achei as informaçoes muito vagas, mas ja q vc falou do sarg vou instala-lo
    ate entao tenho monitorado o uso da banda dele pelas interfaces e pelo queues (inclui ele no queues pra ver qtos mb tava passando por ele.

    uma coisa de achei estranho é o uso da memoria ram
    ta gastando pouca ram!! o sistema todo do debian ta gastando cerca de 150mb de ram. to ate estranhando
    todo mundo fala q consome muita memoria ram entao montei uma maquina com 3gb de ram.
    no tutorial fala pra reservar 40% da ram para o squid, coloquei 1300MB (que ate um pouco mais de 40%) e o tamanho maximo do arquino pra ficar na memoria ram de 256kb. sera q é normal mesmo?rs o cache no hd parece q ta pouco, cerca de 200mb sendo q ficou o dia inteiro funcionando, e pelo queues vi q entrou 650mb

    entao pelas contas entrou 650mb, 200mb foi pro HD e 150mb ficou na ram.... e o resto?rs

    pretendo desligar todos os dias a noite o debian e o mkt (esqueci de falar, uso isso numa lan house, e nao num provedor), sera q era melhor eu reduzir o tamanho do arquivo q ficara na ram q atualmente ta 256kb? se ficar dessa forma mesmo, acho q vou ate colocar o squid em uma maquina mais simples com menos ram.

    outra coisa q estranhei é o uso da ram do mikrotik, a maquina tem 256mb de ram e no final da tarde ja ta qse toda cheia, aumentando progressivamente durante o dia, se o proxy ta no debian, pq ta aumentando o consumo de ram no mikrotik?
    no meu mk tenho 256mb de ram, chegou a consumir 161mb (pico) e apos desligar o debian a memoria do mkt abaixou para 16mb (valor normal antes da instalaçao do proxy)
    uso a versao 2.9.27, e la no webproxy tem um campo q nao tem ai no tutorial do 3.x q é o "maximum object size" q por padrao tava 4096KiB e nao alterei, sera q ta fazendo cache tanto no MK qto no debian???? o "parente proxy" ta marcado para o 192.168.10.2


    ps. desculpe fazer tantas perguntas, mas é q sou novo nisso, e se puder me ajudar agradeço muito!
    Última edição por lelyrock; 10-02-2009 às 22:24.

  20. #60

    Padrão squid 2.7

    Citação Postado originalmente por wifiinternet Ver Post
    primero vc vai usar :

    1 Mikrotik (qualquer versão) funcionando 3 placas de redes (com a placa de rede que vai para a Debian (ip=192.168.10.1/30)
    1 Debian Com 1 placa de rede editado assim (ip=192.168.10.2/mask=255.255.255.255.252/gw q eo mikrotik=192.168.10.1)


    Essa regra e para o mikrotik conversar com a Debian

    Vá em Firewall, dentro da aba NAT, clique em + , na janela a seguir, na primeira aba chamada GENERAL, no campo CHAIN escolha a opção SRCNAT, na opção SRC. ADDRESS coloque 192.168.10.0/30, vá até a aba ACTION E selecione MASQUERADE.



    primeiro a rede vai ficar assim

    internet
    !
    Mikrotik------Debian
    !
    !
    clientes

    agora instale o squid3 e tbm se vc precisar ssh para acessar-lo na sua rede(preferencial)( #apt-get update ) eu uso o putty no windows
    (#apt-get install ssh )vou disponixar para download
    #apt-get update
    #apt-get install squid3

    der permissões as pastas do proxy

    #chmod 777 /var/spool/squid3
    #chmod 777 /var/log/squid3
    #chown proxy.proxy /var/spool/squid3
    #chown proxy.proxy /var/log/squid3


    agora vc tem que apagar seu squid.conf
    #rm -rf etc/squid3/squid.conf
    agora criar-lo
    #vi etc/squid3/squid.conf
    ou use o mcdit
    se tiver em modo grafico va em pelo gedit

    agora leia o squid.conf e altere de acordo com seus hardware e seus clientes e edite do sua preferencia


    #Squid.conf gerado por Adriano Soluções - Adriano Jorge Vitorino Melo Junior
    #Contato (82) 9909-3868
    #
    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128
    visible_hostname webproxy


    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid3/access.log

    #cache.log
    cache_log /var/log/squid3/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 80 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0

    #########################################################################################################
    qual quer duvida desse squid.conf pode falar .

    agora seu squid ta funcionado

    abra seu mikrotik vá em IP > WEB PROXY> SETTINGS

    port:3128
    parent proxy:192.168.10.2
    parent port proxy:5128
    cache driver:system
    cache adriministrador"sua preferencia"
    max. cache size:none
    max client conection :1000
    " server """""""" :1000

    Pronto, seu proxy tem comunicação com o mikrotik e está apto a atender clientes, vamos as configurações para que os clientes passem pelo proxy.

    Vamos supor que a rede que você tem configurada para seus clientes é 10.0.0.0/24 (cliente 1 = 10.0.0.2/24, cliente 2 =10.0.0.3/24 etc...), também vamos pegar o primeiro ip desta classe como o configurado em IP ADDRESS ou seja 10.0.0.1/24.

    Precisamos primeiro permitir que esta classe acesse o proxy:

    Vá em IP > WEB PROXY, na aba ACCESS clique em +, já janela seguinte adicione a classe 10.0.0.0/24 no campo SRC-ADDRESS, na opção action deixe em ALLOW.

    Agora vamos barrar qualquer outra classe para acesso ao proxy:

    Clique novamente no + e na deixe todos os campos como estão, somente altere a opção action para DENY.

    Precisamos agora direcionar todo o trafego da porta 80 para o proxy, vá em IP > FIREWALL > aba NAT clique em + e coloque exatamente como esta na imagem abaixo:
    http://www.vivaolinux.com.br/imagens...rect-proxy.JPG

    Nas imagens acima, na aba GENERAL temos um campo marcado com um [!] escrito IP VÁLIDO DO SEU SERVIDOR,no seu caso o ip daDebian 192.168.10.2 , troque esta mensagem pelo IP válido que você está utilizando nesta máquina e mantenha o [!], no campo interfaces, onde na imagem aparece REDE_8 troque pela interface que atende diretamente seus clientes (ex: ether3).

    Agora temos que bloquear o acesso externo ao proxy, esta regra é muito importante, clique na aba FILTER RULES e clique no +, coloque exatamente como na figura abaixo:http://www.vivaolinux.com.br/imagens...erno-proxy.JPG

    e esse vc estiver no mk 2.9.27 tem que clicar em !x!transparent proxy

    eu tenho 15 anos foi moleza fazer o proxy e pq começei um dias desses
    coloquei esse proxy em uma rede de 200 clientes com uns 100 clientes acessando simultaniamente

    qualquer duvida pode me adicionar ([email protected])

    qualquer duvida dou o suporte a todos do forum



    amigo por favor posso usar o
    Squid version 2.7


    vi q vc ta usando a versão 3.0

    vc ja tentou com essa versão??

    muito obrigdo