+ Responder ao Tópico



  1. #241

    Padrão re: Configurar BGP

    Estou na mesma que vc, conseguiu solucionar teu problema?

    Citação Postado originalmente por scnet Ver Post
    Prezados colegas,

    com a ajuda dos post consegui configurar meu BGP com 2 operadoras e tudo funcionando, mas estou com dificuldade em fazer o balanceamento.

    Operadora 1 = 20MB
    Operadora 2 = 40MB

    O que ocorre que a operadora 1 que possui link menor fica logo com o link full e a outra fica com um consumo semelhante ou seja, a operadora 1 lota e operadora 2 fica em 50% ou que deixa o acesso prejudicado.
    Abaixo estão as configurações caso alguem posso me dar alguma sugestão.

    /routing bgp instance

    set default as=53xxx client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=default \
    out-filter=AS_out2 redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=186.xx.112.1

    /routing bgp network

    add disabled=no network=186.xx.112.0/21 synchronize=no
    add disabled=no network=186.xxx.120.0/21 synchronize=no
    add disabled=no network=186.xxx.112.0/20 synchronize=no

    /routing bgp peer

    add address-families=ip comment="" disabled=no hold-time=3m in-filter=BOGONS instance=default interface=wan_1 multihop=\
    yes name=operadora_1 nexthop-choice=default out-filter=AS_out2 remote-address=200.xx.xxx.217 remote-as=14xxx \
    route-reflect=no tcp-md5-key="" ttl=255 update-source=loopback

    add address-families=ip comment="" disabled=no hold-time=3m in-filter=BOGONS instance=default multihop=yes name=operadora_2 \
    nexthop-choice=default out-filter=AS_out remote-address=189.75.xx.xx remote-as=81xx route-reflect=no tcp-md5-key="" \
    ttl=255 update-source="(unknown)"

    Filtro operadora 1

    add action=discard chain=AS_out2 comment="" disabled=no invert-match=no prefix=!186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=accept chain=AS_out2 comment=yes disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32 \
    set-bgp-local-pref=100 set-bgp-prepend=3 set-bgp-weight=20
    add action=passthrough chain=AS_out2 comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 set-bgp-local-pref=\
    100 set-bgp-prepend=3 set-bgp-weight=20
    add action=passthrough chain=AS_out2 comment="" disabled=no invert-match=no set-bgp-weight=20
    add action=discard bgp-as-path-length=!0-2 chain=AS_out2 comment="" disabled=no invert-match=no[/TABLE]
    filtro operadora 2

    add action=discard chain=AS_out comment="" disabled=no invert-match=no prefix=!186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=accept chain=AS_out comment=yes disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=passthrough chain=AS_out comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 protocol="" \
    set-bgp-weight=20
    add action=passthrough chain=AS_out comment="" disabled=no invert-match=no set-bgp-weight=20
    add action=discard bgp-as-path-length=!0-2 chain=AS_out comment="" disabled=no invert-match=no


    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no



    Li algo sobre anunciar uma parta da classe, como /21 para um link e o outro /21 para o outro link e assim dividir os clientes, como faço isso? é nos filters? qual seria a regra correta a ser colocada? o problema que me refiro está no download.

  2. #242

    Ingresso
    Sep 2005
    Localização
    Cascavel, Parana, Brazil, Brazil
    Posts
    41

    Padrão re: Configurar BGP

    É isso ai pessoal,

    para essa situação de se fazer o "balanceamento" de dois links de capacidades diferentes pode-se dividir o seu bloco e utilizar os filtros para anunciar menos blocos no link de capacidade menor.

    No meu caso que tenho um /21 e um /20, acabei quebrando o /21 em /24 e filtro esses anuncios para o link de maior capacidade, fazendo com que o mais específico neste caso seja pelo link menor.

    Assim consigo controlar manualmente o trafego do meu link menor.

    Se não estiver enganado segui essa dica do alexandrecorrea.

    att



  3. #243

    Padrão re: Configurar BGP

    Citação Postado originalmente por michellantunes Ver Post
    É isso ai pessoal,

    para essa situação de se fazer o "balanceamento" de dois links de capacidades diferentes pode-se dividir o seu bloco e utilizar os filtros para anunciar menos blocos no link de capacidade menor.

    No meu caso que tenho um /21 e um /20, acabei quebrando o /21 em /24 e filtro esses anuncios para o link de maior capacidade, fazendo com que o mais específico neste caso seja pelo link menor.

    Assim consigo controlar manualmente o trafego do meu link menor.

    Se não estiver enganado segui essa dica do alexandrecorrea.

    att
    Neste ponto está minha dúvida,,,, como aplicar estes filtros anunciando parte da classe numa operadora e parte em outra utilizando apenas um roteador mikrotik? Sei que também é necessário filtrar as rotas para que não sejam propagadas de uma instância para a outra. alguém teria um exemplo pratico para postar? agradeço a colaboração.

  4. #244

    Padrão re: Configurar BGP

    Citação Postado originalmente por scnet Ver Post
    Neste ponto está minha dúvida,,,, como aplicar estes filtros anunciando parte da classe numa operadora e parte em outra utilizando apenas um roteador mikrotik? Sei que também é necessário filtrar as rotas para que não sejam propagadas de uma instância para a outra. alguém teria um exemplo pratico para postar? agradeço a colaboração.
    Não precisa criar duas instâncias. Precisa é de filtros diferentes na saída de cada operadora para dar os anúncios respectivos.

    Fonte: ftp://ftp.registro.br/pub/gter/gter3...P-Mikrotik.pdf



  5. #245
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão re: Configurar BGP

    Pessoal, saiu o ASN e pegamos um bloco /21 aqui pra gente.
    Solicitei junto as operadoras para fecharmos o BGP ja, ficaram de me mandar os formularios.
    Tenho umas duvidas bobas pelo fato de nunca ter trabalhado com bgp.

    Como tenho 2 operadoras e os links são de tamanhos diferentes operadora A 35 mega e operadora B somente 10 mega, vi nesse post que poderia estar dividinho o bloco em partes menores para cada faixa sair por uma operadora, onde marco nos filtros para que por exemplo um /23 saia pela operadora B e o restante pela operadora A ? e mesmo uma delas caindo o outro bloco passe automaticamente para o que esta ativo ?

    Outra coisa, os filtros para nao publicar rotas invalidas são esses mesmo ou teria mais alguma coisa ?

    /routing filter add action=discard chain=AS_out comment="" disabled=no invert-match=no prefix=!187.1xx.xxx.0/20 prefix-length=32 set-bgp-weight=20 add action=accept chain=AS_out comment="yes" disabled=no invert-match=no prefix=187.1xx.xxx.0/20 prefix-length=32 set-bgp-weight=20 add action=passthrough chain=AS_out comment="" disabled=no invert-match=no prefix=187.1xx.xxx.0/20 set-bgp-weight=20 add action=passthrough chain=AS_out comment="" disabled=no invert-match=no set-bgp-weight=20 add action=discard bgp-as-path-length=!0-2 chain=AS_out comment="" disabled=no invert-match=no add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=187.19.96.0/21 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/0 prefix-length=27
    Alguem tem tambem algum exemplo de filtros para eu nao virar transito das operadoras ou isso nao tem nada a ver ?

    Ahh mais uma coisa, qual seria melhor eu ja pedir um Full-routing ou artial mesmo?
    Vou usar uma RB 1100 para este BGP que no caso só sera para o BGP mesmo e mandar os blocos divididos em /24 para cada pop e uma pequena parte para outros serviços.

    Para delegar o reverso tenho obrigatoriamente que possuir servidores dns ou posso estar contratando de alguma empresa para esta funçao ?

    Por enquanto são essas minhas duvidas, se eu ter mais alguma posto aqui novamente.


    Agradeço desde ja pelo belo topico.

    Abraços a todos.
    Última edição por edcomrocha; 02-08-2011 às 11:54.

  6. #246

    Padrão re: Configurar BGP

    Olá pessoal,

    Uma duvida creio que simples para quem ja tem BGP.

    Se fala em rota Full e Parcial onde o servidor recebe as rotas do outro provedor, sendo que o processamento neste periodo vai a 100%.. creio que isso é somente inicialmente apenas para armazenar as rotas...

    Vamos supor que após o recebimento das rotas esteje tudo funcionando, após meses precise reiniciar o servidor por qualquer motivo... o servidor irá receber todas as rotas novamente que elevara o processamento ou manterá o que ja recebeu?


    Aproveitando, quem voces podem indicar para configurar o servidor BGP, mande por MP.



    Anderson



  7. #247

    Padrão re: Configurar BGP

    vai receber as rotas novamente.. estas rotas ficam na memoria.. qualquer alteracao no bgp elas sao enviadas/recebidas novamente...

  8. #248

    Padrão re: Configurar BGP

    Citação Postado originalmente por alexandrecorrea Ver Post
    vai receber as rotas novamente.. estas rotas ficam na memoria.. qualquer alteracao no bgp elas sao enviadas/recebidas novamente...
    Olá Alexandre,

    Grato pela resposta.

    Voce conhece alguem que configure servidor BGP.


    Anderson



  9. #249

  10. #250

    Padrão re: Configurar BGP

    Citação Postado originalmente por alexandrecorrea Ver Post
    eu !!
    eheheheh

    Essa foi boa... descupa pessoal.



  11. #251

    Padrão re: Configurar BGP

    Opa!

    Porque o pessoal fala que precisa configurar uma interface loopback por BGP ?

  12. #252

    Padrão re: Configurar BGP

    para que se tenha uma interface 100% up (independente de ter ou nao link) evitando que seu bgp fique indo e vindo com algum problema em interface que nao esteja envolvida.. por ex:

    vc tem um router com 3 interfacess

    interface01 - operadora 01 - 200.200.200.0/30
    interface02 - operadora 02 - 200.100.200.0/30
    interface03 - rede interna - 189.0.0.1/24

    bom, voce fecha o bgp com o ip da interface03 ... se por algum motivo ela der problema.. seu bgp vai cair... mas se voce tivesse fechado usando loopback mesmo com a interface03 down, seu bgp se manteria UP ..


    esse é um dos N fatores...



  13. #253

    Padrão re: Configurar BGP

    Fiz ativação do BGP e deu tudo certo agora pra repassar os ips validos para os clientes não é mais nescessário netmap nem proxy-arp pra isso só jogar os ips validos no pool do pppoe ou direto no cadastro do cliente e era isso !? Facil assim !?


    Torres em bridge no momento clientes conectam via pppoe.

    Fiz teste aqui e foi facil assim.

  14. #254

    Padrão Re: Configurar BGP

    Tipo BGP esta ativo e os IPs sendo anuncioados estou recebendo cerca de 13 mil prefixos por PPPoE esta funcionando com IP publico e privado blz mas agora como faço para colocar IP publico nos clientes por rotas estaticas EX: se eu quiser atribuir para um cliente um bloco de 6 ips validos como faz ?

    Coloquei um IP publico na interface LAN onde vai pra os clientes mas não consigo nem pingar para esse ip e nem navegar usando ip publico se faço a mesma configuração com ip privado funciona blz.

    Fiz assim:
    LAN Clientes :200.70.66.8/29 IP publico a rota neste caso e criada automaticamente em routes.

    Minha maquina:
    LAN: 200.70.66.9
    GW: 200.70.66.8
    DNS 200.70.66.8

    neste caso nem consig pingar para gateway mas se fizer a mesma configuração com IP privado EX: 1.0.0.1/29 funciona blz.

    Pra estabelecer o BGP é necessario ter a rota default apontando para gateway da operadora ?

    Porque pelo que entendi lendo os posts ai se tiver a rota default do MK apontando para gateway da operadora a saida será pela operadora e não pelo BGP é isso mesmo ? No meu caso uso um IP fornecido pelo operadora apontando para gateway que eles me forneceram e o peer do BGP é este mesmo IP do gateway se desativo esses IP o BGP cai.



  15. #255

    Padrão Re: Configurar BGP

    Tive esse mesmo problema aqui se desativo a rota default alguma sites não acessam.

  16. #256

    Padrão Re: Configurar BGP

    O número total de rotas na Internet está chegando a quase 400 mil rotas, se você recebe apenas 13 mil, vai ter mesmo que colocar rota default.

    O peer BGP não deveria depender da rota default, e sim ou ser um IP diretamente conectado ou ter uma rota estática específica.



  17. #257

    Padrão Re: Configurar BGP

    Ele não depende mesmo eu que estava equivocado depois de ler e ler e fazer alguns testes entendi algumas coisa e outras ainda não.

    Tipo todo BGP parcial precisa de rota default ?

    No BGP parcial tudo sai pela rota default ?

    Criei a rota default assim 0.0.0.0/0 apontando para gateway da operadora isso mesmo ?

    Mas meu maior problema é que não consigo utilizar meus ips publicos com rotas estaticas pelo PPPoE funciona normal agora se coloco um IP valido na LAN onde conectam os clientes e tento usar um dos meui IPs publicos direto na interface do cliente usando como gateway o IP publico que coloquei na interface LAN não funciona de jeito nenhum.

    Vou colocar um EX supondo que estes IPs seriam publicos.

    MK
    LAN Clientes : 200.201.77.1/29

    Cliente

    IP - 200.201.77.2/29
    GW - 200.201.77.1
    DNS - 200.201.77.1

    Nessa configuração o cliente já deveria ter internet mas não funciona nem consigo pingar o gateway quando pinga da desntino inalcancavel.

    Se faço mesma config com um IP não privado qualquer EX 1.0.0.1/29 funciona blz mas ai é IP privado e não resolve meu problema.

  18. #258
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Configurar BGP

    Citação Postado originalmente por AlexTrevisol Ver Post
    Ele não depende mesmo eu que estava equivocado depois de ler e ler e fazer alguns testes entendi algumas coisa e outras ainda não.

    Tipo todo BGP parcial precisa de rota default ? Sim, porque você não recebe todas as rotas da internet, então para determinados caminhos você não iria sair, então precisa de uma default.

    No BGP parcial tudo sai pela rota default ? Depende da LOCAL PREFERENCE que as rotas recebidas da operadora tem. Por exemplo, digamos que você set as rotas recebidas com Local Preference 100, se você criar uma default como Local Preference 120, você nem precisaria das rotas da operadora, já que o roteador vai sempre preferir a rota com MAIOR Local Preference. Por outro lado, se você criar uma default com Local Preference 80, o roteador só vai usar a default quando não achar a rota recebida pela operadora.

    Criei a rota default assim 0.0.0.0/0 apontando para gateway da operadora isso mesmo ? Sim, mas o ideal é solicitar que a operadora envie a rota default por BGP, assim você pode manipulá-la com filtros.

    Obs.: O BGP Partial Routing não tem um número de rotas padrão. Cada operadora cria a sua política de partial routing. Por exemplo, é considerado partial routing:

    - Os prefixos gerados pela operadora.
    - Os prefixos dos clientes da operadora.
    - Os prefixos com até X AS_PATH's dos PTT's.
    - Os prefixos com até X AS_PATH dos upstreams das operadoras.

    E assim por diante, cada um escolhe a sua política.

    Qualquer dúvida é só gritar,

    Abraço



  19. #259

    Padrão Re: Configurar BGP

    AlexTrevisol,

    O que tem no seu zebra.conf e ospfd.conf ?

  20. #260

    Padrão Re: Configurar BGP

    Que arquivos são esses ?