+ Responder ao Tópico



  1. Estou na mesma que vc, conseguiu solucionar teu problema?

    Citação Postado originalmente por scnet Ver Post
    Prezados colegas,

    com a ajuda dos post consegui configurar meu BGP com 2 operadoras e tudo funcionando, mas estou com dificuldade em fazer o balanceamento.

    Operadora 1 = 20MB
    Operadora 2 = 40MB

    O que ocorre que a operadora 1 que possui link menor fica logo com o link full e a outra fica com um consumo semelhante ou seja, a operadora 1 lota e operadora 2 fica em 50% ou que deixa o acesso prejudicado.
    Abaixo estão as configurações caso alguem posso me dar alguma sugestão.

    /routing bgp instance

    set default as=53xxx client-to-client-reflection=no comment="" disabled=no ignore-as-path-len=no name=default \
    out-filter=AS_out2 redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=186.xx.112.1

    /routing bgp network

    add disabled=no network=186.xx.112.0/21 synchronize=no
    add disabled=no network=186.xxx.120.0/21 synchronize=no
    add disabled=no network=186.xxx.112.0/20 synchronize=no

    /routing bgp peer

    add address-families=ip comment="" disabled=no hold-time=3m in-filter=BOGONS instance=default interface=wan_1 multihop=\
    yes name=operadora_1 nexthop-choice=default out-filter=AS_out2 remote-address=200.xx.xxx.217 remote-as=14xxx \
    route-reflect=no tcp-md5-key="" ttl=255 update-source=loopback

    add address-families=ip comment="" disabled=no hold-time=3m in-filter=BOGONS instance=default multihop=yes name=operadora_2 \
    nexthop-choice=default out-filter=AS_out remote-address=189.75.xx.xx remote-as=81xx route-reflect=no tcp-md5-key="" \
    ttl=255 update-source="(unknown)"

    Filtro operadora 1

    add action=discard chain=AS_out2 comment="" disabled=no invert-match=no prefix=!186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=accept chain=AS_out2 comment=yes disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32 \
    set-bgp-local-pref=100 set-bgp-prepend=3 set-bgp-weight=20
    add action=passthrough chain=AS_out2 comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 set-bgp-local-pref=\
    100 set-bgp-prepend=3 set-bgp-weight=20
    add action=passthrough chain=AS_out2 comment="" disabled=no invert-match=no set-bgp-weight=20
    add action=discard bgp-as-path-length=!0-2 chain=AS_out2 comment="" disabled=no invert-match=no[/TABLE]
    filtro operadora 2

    add action=discard chain=AS_out comment="" disabled=no invert-match=no prefix=!186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=accept chain=AS_out comment=yes disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32 \
    set-bgp-weight=20
    add action=passthrough chain=AS_out comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 protocol="" \
    set-bgp-weight=20
    add action=passthrough chain=AS_out comment="" disabled=no invert-match=no set-bgp-weight=20
    add action=discard bgp-as-path-length=!0-2 chain=AS_out comment="" disabled=no invert-match=no


    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=186.xxx.112.0/20 prefix-length=32
    add action=discard chain=BOGONS comment="" disabled=no invert-match=no



    Li algo sobre anunciar uma parta da classe, como /21 para um link e o outro /21 para o outro link e assim dividir os clientes, como faço isso? é nos filters? qual seria a regra correta a ser colocada? o problema que me refiro está no download.

  2. É isso ai pessoal,

    para essa situação de se fazer o "balanceamento" de dois links de capacidades diferentes pode-se dividir o seu bloco e utilizar os filtros para anunciar menos blocos no link de capacidade menor.

    No meu caso que tenho um /21 e um /20, acabei quebrando o /21 em /24 e filtro esses anuncios para o link de maior capacidade, fazendo com que o mais específico neste caso seja pelo link menor.

    Assim consigo controlar manualmente o trafego do meu link menor.

    Se não estiver enganado segui essa dica do alexandrecorrea.

    att



  3. Citação Postado originalmente por michellantunes Ver Post
    É isso ai pessoal,

    para essa situação de se fazer o "balanceamento" de dois links de capacidades diferentes pode-se dividir o seu bloco e utilizar os filtros para anunciar menos blocos no link de capacidade menor.

    No meu caso que tenho um /21 e um /20, acabei quebrando o /21 em /24 e filtro esses anuncios para o link de maior capacidade, fazendo com que o mais específico neste caso seja pelo link menor.

    Assim consigo controlar manualmente o trafego do meu link menor.

    Se não estiver enganado segui essa dica do alexandrecorrea.

    att
    Neste ponto está minha dúvida,,,, como aplicar estes filtros anunciando parte da classe numa operadora e parte em outra utilizando apenas um roteador mikrotik? Sei que também é necessário filtrar as rotas para que não sejam propagadas de uma instância para a outra. alguém teria um exemplo pratico para postar? agradeço a colaboração.

  4. Citação Postado originalmente por scnet Ver Post
    Neste ponto está minha dúvida,,,, como aplicar estes filtros anunciando parte da classe numa operadora e parte em outra utilizando apenas um roteador mikrotik? Sei que também é necessário filtrar as rotas para que não sejam propagadas de uma instância para a outra. alguém teria um exemplo pratico para postar? agradeço a colaboração.
    Não precisa criar duas instâncias. Precisa é de filtros diferentes na saída de cada operadora para dar os anúncios respectivos.

    Fonte: ftp://ftp.registro.br/pub/gter/gter3...P-Mikrotik.pdf



  5. Pessoal, saiu o ASN e pegamos um bloco /21 aqui pra gente.
    Solicitei junto as operadoras para fecharmos o BGP ja, ficaram de me mandar os formularios.
    Tenho umas duvidas bobas pelo fato de nunca ter trabalhado com bgp.

    Como tenho 2 operadoras e os links são de tamanhos diferentes operadora A 35 mega e operadora B somente 10 mega, vi nesse post que poderia estar dividinho o bloco em partes menores para cada faixa sair por uma operadora, onde marco nos filtros para que por exemplo um /23 saia pela operadora B e o restante pela operadora A ? e mesmo uma delas caindo o outro bloco passe automaticamente para o que esta ativo ?

    Outra coisa, os filtros para nao publicar rotas invalidas são esses mesmo ou teria mais alguma coisa ?

    /routing filter add action=discard chain=AS_out comment="" disabled=no invert-match=no prefix=!187.1xx.xxx.0/20 prefix-length=32 set-bgp-weight=20 add action=accept chain=AS_out comment="yes" disabled=no invert-match=no prefix=187.1xx.xxx.0/20 prefix-length=32 set-bgp-weight=20 add action=passthrough chain=AS_out comment="" disabled=no invert-match=no prefix=187.1xx.xxx.0/20 set-bgp-weight=20 add action=passthrough chain=AS_out comment="" disabled=no invert-match=no set-bgp-weight=20 add action=discard bgp-as-path-length=!0-2 chain=AS_out comment="" disabled=no invert-match=no add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=187.19.96.0/21 prefix-length=32 add action=discard chain=BOGONS comment="" disabled=no invert-match=no prefix=0.0.0.0/0 prefix-length=27
    Alguem tem tambem algum exemplo de filtros para eu nao virar transito das operadoras ou isso nao tem nada a ver ?

    Ahh mais uma coisa, qual seria melhor eu ja pedir um Full-routing ou artial mesmo?
    Vou usar uma RB 1100 para este BGP que no caso só sera para o BGP mesmo e mandar os blocos divididos em /24 para cada pop e uma pequena parte para outros serviços.

    Para delegar o reverso tenho obrigatoriamente que possuir servidores dns ou posso estar contratando de alguma empresa para esta funçao ?

    Por enquanto são essas minhas duvidas, se eu ter mais alguma posto aqui novamente.


    Agradeço desde ja pelo belo topico.

    Abraços a todos.
    Última edição por edcomrocha; 02-08-2011 às 10:54.






Tópicos Similares

  1. configurar bgp - cisco 2800 series
    Por felix no fórum Cisco
    Respostas: 3
    Último Post: 18-01-2012, 08:58
  2. Como configurar BGP com uma operadora?
    Por Rador no fórum Redes
    Respostas: 3
    Último Post: 26-06-2011, 15:49
  3. Não consigo configurar firewall
    Por buosinet no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-11-2004, 19:09
  4. como configurar perl-5.6.1
    Por haysar no fórum Servidores de Rede
    Respostas: 1
    Último Post: 14-06-2002, 22:39
  5. Não consigo configurar firewall
    Por buosinet no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-03-2002, 21:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L