+ Responder ao Tópico



  1. Citação Postado originalmente por felipe57 Ver Post
    Valeu Gamineiro,

    Mas algumas duvidas

    1) Como vou manipular a rota default? Voce nao esta se referindo a pedir FULL Route para que eu possa manipular as rotas? Nao estou usando filtros pois a sessao BGP ainda nao esta no ar.

    2) Ok, vou usar o primeiro IP do meu AS como router ID e vou criar rotas nos meus roteadores de borda atuais para fazer peering com os roteadores das operadoras.

    Obrigado e Abraco
    Bom dia,

    Você vai manipular com filtros. Primeiramente você deve setar em todas as rotas recebidas o valor de local-preference com 100, o valor padrão já é 100, mas não aparece na lista de rotas, então com o filtro vai aparecer. (habilite a coluna BGP-Local-Pref)

    Se você quer que a rota default seja usada apenas quando não tiver uma rota para o destino solicitado, você atribui a rota default um valor MENOR de local-preference, 80 por exemplo. O roteador sempre vai preferir rotas com MAIOR local-preference.

    Ex.:

    /routing filter
    add action=passthrough chain=IN-FILTERS-ISP1 disabled=no invert-match=no prefix=0.0.0.0/0 prefix-length=0-32 set-bgp-local-pref=100
    add action=passthrough chain=IN-FILTERS-ISP1 disabled=no invert-match=no prefix=0.0.0.0/0 prefix-length=0 set-bgp-local-pref=80

    Você pode também criar a rota default MANUALMENTE, assim, observando os parâmetros em destaque.

    /ip routes
    dst-address=0.0.0.0/0 gateway=200.xxx.xxx.1 check-gateway=ping distance=20 bgp-local-pref=100

    distance=20 é para ficar com o mesmo valor das rotas recebidas por BGP.

    Vamos falando,
    Abraço

  2. Colegas, Sou novo em BGP. Já li um bocado e é um material muito interessante. Acabo de adquirir um ASN /20 e tenho 2 links (Embratel e OI). Pedi o roteamento para as operadoras e já estou recebendo full routing das duas. Até aqui, ótimo! Acontece que todos os pacotes estão saindo por uma só operadora, apesar de estarem voltando pelos dois links. Investigando o caso, vi que das duas entradas da mesma rota obtida das operadores, somente uma está com a flag de Ativo.
    Código :
     [admin@MikroTik] > /ip route  print detail where dst-address=208.64.248.0/21 
     0 ADb  dst-address=208.64.248.0/21 gateway=187.125.145.193 gateway-status=187.125.145.193 reachable OI distance=20 scope=40 target-scope=30 bgp-as-path="7738,8657,23342,32743" bgp-local-pref=200          bgp-atomic-aggregate=yes bgp-origin=igp received-from=oi_full  
     1  Db  dst-address=208.64.248.0/21 gateway=200.251.7.56 gateway-status=200.251.7.56 recursive via 200.253.132.81 EMBRATEL distance=20 scope=40 target-scope=30 bgp-as-path="4230,3356,23342,32743"          bgp-local-pref=200 bgp-atomic-aggregate=yes bgp-origin=igp bgp-communities=4230:1 received-from=embratel_full
    Este comportamento é normal? Se a rota ativa estiver inabilitada pela falta daquele link, a outra rota "levanta"? A minha intenção é chegar numa configuração de redundância e balanceamento. Grato



  3. Bom dia.

    Você não precisa de um Full Routing para apenas 2 upstreams, você está apenas aumento o processamento de seu roteador desnecessariamente.

    Você precisa de filtros para fazer o "balanceamento".

    Nos passe mais dados da configuração para podermos ajudar.

    Abraço

  4. Pessoal no caso de configurar BGP com interface loopback precisa solicitar informar pra operadora que se esta usando loopback pra configurar a sessão ?

    Uso da interface loopback para BGP não seria uma pratica normal !?



  5. Citação Postado originalmente por AlexTrevisol Ver Post
    Pessoal no caso de configurar BGP com interface loopback precisa solicitar informar pra operadora que se esta usando loopback pra configurar a sessão ?

    Uso da interface loopback para BGP não seria uma pratica normal !?
    Bo

    Boa tarde,

    Loopback para BGP é sim uma boa prática normal, mas apenas para iBGP, ou seja, quando você tem mais de 1 roteador que faz BGP na sua rede.

    Configurar uma interface de loopback serve para quando se tem mais de um caminho físico até um roteador, então você terá uma caminho de backup até o roteador, fazendo com que a sessão iBGP não caia.

    Muitas pessoas usam loopback para fechar a sessão com operadora, mas como só existe um caminho até a operadora, não tem porque fazer isso. O correto é fazer com o IP de transporte que a operadora te passar, normalmente um /30.

    Loopback apenas para roteamento INTERNO da rede.

    Abraço






Tópicos Similares

  1. configurar bgp - cisco 2800 series
    Por felix no fórum Cisco
    Respostas: 3
    Último Post: 18-01-2012, 08:58
  2. Como configurar BGP com uma operadora?
    Por Rador no fórum Redes
    Respostas: 3
    Último Post: 26-06-2011, 15:49
  3. Não consigo configurar firewall
    Por buosinet no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-11-2004, 19:09
  4. como configurar perl-5.6.1
    Por haysar no fórum Servidores de Rede
    Respostas: 1
    Último Post: 14-06-2002, 22:39
  5. Não consigo configurar firewall
    Por buosinet no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-03-2002, 21:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L