Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    [[email protected]:~$]: /usr/sbin/squid -v
    Squid Cache: Version 3.0.STABLE9

    [[email protected]:~$]: /usr/sbin/squid -v
    Squid Cache: Version 3.0.STABLE9

    iguaizinhas. Não houve upgrade, essa é a ultima versão disponivel.

    ##--> squid.conf (isso não deve ajudar muito, uma vez que nao foi alterado antes da "paralisia".

    http_port 128.0.11.5:3128 transparent
    visible_hostname Srv5
    #
    icp_port 0
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    acl apache rep_header Server ^Apache
    #broken_vary_encoding allow apache
    cache_mem 256 MB
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 5096 KB
    cache_dir ufs /var/spool/squid 512 128 256
    access_log /var/log/squid/access.log squid
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    pid_filename /var/run/squid.pid
    ftp_user [email protected]
    hosts_file /etc/hosts
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 # https
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    acl festa_do_kaki src "/etc/squid/regras/festa_do_kaki.txt"
    acl dom_permitidos dstdom_regex -i "/etc/squid/regras/url_permitidas.txt"
    acl ips_permitidos url_regex -i "/etc/squid/regras/ips_permitidos.txt"
    acl rede_interna src 128.0.0.0/16
    http_access deny !rede_interna
    http_access allow festa_do_kaki
    http_access allow dom_permitidos
    http_access allow ips_permitidos
    http_reply_access allow all
    icp_access allow all
    http_access deny all
    error_directory /usr/share/squid/errors/Portuguese
    coredump_dir /var/spool/squid
    high_page_fault_warning 0
    high_memory_warning 0

  2. #22
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão

    Irado... so por curiosidade.. vc ja tentou rodar o squid em outra porta ??? so pra fazer um teste ??



  3. #23
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Desculpe a intromissão num papo tão bom de vocês
    Massss, tenta instalar o squid 2.7. O squid 3.0 é uma implementação em C++, o 2.7 é o oficial (tanto é que o 2.7 já vem nativamente com o patch ZPH, o 3.0 não)

  4. #24

    Padrão

    Citação Postado originalmente por scorpion Ver Post
    Irado... so por curiosidade.. vc ja tentou rodar o squid em outra porta ??? so pra fazer um teste ??
    já sim.. não adiantou nada, continua congelado.



  5. #25

    Padrão

    Citação Postado originalmente por osmano807 Ver Post
    Desculpe a intromissão num papo tão bom de vocês
    Massss, tenta instalar o squid 2.7. O squid 3.0 é uma implementação em C++, o 2.7 é o oficial (tanto é que o 2.7 já vem nativamente com o patch ZPH, o 3.0 não)
    o original foi 2.7 - que foi o tal que congelou - rss..

    de qualquer forma, OFICIAL (conforme o site squid) é a versão 3-Stable10:
    squid : Optimising Web Delivery

    /me bem desconfiado que o problema seja o slack mesmo

  6. #26

    Padrão

    Irado,

    Eu já tive um problema semelhante no Debian 3.0. O problema é que eu não consegui depurar o problema porque o outro Admin reinstalou a máquina antes de qualquer coisa.

    Podemos fazer um teste meio "cabuloso"... rodar o squid com o strace e ver se ele está dando erro em alguma chamada para criação de socket ou algo parecido. A saída vai ficar gigantesca, mas...

    Outra coisa, já verificou se está sendo criando algum dump no /var/spool/squid ?



  7. #27

    Padrão

    bem.. fiz mais ou menos o que o seu colega fez: estou usando OUTRA maquina e OUTRO SO (CentOS), por via das dúvidas. Não dá, em termos de empresa, pra gente ficar sentado em cima de um problema. Nem fiquei traumatizado - rss - minha distro preferida é Slackware, mas isso não pode me prender, profissionalmente.

    Vou tentar reproduzir isso em casa - apesar de ambiente/maquina completamente diferentes.

    Obrigado a todos que ajudaram - pelo menos no apoio moral

  8. #28

    Padrão

    Puxa galera, eu uso o Myauth no slackware e tem um servidor meu que tá nessa mesma zica, inclusive estou a quase 1 semana sem squid, liberadão sem cache pra galera
    Já tentei de tudo, acredito que seja algum bug no slackware, ou algum tipo de vírus sei lá, pq eu formatei esse servidor a algum tempo qdo deu esse problema e não consegui resolver, aí assim que formatei funcionou um côco por várias semanas, aí de uma hora pra outra o disgramado parou denovo, eu usava a versão 10.2, agora depois que formatei coloquei a versão 12 mas o problema foi o mesmo.
    Acredito eu que seja o mesmo problema do tópico.
    Estive pensando em colocar outro servidor com o Debian só pra rodar o squid e apontar o antigo pra ele, o que vcs acham? andei lendo na net e com alguns amigos da facul e a galera disse que o Debian é um dos melhores para esse finalidade, o que vcs acham???

    Um abraço...



  9. #29

    Padrão

    eu, particularmente, não gosto da Debian, tive algumas péssimas experiencias com o apt-get update/upgrade - caiu em loop (rss).

    Como mencionei em outro post: troquei de maquina E de distribuição, fui para CentOS. Não foi uma escolha aleatória, então sugiro FORTEMENTE vc avaliar as caracteristicas dessa distribuição.