+ Responder ao Tópico



  1. #1

    Padrão Problema no pacote

    Galera eu atualizei toda a minha base de pacotes no debian, porem agora to com esse erro quando vo instalar um novo pacote

    Astrix:/downloads# dpkg -i havp_0.89-1_i386.deb
    dpkg: parse error, in file `/var/lib/dpkg/status' near line 8909 package `openoffice.org-core':
    `Conflicts' field, invalid package name `

    Ja tentei remover esse pacote mais num da certo oque eu faço ?

  2. #2

    Padrão

    Procurei algumas coisas, e li que poderia entrar no /var/lib/dpkg/status e apagar a linha que esta com problema fiz isso mais apresenta erro em outra linha agora, ou seja tem uma depencia, oque posso fazer mais ?



  3. #3

    Padrão

    Citação Postado originalmente por GuE Ver Post
    Procurei algumas coisas, e li que poderia entrar no /var/lib/dpkg/status e apagar a linha que esta com problema fiz isso mais apresenta erro em outra linha agora, ou seja tem uma depencia, oque posso fazer mais ?
    Isso tá com cara de ser na linha anterior! É igual programação em C. Se vc esqueçe um ; no fim da linha 1 ele acusa erro na linha 2!!

    Dá uma olhada nas linhas anteriores e tenta achar alguma coisa...

  4. #4

    Padrão

    Opa removi o bloco inteiro esta ok agora porem quando eu mando o comando abaixo:

    Astrix:/downloads# dpkg -i havp_0.89-1_i386.deb
    Selecting previously deselected package havp.
    (Reading database ... 70541 files and directories currently installed.)
    Unpacking havp (from havp_0.89-1_i386.deb) ...
    dpkg: dependency problems prevent configuration of havp:
    havp depends on libc6 (>= 2.7-1); however:
    Version of libc6 on system is 2.3.6.ds1-13etch7.
    havp depends on libstdc++6 (>= 4.2.1); however:
    Version of libstdc++6 on system is 4.1.1-21.
    dpkg: error processing havp (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    havp

    Fala que eu preciso dessas dependencias ate ae tudo ok, mais eu já tenho ela porem uma versão anterior, como eu faço upgrade dela pois se eu mando instalar ele fala que ja tenho, se eu vo remover pra instalar denovo ele não deixa pq tenho muitas dependencias de outros aplicativos.

    Astrix:/downloads# dpkg -l libc6
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-==============-==============-============================================
    ri libc6 2.3.6.ds1-13et GNU C Library: Shared libraries

    Alguem sabe me dizer ?



  5. #5

    Padrão

    tenta pegar os pacotes libc6 e libstdc++6pra instalar. Ou tenta via apt-get... Quando tive algo parecido foi porque eu tava querendo instalar um programa que necessitava de bibliotecas que só estavam disponíveis pro kernel 2.6, na época eu tava com o kernel 2.4...

  6. #6

    Padrão

    Eita, fiz o download lá no site do debian Debian -- Details of package libc6 in etch, porem olha agora

    Astrix:/downloads# dpkg -i libc6_2.7-16_i386.deb
    dpkg: regarding libc6_2.7-16_i386.deb containing libc6:
    libc6 conflicts with tzdata-etch
    tzdata provides tzdata-etch and is installed.
    dpkg: error processing libc6_2.7-16_i386.deb (--install):
    conflicting packages - not installing libc6
    Errors were encountered while processing:
    libc6_2.7-16_i386.deb

    da conflito com outra coisa que doido, já passou por isso ?



  7. #7

    Padrão

    Cara, verifica oq q utiliza esse pacote tzdat... Se não tiver nada usando remove.
    às vezes se vc usar o apt-get ao inves do dpkg ele já resolva essas coisas pra vc!

    Se ele continuar enchendo o saco, o último recurso é forçar a instalação...