A versão 3 já tem um patch, mas pelo que eu sei, precisa fazer um patch no kernel também.
Prefiro o squid 2.7, já vem com tudo pronto.