+ Responder ao Tópico



  1. #1

    Padrão Com dois Switch dá problemas

    Eu tinha um só switch lá na torre. entre os Aps na torre e o servidor Mk aqui em baixo.
    Funcionava beleza. Switch D-link 8 portas.

    Coloquei mais um switch junto ao servidor e deu pau na rede. Switch 3Com
    Ficam todos os leds piscando. E o acesso pelos APs fica extremamente lento.
    Quando desconecto o cabo que vem lá de cima do outro switch, e deixo a rede só no cabeado, tudo volta ao normal.
    Ou se tiro o cabeado e deixo só wireless volta tudo ao normal também.

    Já troquei por outro switch Compex e o problema é o mesmo.
    Nâo é cabo, pois eram os mesmos que antes já estava em uso.

    O que pode estar causando este conflito?

  2. #2

    Padrão

    Fala amigo... pode ser "Broadcast Storm" .

    Olha só, aqui as vezes acontece isso, principalmente com 3com, andei pesquisando e descobri isso:

    O temido "Broadcast Storm"

    Não existe nada mais tenebroso em uma rede local que um "broadcast storm" (na tradução literal, tempestade de difusões). Quem já presenciou um pode perceber que toda a rede para de funcionar, os servidores ficam extremamente lentos e não há nenhuma pista de onde o problema está sendo originado. O que fazer para evitar este pesadelo?
    Broadcasts são muito comuns na rede. São mensagens enviadas ao endereço de acesso FF-FF-FF-FF-FF-FF. Estas mensagens são replicadas em todas as portas de todos os switches que estão dentro de uma mesma rede ou dentro de uma mesma VLAN.
    O que causa?

    Um Broadcast storm ocorre quando uma mensagem gera uma resposta que gera uma nova mensagem em um efeito de bola de neve.
    A principal causa do Broadcast Storms são "loops" na rede. Locais onde um switch é ligado a outro por mais de um cabo. O protocolo Spanning-Tree deveria evitar este problema, mas se estiver desabilitado ou com problema, o storm pode aparecer.
    Alguns vírus podem causar um "storm" também (de menores proporções). Os vírus começam a buscar novas máquinas para infectar enviando um pacote de "arp" (address resolution protocol) para todas as máquinas dentro da faixa de endereços. Se o endereçamento de rede é classe B, isto significa 65535 broadcasts a cada tentativa.
    Algums impressoras tem drivers que fazem o mesmo na busca de um impressora. Um antigo driver da HP Laserjet 3 causava este problema quando os drivers estavam instalados nas máquinas e a impressora era removida. Todos os usuários iniciavam uma procura pela impressora fazendo broadcasts pela rede. Com uma rede de 500 nós com acesso à esta impressora, significava 500 estações fazendo broadcast ao mesmo tempo.
    Como detectar?

    Use um analisador de protocolo e filtre apenas os broadcasts. Se sua rede esta experimentando mais de 500 broadcasts por segundo, certamente você está enfrentando o problema. Broadcasts acima de 100 por segundo já são indesejáveis. Em um storm com loop, muitas vezes você vai ver dezenas de milhares de broadcasts por segundo (rede no chão).
    Como se previnir?

    Switches camada 3 permitem a segmentação de rede em várias VLANs. Os Broadcasts não atravessam as VLANs permitindo que o problema fique contido.
    A maioria dos swicthes hoje possui controle para Broadcast Storm que evita que a rede fique congestionada limitando o número de broadcasts simultâneos. No entanto, como esta solução bloqueia também broadcasts legítimos, alguns problemas intermitentes podem ocorrer.
    O uso correto do protocolo Spanning-Tree pode evitar os problemas de Loops. Cuidado, pois muitos switches tem implementações com bugs deste protocolo.

    FONTE: O temido "Broadcast Storm"



  3. #3

    Padrão

    Daí Jodrix,

    Acho que pode mesmo ser por aí.
    Nunca tinha ouvido falar nisto, mas com a pista que voce deu eu já comecei a estudar um pouco mais.
    Já baixei o Wireshark e monitorei. Gravei o arquivo gerado, só que não entendi.
    Eu vou enviar para o teu email. Dá uma olhada e me diz se nota algo de anormal.
    Mas que acusa tráfego na rede, mesmo sem o meu computador estar enviando nada, acusa.

    Isto pode esplicar o porquê do switch estar piscando. E piscam todas os leds juntos, não só o que recebe o cabo de rede lá de cima da torre. O led que está conectado um micro, sem passar pelo rádio pisca junto.

    Eu tirei o switch 3Com e coloquei um Compex. Continua piscando todos os leds sempre na mesma cadência, mas pelo menos a rede não trava.
    Só que este Compex não é homologado. Por isso vou ter que achar uma solução.
    E o 3Com que estava lá eu troxe para minha casa e aqui ele continua piscando intermitentemente. O compex só piscava com tráfego.

    outra coisa que notei foi antes eu abria um AP e ele ficava disponível muito tempo. Agora, ao passar alguns minutos eu tenho que entrar novamente a senha deles.
    Lá no MK esta configurado como RSPT. SErá que resolveria passar para STP?
    ----
    P.S - Tu recebeu os arquivos do OsWave que enviei?


    Citação Postado originalmente por jodrix Ver Post
    Fala amigo... pode ser "Broadcast Storm" .

    Olha só, aqui as vezes acontece isso, principalmente com 3com, andei pesquisando e descobri isso:

    O temido "Broadcast Storm"
    [/URL]
    Última edição por 1929; 16-11-2008 às 08:20.

  4. #4

    Padrão

    1929,

    Quanto a switch homologado tenho utilizado duas marcas:
    LG-NORTEL: SWITCH 08P 10/100 LG-NORTEL - LNES8
    e INTELBRAS SF-800 08P 10/100, ambos possuem custo bem interessante.

    Quanto ao erro que você citou me parece ser realmente broadcast, de uma monitorada na rede...

    Espero ter colaborado...

    Um Abraço,
    Marcelo Piaz Vianna



  5. #5

    Padrão

    Obrigado pela dica Marcelo.

    Eu procurei ao comprar outro switch, pela homologação. E tinha achado o Intelbras, mas não acreditei e acho que me ferrei. Paguei 140,00 mais frete pelo 3Com.

    E quanto ao monitoramento, aos poucos eu vou me familiarizando com o processo, com a ajuda dos amigos.

    Citação Postado originalmente por mvianna Ver Post
    1929,

    Quanto a switch homologado tenho utilizado duas marcas:
    LG-NORTEL: SWITCH 08P 10/100 LG-NORTEL - LNES8
    e INTELBRAS SF-800 08P 10/100, ambos possuem custo bem interessante.

    Quanto ao erro que você citou me parece ser realmente broadcast, de uma monitorada na rede...

    Espero ter colaborado...

    Um Abraço,
    Marcelo Piaz Vianna

  6. #6

    Padrão

    1929,

    hehehe, sei como eh... esse LG-NORTEL é muito bom tb, abri um e reparei que vem ate com um dissipador no chipset, custa uns R$ 40,00 a R$ 50,00 e o Intelbras uns R$ 30,00 a R$ 40,00.

    Vou abrir qqr dia um Intelbras pra dar uma olhada e posto aqui... :P

    Um Abraço,
    Marcelo Piaz Vianna



  7. #7

    Padrão

    Amigo, você pode evitar isso ligando ao invés de um switch um roteador (direto na porta wan dele), assim você vai conseguir pegar o sinal e nada que entrar de pacotes irá sair, o custo de um roteador da d-link é baixo, menos de 100 reais, e você evita muita dor de cabeça.

    César.

  8. #8

    Padrão

    Citação Postado originalmente por cesarkallas Ver Post
    Amigo, você pode evitar isso ligando ao invés de um switch um roteador (direto na porta wan dele), assim você vai conseguir pegar o sinal e nada que entrar de pacotes irá sair, o custo de um roteador da d-link é baixo, menos de 100 reais, e você evita muita dor de cabeça.

    César.
    Preciso entender melhor a sugestão.

    Eu tenho o servidor MK. Dele sai cabo de rede até o primeiro switch. Deste sai cabos para pcs.
    E sai também um cabo para outro switch D-link que está lá em cima na torre.
    Antes eu não tinha este primeiro switch aqui em baixo e não dava isso.

    Então se eu colocar no lugar deste primeiro switch um AP. eu vou estrangular o tráfego nele, já que lá em cima são 6 Aps.
    A não ser que eu usasse ele só como switch, desabilitando o wireless. É isso que você sugere?

    Agora que no primeiro switch coloquei um compex no lugar do 3Com não travou mais, mas os leds ficam piscando todos ao mesmo tempo, mesmo sem tráfego.
    E aqui em casa quando o Compex estava aqui, só piscava quando tinha o tráfego do meu PC. E agora que está aqui o 3Com, ele está piscando sempre.



  9. #9

    Padrão

    Bom dei uma lida rapida entao vou passar uma observação simples mas que no mes passado vi um bom tecnico apanhar ...

    Situação: Ao ligar um cabo de rede no micro os leds piscam o tempo todo e a rede cai....
    Possivel problema: Loop vou explicar o que aconteceu em um cliente meu

    O tecnico havia um switch dlink ligando alguns PCs e um cabo ia ate a placa de rede do servidor.. depois ele colocou um encore que enviava um cabo para um Aprouter e tambem neste mesmo encore um cabo saia para o servidor.. ate aqui ok, mas ele fez um cabo cross que ligava encore ao Dlink... com isto o problema esta feito....

    Mas no meio de muitos cabos, voltas, e dealhe "sem identificação"

    Procure analisar a topologia da sua rede, espero que encontre o problema e a solucao




  10. #10

    Padrão

    Citação Postado originalmente por leoservice Ver Post
    Bom dei uma lida rapida entao vou passar uma observação simples mas que no mes passado vi um bom tecnico apanhar ...

    Situação: Ao ligar um cabo de rede no micro os leds piscam o tempo todo e a rede cai....
    Possivel problema: Loop vou explicar o que aconteceu em um cliente meu

    O tecnico havia um switch dlink ligando alguns PCs e um cabo ia ate a placa de rede do servidor.. depois ele colocou um encore que enviava um cabo para um Aprouter e tambem neste mesmo encore um cabo saia para o servidor.. ate aqui ok, mas ele fez um cabo cross que ligava encore ao Dlink... com isto o problema esta feito....

    Mas no meio de muitos cabos, voltas, e dealhe "sem identificação"

    Procure analisar a topologia da sua rede, espero que encontre o problema e a solucao



    Eu não tinha me preocupado com o cabo se era cross ou não, visto que nos manuais dos switches diz que eles reconhecem automaticamente.
    Simplesmente peguei um cabo curto já pronto e coloquei na placa de rede do servidor e no primeiro switch. Os outros cabos já estavam em uso normalmente. Pode ser por aí também.
    Mas amanhã vou lá na base e vou conferir e retorno.



  11. #11

    Padrão

    Citação Postado originalmente por mvianna Ver Post
    1929,

    Quanto a switch homologado tenho utilizado duas marcas:
    LG-NORTEL: SWITCH 08P 10/100 LG-NORTEL - LNES8
    e INTELBRAS SF-800 08P 10/100, ambos possuem custo bem interessante.

    Quanto ao erro que você citou me parece ser realmente broadcast, de uma monitorada na rede...

    Espero ter colaborado...

    Um Abraço,
    Marcelo Piaz Vianna

    Marcelo,

    Boa Noite!

    Estou trocando meus Switch atuais pelos Intelbras citados por vocês e até o presente momento estou muito satisfeito, porém ainda não consegui encontratar a homologação deles, diante isso gostaria que por favor você me indica-se onde posso encontrar essa homologação.

    Agradeço antecipadamente pela sua ajuda.

    Abraços,

    Aprendiz