+ Responder ao Tópico



  1. #1

    Padrão Como atribuir DHCP automatico e ao mesmo tempo amarrar ip+mac

    Gostaria de saber se tem como eu atribuir DHCP automatico no MK e ao mesmo tempo amarrar IP+MAC, para que o cliente não fique mudando toda hora os ips.


    aguardo ajuda....

  2. #2

    Padrão

    Deixa o address pool do servidor dhcp como static-only e na aba lease você cadastra os macs e os ips que para cada mac



  3. #3

    Padrão

    Se liga faz o seguinte...

    Vc jah deve ter criado o seu servidor DHCP.....
    Em seguida basta vc deixar o address pool do servidor dhcp como static-only (assim como o colega assim citou).

    Depois vá em:

    /ip dhcp-server lease ... e assim atrele o Mac deseja a um IP que esteja no seu range do dhcp ja criado

    Ex.:
    Rede: 192.168.200.0/26
    Gw: 192.168.200.1
    DNS.: xxx.xxx.xxx.xxx
    Logo vc tera os ip´s do 192.168.200.2 ate o 192.168.200.62 para estar atribuindo para seus clientes.

    /ip dhcp-server lease add mac-address=xx-xx-xx-xx-xx-xx addresss=192.168.200.2

    Pronto agora este Mac jah esta atrelado a este IP.

    Qlqr dúvida poste ai blz....flw

  4. #4

    Padrão

    Citação Postado originalmente por ccampus Ver Post
    Gostaria de saber se tem como eu atribuir DHCP automatico no MK e ao mesmo tempo amarrar IP+MAC, para que o cliente não fique mudando toda hora os ips.


    aguardo ajuda....

    é so voce marcar ADD ARP FOR LEASES no dhcp que voce criou.

    Ele vai adicionar sozinho o mac com ip no arp apos cadastro no leases.



  5. #5

    Padrão

    Ô brother, tive um problema aqui e não cheguei as 7 como combinado, mas estou on-line agora...Desculpe

  6. #6

    Padrão

    Galera sou novato na area de MK, ainda nao configurei o DHCP server, então queria configurá-lo direito e atribuir os ip's aos macs desejados.

    passo-a-passo.



  7. #7
    Avatar de shuttner
    Ingresso
    Aug 2008
    Localização
    Boa Vista - Roraima
    Posts
    257
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por ccampus Ver Post
    Galera sou novato na area de MK, ainda nao configurei o DHCP server, então queria configurá-lo direito e atribuir os ip's aos macs desejados.

    passo-a-passo.
    Cara vc ja leu aqui
    Tutoriais/Wireless/guia-passoa-passo-mikrotik - UnderLinux Wiki

    Se tiver problemas
    [email protected]

  8. #8

    Padrão

    Citação Postado originalmente por shuttner Ver Post

    O DHCP automático eu consegui fácil, fácil, mas atrelar os ip +mac ainda não consegui...

    podem me ajudar???
    Mais detalhadamente, afinal sou aprendiz de MK



  9. #9

    Padrão

    Citação Postado originalmente por ccampus Ver Post
    ...podem me ajudar???
    ...
    Assim amigo, "facim":

    Setar o dhcp-server como static:
    /ip dhcp-server set server_name address-pool=static-only add-arp=yes

    Add os clientes ao lease:
    /ip dhcp-server lease add address=ipdocliente mac-address=macdocliente

    So fazer isto ae que ja vai ficar atrelado e nao vai precisar add os ips e mac em ip arp, pois o servidor ja fara dinamicamente.



  10. #10

    Padrão

    me passa seu MSN que lhe passo a passo as configurações de acordo c/ sua rede.



  11. #11

    Padrão

    Minha solução é esta:

    Cadastro dos ips da rede.


    / ip address
    add address=192.168.254.254/24 network=192.168.254.0 broadcast=192.168.254.255 interface=LAN comment="Rede 192.168.254.254" disabled=no
    add address=10.10.0.2/24 network=10.10.0.0 broadcast=10.10.0.255 comment="Velox 1Mb" disabled=yes
    add address=192.168.1.1/29 network=192.168.1.0 broadcast=192.168.1.7 interface=LAN comment="Intranet Willian" disabled=no
    add address=192.168.2.1/30 network=192.168.2.0 broadcast=192.168.2.3 interface=LAN comment="Dhcp Clientes" disabled=no
    add address=192.168.3.1/30 network=192.168.3.0 broadcast=192.168.3.3 interface=LAN comment="" disabled=no
    add address=192.168.4.1/30 network=192.168.4.0 broadcast=192.168.4.3 interface=LAN comment="" disabled=no
    add address=192.168.5.1/30 network=192.168.5.0 broadcast=192.168.5.3 interface=LAN comment="" disabled=no
    add address=192.168.6.1/30 network=192.168.6.0 broadcast=192.168.6.3 interface=LAN comment="" disabled=no
    add address=192.168.7.1/30 network=192.168.7.0 broadcast=192.168.7.3 interface=LAN comment="" disabled=no
    add address=192.168.8.1/30 network=192.168.8.0 broadcast=192.168.8.3 interface=LAN comment="" disabled=no


    Criando pool para o DHCP dos clientes.

    / ip pool
    add name="Servidor DHCP" ranges=192.168.254.249-192.168.254.253
    add name="pool1" ranges=192.168.1.2-192.168.1.6
    add name="pool2" ranges=192.168.2.2
    add name="pool3" ranges=192.168.3.2
    add name="pool4" ranges=192.168.4.2
    add name="pool5" ranges=192.168.5.2
    add name="pool6" ranges=192.168.6.2
    add name="pool7" ranges=192.168.7.2
    add name="pool8" ranges=192.168.8.2


    Criando servidor dhcp usando a rede 192.168.254.0.
    Coloquei o tempo alto no lease-time afim de sanar o travamento de ip no cliente, pois quando acabava o tempo algumas maquinas deixavam de funcionar, nao
    pegando mais nenhum ip.

    / ip dhcp-server
    add name="Servidor DHCP" interface=LAN lease-time=14w2d4h40m39s address-pool="Servidor DHCP" bootp-support=static add-arp=yes authoritative=after-2sec-delay disabled=no

    / ip dhcp-server config
    set store-leases-disk=5m



    Aqui cadastro as redes no servidor DHCP, cadastro a rede principal, no caso a rede 192.168.254.0/24 e as outras redes usando netmasck 30 # suportando assim somente dois ips, no caso o servidor e o cliente.

    / ip dhcp-server network
    add address=192.168.1.0/29 gateway=192.168.1.1 dns-server=208.67.222.222,208.67.220.220 comment="Intranet Willian"
    add address=192.168.2.2/32 gateway=192.168.2.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment="Dhcp Clientes"
    add address=192.168.3.2/32 gateway=192.168.3.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.4.2/32 gateway=192.168.4.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.5.2/32 gateway=192.168.5.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""

    add address=192.168.6.2/32 gateway=192.168.6.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.7.2/32 gateway=192.168.7.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.8.2/32 gateway=192.168.8.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.9.2/32 gateway=192.168.9.1 netmask=30 dns-server=208.67.222.222,208.67.220.220 comment=""
    add address=192.168.254.0/24 gateway=192.168.254.254 dns-server=208.67.222.222,208.67.220.220 comment="Rede 192.168.254.254"


    A primeira vez que o cliente é conectado a rede ele vai pegar um ip da rede 192.168.254.0 entre os ips que limitei la no pool, no caso do # 192.168.254.249 ao 192.168.254.253.
    Do um MAKE STATIC no cliente e logo em seguida atribuo uma faixa de ip livre para ele.

    / ip dhcp-server lease
    add address=192.168.1.3 mac-address=00:11:09:7B:69:E8 client-id="1:0:11:9:7b:69:e8" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.1.2 mac-address=00:1A:73:2F:4C:FB client-id="1:0:1a:73:2f:4c:fb" server="Servidor DHCP" comment="Intranet Willian" disabled=no
    add address=192.168.1.4 mac-address=00:0E:2E:B1:B0:3D client-id="1:0:e:2e:b1:b0:3d" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.1.5 mac-address=00:16:D3:93:C4:88 client-id="1:0:16:d3:93:c4:88" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.1.6 mac-address=00:1F:D0:FF:34:98 client-id="1:0:1f:d0:ff:34:98" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.2.2 mac-address=00:1A:92:36:B7:B3 client-id="1:0:1a:92:36:b7:b3" server="Servidor DHCP" comment="Dhcp Clientes" disabled=no
    add address=192.168.3.2 mac-address=00:16:EC:A7:0D:96 client-id="1:0:16:ec:a7:0d:96" server="Servidor DHCP" always-broadcast=yes comment="" disabled=no
    add address=192.168.4.2 mac-address=00:14:2A:19:67:70 client-id="1:0:14:2a:19:67:70" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.5.2 mac-address=00:1F:D0:F1:4D:CD client-id="1:0:1f:d0:f1:4d:cd" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.6.2 mac-address=00:50:BF:97:38:48 client-id="1:0:50:bf:97:38:48" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.7.2 mac-address=00:1D:60:03:80:87 client-id="1:0:1D:60:03:80:87" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.8.2 mac-address=00:15:58:B6:75:E5 client-id="1:0:15:58:b6:75:e5" server="Servidor DHCP" comment="" disabled=no
    add address=192.168.9.2 mac-address=00:00:92:36:B7:B3 client-id="1:0:00:92:36:b7:b3" server="Servidor DHCP" always-broadcast=yes comment="" disabled=no


    Fica aqui minha contribuição para DHCP+IP+MAC+CACHEFULL funcionando, é só copiar e testar.

    Para os mais esperientes fica a pergunta:

    Posso usar essa solução em hotspot?

  12. #12

    Padrão

    Citação Postado originalmente por Demo Bill Ver Post
    ...

    Posso usar essa solução em hotspot?
    Pode sim amigo, basta informar uma pool para o hotspot, no caso a primeira, e o next pool faz o restante, ou mesmo inserir todos os ip em apenas uma pool.



  13. #13

    Padrão

    Mr. Mg esta vendo este topico onde vc estava ajudando o rapaz, porem ele nao especificou no final como ele conseguiu fazer.

    Estou com a mesma duvida dele sobre o servidor DHCP que mostra o IP principal do meu MK

    https://under-linux.org/forums/mikro...ias-redes.html

    Tem alguma forma de não mostrar o servidor DHCP ?

  14. #14

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    ...
    Tem alguma forma de não mostrar o servidor DHCP ?
    A forma de deixar o servidor dhcp sem atribuir os ips automaticamente é fazendo a lease e a network com as rede pretendidas.

    Tipo:
    /ip dhcp-server lease add address=192.168.2.2
    /ip dhcp-server lease add address=192.168.3.2
    /ip dhcp-server lease add address=192.168.4.2
    /ip dhcp-server lease add address=192.168.5.2

    /ip dhcp-serve network add address=192.168.2.0/30
    /ip dhcp-serve network add address=192.168.3.0/30
    /ip dhcp-serve network add address=192.168.4.0/30
    /ip dhcp-serve network add address=192.168.5.0/30

    caso queira add uma pool com todas as redes:

    /ip pool add name=pool-dhcp-server ranges=192.168.2.2,192.168.3.2,192.168.4.2,192.168.5.2



  15. #15

    Padrão

    Obrigado por sua resposta Mr. RG

    eu não entendi 100% sua resposta....pois voce diz em nao deixar o dhcp atribuir automaticamente neh?

    No meu caso eu pretendo usar a mascar /30 para cada IP da mesma forma que aquele amigo disse no topico dele...pois uso assim no BFW e gostaria de saber usar no MK.

    Para detalhar a forma que estou fazendo, fiz um print screen da imagem....se você puder me auxiliar onde estou errando e sugerir algo ficarei muito grato...pois estou gatinhando no Mk ainda e tenho um pouco de dificuldades em saber como montar as configs.

    Print_Screen_Mkteste

    Montei as configs conforme a numeração.....até fiz da forma que você me disse de fazer um Pool só, mais gostaria de uma opiniao sua sobre o que tem ai na imagem.

    Muito obrigado pela força...abraçao
    Última edição por Gustavinho; 04-12-2008 às 01:51.

  16. #16

    Padrão

    Olá amigo,
    Na verdade você nem vai precisar de uma pool, e também não precisa add os ipsxmacs na arp manualmente, basta marcar a box, ADD ARP for lease.
    No mais é isto mesmo, você crie seus endereços em Address, add o ipxmac na lease e cria a network. No firewall nat não se deve informar o src-address e sim a out-interface.



  17. #17

    Padrão

    Pow maravilha Mr. RG, mais uma vez obrigado.

    Então como eu vou atribuir os ips com mascara 30 eu não necessito de uma Pool pra eles, bastando eu fazer:

    *Cadastrar o ip no address
    *add o IPxMac na lease
    *criar a network
    seria isso então? pois eu vi que o pessoal criava a pool para os Ips.

    Fiz um teste com o hotspot e funcionou beleza, só que quando fui tira-lo não consegui mais navegar, tiver que voltar a usar ele...teria algo a ver com os ips?

    mto obrigado

  18. #18

    Padrão

    Citação Postado originalmente por gustavinho69
    Olá Demo bill beleza cara? espero que sim

    Então eu tava vendo uma resposta sua nesse topico https://under-linux.org/forums/mikro...-ip-mac-2.html

    E como to montando algo semelhante ao seu , fiquei com uma duvida.

    Nessa parte que você diz da rede principal
    / ip address
    add address=192.168.254.254/24 network=192.168.254.0 broadcast=192.168.254.255 interface=LAN comment="Rede 192.168.254.254" disabled=no


    é a rede que você usa para conectar no MK certo?

    Você criou também um range com mascara 29 pra sua intranet
    add address=192.168.1.1/29 network=192.168.1.0 broadcast=192.168.1.7 interface=LAN comment="Intranet Willian" disabled=no

    Estou tentando utilizar a mesma faixa da rede principal do meu MK como a sua da intranet mais não esta dando certo, ele atribui o IP mais a mascara fica 255.0.0.0 e as maquinas não se enchergam.

    fiz uma imagem pra vc ver como está, se puder me ajuda ficarei grato.

    IMG

    vlw atenção...abração
    Tudo beleza meu jovem,

    é estranho ele naum colocar a mask correta, no minimo deve ter alguma configuraçao errada em algum lugar, segue ai uma imagem com os detalhes, da uma olhadinha e ve se pode te ajudar a resolver o problema da usa rede ai.

    http://img517.imageshack.us/img517/3931/dhcpmkkw8.gif

    Qualquer coisa entra em contato.

    Falow!!