+ Responder ao Tópico



  1. #1

    Padrão Script para remover hosts

    Saudações a todos,

    Estou tentando fazer um script para remover todos os hosts que são criados dinâmicamente dentro de /ip hotspot host . mas não estou conseguindo.

    Por exemplo, se eu crio a variável abaixo:

    :local allhosts [/ip hotspot host print count-only];

    a variável "allhosts" contém a quantidade de hosts existentes, mas se eu tento remover passando esssa variável como parâmetro, é removido apenas o último host.

    Alguém tem alguma dica?

    Obrigado pela atenção

  2. #2

    Padrão

    Amigo,
    Desta forma ae:

    /system script add name=rmhost source="/ip hotspot host [/ip hotspot host find dynamic=yes]"

    Agora eh so criar um scheduler que execute a cada 5 segundos.



  3. #3

    Padrão

    Qual é a vantagem de remover host,estou curioso em saber.

  4. #4

    Padrão

    caro amigo esta script nao esta funcionando, vc teria alguma outra sugestao ?



  5. #5

    Padrão

    Este negocio de querer tudo mastigado (ctrl+c e ctrl+v) dah nisto, faltou inserir o remove:

    /system script add name=rmhost source="/ip hotspot host remove [/ip hotspot host find dynamic=yes]"

  6. #6
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por gulinhaster Ver Post
    Qual é a vantagem de remover host,estou curioso em saber.
    tbm estou curioso!



  7. #7

    Padrão

    Pode ter varias utilidades. Não sei para que o amigo precisa.

    Mais vou dar um exemplo de uma:

    O cara usa um soft que faz o gerenciamento de cobrança via radius por exemplo. O cara logou hoje e amanha seria o dia de bloqueio dele. Não vai acontecer porque ele já vai estar logado no sistema. Seria uma utilidade ele executar este script sempre na meia noite do dia do bloqueio pra forçar todos os usuarios a logarem novamente sem ter que reiniciar o mikrotik. E assim ser validado ou não o acesso dele caso esteja em dias com o provedor.

    Ou simplesmente por algun criteria ele querer que todos se registrem novamente. Vai da criatividade ou necessidade de cada um...

  8. #8

    Padrão Obrigado

    Mto obrigado caro amigo, desculpa a minha ignorancia, mas estou começando.

    Estou com um problema no hosts do hotspot, esta aparecendo mtos IPs validos, e com isso esses IPs acabam ocupando o meu pool de IPs.

    Vc saberia oq poderia ser isso ?

    Att.

    JR



  9. #9

    Padrão

    Dá alguns detalhes de como tá suas configuração de interfaces de rede, configuração do hotspot etc.

  10. #10

    Padrão

    Citação Postado originalmente por alancp Ver Post
    Pode ter varias utilidades. Não sei para que o amigo precisa.

    Mais vou dar um exemplo de uma:

    O cara usa um soft que faz o gerenciamento de cobrança via radius por exemplo. O cara logou hoje e amanha seria o dia de bloqueio dele. Não vai acontecer porque ele já vai estar logado no sistema. Seria uma utilidade ele executar este script sempre na meia noite do dia do bloqueio pra forçar todos os usuarios a logarem novamente sem ter que reiniciar o mikrotik. E assim ser validado ou não o acesso dele caso esteja em dias com o provedor.

    Ou simplesmente por algun criteria ele querer que todos se registrem novamente. Vai da criatividade ou necessidade de cada um...

    Valeu pela explicação.



  11. #11

    Padrão Config

    Caro amigo,
    Notei q isso somente ocorre qdo estou utilizando o MK para realizar a autenticaçao ADSL (ppoe).
    A situaçao é a seguinte:
    ADSL = MK = rede de clientes
    MK esta com o webproxy ativado, ddns e hotspot com DHCP.

    Att.

    JR

  12. #12

    Padrão

    Citação Postado originalmente por maleficavatar Ver Post
    Saudações a todos,

    Estou tentando fazer um script para remover todos os hosts que são criados dinâmicamente dentro de /ip hotspot host . mas não estou conseguindo.

    Por exemplo, se eu crio a variável abaixo:

    :local allhosts [/ip hotspot host print count-only];

    a variável "allhosts" contém a quantidade de hosts existentes, mas se eu tento remover passando esssa variável como parâmetro, é removido apenas o último host.

    Alguém tem alguma dica?

    Obrigado pela atenção
    Cara se você só quer remover os host talvez também de se você desativar seu Server hotsp todos os clientes conectados serão removidos bom tente ai aqui deu certo.
    /ip hotspot disable [find name="aqui vc coloca o nome do seu Server hospot"]
    :delay 5
    /ip hotspot enable [find name="
    aqui vc coloca o nome do seu Server hospot"]
    :log info "
    aqui vc coloca qualquer coisa tipo user removidos só pra constar em log"

    esse script vai dar um disable no seu Server hotspot, após 5 segundos ele da um enable.
    Basta você agendar a hora que você quer que ele seja executado.



  13. #13

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Amigo,
    Desta forma ae:

    /system script add name=rmhost source="/ip hotspot host [/ip hotspot host find dynamic=yes]"

    Agora eh so criar um scheduler que execute a cada 5 segundos.

    Sempre aparece entre os meus host ips q não uso e queria criar um script pra fazer uma busca da seguinte maneira.

    remove = todos ip que não pertencer a faixa 10.0.0.0/8

    Alguem sabe me dizer como?