Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. #61

    Padrão

    Install and Configure Cacti


    1. Extract the distribution tarball.
      shell> tar xzvf cacti-version.tar.gz
    2. Create the MySQL database:
      shell> mysqladmin --user=root create cacti
    3. Import the default cacti database:
      shell> mysql cacti < cacti.sql
    4. Optional: Create a MySQL username and password for Cacti.
      shell> mysql --user=root mysqlmysql> GRANT ALL ON cacti.* TO [email protected] IDENTIFIED BY 'somepassword';mysql> flush privileges;
    5. Edit include/config.php and specify the database type, name, host, user and password for your Cacti configuration.
      $database_type = "mysql";$database_default = "cacti";$database_hostname = "localhost";$database_username = "cactiuser";$database_password = "cacti";
    6. Set the appropriate permissions on cacti's directories for graph/log generation. You should execute these commands from inside cacti's directory to change the permissions.
      shell> chown -R cactiuser rra/ log/(Enter a valid username for cactiuser, this user will also be used in the next step for data gathering.)
    7. Add a line to your /etc/crontab file similar to:
      */5 * * * * cactiuser php /var/www/html/cacti/poller.php > /dev/null 2>&1Replace cactiuser with the valid user specified in the previous step.
      Replace /var/www/html/cacti/ with your full Cacti path.
    8. Point your web browser to:
      Log in the with a username/password of admin. You will be required to change this password immediately. Make sure to fill in all of the path variables carefully and correctly on the following screen.


    se seguir isso ae, tem q fungar...

    abraçosssssss

  2. #62

    Padrão

    7.Add a line to your /etc/crontab file similar to:
    */5 * * * * cactiuser php /var/www/html/cacti/poller.php > /dev/null 2>&1Replace cactiuser with the valid user specified in the previous step
    ------------------
    Essa linha ai, vai depedende da versao do PHP q se usa, e da posta onde ta instalado o CACTI, e do comando, POLLER, ou CMD... e é justamente essa linha q cria as RRA, pra gerar os graficos... entao tem q ta batendo conforme instalado o cacti.

    Esse seu tuto ai q se pego, ta com PHP antigo, mysql, e apache1..
    o q eu fiz usei apache2 mysql.5.7 php5... mas o q vale é funciona.



  3. #63

    Padrão

    sim sim, eu vi q o seu está atualizdo, só passei pra ver se ajuda alguem, talves fosse um detalhe como esse,...e ae já tem a permissão q vc falou o amigo thenet....abraçossssssss

  4. #64

    Padrão

    amigos...verifiquei aqui e o que ta acontecendo, é que não está sendo criado os arquivos rrd na pasta /rra ... talvez seja permissão, mas ja tentei de tudo e nao vai.

    alguem pode me dar uma luz? rsrs

    valew



  5. #65

    Padrão

    Citação Postado originalmente por thenet Ver Post
    amigos...verifiquei aqui e o que ta acontecendo, é que não está sendo criado os arquivos rrd na pasta /rra ... talvez seja permissão, mas ja tentei de tudo e nao vai.

    alguem pode me dar uma luz? rsrs

    valew
    é Permissao na PASTA... se tem q coloca 7777... e coloca o usuario cacti tbm pra ter acesso, mas no seu caso é a pasta mesmo... libera acesso pra toda pasta CACTI, nao so a pasta RRA e LOG..

  6. #66

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    é Permissao na PASTA... se tem q coloca 7777... e coloca o usuario cacti tbm pra ter acesso, mas no seu caso é a pasta mesmo... libera acesso pra toda pasta CACTI, nao so a pasta RRA e LOG..
    amigo, ainda não consegui. ja tentei fazer com outros usuarios, dei liberação 7777 pra todos arquivos e pastas do cacti e nada. sempre mesmo erro.
    alguma outra dica?

    muito obrigado.



  7. #67

    Padrão

    Amigo, qual versao do cacti se ta usando, a 7b, ta com defeito... no RRD ai nao gera os graficos,, bom no caso aki vi la no Cacti>> System Utilitaries>> la tem 2 jeitos pra ve onde ta o erro, o primeiro é ir em Technical Support, e ve se ta tudo ok, e o segundo é ir em View Cacti Log File, e ve se ta ok, nao tem nenhuma linha vermelha ou amarela contendo erros...

  8. #68

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    Amigo, qual versao do cacti se ta usando, a 7b, ta com defeito... no RRD ai nao gera os graficos,, bom no caso aki vi la no Cacti>> System Utilitaries>> la tem 2 jeitos pra ve onde ta o erro, o primeiro é ir em Technical Support, e ve se ta tudo ok, e o segundo é ir em View Cacti Log File, e ve se ta ok, nao tem nenhuma linha vermelha ou amarela contendo erros...
    amigo..ja fiz de tudo e nada..rsrs
    o status dos devices estão em UP e nada de criar as rrd. nada de erro indicando. ja tenti tudo q eh permissão.



  9. #69

    Padrão

    SIm fera, aki tbm tava assim, o STATUS tava UP e tal, sem erros e nao gerava grafico, pq o RRD tava com erro e so vi o erro na em System Utilitaries.... ai vi q era permissao... e resolvi...

  10. #70

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    SIm fera, aki tbm tava assim, o STATUS tava UP e tal, sem erros e nao gerava grafico, pq o RRD tava com erro e so vi o erro na em System Utilitaries.... ai vi q era permissao... e resolvi...
    vou tentar novamente.
    mas não tem mais o que fazer com permissão, creio eu. ja dei 'chmod -R 7777 cacti/' , ja dei o 'chown -R cacti cacti/'
    e nada.
    ja tentei fazer com que o root seja o usuario para utilizar, e deu a mesma coisa.
    to ficando doido rsrs

    valew



  11. #71

    Padrão

    talves "chmod 777 cacti/" e "chown -R cacti.cacti cacti/"


    teste ae

  12. #72

    Padrão

    A soluçao coloca isso do lado do servidor, e pronto nao da mais problemas....
    [ame=http://www.youtube.com/watch?v=u-rS3S0smZ4]YouTube - Baianas do Candomblé[/ame]



  13. #73

    Padrão

    vou criar o grafico desse vidoe, vamos ver se resolve uhahuahuahu
    dei uma parada pra adiantar outros projetos.. logo mais tento novamente.
    valew peas ajudas galera.

  14. #74
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    ai galera Parabéns pelo tópico resolveu meus problemas de graficos para clientes, com hotspot, Mr_Doom, ja fui cliente do seu provedor ai, e achei muito bom seu painel do cliente...


    abraços....



  15. #75

    Padrão

    Citação Postado originalmente por ederamboni Ver Post
    ai galera Parabéns pelo tópico resolveu meus problemas de graficos para clientes, com hotspot, Mr_Doom, ja fui cliente do seu provedor ai, e achei muito bom seu painel do cliente...


    abraços....

    opa, obrigado...estamos ae...qq coisa poste..abraços

  16. #76
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    cara show de bola, acabei de configura meu cacti, e esta rodando perfeito pegando os dados dinamicos, agora é so pensar como mostra esses gráfico para os clientes quando eles acessarem o painel deles...

    abraços...



  17. #77

    Padrão

    Aki to utilizando um sistema q estamos montando, ai ele pega o grafico gera uma OS pro cliente, ai o cliente quando solicitar visita, ja sai impresso o uso dele, e tamu fazendo agora pro site, ai o cliente acessa a conta e ve o uso.

  18. #78
    Moderador Avatar de ederamboni
    Ingresso
    Oct 2004
    Localização
    Montes Claros
    Posts
    880
    Posts de Blog
    13

    Padrão

    Citação Postado originalmente por aka2005 Ver Post
    Aki to utilizando um sistema q estamos montando, ai ele pega o grafico gera uma OS pro cliente, ai o cliente quando solicitar visita, ja sai impresso o uso dele, e tamu fazendo agora pro site, ai o cliente acessa a conta e ve o uso.

    legal e mais ou menos os eu pretendo...