+ Responder ao Tópico



  1. #1

    Padrão Se for o caso eu pago. Desde que funcione.

    Ja que ninguem deu a solução para o meu problema e eu ja vi muitos falarem que consegue fazer. E sei tambem que ninguem trabalha de graça. resolvi posta aki. se alguem se disponibilizar a arrumar meu problema eu não me importo de pagar.

    lembrando desde que funcione.

    o que eu quero e facil....

    quero fazer o cache no meu MK 3.13 funciona e se for possivel fazer o famoso cache full ... lembrando que se for por o cache full. ele quando estiver usando o cache nao pode consumir o link. eu quero como o CATVBRASIL postou um outro dia.

    se alguem tiver interesse estou aki.

    69 3421-7872 69 9205-0676 ou [email protected]

    agradeço desde já.
    caio fabeni

  2. #2

    Padrão

    que tipo deconecao vc usa para os clientes
    ip fixo hostpot pppoe
    ????



  3. #3

    Padrão

    Cara eu uso HotSpot. agora atualizei minha vesao para o MK 3.16 e o cache parece que esta funcionando. tipowww
    Olho na interface a placa da net esta correndo tipow ... 200K e a placa dos clientes esta correndo 800K.

    mas eu queria que fosse como o squid . abaixasse um arquivo e na segunda vez que for baixa ele viesse rapidao.

    mas quando faço o down pela segunda vez ele vem consumindo a interface da net. meu web-cache esta assim ....

    enabled: yes
    src-address: 0.0.0.0
    port: 3126
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "NetCom"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: yes
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: sata1


    meu nat assim ...

    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Marcara para todas os Ranges
    chain=srcnat action=masquerade
    1 ;;; Redirecionamento Proxy
    chain=dstnat action=redirect to-ports=3126 protocol=tcp
    src-address=192.168.2.0/24 in-interface=Rede dst-port=80

  4. #4

    Thumbs up Vc já tentou dessa forma?

    As regras postadas em https://under-linux.org/forums/mikro...nando-blz.html funciona pra qq versao 3 do MK, ou seja da 3.0 em diante.



  5. #5

    Padrão

    Eu tambem ja tentei fazer isso ai sim. mas nao deu certo. mas agora minha duvida maior é......
    Meu web-cache aparentemente esta funcionando, corre trafego e tudo mas quando baixo o down pela segunda vez ele vem consumindo a net. e pelo oq eu entendo ele nao poderia fazer isso. ai fica minha duvida sera que é bug da versao 3.16.

    mas desde ja agradeço a sua atençao amigo.

  6. #6
    Avatar de shuttner
    Ingresso
    Aug 2008
    Localização
    Boa Vista - Roraima
    Posts
    257
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por netcom Ver Post
    Eu tambem ja tentei fazer isso ai sim. mas nao deu certo. mas agora minha duvida maior é......
    Meu web-cache aparentemente esta funcionando, corre trafego e tudo mas quando baixo o down pela segunda vez ele vem consumindo a net. e pelo oq eu entendo ele nao poderia fazer isso. ai fica minha duvida sera que é bug da versao 3.16.

    mas desde ja agradeço a sua atençao amigo.
    Vc ja deu lida no wiki do mikrotik
    Queue with Masquerading and Internal Web-Proxy - MikroTik Wiki

    Estou usando o cache-full na versão 2.9.27 e funcionando blz
    baixando do cache sem consumir da net



  7. #7
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    Saiu a versão 3.17 stable do MK.

  8. #8

    Padrão

    E li sim o wiki. mas num deu em nada. Vou baixa agora mesmo a versao 3.17 pra eu fazer um teste. mas muito obrigado. lembrando na versao 2.9.27 eu consegui fazer sim . estou com problema nessa nova versao. .

    mas desde ja agradeço a todos. vou baixa a outra versao e ja posto aki o resultado.

    vlw



  9. #9

    Padrão

    Uma pergunta, vc ta usando pc ou routerboard? na routerboard o webproxy nao tem cache! entao toda vez que vc acessa ele puxa na internet!

  10. #10

    Padrão

    O meu nobre eu to usando pc.

    Mas depois de uma semana apanhando consegui fazer o cache funciona em paralelo e tambem consegui fazer o cache-full funciona sem consumir o link.

    tava bem embaixo do nariz e nao tinha visto. mas to fazendo uns teste segunda vou posta tudo aki. lembrando que to usando a versao 3.17.

    mas ate agora esta uma belezura....

    mas agradeço mesmo a atençao. se precisa das regras vou posta na segunda.



  11. #11

    Padrão e banal mais tenta ai

    Quando vc usa hotspot, tem que irm em IP>hotspot>server>profile( oq vc ta usando). na guia general tem HTTP Proxy : (ip do seu proxy) e HTTP proxy port: (porta do porxu..Ex: 3128).
    eu uso a 2.9.27 (jack sparow) é o meu proxy so funfou depois que fiz isso.
    da uma olha ai, se resolver pode depositar na minha conta do bradesco 1446 / 0541013-4 qualquer contia.hehehehe to zuando.. so to querendo ajuadar.

  12. #12

    Padrão

    Citação Postado originalmente por muriloc4 Ver Post
    Quando vc usa hotspot, tem que irm em IP>hotspot>server>profile( oq vc ta usando). na guia general tem HTTP Proxy : (ip do seu proxy) e HTTP proxy port: (porta do porxu..Ex: 3128).
    eu uso a 2.9.27 (jack sparow) é o meu proxy so funfou depois que fiz isso.
    da uma olha ai, se resolver pode depositar na minha conta do bradesco 1446 / 0541013-4 qualquer contia.hehehehe to zuando.. so to querendo ajuadar.
    Funciona, porém não seria a melhor solução (desta forma o proxy não irá trabalhar de forma transparente)...



  13. #13

    Padrão

    boa noite eu fiz mas usei apenas regra no firewall e funciono blz.
    agradeço a todos que me ajudou . agora meu serve esta show. proximo passo integra um server de dns no debian. vamos a luta.

  14. #14

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Funciona, porém não seria a melhor solução (desta forma o proxy não irá trabalhar de forma transparente)...
    Se você configurar nas configurações do profile do hotspot para o:
    HTTP Proxy : 127.0.0.1 (localhost) e;
    HTTP proxy port: 3126 (porta do proxy.
    o cache vai trabalhar de forma tranparente.



  15. #15

    Padrão

    Essa e pra dar certo !


    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection \
    new-connection-mark=conn_squid-up passthrough=yes comment="CACHE FULL" disabled=no
    add chain=output connection-mark=conn_squid-up action=mark-packet new-packet-mark=pacotes_squid-up \
    passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=3128 action=mark-connection new-connection-mark=conn_squid-down \
    passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=conn_squid-down action=mark-packet new-packet-mark=pacotes_squid-down \
    passthrough=yes comment="" disabled=no

    /ip firewall filter
    add chain=input protocol=tcp dst-port=3128 action=accept comment="ACEITAR CONEXOES PROXY" disabled=no

    /queue tree
    add name="\[CACHE-FULL\] - Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default \
    priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="\[CACHE-FULL\] - Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default \
    priority=1 max-limit=5000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no



    Espero ter ajudado...


    Flw !!!

  16. #16

    Padrão

    Já que está querendo qualidade e robustez e pretende pagar por tal, compre uma cpu e instale o linux para servir como caching. Não é que estou desmerencendo o caching do mikrotik.



  17. #17

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Já que está querendo qualidade e robustez e pretende pagar por tal, compre uma cpu e instale o linux para servir como caching. Não é que estou desmerencendo o caching do mikrotik.
    Opa. blz ?

    Ja fiz isso comprei um Dell e coloquei com cache o problema que estava apanhando pra por pra roda mas ja consegui. eu tava comendo barriga. agora esta tudo ok.

    vlw ai galera.

  18. #18

    Padrão

    Citação Postado originalmente por netcom Ver Post
    Opa. blz ?

    Ja fiz isso comprei um Dell e coloquei com cache o problema que estava apanhando pra por pra roda mas ja consegui. eu tava comendo barriga. agora esta tudo ok.

    vlw ai galera.
    O cache do MK é perfeito!!

    Quando sabe-se configurar funciona 100%......



  19. #19

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    O cache do MK é perfeito!!

    Quando sabe-se configurar funciona 100%......

    Eu concordo plenamete com vc CATVBrasil. Mas acredito que o Squid com Debian tenha um desempenho superior ao do MK.

  20. #20

    Padrão

    É como eu falei acima, não estou desmerecendo o proxy do mikrotik. Mas um servidor cache onde se pode fazer mil e uma configuração não seria melhor?