+ Responder ao Tópico



  1. #1

    Padrão Bloquear MAC por horário

    Eu tenho a seguinte estrutura:

    Mikrotik Fazendo PPPoE e Autenticador Radius.

    Preciso de criar uma regra de firewall onde o Mikrotik não permita determinador MAC conectar em um espaço de tempo que eu vou setar.

    Ex:

    00:11:22:33:44:55
    Não conectar das 8:00 até 11:59 (bloquear totalmente o acesso nesse hr)
    Apenas 12:00 até 7:59 (conecta no hr permitido e quando completar 8:00 derruba a conexão

  2. #2

    Padrão

    Faça deste jeito:
    /ip firewall filter add chain=forward action=drop src-mac-address=00:11:22:33:44:55 time=2h-5h,sat,fri,thu,wed,tue,mon,sun



  3. #3

    Padrão

    Raniel vc poderia explicar melhor esse horario 2h-5h ?

    No meu caso quero bloquear o acesso do meu sobrinho a partir de 23h(noite) até 05:59 da manhã...quando der 06:00 hora da manhã a conexão da net volta. Uso hotspot e sei que tenho que fazer isso pelo mac em ip firewall filter...mas não consigo entender esse horario.

    Espero tua ajuda ok.

  4. #4

    Padrão

    Já que usa hotspot, pode fazer um profile de bloqueio e criar um script para setar o profile dele para o do bloqueio na hora desejada e voltar o profile dele desbloqueado também na hora desejada. Faço isto e funciona legal.



  5. #5

    Padrão

    Obrigado...mas nao foi essa a minha pergunta (Raniel vc poderia explicar melhor esse horario 2h-5h ?)...mas de qualquer forna é uma alternativa.

  6. #6

    Padrão

    Funciona da seguinte forma, das 2 as 5 o mac estará bloqueado.



  7. #7

    Padrão

    Como seria esse script? pelo hotspot...

  8. #8

    Padrão

    Aqui eu fiz o seguinte amigo,
    Criei uma pag personalizada e um profile. Daí eu criei um script que busca o nome do usuário e altera o profile dele no tempo determinado pelo scheduler e outro script para desconectar, caso ele esteje conectado no momento.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         tela.gif
Visualizações:	300
Tamanho: 	29,0 KB
ID:      	3390  



  9. #9

    Padrão FILHO "ABORECENTE"

    Citação Postado originalmente por Raniel Ver Post
    Aqui eu fiz o seguinte amigo,
    Criei uma pag personalizada e um profile. Daí eu criei um script que busca o nome do usuário e altera o profile dele no tempo determinado pelo scheduler e outro script para desconectar, caso ele esteje conectado no momento.

    Caro Raniel
    tem como vc montar um passo a passo desta operação???

    AKI USO O HOTSPOT

    TENHO MEU FILHO "ABORECENTE" Q TA NA NET ATE ALTAS HORAS

    DESDE JA AGRADEÇO
    Última edição por ivovid; 15-02-2009 às 18:17.

  10. #10

    Padrão

    Citação Postado originalmente por ivovid Ver Post
    Caro Raniel
    tem como vc montar um passo a passo desta operação???

    AKI USO O HOTSPOT

    TENHO MEU FILHO "ABORECENTE" Q TA NA NET ATE ALTAS HORAS

    DESDE JA AGRADEÇO
    Olá amigo,
    O que tem que fazer é um profile com um tempo de sessão no máximo 30 segundos e com o adversiment da pag de bloqueio. Criar um script para buscar o nome do usuário e alterar apenas o profile. Depois faça um scheduler para executar os scripts. Aí para você voltar ao profile desbloqueado é só você fazer outro script-scheduler para voltar o profile dele.



  11. #11

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Olá amigo,
    O que tem que fazer é um profile com um tempo de sessão no máximo 30 segundos e com o adversiment da pag de bloqueio. Criar um script para buscar o nome do usuário e alterar apenas o profile. Depois faça um scheduler para executar os scripts. Aí para você voltar ao profile desbloqueado é só você fazer outro script-scheduler para voltar o profile dele.

    Caro Raniel

    muito obrigado por me responder + uma vez

    ok entendi q tenho q montar esses script e programa-los no scheduler

    vc teria esse script ai ?? ou poderia me orientar de como monta-los

    acho q seria util para + pessoas

  12. #12

    Padrão

    O que tem que fazer é isto meu amigo,
    Fazer um script para procurar o nome do cliente e bloquear
    Código :
    /ip hotspot user set "[B]joao[/B]" profile=block;
    Depois fazer outro para deslogar, caso ele esteja logado
    Código :
    /ip hotspot active remove [/ip hotspot active find user="[B]joao[/B]"];
    Por último fazer um para ativar
    Código :
    /ip hotspot user set "[B]joao[/B]" profile=Normal
    Agora é só fazer os schedulers.



  13. #13

    Padrão

    Outra coisa,
    Caso queira, pode fazer uma variável local para com os usuários e usar apenas uma regra para todos

    Na variável, coloque todos os clientes a serem bloqueados e desbloqueados:
    Código :
    :local clientes "joao","jose";
    :/ip hotspot user set "$clientes" profile=block;

    Código :
    :local clientes "joao","jose";
    :/ip hotspot active remove [/ip hotspot active find user="$clientes"];

    Código :
    :local clientes "joao","jose";
    :/ip hotspot user set "$clientes" profile=Normal;

    Isto é apenas uma introdução.

  14. #14

    Padrão

    OLÁ RANIEL COMO VAI... ESTIVE ACOMPANHANDO SEUS POSTs E VC TEM ME AJUDADO BASTANTE RANIEL POR FAVOR COMO EU PODERIA JOGAR MEUS CLIENTES PARA O PROFILE BLOQUEADO DO HOTSPOT ALTOMATICAMENTO EM UM HORARIO OU DIA DETERMINADO

    MUITO OBRIGADO RANIEL



  15. #15

    Padrão

    Usa a forma que postei nos dois posts e use dois scheduler para bloquear/desbloquear.

  16. #16

    Padrão

    Ola!
    Amigo sou novo no MK mas vc pode fazer na rb

    vai em
    wireless table ---> clique no nome do cliente que deseja estipular o horario----> clica em time --> agora é so configurar os horario e dias desejado.

    lembrando sua rb deve estar configurada pra autenticar por mac ok

    não sei se fui claro o meu aqui funciona assim e muito bem

    t+++