+ Responder ao Tópico



  1. #1

    Padrão Como criar um script para apagar e cache?

    Olá!
    Pessoal, estou com a seguinte duvida, como criar um script para apagar e cache? Já fiz de varias formas aqui e não obtive sucesso,consigo parar o cache e etc, mas não consigo fazer o comando clear rodar e conseguentemente limpar meu cache. Quero deixa esse script rodando uma vez por mês. Desde já, obrigado pela ajuda.

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.925
    Posts de Blog
    1

    Padrão

    vamu la
    cria um arquivo com nome da sua escolha com o seguinte conteudo


    ex:

    vi /usr/local/bin/clear_cache


    #!/bin/sh

    # --- Regra para não parar a navegação dos clientes ---#
    iptables -t nat -I POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT

    #--- Parando squid ---#
    killall -9 squid

    #--- Apagando Cache ---#
    rm -rf /diretorio do cache
    ex:
    rm -rf /var/cache/squid/*

    #--- Apagando log ---#
    rm -rf /diretorio do log
    ex:
    rm -rf /var/log/squid/*

    #--- Criando Estrutura do cache ---#
    squid -z

    #--- Iniciando squid ---#
    squid -D

    #--- Direionamento para o squid ---#
    iptables -t nat -D POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT


    valde o arquivo
    de a permissão de escrita para ele
    chmod +x /usr/local/bin/clear_cache

    e adicione ele na crontab

    crontab -e
    0 0 1 * * /usr/local/bin/clear_cache



    assim ele ira rodar o script as 00:00 do dia 1 de cada mes



  3. #3

    Padrão

    Citação Postado originalmente por Benatto Ver Post
    vamu la
    cria um arquivo com nome da sua escolha com o seguinte conteudo


    ex:

    vi /usr/local/bin/clear_cache


    #!/bin/sh

    # --- Regra para não parar a navegação dos clientes ---#
    iptables -t nat -I POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT

    #--- Parando squid ---#
    killall -9 squid

    #--- Apagando Cache ---#
    rm -rf /diretorio do cache
    ex:
    rm -rf /var/cache/squid/*

    #--- Apagando log ---#
    rm -rf /diretorio do log
    ex:
    rm -rf /var/log/squid/*

    #--- Criando Estrutura do cache ---#
    squid -z

    #--- Iniciando squid ---#
    squid -D

    #--- Direionamento para o squid ---#
    iptables -t nat -D POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT


    valde o arquivo
    de a permissão de escrita para ele
    chmod +x /usr/local/bin/clear_cache

    e adicione ele na crontab

    crontab -e
    0 0 1 * * /usr/local/bin/clear_cache



    assim ele ira rodar o script as 00:00 do dia 1 de cada mes
    Muito orbigado pelo esclarecimento. Esse conteudo me será útil demais, pois também vou utilizar proxy em paralelo. Mas na realidade esqueci de especificar no topico que as regras eram para o mikrotik, por isso se puder me passar também, ficarei ainda mais agradecido.

  4. #4

    Padrão

    Olá amigo,
    Discordando da limpeza do cache. Tá o script para a limpeza.

    Para o mikrotik 2.9.x

    /system script add name=cache_clear source="/ip web-proxy set enabled=no; \ /ip web-proxy clear-cache;"


    Para o mikrotik 3.x

    /system script add name=cache_clear source="/ip proxy set enabled=no; \ /ip web-proxy clear-cache;"

    Executar no tempo programado

    /system scheduler add name=clear_cache interval=30d start-date=da
    ta start-time=tempo on-event=cache_clear



  5. #5

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Olá amigo,
    Discordando da limpeza do cache. Tá o script para a limpeza.

    Para o mikrotik 2.9.x

    /system script add name=cache_clear source="/ip web-proxy set enabled=no; \ /ip web-proxy clear-cache;"


    Para o mikrotik 3.x

    /system script add name=cache_clear source="/ip proxy set enabled=no; \ /ip web-proxy clear-cache;"

    Executar no tempo programado

    /system scheduler add name=clear_cache interval=30d start-date=da
    ta start-time=tempo on-event=cache_clear
    não é só ir la em web-proxy, settings e dar um clear cache???

  6. #6

    Padrão

    Não.
    Primeiro teria que dar um disable para depois dar um clear-cache



  7. #7

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Não.
    Primeiro teria que dar um disable para depois dar um clear-cache
    Não deveria ter uma outra regra para desabilitar o desvio 80 e 3128 no Firewall antes de desabilitar o Web-Prox ?
    Assim os clientes não teriam problemas com a navegação durante a limpeza ...

  8. #8

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Não.
    Primeiro teria que dar um disable para depois dar um clear-cache
    Certo, esqueci do disable, mais não é mais facil doque ficar editando regras???



  9. #9

    Padrão

    Pode sim fazer uma regra para desabilitar a regra de redirecionamento.
    E é bem melhor fazer o script uma só vez do que ficar se preocupando em limpar o cache na mão todo mês.

  10. #10

    Padrão

    Algem Ja conceguio a Ragra para Limpar o Cache sem para a navegação?



  11. #11

    Padrão Script enable x Disable firewall filter

    Muito bom meninos funcionou perfeitamente muito obrigada.....
    Agora estou com um problema que nao consigo resolver sozinha,
    Estou tentando bloquear msn para alguns ips em horario de trabalho ( ate aqui tudo otimo e funcionando )
    Agora vem o problema eu quero liberar o acesso no horario de almoco, e nao consigo criar um script para que todo dias em um determinado horario eu desabilite a regra em ip firewall filter

    Ja tentei

    /ip firewall filter disable "numero da regra"

    para saber o numero dela vou em ip firewall filter print
    Assim obtenho o numero da regra.

    Desde ja agradeco a todos


  12. #12

    Padrão

    Citação Postado originalmente por luanarivitec Ver Post
    Muito bom meninos funcionou perfeitamente muito obrigada.....
    Agora estou com um problema que nao consigo resolver sozinha,
    Estou tentando bloquear msn para alguns ips em horario de trabalho ( ate aqui tudo otimo e funcionando )
    Agora vem o problema eu quero liberar o acesso no horario de almoco, e nao consigo criar um script para que todo dias em um determinado horario eu desabilite a regra em ip firewall filter

    Ja tentei

    /ip firewall filter disable "numero da regra"

    para saber o numero dela vou em ip firewall filter print
    Assim obtenho o numero da regra.

    Desde ja agradeco a todos

    Olá minha cara,
    Você pode fazer da seguinte forma:
    add um comment para a regra, tipo: dis_msn e ena_msn

    Depois fazer o seguinte script:

    /system script add name="msn_on" source="/ip firewall filter disable [/ip firewall filter find comment=ena_msn]"

    Depois é só fazer os schedulers de acordo com sua necessidade.

    Acredito que com base nisto você chegue a uma solução.



  13. #13

    Padrão Agradecimento

    Muitissimo obrigada...funcionou perfeitamente....