Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por cleivon Ver Post
    Amigo quero agradecer jua ajuda, e dizer que eu sou novo no mk, porem no meu não funcionou, digitei os script manualmente pois não consegui inserir pelo teminal,, mais gostaria de perguntar porque temos estes nomes todosolicy=\ftp,reboot,read,write,policy,test,w inbox,password,sniff
    no meu não encontrei o ftp e o w inbox? e resto fica marcado ou desmarcado? onde coloco este source=\
    "/ip route {set [find comment=GrupA] gateway=192.168.10.1 }´ colo o que esta entre aspas no campo abaixo. como maco o comemt do router?? os links estão ok quando cai conta o tempo e aparece down, porem não redireciona para o outro link. estou somente com uma máquina no link 1 para teste o link 2 e o mais usado, assim deixei todos nela até testar a regra. para depois dividir legual.

    abraço..

    o q ta acontecendo de errado e quando eu escrevo (winbox) aqui no post ele ta ficando separado ele tem que ficar junto.

    mas se vc quizer criar manualmente da pra fazrer tbm
    vc vai abri a aba ip depois scripts
    ai clica no + pra adicionar ai vc vai colocar o nome do primeiro escript (link1_on) e depois e so colar este comando no soucer: /ip route {set [find comment=GrupA] gateway=192.168.10.1 }
    e depois e so fazer com os outro (link1_off), (link2_on), (link2_off).

    e parte dos comentarios vc faz assim

    vc vai abri a aba ip depois routes

    procura seu dois gateway 192.168.10.2 nesse aki vc vai apertar com o botao direito encima dele e depois clica em comment e depois e so escrever (GrupA) e faça isso tbm no outro gateway 192.168.254.1 com o comment (GrupB).

  2. #22
    cleivon
    Visitante

    Padrão teste

    amigo efetuei mais teste, aqui. lembrando que para não atrapalhar os clientes loloquei no meu mangle a classe de ip assim ...0.0/25 e o outro ... 0.128/25 assim os clientes acima do ip 128 estão no link 1. coloquei uma maquina no ip 130, meus clientes neste server so vão ate o ...0.96
    pus o pc para pinguar externo no uol.com.br.. quando desligo o link 1. no scrip list no campo Run Count ele muda de 1 para 2 e sucesivamente nos dois lugares off e on.. porem não assume o outro gatw.. veja so.. no link1 off coloc o gatw do link2 e no link1-on o gatw do link1, assim se ele esta em up fica no seu gatw. se cai ´para down passa para o outro, não esta certo.. porque ele não direciona. lembrando que antes ele não contava no campo Run Count devido eu ter colocado no Source no inicio e no final da frase os acentos: " depois que tirei ele passau a contar, assim que cai o link conta no off e quando volta conta no on..
    Será que pode ser a versão.. uso a 2.9.51.. licenciada.
    agradeço muito pela sua cooperação..

    abraço.



  3. #23

    Padrão

    Citação Postado originalmente por cleivon Ver Post
    amigo efetuei mais teste, aqui. lembrando que para não atrapalhar os clientes loloquei no meu mangle a classe de ip assim ...0.0/25 e o outro ... 0.128/25 assim os clientes acima do ip 128 estão no link 1. coloquei uma maquina no ip 130, meus clientes neste server so vão ate o ...0.96
    pus o pc para pinguar externo no uol.com.br.. quando desligo o link 1. no scrip list no campo Run Count ele muda de 1 para 2 e sucesivamente nos dois lugares off e on.. porem não assume o outro gatw.. veja so.. no link1 off coloc o gatw do link2 e no link1-on o gatw do link1, assim se ele esta em up fica no seu gatw. se cai ´para down passa para o outro, não esta certo.. porque ele não direciona. lembrando que antes ele não contava no campo Run Count devido eu ter colocado no Source no inicio e no final da frase os acentos: " depois que tirei ele passau a contar, assim que cai o link conta no off e quando volta conta no on..
    Será que pode ser a versão.. uso a 2.9.51.. licenciada.
    agradeço muito pela sua cooperação..

    abraço.
    aqui esta tudo q vc precisa

    ROTA.txt

  4. #24
    cleivon
    Visitante

    Padrão Tudo Ok

    Ola Amigo,, copiei o que vc mandou e fiz assim como vc falou, porem os scripts não forão, assim decidi testar em uma vers. 3.17 e funcionou blz... agardeço a sua ajuda, obrigado mesmo..
    ficou joia, estu pensando até em vender meu load balance TTR 8400 da taitell Telecom.. assim ficou melho.. pelo MK..

    abraço.



  5. #25
    cleivon
    Visitante

    Padrão Proxi

    Ola amigos, alguem sabe me dizer se e possivel configurar proxi com este load 2 funcionando, tentei mais não consegui, como fica a regra no nat? e o bloqueio externo fica nos dois links ou duas regras uma para cada link?

    abraço.

  6. #26

    Padrão


    LOAD BALANCE 2

    Esse vc separa por grupos de usuarios da sua rede.

    Exemplo:

    Interface


    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:


    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

    galera agora vou colocar uns sripts para se for o caso de algum link cair:

    Regras:

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on




    cara, muito obrigado! era isso mesmo que eu precisava, devo testar isso ainda esse mes, mas me tire uma duvida, alias, tres duvidas.


    posso criar 4 grupos para 2 gatways ou poderia dar algum conflito?
    exemplo: grupo A e grupo C pelo gateway 10.10.10.1 e o grupo B e grupo D pelo gateway 20.20.20.1
    isso pq tenho maquinas com um limites de ip em cada sala, porem todos precisam estar na mesma faixa de ip (192.168.1.x). ai neste caso como ficaria a regra do script para o caso de um link cair o outro assumir?


    querendo entender melhor as suas regras, pela regra q vc criou em netwatch (interval=5m timeout=1s up), o MK testa a cada 5minutos se o link que caiu voltou a funcionar se o tempo de resposta dele for menor que 1segundo?


    tem como eu configurar o MK apenas editando e colando esses scripts ou tenho q fazer la pelo winbox marcando as caixinhas mesmo?rs


    e muuuuito obrigado pela ajuda!!!



  7. #27

    Padrão

    Amigo por gentileza essas regras funcionam com hotspot, estive tentando aqui e não obtive sucesso quanto ao funcionamento dos dois links










    Citação Postado originalmente por isacloko Ver Post
    galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

    LOAD BALANCE 1

    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!

    exemplo:

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra

    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra

    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10


    LOAD BALANCE 2

    Esse vc separa por grupos de usuarios da sua rede.

    Exemplo:

    Interface

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:


    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

    galera agora vou colocar uns sripts para se for o caso de algum link cair:

    Regras:

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


    exemplo 2

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24

    Regras

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.64
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.65-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupC" \
    disabled=no new-routing-mark=GrupC passthrough=no src-address=\
    192.168.0.129-192.168.0.192
    add action=mark-routing chain=prerouting comment="GrupD" \
    disabled=no new-routing-mark=GrupD passthrough=no src-address=\
    192.168.0.193-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10

    LOAD BALANCE 3

    esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.

    Mikrotik Versão 2.9

    exemplo:

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    Regras

    / ip firewall mangle
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no


    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no

    add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes

    Mikrotik 3.10 contendo 5 Links

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24
    Link5 ip - 50.50.50.1/24

    Regras

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link1 nth=4,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link1 \
    disabled=no in-interface=Rede new-routing-mark=link1 passthrough=no
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link2 nth=4,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link2 \
    disabled=no in-interface=Rede new-routing-mark=link2 passthrough=yes
    add action=mark-connection chain=prerouting comment=Link3 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link3 nth=4,2 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link3 \
    disabled=no in-interface=Rede new-routing-mark=link3 passthrough=no
    add action=mark-connection chain=prerouting comment=Link4 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link4 nth=4,3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link4 \
    disabled=no in-interface=Rede new-routing-mark=link4 passthrough=no
    add action=mark-connection chain=prerouting comment=Link5 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link5 nth=4,4 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link5 \
    disabled=no in-interface=Rede new-routing-mark=link5 passthrough=no
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=link2 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=link2 passthrough=yes routing-mark=link2
    add action=add-src-to-address-list address-list=ips address-list-timeout=0s \
    chain=prerouting comment="" disabled=no in-interface=Rede

    /ip firewall nat
    add action=src-nat chain=srcnat comment="" connection-mark=link1 disabled=no \
    to-addresses=10.10.10.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link2 disabled=no \
    to-addresses=20.20.20.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link3 disabled=no \
    to-addresses=30.30.30.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link4 disabled=no \
    to-addresses=40.40.40.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link5 disabled=no \
    to-addresses=50.50.50.1 to-ports=0-65535

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=link1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=link2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=link3 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=link4 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    50.50.50.1 routing-mark=link5 scope=30 target-scope=10


    Espero que ajude muita gente, qualquer duvida e so postar obrigado


  8. #28

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    cara, muito obrigado! era isso mesmo que eu precisava, devo testar isso ainda esse mes, mas me tire uma duvida, alias, tres duvidas.


    posso criar 4 grupos para 2 gatways ou poderia dar algum conflito?
    exemplo: grupo A e grupo C pelo gateway 10.10.10.1 e o grupo B e grupo D pelo gateway 20.20.20.1
    isso pq tenho maquinas com um limites de ip em cada sala, porem todos precisam estar na mesma faixa de ip (192.168.1.x). ai neste caso como ficaria a regra do script para o caso de um link cair o outro assumir?


    querendo entender melhor as suas regras, pela regra q vc criou em netwatch (interval=5m timeout=1s up), o MK testa a cada 5minutos se o link que caiu voltou a funcionar se o tempo de resposta dele for menor que 1segundo?


    tem como eu configurar o MK apenas editando e colando esses scripts ou tenho q fazer la pelo winbox marcando as caixinhas mesmo?rs


    e muuuuito obrigado pela ajuda!!!

    1 vc pode colocar a quantidade de gateway q vc quiser n da conflito n.

    2. isto mesmo a cada 5 minutos e a 1 ms, mas se vc usar algum tipo de sinal a radio pra receber internet aconcelho aumentar a taxa de ms.

    3 e so copiar e e editar e colar no new terminal.

    lembrando que no meu exemplo na parte dos scripts tem um negocinho errado onde ta ecrito (winbox) ai no exemplo ele saiu separado assim (w inbox) e so juntar.

    blz



  9. #29

    Padrão

    sim, eu recebo o sinal via radio, mas no seu script ta escrito "1s" seria 1segundo ou 1milesimo de segundo? pq se nao me engano 1segundo é 1000ms, oq seria mais q suficiente pra um sinal a radio....

    outras duvidas surgiram agora, se puder me fazer o favor de tira-las...

    acho q nao influencia, mas tira a duvida fazendo favor: o mk nao ta recebendo o link direto via wireless, ta chegando por um ap e descendo via cabo rj45 ate o mk, e o AP q recebo o sinal ta em bridge, e é a mesma faixa de ip de outros clientes da empresa q me fornece o link (da pra enchergar eles pelo AP), teria q fazer um nat nesse AP para uma outra faixa de ip? em ip/neighbors consigo ver outros MK na mesma faixa de ip que nao sao meus.


    depois de enviar as regras pelo new terminal, como faço para altera-las ou retirar essas regras?
    desculpe se for a pergunta for meio boba e nao relaconada ao load balance, é q nao tenho muita experiencia com isso ainda...rs


    o segundo link que estou pegando é de uma empresa diferente e eles passam dns diferente, ja ate testei pra ver se um dns serve pro outro link mas nao serve, parece q cada empresa tem seu proprio serv (ou cache) de dns.... e como eles sempre passam 2 dns (xxx.xxx.xxx.101 e xxx.xxx.xxx.102) como vou configurar isso?rs


    como ainda tava usando (e to usando) apenas um link na rede, eu tinha criado um cache de dns de 10mb (la no ip/dns do mk) e repassado aos clientes, de forma que o dns ficou o mesmo numero do meu gateway (ip do mk), mas como o mk apenas redireciona a minha requisao para outro dns externo (que é o dns da empresa q me fornece o link), como faço agora com 4 dns sendo q 2dns seria para um grupo e os outros 2 dns para o outro grupo?

    soluçao1:
    pego o dns de uma empresa (vou chamar de link1) e coloco no mk em ip/dns como primario e o dns primario da outra empresa (vou chamar de link2) e coloco no MK como secundario e mantenho o ip do meu MK como dns nos clientes

    soluçao2:
    desfaço esse meu cache de dns e coloco o dns de cada empresa nos clientes:
    grupo A dns primario e secundario do link1
    grupo B dns primario e secundario do link2

    acho q essa soluçao 2 traria outro problema, quando um link cair, o outro nao vai assumir, pois o dns é da outra empresa ne? mas na soluçao1 daria certo? acho q so teria q correr o risco do servidor de dns primario de uma das empresa nao dar problema e se der troco pelo secundario dentro do mk.

    isso tudo q falei seria mesmo necessario ou nem precisa???rs
    se tiver alguma pergunta mau formulada q nao intendeu me fala q tento explica de outra forma...rs

  10. #30

    Padrão

    Citação Postado originalmente por lelyrock Ver Post
    sim, eu recebo o sinal via radio, mas no seu script ta escrito "1s" seria 1segundo ou 1milesimo de segundo? pq se nao me engano 1segundo é 1000ms, oq seria mais q suficiente pra um sinal a radio....

    outras duvidas surgiram agora, se puder me fazer o favor de tira-las...

    acho q nao influencia, mas tira a duvida fazendo favor: o mk nao ta recebendo o link direto via wireless, ta chegando por um ap e descendo via cabo rj45 ate o mk, e o AP q recebo o sinal ta em bridge, e é a mesma faixa de ip de outros clientes da empresa q me fornece o link (da pra enchergar eles pelo AP), teria q fazer um nat nesse AP para uma outra faixa de ip? em ip/neighbors consigo ver outros MK na mesma faixa de ip que nao sao meus.


    depois de enviar as regras pelo new terminal, como faço para altera-las ou retirar essas regras?
    desculpe se for a pergunta for meio boba e nao relaconada ao load balance, é q nao tenho muita experiencia com isso ainda...rs


    o segundo link que estou pegando é de uma empresa diferente e eles passam dns diferente, ja ate testei pra ver se um dns serve pro outro link mas nao serve, parece q cada empresa tem seu proprio serv (ou cache) de dns.... e como eles sempre passam 2 dns (xxx.xxx.xxx.101 e xxx.xxx.xxx.102) como vou configurar isso?rs


    como ainda tava usando (e to usando) apenas um link na rede, eu tinha criado um cache de dns de 10mb (la no ip/dns do mk) e repassado aos clientes, de forma que o dns ficou o mesmo numero do meu gateway (ip do mk), mas como o mk apenas redireciona a minha requisao para outro dns externo (que é o dns da empresa q me fornece o link), como faço agora com 4 dns sendo q 2dns seria para um grupo e os outros 2 dns para o outro grupo?

    soluçao1:
    pego o dns de uma empresa (vou chamar de link1) e coloco no mk em ip/dns como primario e o dns primario da outra empresa (vou chamar de link2) e coloco no MK como secundario e mantenho o ip do meu MK como dns nos clientes

    soluçao2:
    desfaço esse meu cache de dns e coloco o dns de cada empresa nos clientes:
    grupo A dns primario e secundario do link1
    grupo B dns primario e secundario do link2

    acho q essa soluçao 2 traria outro problema, quando um link cair, o outro nao vai assumir, pois o dns é da outra empresa ne? mas na soluçao1 daria certo? acho q so teria q correr o risco do servidor de dns primario de uma das empresa nao dar problema e se der troco pelo secundario dentro do mk.

    isso tudo q falei seria mesmo necessario ou nem precisa???rs
    se tiver alguma pergunta mau formulada q nao intendeu me fala q tento explica de outra forma...rs



    1. n precisa fazer nat n, e so colocar normal o ip que vc recebe no mk em (address) e o gatway na rota que vc desejar (ip route), vc so vai ter problema se o ip que vc recebe fosse igual ao ip que vc joga na sua rede
    ex.
    entrada = 192.168.0.100
    saida (sua rede) = 192.168.0.1/24

    ai vc teria que trocar seu ip ou colocar seu AP como client isp (router).

    2. vc vai copiar e coloar no bloco de notas, depois vc edita o nome das interfaces e os ips, depois de tudo editado, e so colar la no new terminal e pronto.

    3. eu ficaria com a solucao1, coloque os dns no mk, e no cliente vc coloca o ip do seu MK como dns, so n esqueça de marca la no mk em ip dns allow request.



  11. #31

    Padrão

    entao ta traquilo, ficou mais facil q eu pensava...rs
    vou testar esse mes ainda e volto com os resultados...

    ultima duvida,
    depois q mando as regras via new terminal nao tem mesmo como reeditalas ou excluir apenas essas regras? penso se a regra nao der certo e precisar desfazer para voltar o sistema como antes.... ai pra corrigi-las eu teria fazer um backup antes e repor o backup depois? ou teria q formatar?

  12. #32

    Padrão

    [quote=isacloko;367255]galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas



    LOAD BALANCE 2

    Esse vc separa por grupos de usuarios da sua rede.

    Exemplo:

    Interface

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:


    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

    galera agora vou colocar uns sripts para se for o caso de algum link cair:

    Regras:

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


    Bom dia , Cara cadê o NAT do exemplo 2 ??? Não tem ?



  13. #33

    Padrão

    Citação Postado originalmente por isacloko Ver Post
    vc me poderia me passar suas regras no mikrotik pra mim da uma analizada do seu proxy paralelo?

    Amigo, sobre o load balance, de 2 links por grupos, posso fazer com PPOE? meus ips sao fixos, mais sao da mesma operadora

  14. #34

    Padrão Load Balance 1

    [quote=isacloko;367255]galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

    LOAD BALANCE 1

    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!

    exemplo:

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra

    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra

    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10

    ----------------------------
    Não estaria faltando um pedaço aqui?
    Em todas diz routing-mark="extra" mas não vi nenhum local onde se faça a marcação desta rota "extra".
    Alguém testou e verificou se funciona???

    Sou novo aqui, então desculpem qualquer deslize, ou se estiver fora das normas basta me avisarem.

    Obrigado



  15. #35

    Padrão

    [quote=rjunior543;379032]
    Citação Postado originalmente por isacloko Ver Post
    galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

    LOAD BALANCE 1

    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!

    exemplo:

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra

    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra

    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10

    ----------------------------
    Não estaria faltando um pedaço aqui?
    Em todas diz routing-mark="extra" mas não vi nenhum local onde se faça a marcação desta rota "extra".
    Alguém testou e verificou se funciona???

    Sou novo aqui, então desculpem qualquer deslize, ou se estiver fora das normas basta me avisarem.

    Obrigado
    ai e marcação da rota
    logo aqui


    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10

  16. #36

    Padrão bb...

    alguem teve problema com o site do banco do brasil? conseguiram resolver...



  17. #37

    Padrão qual melhor load balance??

    ola amigo!
    qual o melhor load balance pra mim?
    eu tenho 4m de adsl telefonica + 1m dedicado telefonica
    tenho um pc com mk rodando com uma 2 placa de rede. uma link e outra cliente.
    vc pode dar uma dica? ah eu uso hotspot login e senha + mac do cliente. tenho webycash rodando no memso mk.
    meu pc com mk faz tudo e tenho uma rb em modo brigde com 4 cartão 8602.

    oque mais eu tenho q informar para vc me orientar?

    fico grato desde de ja. pois ja estou pagando por mes 1200,00 no meu link e nao to aproveitando.
    me ajudem por favor. meu hotmail [email protected]

  18. #38

    Padrão

    Cara, preciso de sua ajuda....

    Seguinte, vou ser bem sincero contigo, eu to aprendendo agora sobre balanceamento de banda eu to totalmente cru, não sei nada ainda, mais preciso de resolver um problema URGENTE, espero mesmo que vc possa me ajudar...

    Vamos lá...

    Eu trabalho com HOTSPOT tenho uma torre base onde fica o meu Servidor e três torres de distribuição (trabalho com PC-AP), trabalho com ADSL, mais como a minha velocidade de ADSL já tava ficando comprometida, tive que pedir um outro ADSL, só que esse outro pedi num local diferente que não enxerga a torre base de distribuição, porém fica a 30 mts de uma das torres.

    Minhas dúvidas são:

    01 - Eu consigo fazer o balanceamento de banda tendo um ADSL numa torre e outro ADSL na outra torre;
    02 - Como configuro o balanceamento para que todas as torres utilizem ao mesmo tempo os 2 ADSL (como disse já peço desculpas, pois naum tenho idéia de onde começar).

    Conto com a ajuda de todos.....

    Obrigado...



  19. #39

    Padrão

    me ajuda a entender ver se esse diagrama que fiz esta certo.. ai me responde que te dou uma resposta, a imagem ta ai em anexo.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         test.JPG
Visualizações:	82
Tamanho: 	27,6 KB
ID:      	3936  

  20. #40

    Padrão

    Citação Postado originalmente por isacloko Ver Post
    me ajuda a entender ver se esse diagrama que fiz esta certo.. ai me responde que te dou uma resposta, a imagem ta ai em anexo.
    Cara, fez esse outro diagrama, vê se vc consegue entender, ele define bem como tem que ficar...

    Valeuss...
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         FORUM.JPG
Visualizações:	80
Tamanho: 	35,5 KB
ID:      	3946