Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por Aplink Ver Post
    Caro tmelooliveira,

    Essas configurações vc fez no servidor ou no AP ?

    Estou com o mesmo problema que vc. Tenho acesso via VPN, pingo todas as estações, mas o IP da minha RB eu não consigo pingar. Será que é o modo do ARP da interface, o meu está como ARP=Enable.
    Olá Aplink... como assim pinga as estações? Você quer dizer os clientes? Se sim é um indicio que alguma configuração da RB está errada... se vc usa controle IP x MAC você tem que liberar o mac da RB tambem e o mais obvio como falei mais acima... o gateway da sua RB tem que estar setada corretamente... até.

    PS: Não se preocupe, não é questão de arp... ou é configuração de rede errada ou então alguma regra de firewall.

  2. #22

    Padrão



    TheWawk, obrigado pela resposta. Consegui resolver o problema. Era o ARP mesmo.

    Eu faço o controle IP x MAC. O MAC da RB já estava liberado. Quando eu acessava o Servidor pelo winbox eu consiguia pingar a RB e acessá-la via Telnet. Mas quando conectava via VPN eu nao consigo pingar a RB diretamente da minha máquina.

    Fiz a alteração da interface que está ligada na RB para ARP:Proxy-arp e quando conectado via VPN comecei a pingar a RB e acessá-la via Winbox.

    Problema resolvido.

    Muito Obrigado



  3. #23

    Padrão

    Citação Postado originalmente por Aplink Ver Post

    TheWawk, obrigado pela resposta. Consegui resolver o problema. Era o ARP mesmo.

    Eu faço o controle IP x MAC. O MAC da RB já estava liberado. Quando eu acessava o Servidor pelo winbox eu consiguia pingar a RB e acessá-la via Telnet. Mas quando conectava via VPN eu nao consigo pingar a RB diretamente da minha máquina.

    Fiz a alteração da interface que está ligada na RB para ARP:Proxy-arp e quando conectado via VPN comecei a pingar a RB e acessá-la via Winbox.

    Problema resolvido.

    Muito Obrigado
    Estranho... bom se resolveu otimo... mas deve haver algum problema de roteamento para a sua rb, pois proxy-arp não é necessario em nenhum caso, mas blz então... até mais.

  4. #24

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá.... os gateways dos 2 equipamentos estão configurados corretamente? Pra acessa-los usando VPN toda a configuração de rede tem que estar ok... você fez o NAT para a faixa de ips da VPN? Até.
    Olá amigo, faz um favor, dê uma olhada 189.104.176.85 login:admin password:admin e me diga se falta algo ou se tem algo errado, eu conecto via VPN e acesso o servidor 192.168.10.1 mas o AP 192.168.10.2 ñ, valeu!



  5. #25

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá amigo, faz um favor, dê uma olhada 189.104.176.85 login:admin password:admin e me diga se falta algo ou se tem algo errado, eu conecto via VPN e acesso o servidor 192.168.10.1 mas o AP 192.168.10.2 ñ, valeu!
    Amigo faz isso, altera o profile da vpn e no lugar do local-ip 192.168.10.1 coloca 172.16.254.1, depois altera o pool da VPN para 172.16.254.2-172.16.254.10 e por ultimo faça um masquerade para essa faixa, só isso deve resolver o seu problema.... vc colocou a rede da vpn igual a sua rede de hotspot.... a vpn tem que ter uma rede só para ela ok... ai tá dando problema de roteamento... outra coisa você disse que o ap está com o ip 192.168.10.2, mas nem do seu proprio servidor eu consigo pingar ele... alias não consigo pingar nenhum cliente seu, deve haver alguma regra de firewall bloqueando, uma dica... coloca uma faixa de ip só para o seu radio... coloca por ex. 172.1.1.1/24 na ether1 do seu server e coloca o seu radio em 172.1.1.2/24 com gateway 172.1.1.1 e libere todo o forward entre a vpn e essa nova faixa do radio, até mais.

  6. #26

    Question

    Citação Postado originalmente por TheHawk Ver Post
    Olá amigo tmelooliveira, isso ai é simples.... ative o servidor PPTP do seu mikrotik principal, cadastre um login e uma senha pra vc e o um profile pro servidor pptp, dai você conecta por essa conexão pptp (que pode usar vpn ou não, fica ao seu criterio) e vc vai estar dentro da sua rede como se estivesse na rede local (e na verdade vc está na rede local, ), dai é só digitar no winbox o ip da rede local do seu pc-ap e acessar ele diretamente.... simples não .... espero ter ajudado, até mais.
    Amigo, sou iniciante no Mikrotik, aonde eu ativo essa opção "PPTP" ?

    Grato!



  7. #27

    Padrão

    Citação Postado originalmente por tubyou Ver Post
    Amigo, sou iniciante no Mikrotik, aonde eu ativo essa opção "PPTP" ?

    Grato!
    No seu winbox, entre em PPP, depois na aba Interfaces vai ter um botão chamado PPTP Server, lá estão as opções pra ativar o servidor PPTP, até.

  8. #28

    Padrão

    Ola The Hank, fiz o server PPtP como você falou,estou conseguindo estabelecer a conexao usando windows xp até o servidor mikrotik, mas logo apos estabelecer conexao, nao tenho acesso a nada na minha rede do mikrotik.O que pode ser??? No servidor mikrotik eu fiz o script do change ip:

    /tool dns-update nam=wmspot.changeip.net address=127.0.0.255 key-name=meuuser key=meu pass

    consigo acessar meu mikrotik de fora via winbox normalmente:

    meu modem está em bridge na ether1 , e na ether 2 estou usando a rede 192.168.0.1/24 e estou usando mascarede nat, na interface de saida, ether2 tenho dois nanos na com ip 192.168.0.7 e 192.168.0.6. no pptp usei a rede 192.168.2.1 como local addres e como remote addres botei um pool de 192.168.2.10-192.168.2.20. Meu objetivo e me conectar nesse servidor atraves do PPtP para ter acesso aos meus nanos!!! pode me ajudar????

    obrigado!!!



  9. #29

    Padrão

    Citação Postado originalmente por tmelooliveira Ver Post
    Ola amigos, com a ajuda do The Hawk e do Google, consegui fazer o que queria..

    Segue abaixo os codigos para colocar no Mikrotik!!

    Depois faça o passo que o The Hawk colocou ai em cima ^.

    / interface ethernet
    set ether1 name="ether1"

    / interface bridge
    add name="lan" arp=proxy-arp

    / interface bridge port
    add interface=ether1 bridge=lan

    / ip address
    add address=192.168.0.1/24 interface=lan

    / ip dns
    allow-remote-requests=yes

    / ip firewall service-port
    set gre disabled=no
    set pptp disabled=no

    / ip pool
    add name="pptp" ranges=192.168.0.200-192.168.0.229

    / ppp profile
    add name="pptp-in" local-address=192.168.0.1 remote-address=pptp use-encryption=required only-one=yes change-tcp-mss=yes dns-server=192.168.0.1

    / interface pptp-server server
    set enabled=yes max-mtu=1460 max-mru=1460 authentication=chap,mschap1,mschap2 default-profile=pptp-in

    / ppp secret
    add name="user-1" service=pptp password="******" profile=pptp-in
    add name="user-2" service=pptp password="******" profile=pptp-in
    # ...

    Depois é so configurar a conexão como o the hawk falou no XP!!

    Fonte - Wiki Mikrotik


    Grato!!

    Tiago

    Fiz exatamente como está e consegui conectar e tudo, só que só consigo pingar no servidor não consigo pingar em nenhuma outra máquina na rede, sabe de alguma coisa que possa me ajudar?

  10. #30

    Padrão

    /tool dns-update nam=wmspot.changeip.net address=127.0.0.255 key-name=meuuser key=meu pass


    O que seria esse script? seria para o mikrotik entender que o ip. 127.0.0.255, tem que ser convertido para o nome do changeip que voce criou?



  11. #31

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá amigo tmelooliveira, isso ai é simples.... ative o servidor PPTP do seu mikrotik principal, cadastre um login e uma senha pra vc e o um profile pro servidor pptp, dai você conecta por essa conexão pptp (que pode usar vpn ou não, fica ao seu criterio) e vc vai estar dentro da sua rede como se estivesse na rede local (e na verdade vc está na rede local, ), dai é só digitar no winbox o ip da rede local do seu pc-ap e acessar ele diretamente.... simples não .... espero ter ajudado, até mais.
    Amigo sou iniciante no mikrotik, estou tentando acompanhar lendo e relendo pra entender as regras e como funciona, vc poderia tirar uma duvida pra mim:

    eu faço todas essas regras que vc postou, (isso no mk que esta em outro bairro), aqui estou eu em uma lan house, crio um discador (conforme vc ensinou), e me conecto nele, seria apenas isso?
    se for.. como a internet da lan house vai saber que esse discador corresponde ao meu mk que esta em outro bairro? eu acesso ele remotamente, entao teria que entrar esse minha conta do changeip, em algum lugar pra fazer isso certo?

    desde ja te agradeço amigo,

  12. #32

    Padrão

    Citação Postado originalmente por TheHawk Ver Post
    Olá tmelooliveira, era exatamente isso ai que eu estava falando, só não tinha passado as configurações.... só não entendi pra que essa bridge ai no meio? e nem pra que esse proxy-arp... não precisa de nenhum dos 2, basta criar o servidor pptp, senha, usuario e pool de ips... e pronto.... espero ter ajudado, até mais.
    rsrsrsrsrsrs......



  13. #33

    Padrão

    Citação Postado originalmente por wellysson Ver Post
    Fiz exatamente como está e consegui conectar e tudo, só que só consigo pingar no servidor não consigo pingar em nenhuma outra máquina na rede, sabe de alguma coisa que possa me ajudar?
    faltarão as rotas

  14. #34

    Padrão

    voce fez os roteamentos????
    em ip>routes



  15. #35
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por francistomba Ver Post
    Amigo sou iniciante no mikrotik, estou tentando acompanhar lendo e relendo pra entender as regras e como funciona, vc poderia tirar uma duvida pra mim:

    eu faço todas essas regras que vc postou, (isso no mk que esta em outro bairro), aqui estou eu em uma lan house, crio um discador (conforme vc ensinou), e me conecto nele, seria apenas isso?
    se for.. como a internet da lan house vai saber que esse discador corresponde ao meu mk que esta em outro bairro? eu acesso ele remotamente, entao teria que entrar esse minha conta do changeip, em algum lugar pra fazer isso certo?

    desde ja te agradeço amigo,
    Amigo, você coloca essas regras no seu mikrotik, e quando você estiver na lan house, e criar a conexão vpn ( o discador), quando ele pedir o IP, você deve colocar o IP do adsl, (não o IP da sua rede ex. 192.168.0.X), mas como você disse que ja tem a conta no (changeip), coloque apenas esse endereço criado.
    (Assim que a internet da lan house vai saber que corresponde ao seu mk, srsrrssrsrs).
    abraços,

  16. #36

    Padrão

    Citação Postado originalmente por tmelooliveira Ver Post
    Ola amigos, com a ajuda do The Hawk e do Google, consegui fazer o que queria..

    Segue abaixo os codigos para colocar no Mikrotik!!

    / ip firewall service-port
    set gre disabled=no
    set pptp disabled=no


    Grato!!

    Tiago
    Grande Melo,

    eu uso uma rb450 com o mk 3.23 e nao consigo habilitar essa opção do GRE... indo em /ip firewall service-port... soh tem a opção pptp

    veja meu print:

    Código :
    print
    Flags: X - disabled, I - invalid 
     #   NAME                                                                 PORTS
     0   ftp                                                                  21   
     1   tftp                                                                 69   
     2   irc                                                                  6667 
     3   h323                                                                
     4   sip                                                                  5060 
                                                                              5061 
     5   pptp

    nao tem a opçao GRE e mesmo q eu digite: set gre disabled=no (ou yes).. dah erro.. item number invalid..

    alguma luz?



  17. #37

    Padrão

    E ai amigo, vou estudar seu caso e retorno, estava distante desse topico....

    Abraço Tiago

  18. #38

    Padrão

    Como faz estas rotas eu acho isso q esta faltando na minha configuraçao. Nao consigo pingar meu ap do servidor de forma alguma. O meu servidor tem dois endereços na porta q sai para o Hotspot uma 20.20.0.1 para os clientes e outra a 192.168.0.1 para o Ap, ja esta tudo certo no ap conforme esta escrito aqui.



  19. #39
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    Eu tava sem tempo de bolar algo pra acessar coloquei uma maquininha meia boca com windows 2003 server do lado do Mikrotik acesso ela via Terminal Service, instalei o Dude nela, os log do Mk sao gerados nele com isso tenho acesso total a rede e aos aps somente com regras nat do mk para o 2003

  20. #40

    Padrão

    Eu nao estava conseguindo acesar pesquisando no forum descubri o problema, é pq eu uso a função hotspot aqui tive q liberar o ip da RB la em hotspot - ip bindings - add coloquei o mac e o ip da RB e deixei no type bypassed. Dai funcionou tudo disquei no pptp e funcino tudo o resto como esta escrito ai. para quem uso hotspot tem q fazer isso se nao nao funciona