+ Responder ao Tópico



  1. #1

    Padrão Problemas com web-proxy versao 2.9.51

    Boa noite pessoal. Às vezes fico pensando e não consigo entender por quer
    Certas coisas acontecem, ou seja, foge a lógica. Em 1 dos meus servidores usei a versão do MK 2.9.27 cracked por mais de 1 ano e nunca tive problema com meu web-proxy no entanto, precisei utilizar alguns scripts e estes não funcionaram nesta versão, mesmo estando tudo correto. Foi quando um amigo aqui do fórum me sugeriu que trocasse a versão craked por a 2.9.51 registrada pois poderia ser problema da versão o motivo dos scripts não funfarem, assim o fiz e de imediato senti efeitos positivos, os scripts passaram a funcionar belezinha. Por outro lado passei a ter o seguinte problema: meu web - proxy com chache-full funciona em torno de 6 a oito dias normalmente, quando der repente algum cliente liga e pergunta se ta havendo algum problema no serve pois eles se conectam mas não conseguem navegar. Ai pelo winbox ao verificar o web - proxy ta La: "error logeed" se tento limpar o cachê apresenta o mesmo erro ae tento formatar o drivers visto que utilizo hd slave separado, é iniciada a formatação e depois de 15 segundos volta a apresentar o mesmo erro. Então retiro o HD e instalo o MK versão craked 2.9.27 nele e recoloco no servidor, ele aceita a formatação e volta a volta a funcionar normalmente no web - proxy. Alguém já passou por isso? Qual seria o mistério? Aguardo solução ou sugestão dos mais experientes. Um bom domingo para todos.
    Última edição por Mirandapb; 07-02-2009 às 23:27.

  2. #2
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Vou te dar uma solução não ortodoxica, mas vai resolver. Ok?

    System scripts > add > name = reboot > source > /system reboot

    System scheduler > add > name = reboot > start time 06:00:00 > interval 1d 00:00:00 > On event reboot



  3. #3

    Padrão

    Já observei algumas vezes qua quando clico em excluir o cache antes q ele tenha terminado de desligar ele dá um erro parecido...
    vc usa script para apagar o cache automatico?
    ja tentou ver se não é o tempo q ele leva pra desligar o cache q é muito curto... e começa a excluir mesmo antes de terminar a ação?

    testa e posta pra agente tentar te ajudar
    valeu

  4. #4
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Ontem estava vendo web-proxy de um cliente e ele estava com erro na configuração do tamanho da RAM usada. Olhe no log e acompanhe os erros (vermelho).



  5. #5

    Padrão

    Vou tentar a primeira solução que voce sugeriu, rebootar o sistema. Mas acredito que seria mais eficiente um script para limpar o cache no meu caso a cada 3 dias. mas ja tentei isso mas não consegui se alguem puder me ajudar nesse scripts ficarei bastante agradecido.

  6. #6
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Para o mikrotik 2.9.x

    /system script add name=cache_clear source="/ip web-proxy set enabled=no; \ /ip web-proxy clear-cache;"


    Para o mikrotik 3.x

    /system script add name=cache_clear source="/ip proxy set enabled=no; \ /ip web-proxy clear-cache;"

    Executar no tempo programado

    /system scheduler add name=clear_cache interval=3d start-date=da
    ta start-time=tempo on-event=cache_clear


    Autor RANIEL auterado para 3 dias.



  7. #7

    Padrão

    Amigo primeiramente quero agradecer pela sua boa vontade em colaborar, e assim que funfar esse script vou clicar no botao agradecer, mas acontece que ao mandar rodar o script ele para o cache o que ja é um bom inicio, mas não inicia a limpeza, acho que falta um cabelinho de sapo para rodar filé. Outro detalhe é que se não houver uma linha de script antes para adesativar a regra de redirecionamento do proxy, os clientes vao ficar sem navegação ate que o cache seja totalmente limpo e reiniciado. Me desculpa se eu estiver errado mas acredito que um script completo para essa tarefa deveria constar das seguintes ações: 1 - desativar o redirecionamento do proxy, 2 parar o cache(esse ja esta funfando) 3 limpar o cache e 4 reativar regra de redirecionamento do proxy bem como o cache.
    Última edição por Mirandapb; 09-02-2009 às 03:00.

  8. #8
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15
    Última edição por interhome; 11-02-2009 às 17:53.



  9. #9

    Padrão

    Ok InterHome esse script é realmente de minha autoria, acredito que voce não atentou para meu nome, veja que o autor do topico é o mesmo do link que me sugere. Assim que resolvi meu problema, resolvi compartilhar a experiencias criando esse mini tutorial, com a finalidade de ajudar a outros companheiros que desejam limpar seu cache de forma automatizada. De qualquer forma agradeço sua intenção.

  10. #10
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Tenho andado com muito trabalho e pouco tenho tido tempo para fazer um monte de coisas. Quando vi o tutorial lembrei que era o que voce queria. Passei aqui rapido para colocar e sai. De qualquer forma ontem tive um problema que a muito tempo não me pertubava. Erro 504 Http Proxy. Para te falar a verdade não sei como resolver. Agora quem esta com problemas sou eu.
    Tudo de bom.