Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #7
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    Para funcionar:

    Se vc colocar uma maquina ligado e apontanda diretamente para o seu squid, tem que navegar.

    Logo apos no mk,

    Nao pode ter um drop no firewall, para teste rapido marcar todas as regras do firewall e desabilite

    Faz um nat da rede do seu squid, para teste,

    /ip firewall nat

    add

    chain dstnat action masquerade

    Tem que navegar

    Caso não, de traceroute para um site, tipo www.uol.com e veja aonde esta parando

  2. #8

    Padrão

    Agradeço muito a atenção, tenho empenhado muito tempo na tentativa de fazer com que o proxy no debian funcione sem a necessidade do parent proxy do mikrotik.

    mais ta um pouco complicado, vou postar detalhes da minha conf.

    ether1 link ip da operadora
    ether 2 clientes 10.0.0.1/24
    ether 3 debian 192.168.200.1/24

    o debian ta com 192.168.100.2 e ja navegando com o squid habilitado

    só quero redirecionar as requisições da porta 80 dos clientes para a 3128 do squid sem o uso do web-proxy do mikrotik.



  3. #9
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    / ip firewall nat
    add chain=dstnat src-address=10.0.0.0/24 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.100.2 to-ports=3128 \
    comment="NAT - Proxy" disabled=no

  4. #10
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    Esse camarada fez um sistema que roda em debian e disponibiliza a versao 2 para baixar gratuitamente para quem só quer usar o squid.

    Manual :: MK-AUTH



  5. #11

    Padrão

    Citação Postado originalmente por interhome Ver Post
    / ip firewall nat
    add chain=dstnat src-address=10.0.0.0/24 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.100.2 to-ports=3128 \
    comment="NAT - Proxy" disabled=no
    ERROR

    The requested URL could not be retrieved

    ta dando esse erro quando habilito a regra

  6. #12
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.111
    Posts de Blog
    15

    Padrão

    / ip firewall nat
    add chain=dstnat src-address=10.0.0.0/24 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.200.1 to-ports=3128 \
    comment="NAT - Proxy" disabled=no

    Estava errado o ip do debian, o debian é 192.168.200.1 ? Caso não coloque o ip da interface do Debian.