+ Responder ao Tópico



  1. #1

    Padrão Squid nao entra paginas Banco Real,Globo.com,Squid-Cache.org,etc

    Ola a todos,

    Possuo instalado em minha makina um Slack 12 com um Squid 3.0 Stable 8 com ZPH,bem,tentei com outras versoes porem continuo com o mesmo problema,caso alguem saiba como posso resolver pelo amor de deus,agradeceria mto..

    Nao entra em site da globo.com,squid-cache.org,bancoreal.com.br,bem alguns sites no genero assim somente,os outros carregam tudo 100% tanto n osquid 3.0 tanto no 2.6,2.7 bem em fim,nao sei oque ocorre,se talvez as paginas tenham alguma particularidade entre elas que nao abrem sem adicionar um parametro na instalacao ou desativar algum servico nao sei...a pagina fica aguarde,carregando e dali nao sai..somente essas assim..

    Segue squid.conf

    Código :
    http_port 3128 transparent
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    cache_mem 64 MB
    maximum_object_size 40 MB
    cache_dir aufs /var/cache/squid 5000 16 256
    access_log none
    cache_store_log none 
    allow_underscore on #ja tentei com ou sem check_hostname,e tbm sem o allow_underscore msm
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access allow all
    http_reply_access allow all
     
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off
    zph_preserve_miss_tos on
     
    forwarded_for off
    coredump_dir /var/cache/squid
    detect_broken_pconn on
    pipeline_prefetch on

    Caso alguem tenha uma luz agradeceria mto ao pessoal do forum,

    Grande abracos a todos,

    Gustavo
    Última edição por tskstar; 27-02-2009 às 14:17.

  2. #2
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Tenta rodar o squid com esse comando

    squid -Dd 3

    Depois, posta a saída do comando.



  3. #3

    Padrão

    Citação Postado originalmente por osmano807 Ver Post
    Tenta rodar o squid com esse comando

    squid -Dd 3

    Depois, posta a saída do comando.

    Segue a saida:

    Código :
    [email protected]:/usr/etc# squid -Dd 3
    [email protected]:/usr/etc# 2009/02/27 14:28:02| Starting Squid Cache version 3.0.STABLE8 for i686-pc-linux-gnu...
    2009/02/27 14:28:02| Process ID 2946
    2009/02/27 14:28:02| With 1024 file descriptors available
    2009/02/27 14:28:02| DNS Socket created at 0.0.0.0, port 39569, FD 7
    2009/02/27 14:28:02| Adding domain gnet.com from /etc/resolv.conf
    2009/02/27 14:28:02| Warning: Could not find any nameservers. Trying to use localhost
    2009/02/27 14:28:02| Please check your /etc/resolv.conf file
    2009/02/27 14:28:02| or use the 'dns_nameservers' option in squid.conf.
    2009/02/27 14:28:02| User-Agent logging is disabled.
    2009/02/27 14:28:02| Referer logging is disabled.
    2009/02/27 14:28:02| Unlinkd pipe opened on FD 11
    2009/02/27 14:28:02| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    2009/02/27 14:28:02| Store logging disabled
    2009/02/27 14:28:02| Swap maxSize 5120000 KB, estimated 393846 objects
    2009/02/27 14:28:02| Target number of buckets: 19692
    2009/02/27 14:28:02| Using 32768 Store buckets
    2009/02/27 14:28:02| Max Mem  size: 65536 KB
    2009/02/27 14:28:02| Max Swap size: 5120000 KB
    2009/02/27 14:28:02| Version 1 of swap file with LFS support detected...
    2009/02/27 14:28:02| Rebuilding storage in /var/cache/squid (DIRTY)
    2009/02/27 14:28:02| Using Least Load store dir selection
    2009/02/27 14:28:02| Set Current Directory to /var/cache/squid
    2009/02/27 14:28:02| Loaded Icons.
    2009/02/27 14:28:02| Accepting transparently proxied HTTP connections at 0.0.0.0, port 3128, FD 12.
    2009/02/27 14:28:02| HTCP Disabled.
    2009/02/27 14:28:02| Ready to serve requests.
    2009/02/27 14:28:02| Done reading /var/cache/squid swaplog (36 entries)
    2009/02/27 14:28:02| Finished rebuilding storage from disk.
    2009/02/27 14:28:02|        36 Entries scanned
    2009/02/27 14:28:02|         0 Invalid entries.
    2009/02/27 14:28:02|         0 With invalid flags.
    2009/02/27 14:28:02|        36 Objects loaded.
    2009/02/27 14:28:02|         0 Objects expired.
    2009/02/27 14:28:02|         0 Objects cancelled.
    2009/02/27 14:28:02|         0 Duplicate URLs purged.
    2009/02/27 14:28:02|         0 Swapfile clashes avoided.
    2009/02/27 14:28:02|   Took 0.01 seconds (2551.92 objects/sec).
    2009/02/27 14:28:02| Beginning Validation Procedure
    2009/02/27 14:28:02|   Completed Validation Procedure
    2009/02/27 14:28:02|   Validated 97 Entries
    2009/02/27 14:28:02|   store_swap_size = 276
    2009/02/27 14:28:03| storeLateRelease: released 0 objects

    Ah...ai tentei entrar no site da globo.com ele deu assim oh

    Código :
    [email protected]:/usr/etc# 2009/02/27 14:28:45| clientNatLookup: NF getsockopt(SO_ORIG INAL_DST) failed: (92) Protocol not available
    2009/02/27 14:28:46| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:28:46| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:28:49| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:09| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:10| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:10| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:11| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:11| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:12| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:12| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:12| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:13| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:13| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:29:13| ZPH: Preserving TOS on miss, TOS=0
    2009/02/27 14:30:36| clientNatLookup: NF getsockopt(SO_ORIGINAL_DST) failed: (92 ) Protocol not available
    Última edição por tskstar; 27-02-2009 às 14:34.

  4. #4
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Isso pelo que vi, é um módulo iptables não carregado:

    modprobe ip_conntrack



  5. #5

    Padrão

    Citação Postado originalmente por osmano807 Ver Post
    Isso pelo que vi, é um módulo iptables não carregado:

    modprobe ip_conntrack


    Obrigado osmano,pela dica,mais como faço para corrigir,no caso tenho somente que executar esse comando no konsole e nada mais ?

    Pois encerrei o squid,digitei isso,iniciei dnvo e infelizmente continua ainda..

    Sera que estou fazendo certo a regra de NAT no mikrotik para o cache ?

    Estou usando dst-nat,segue codigo abaixo,

    que estou usando na tabela de NAT do Mikrotik,

    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Masquerade PROXY" disabled=no \
        src-address=10.111.1.2
    add action=masquerade chain=srcnat comment="Masquerade Clientes" disabled=no \
        src-address=192.168.168.0/24
    add action=accept chain=dstnat comment="" disabled=yes dst-address=10.111.1.2 \
        dst-port=80 protocol=tcp src-address=10.111.1.2
    add action=dst-nat chain=dstnat comment="" disabled=yes dst-address=\
        !201.11.70.157 dst-port=80 in-interface=Cliente protocol=tcp src-address=\
        192.168.168.0/24 to-addresses=10.111.1.2 to-ports=3128

    Obrigado pela atencao e colaboracao em me ajudar,nao sei mais oque fazer amigo..

    Grande abcs

    Gustavo

  6. #6

    Padrão

    bastante estranho esse erro.. talvez seu squid nao tenha sido compilado corretamente

    digite

    squid -v

    e cole aqui



  7. #7

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    bastante estranho esse erro.. talvez seu squid nao tenha sido compilado corretamente

    digite

    squid -v

    e cole aqui
    Ola,obrigado a voces 2 pela help ai!

    Jaja estarei na empresa ai colo a vocês a saida do squid -v...

    Bem referente a compilacao,na hora de fazer os parametros,ali no ./configure,tenho que utilizar algum parametro especial em si ? Ja tentei com alguns parametros que vi no topico de nosso amigo Mr. RG e ja tentei sem nada tambem,nao sei se teria algum parametro que seria interessante colocar...

    Nao manjo mto de linux,estou nele a 6 meses ainda,conto a ajuda de vocês,isso esta me tirando o sono..

    Obrigado amigos,

    Gustavo

  8. #8

    Padrão

    Bem galera,

    Agora andei percebendo algumas coisas..

    Agora o linux aqui,o slack,nao esta abrindo mesmo sem o squid sem instalado,ou seja acabei de formatar e maquina e coloca o slack limpo e esses 3 sites continuam nao abrindo,ou seja o problema nao deve estar no squid,e sim no slack...alguem tem alguma ideia do que pode ser ? Provavelmente o problema esta no S.O. mesmo...caso alguem tenha alguma luz...

    Grande abcs,

    Gustavo



  9. #9

    Padrão

    Um legítimo pitaco de quem não entende de squid e linux, mas esses sites parecem ter em comum o https (porta 443).

  10. #10

    Padrão

    Citação Postado originalmente por lfaria Ver Post
    Um legítimo pitaco de quem não entende de squid e linux, mas esses sites parecem ter em comum o https (porta 443).
    Mais o site do squid-cache.org,globo.com creio que nao tenham https nao ? agora o real com ctz deve ter..

    Mais mto estranho,na makina ao lado WinXP roda tudo ok,sem proxy sem nada neh..agora essa makina aonde estou instalando o proxy,com ou sem squid ele nao abre esses sites..bizarro..

    Olha..sei la qq pode ser,se tvz alguma coisa q falta iniciar no slack,algum parametro,nao sei..



  11. #11

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Mais o site do squid-cache.org,globo.com creio que nao tenham https nao ? agora o real com ctz deve ter..

    Mais mto estranho,na makina ao lado WinXP roda tudo ok,sem proxy sem nada neh..agora essa makina aonde estou instalando o proxy,com ou sem squid ele nao abre esses sites..bizarro..

    Olha..sei la qq pode ser,se tvz alguma coisa q falta iniciar no slack,algum parametro,nao sei..

    amigo, seu problema não seria o dns?

    tenta configurar o nameserver no arquivo resolv.conf com outros dns

  12. #12

    Padrão

    Bem primeira gostaria de agradecer a todos pela ajuda que prestaram,e pelo bom interesse!

    O problema foi localizado,estava no Mikrotik,na RB que foi atualizada para a versao 3.20,ai as configuracoes foram transferidas e tudo mais,masi tinha algo errado mesmo assim,afinal ja estava de cabelo em pe mais nao pensei no mais logico...

    Bem resolvi entao dar um system > reset > no mikrotik,refiz rede basico,somente definindo IP da ether1 (router wireless),ether2 (LINUX) e o wlan1 (Conectando via PPPoE com a minha torre como cliente),bem tudo funcionou 100% ate agora a navegacoa,irei instalar o squid e fazer os testes em 30minutos postarei de volta se estara tudo funcionando ok!

    Acredito que na mudanca de versao deva ter ocorrido algum problema ai..vai entender..

    Abracos a todos,

    Gustavo