+ Responder ao Tópico



  1. #1

    Smile Qual hardware usar no proxy squid

    Ola pessoal, pesso a ajuda de vcs para decidirmos o que é melhor. Tenho um servidor MKT 3.20 com 512 de memoria e um compactflash de 256MB ele sera só pra gerenciar os controles, o cache eu faço no squid 2.6 STABLE5 a duvida é um seguinte tenho duas configurações aki e queria saber qual é melhor pra colocar pois tenho um QUADCORE com 4GB de memoria e HD de 500GB e o outro é um PENTUM4 2GHZ e 1GB de memoria e HD de 80GB, tenho 80 clientes qual eu uso para o servidor de cache linux squid o quadcore ou o pentum 4? o quadcore nao seria um disperdicio de maquina ou quanto mais potente melhor o q os senhores achão? Obs: o squid esta integrado no MKT e não em PARENT PROXY. Aguardo a ajuda dos senhores para decidir OK. vlw pessoal.

  2. #2

    Padrão

    ola amigo, gostaria de uma ajuda sua...

    fugindo um pouco da sua duvida, vejo que voce conseguiu fazer a integracao entre squid e mikrotik. Como voce fez isso?
    eu fiz por parent proxy mas n achei legal, teria como vc me ensinar a fazer isso??

    agradeceria muito a sua ajuda.



  3. #3

    Padrão

    vai de quad core mais vc tem que usar um distribuição que reconheça seu processador eu indicaria o debin 5 que saiu esse ano ate por ter um maior gantidade de hardware que ele vai reconhecer e o tambem colocaria os seus 4 gigas de memorias ou ate mais vai ficar uma maquina muito boa para proxy com as configuraçoes adequadas

  4. #4

    Padrão

    Citação Postado originalmente por dbenedito Ver Post
    vai de quad core mais vc tem que usar um distribuição que reconheça seu processador eu indicaria o debin 5 que saiu esse ano ate por ter um maior gantidade de hardware que ele vai reconhecer e o tambem colocaria os seus 4 gigas de memorias ou ate mais vai ficar uma maquina muito boa para proxy com as configuraçoes adequadas

    Vlw pela dica irmão nao sabia desse debian 5, vou baixa-lo e testar. te mais... brigaduuu...



  5. #5

    Padrão

    Citação Postado originalmente por debughacker Ver Post
    ola amigo, gostaria de uma ajuda sua...

    fugindo um pouco da sua duvida, vejo que voce conseguiu fazer a integracao entre squid e mikrotik. Como voce fez isso?
    eu fiz por parent proxy mas n achei legal, teria como vc me ensinar a fazer isso??

    agradeceria muito a sua ajuda.

    Claro q posso irmão, lembrando que eu nao sou fera em linux nem mikrotik, estou começando, essa configuração que fiz foi um amigo meu que me passou mas só funciona com o mikrotik versão 3.x. Vou postar as regras do MK e o squid.conf blz...

  6. #6

    Padrão

    PERAE PERAE PERAE
    VC ESTA QUERENDO DIZER QUE VC INSTALOU O SQUID NO MIKROTIK ???????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

    NAO PODE SER

    VC NAO ESTA ENGANADO NÃO???



  7. #7

    Padrão

    Como assim o squid 2.6 STABLE5 funciona só no MK 3 que regras são essas? vou acompanhar !!!

  8. #8
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Bom, para reconhecer os 4GB de memória RAM, tem que instalar a versão 64bits. Ah, talvez tenha que ver sobre o squid utilizar os 4 cores, acho que já implementaram multicore, mas vamos ver.



  9. #9

    Padrão

    Citação Postado originalmente por marcosddc Ver Post
    PERAE PERAE PERAE
    VC ESTA QUERENDO DIZER QUE VC INSTALOU O SQUID NO MIKROTIK ???????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

    NAO PODE SER

    VC NAO ESTA ENGANADO NÃO???

    Não amigo estou usando o squid em uma maquina e o MKT em outra, o cache é feito no squid estou usando ele ( o squid) ligado a um suite e no mesmo suite eu conectei o MKT e fiz um DST-NAT entendeu... blz direcionando a porta 80 para a porta 3128 do squid. qualquer coisa pode perguntar ok

  10. #10

    Padrão

    Citação Postado originalmente por WWANInternet Ver Post
    Como assim o squid 2.6 STABLE5 funciona só no MK 3 que regras são essas? vou acompanhar !!!

    desculpa amigo nao me expressei direito, na verdade o q nao conseguimos fazer funcionar com essas regras foi o cache full, no 2.9.27 funcionou bacana mas o cache full não, nao q nao funcione axo q um safo no MK consegue, ai testamos a versão 3.x e ficou file fazendo o cache no squid e o proxy full funcionando blz. vlw...



  11. #11

  12. #12

    Padrão

    Vou Postar aqui a configuração com as regras para colocar no MK já com o cache FULL (lembrando que com essas regras o cache full só funciona na versão 3.x, se algum de vcs souber uma regra para 2.9.27 que funcione o cache full posta ae que ficarei muito agradecido, e vou postar o meu squid.conf. Vamos lá...
    Lembrando que o debian e o mikrotik tem que estar na mesma faixa de ip
    No mikrotik vc fará uma outra interface e colocara a faixa de ip dos clientes ok.

    Topologia: LINK=è SUITE =è do suíte sai um cabo para o servidor debian e outro para o Mikrotik. Ok
    Sevidor debian 01 placa de rede
    Servidor mikrotik 02 placas de rede

    Primeiro instale o debian
    Depois do debian instalado execute esses comandos para instalar os programas que vc ira usar.
    Aptitude upgrade
    Aptitude install ssh (precisa do cd do debian para conluir a instalação)
    Aptitude install squid

    Depois coloque o squid.conf desse jeito alterando o ip, cachê mem, e o resto do seu jeito.

    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128 transparent
    visible_hostname webproxy


    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.2.1/24
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid/access.log

    #cache.log
    cache_log /var/log/squid/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 512 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 20 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0


    Regras no MIKROTIK

    192.168.2.3 ip do servidor debian
    O ip do mikrotik sera 192.168.2.2

    /Ip firewall nat

    add chain=dstnat src-address=192.168.2.3 dst-address=192.168.2.3 protocol=tcp dst-port=80 action=accept comment="Cache Full" disabled=no

    add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.3 to-ports=5128 comment="" disabled=no



    fazer masquerade
    masquerade em out interface coloca a do link e só



    / ip firewall mangle
    add chain=forward content="X-Cache: HIT" action=mark-connection new-connection-mark=forward-hits passthrough=yes comment="Cache Full" disabled=no
    add chain=forward connection-mark=forward-hits src-address-list="" action=mark-packet new-packet-mark=cache-hits passthrough=no comment="" disabled=no

    add chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes comment="" disabled=no


    /ip firewall mangle
    add action=mark-connection chain=forward comment="Cache Full" content="X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=yes
    add action=mark-packet chain=forward comment="" connection-mark=forward-hits disabled=no new-packet-mark=cache-hits passthrough=no src-address-list=""
    add action=mark-connection chain=postrouting comment="" disabled=no dscp=48 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=no

    Bom pra funcionar o básico é isso o resto vc já sabe, firewall etc...
    Primeiro faça testes veja se esta ok pra depois colocar pros clientes pois cada caso é um caso funcionou filé aki. Vlw...



  13. #13

    Padrão Que isso !!

    Quer fazer o squid voar !?!?! heheheh
    o squid não utiliza tanto do processador, o que ele gosta é de memoria RAM muita mesmo, quanto mais melhor.
    te aconselho colocar esse P4 ai pra rodar e utilizar esses 4GB de memoria e esse HD de 500

    *maximum_object_size para 100 MB (tamanho dos arquivos cache no HD)

    *aumenta o cache_mem 3072 (deixando 1 GB livre para o sistema)

    *cache_dir ufs /var/spool/squid 460800 256 512 (Capacidade de Armazenamento para 450GB deixando 50GB para sistema)

    fica aqui a minha opnião
    Última edição por magrock; 17-03-2009 às 03:05.

  14. #14

    Padrão

    Opa, valeu pela dica irmão me ajudou muito vlw mesmo....



  15. #15
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    poh cara legal... mas pensando assim... com tanta memoria e processador ,,,, nao seria melhor fazer o squid rodar em duas ou tres instancias???.... eu estou fazendo o mk com o thunder-cache que faz cache de youtube globo windowsupdate redtube terra uol globo, ele eh mto bom mas queria rodar um segundo squid2 na mesma maquina mas fazendo cache comum de paginas... eu to com um makina core 2 duo com 4gb de memoria, vou ver se consigo testar ela nas torres amanha a sua config do mk vai me ajudar mto pois ainda tava perdido nessa parte...

  16. #16
    Avatar de evil_inside
    Ingresso
    Aug 2004
    Localização
    Bagé, Rio Grande do Sul, Brazil, Brazil
    Posts
    275

    Padrão

    se vc tem 80 clientes o P4 vai sobrar maquina.
    conseguira c/ ele ir até uns 300 clientes, dependendo do uso deles.

    o meu proxy era um athlon64 3200+ c/ 1gb e hd de 80gb SATA, aguentou até 600 clientes, rodando squid 2.6 num slackware 12

    agora estou c/ um dual xeon 3.2 c/ 2gb e 2hd scsi em raid0, c/ slackware 12.2 e squid2.6 stable13



  17. #17

  18. #18

    Padrão

    Não sei se foi mensionado Rafael procure não armazenar arquivos muito grande no seu servidor proxy, cache de até 4096kb seria um ideal (Mesmo eu achando muito).
    Também instale um indexador, tem por exemplo o ecache no seu servidor pois o Squid ele insiste em fazer cache duas vezes da mesma coisa.
    Pra instalação te recomendaria o ubuntu server que é o de mais simples configuração, caso você entenda, parta para o Slackware ou para o SuSE



  19. #19

    Padrão

    Opa vlw pela dica irmão... tai nao sabia disso vlw mesmo...