Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por O-Ren Ver Post
    Já que o amigo citou tempo de experiencia com mikrotik, eu também tenho pouco tempo.
    Mas gostaria de saber a quanto tempo o nosso amigo CATV e Raniel tem de experiencia com mikrotik.
    Minha humilde experiência com Mikrotik:

    Já participei de quase 10 treinamentos de mikrotik, inclusive o primeiro que foi realizado no Brasil (realizado pela INDEX do méxico), trabalho a mais de 4 anos com este sistema, construi o primeiro manual passo a passo do mikrotik (a qual está beirando 200 mil acessos, só no under), mandei traduzir o manual original (em inglês do Mikrotik), sou consultor oficial da Mikrotik, realizo treinamentos privados em empresas e provedores, atendo a prefeituras em vários estados, já atendi um total de mais de 700 empresas pelo Brasil, participei e palestrei no MUM-SP e etc...

    Só tenho essa pouca experiência.


  2. #22

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Minha humilde experiência com Mikrotik:

    Já participei de quase 10 treinamentos de mikrotik, inclusive o primeiro que foi realizado no Brasil (realizado pela INDEX do méxico), trabalho a mais de 4 anos com este sistema, construi o primeiro manual passo a passo do mikrotik (a qual está beirando 200 mil acessos, só no under), mandei traduzir o manual original (em inglês do Mikrotik), sou consultor oficial da Mikrotik, realizo treinamentos privados em empresas e provedores, atendo a prefeituras em vários estados, já atendi um total de mais de 700 empresas pelo Brasil, participei e palestrei no MUM-SP e etc...

    Só tenho essa pouca experiência.

    Olá catvbrasil!

    Eu também não tive muito êxito com marcações da porta 80, tive muita lentidão da rede, pois o numero de requisições na mesma representa um consumo de 70% do meu link, por isso pensei em fazer QoS na porta 80 porém sem sucesso, foi a partir dai que coloquei um proxy na minha topologia, primeiramente em paralelo mas depois mudei as configurações e criei um DNAT para o squid, dentro dessa situação onde hoje tenho um proxy na rede não vejo como marcar a porta 80 sem afetar tbm o desempenho do proxy, ou seja sem proxy já nao obtive muito sucesso e com proxy fiquei totalmente sem ideia de como fazer QoS na porta 80.

    Peço que o amigo nos dê uma idéia matematica de como fazer marcação na porta 80 com sucesso.

    Abraços



  3. #23

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    Olá catvbrasil!

    Eu também não tive muito êxito com marcações da porta 80, tive muita lentidão da rede, pois o numero de requisições na mesma representa um consumo de 70% do meu link, por isso pensei em fazer QoS na porta 80 porém sem sucesso, foi a partir dai que coloquei um proxy na minha topologia, primeiramente em paralelo mas depois mudei as configurações e criei um DNAT para o squid, dentro dessa situação onde hoje tenho um proxy na rede não vejo como marcar a porta 80 sem afetar tbm o desempenho do proxy, ou seja sem proxy já nao obtive muito sucesso e com proxy fiquei totalmente sem ideia de como fazer QoS na porta 80.

    Peço que o amigo nos dê uma idéia matematica de como fazer marcação na porta 80 com sucesso.

    Abraços
    Normalmente o problema da lentidão está relacionada a outros fatores. O que seria o mangle? O mangle é apenas um marcador, nada mais. O simples fato de marcar a porta 80 não irá acontecer nada... O erro pode está acontecendo na hora de colocar esses pacotes marcados em uma QoS ou algo do tipo. Quer ver como tenho razão? Muitos aqui não sabem para que serve as opções global-in, global-out e global-total, em queue tree e fazem o emprego errônio destas funções. Depois não querem que fique tudo uma bosta.

  4. #24

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Normalmente o problema da lentidão está relacionada a outros fatores. O que seria o mangle? O mangle é apenas um marcador, nada mais. O simples fato de marcar a porta 80 não irá acontecer nada... O erro pode está acontecendo na hora de colocar esses pacotes marcados em uma QoS ou algo do tipo. Quer ver como tenho razão? Muitos aqui não sabem para que serve as opções global-in, global-out e global-total, em queue tree e fazem o emprego errônio destas funções. Depois não querem que fique tudo uma bosta.

    Olá!

    Quando falei de marcação (conexões e pacotes) no mangle me referia a QoS em sí (resumo de palavras), pois sei que para existir QoS em sua forma mais clássica e convencional no MK usa-se o mangle para marcar conexões e pacote e posteriormente a queue tree para estabelecer o controle do que esta marcado usando os parâmetros Global-in = Representa todas as interfaces de entrada, Global-out = representa todas as intrerfaces de saida, e ou Global-total = Representa uma interface virtual através da qual todos os dados da rede atravessam tanto o que entra como o que sai, ex: bridge.

    Minha duvida não é quanto a ferramenta, mas sim quanto a idéia matemática do negócio especificamente para a porta 80.

    Abraços



  5. #25

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    Olá!

    Quando falei de marcação (conexões e pacotes) no mangle me referia a QoS em sí (resumo de palavras), pois sei que para existir QoS em sua forma mais clássica e convencional no MK usa-se o mangle para marcar conexões e pacote e posteriormente a queue tree para estabelecer o controle do que esta marcado usando os parâmetros Global-in = Representa todas as interfaces de entrada, Global-out = representa todas as intrerfaces de saida, e ou Global-total = Representa uma interface virtual através da qual todos os dados da rede atravessam tanto o que entra como o que sai, ex: bridge.

    Minha duvida não é quanto a ferramenta, mas sim quanto a idéia matemática do negócio especificamente para a porta 80.

    Abraços
    Como você está montando sua QoS? Manda sua regra do mangle apenas da porta 80 e as regras do queue tree.

    Sobre o global-in, global-out e global-total, vc quase acertou:

    Global-in = Representa todo o tráfego de entrada (idependente da interface)
    Global-out = Representa todo o tráfego de saída (idependente da interface)
    Global-total = Representa todo o tráfego de entrada e saída das interfaces

    Note que todas as interfaces, possuem tráfego de entrada e saída. Então há um grande erro, que o pessoal acha que global-in, por exemplo, representa apenas a interface pública e que global-out, representa apenas a interface de saída dos clientes. Ae quando se monta a QoS, fica uma bosta. Saiba que o Mikrotik não sabe diferenciar o que é interface pública ou interface de clientes. Ele só entende o que é tráfego de entrada ou tráfego de saída, independente da interface.

    Se você pega por exemplo e marca a porta 80 e coloca em uma QoS, desta forma:

    Erro comum 1 (to cansado de pegar em servidores alheios):

    /queue tree
    Global-in, porta 80, 200k
    Global-out, porta 80, 500k


    Todos os clientes irão ser limitados dentro destes valores, tanto na entrada dos dados (upload), tanto na saída dos dados (download) e tem mais, os valores definidos são compartilhados para todos os clientes, que por sua vez, deverão brigar por ele... Imagine ae, uma QoS errada, dizendo que a banda de download é de 500k para 500 clientes.

  6. #26

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Como você está montando sua QoS? Manda sua regra do mangle apenas da porta 80 e as regras do queue tree.

    Sobre o global-in, global-out e global-total, vc quase acertou:

    Global-in = Representa todo o tráfego de entrada (idependente da interface)
    Global-out = Representa todo o tráfego de saída (idependente da interface)
    Global-total = Representa todo o tráfego de entrada e saída das interfaces

    Note que todas as interfaces, possuem tráfego de entrada e saída. Então há um grande erro, que o pessoal acha que global-in, por exemplo, representa apenas a interface pública e que global-out, representa apenas a interface de saída dos clientes. Ae quando se monta a QoS, fica uma bosta. Saiba que o Mikrotik não sabe diferenciar o que é interface pública ou interface de clientes. Ele só entende o que é tráfego de entrada ou tráfego de saída, independente da interface.

    Se você pega por exemplo e marca a porta 80 e coloca em uma QoS, desta forma:

    Erro comum 1 (to cansado de pegar em servidores alheios):

    /queue tree
    Global-in, porta 80, 200k
    Global-out, porta 80, 500k


    Todos os clientes irão ser limitados dentro destes valores, tanto na entrada dos dados (upload), tanto na saída dos dados (download) e tem mais, os valores definidos são compartilhados para todos os clientes, que por sua vez, deverão brigar por ele... Imagine ae, uma QoS errada, dizendo que a banda de download é de 500k para 500 clientes.
    Olá

    Entendi perfeitamente, e muito obrigado pelo esclarecimento, mas acho que nao me fiz entender de forma mais especifica no assunto, vai parecer que estamos discutindo semântica, mas é importante para todos qualquer esclarecimento, então vamos lá:

    Em redes de computadores, interface representa um meio físico ou lógico para diversos fins (interação, comunicação, compatibilidade, representação etc etc e tal)

    Entao no assunto em questão o parânetro Global-in é um meio lógico para entrada de dados, consecutivamente Global-out para saida e Global-total para entrada/saida de dados, resumindo, qual o entendimento que isso nos tráz?

    Que os parametros citado acima sao interfaces, ou seja meios lógicos para um determinado fim,
    ex:
    Global-in (Ingress queue)
    Global-out (Egress queue)
    Global-total (Ingress/Egress queue)
    respectivamtente, fila de entrada de dados, fila de saida de dados e fila entrada/saida de dados.

    Então no post nao me referí a um meio fisico (Interface Publica ou de Clientes ex: ether1, wlan1 etc...)

    Abraços



  7. #27

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    Olá

    Entendi perfeitamente, e muito obrigado pelo esclarecimento, mas acho que nao me fiz entender de forma mais especifica no assunto, vai parecer que estamos discutindo semântica, mas é importante para todos qualquer esclarecimento, então vamos lá:

    Em redes de computadores, interface representa um meio físico ou lógico para diversos fins (interação, comunicação, compatibilidade, representação etc etc e tal)

    Entao no assunto em questão o parânetro Global-in é um meio lógico para entrada de dados, consecutivamente Global-out para saida e Global-total para entrada/saida de dados, resumindo, qual o entendimento que isso nos tráz?

    Que os parametros citado acima sao interfaces, ou seja meios lógicos para um determinado fim,
    ex:
    Global-in (Ingress queue)
    Global-out (Egress queue)
    Global-total (Ingress/Egress queue)
    respectivamtente, fila de entrada de dados, fila de saida de dados e fila entrada/saida de dados.

    Então no post nao me referí a um meio fisico (Interface Publica ou de Clientes ex: ether1, wlan1 etc...)

    Abraços
    hehehehe... traquilo!!!

    Só faltou suas regras...

  8. #28

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    hehehehe... traquilo!!!

    Só faltou suas regras...
    As regras eu não as tenho mais, pois á 2 meses atraz tirei o pczinho que tinha como roteador e coloquei uma RB1000, entao nao me preocupei com backup da regras, estou sem QoS no momento, mas ja determinei que vou aplicar esse recurso na minha rede a partir da segunda-feira.
    Mas basicamente o que tinha era algo assim:

    exemplo somente da porta 80 e 443 (trafego http e https)

    HTTP:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="HTTP Connection" disabled=yes dst-port=80 new-connection-mark=http_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="HTTP Packet" connection-mark=http_conn disabled=yes new-packet-mark=http_packet passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3000000 name=http-in packet-mark=http_packet parent=global-in priority=2 \
    queue=default-small

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3000000 name=http-in packet-mark=http_packet parent=global-out priority=2 \
    queue=default-small


    HTTPs:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="HTTPs Connection" disabled=yes dst-port=443 new-connection-mark=https_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="HTTPs Packet" connection-mark=https_conn disabled=yes new-packet-mark=https_packket passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=1024000 name=https-in packet-mark=https_packket parent=global-in \
    priority=2 queue=default-small

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=1024000 name=https-in packet-mark=https_packket parent=global-out \
    priority=2 queue=default-small

    O tráfego não chegava estorando o max-limit, porem o desemprenho da rede ficava terrivel.

    Abraços
    Última edição por rrinfor; 15-03-2009 às 17:21.



  9. #29

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    ...
    Só lembrando que aqui devemos compartilhar com as pessoas as coisas certas. Asneiras ou exibicionismo só para parecer que saber muito, não serão toleradas, beleza?
    Pois é amigo,
    Nesta parte concordo inteiramente contigo.

  10. #30

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Como você está montando sua QoS? Manda sua regra do mangle apenas da porta 80 e as regras do queue tree.

    Todos os clientes irão ser limitados dentro destes valores, tanto na entrada dos dados (upload), tanto na saída dos dados (download) e tem mais, os valores definidos são compartilhados para todos os clientes, que por sua vez, deverão brigar por ele... Imagine ae, uma QoS errada, dizendo que a banda de download é de 500k para 500 clientes.
    ola David,

    entendi sua dica, mas e no meu caso que não dou limite para a porta 80, e mesmo assim da lentidão na rede?
    deixo ai um export, se poder tirar essa duvida tenho certeza que sera de muita utilidade para todos.
    abraços.

    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=proxy passthrough=yes \
    comment="PROXY FULL" disabled=no
    add chain=output connection-mark=proxy action=mark-packet \
    new-packet-mark=proxy-full passthrough=yes comment="" disabled=no
    add chain=input protocol=tcp dst-port=8291 action=mark-connection \
    new-connection-mark=acesso-winbox passthrough=yes comment="WINBOX" \
    disabled=no
    add chain=prerouting connection-mark=acesso-winbox action=mark-packet \
    new-packet-mark=winbox passthrough=no comment="" disabled=no
    add chain=prerouting protocol=tcp src-port=80 action=mark-packet \
    new-packet-mark=www_in passthrough=no comment="WWW" disabled=no
    add chain=postrouting protocol=tcp dst-port=80 action=mark-packet \
    new-packet-mark=www_out passthrough=no comment="" disabled=no
    add chain=prerouting protocol=udp src-port=53 action=mark-packet \
    new-packet-mark=dns_in passthrough=no comment="DNS" disabled=no
    add chain=postrouting protocol=udp dst-port=53 action=mark-packet \
    new-packet-mark=dns_out passthrough=no comment="" disabled=no
    add chain=prerouting protocol=icmp action=mark-packet new-packet-mark=icmp_in \
    passthrough=no comment="ICMP" disabled=no
    add chain=postrouting protocol=icmp action=mark-packet \
    new-packet-mark=icmp_out passthrough=no comment="" disabled=no
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p-regra passthrough=yes comment="REGRAS P2P" \
    disabled=no
    add chain=prerouting connection-mark=p2p-regra action=mark-packet \
    new-packet-mark=p2p passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp src-port=64872-64875 action=mark-connection \
    new-connection-mark=conn_hotspot passthrough=yes comment="DEIXAR PAGINA DE \
    LOGIN SEM CONTROLE DE BANDA" disabled=no
    add chain=output protocol=tcp src-port=64872-64875 action=mark-connection \
    new-connection-mark=conn_hotspot passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=conn_hotspot action=mark-packet \
    new-packet-mark=pacotes_hotspot passthrough=yes comment="" disabled=no
    add chain=output connection-mark=conn_hotspot action=mark-packet \
    new-packet-mark=pacotes_hotspot passthrough=yes comment="" disabled=no
    add chain=prerouting src-mac-address=00:05:00:20:8F:67 action=mark-connection \
    new-connection-mark="marcar por mac" passthrough=yes comment="MARCAÇÃO POR \
    MAC " disabled=yes
    add chain=prerouting connection-mark="marcar por mac" action=mark-packet \
    new-packet-mark="marcando mac" passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=21 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes \
    comment="Marcando Pacotes Sem Limite Conexao - 192.168.0.1/24" disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=22 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=23 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=25 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=53 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=80 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=110 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=443 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=8080 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no
    add chain=forward src-address=192.168.0.0/24 protocol=tcp dst-port=6891-6901 \
    action=mark-packet new-packet-mark=semlimite passthrough=yes comment="" \
    disabled=no


    / queue tree
    add name="p2p down-block" parent=global-in packet-mark=p2p limit-at=0 \
    queue=default priority=8 max-limit=100000 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="p2p up-block" parent=global-out packet-mark=p2p limit-at=0 \
    queue=default priority=8 max-limit=50000 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="proxy-full" parent=global-out packet-mark=proxy-full limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="winbox" parent=global-total packet-mark=winbox limit-at=0 \
    queue=default priority=2 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="www in" parent=global-in packet-mark=www_in limit-at=0 queue=default \
    priority=2 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    add name="www out" parent=global-out packet-mark=www_out limit-at=0 \
    queue=default priority=2 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="dns in" parent=global-in packet-mark=dns_in limit-at=0 queue=default \
    priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    add name="dns out" parent=global-out packet-mark=dns_out limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="icmp in" parent=global-in packet-mark=icmp_in limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="icmp out" parent=global-out packet-mark=icmp_out limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="pag hotspot" parent=global-total packet-mark=pacotes_hotspot \
    limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no



  11. #31

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    As regras eu não as tenho mais, pois á 2 meses atraz tirei o pczinho que tinha como roteador e coloquei uma RB1000, entao nao me preocupei com backup da regras, estou sem QoS no momento, mas ja determinei que vou aplicar esse recurso na minha rede a partir da segunda-feira.
    Mas basicamente o que tinha era algo assim:

    exemplo somente da porta 80 e 443 (trafego http e https)

    HTTP:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="HTTP Connection" disabled=yes dst-port=80 new-connection-mark=http_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="HTTP Packet" connection-mark=http_conn disabled=yes new-packet-mark=http_packet passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3000000 name=http-in packet-mark=http_packet parent=global-in priority=2 \
    queue=default-small

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3000000 name=http-in packet-mark=http_packet parent=global-out priority=2 \
    queue=default-small


    HTTPs:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="HTTPs Connection" disabled=yes dst-port=443 new-connection-mark=https_conn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="HTTPs Packet" connection-mark=https_conn disabled=yes new-packet-mark=https_packket passthrough=no

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=1024000 name=https-in packet-mark=https_packket parent=global-in \
    priority=2 queue=default-small

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=1024000 name=https-in packet-mark=https_packket parent=global-out \
    priority=2 queue=default-small

    O tráfego não chegava estorando o max-limit, porem o desemprenho da rede ficava terrivel.

    Abraços
    Onde você colocou "global-in" e "global-out", experimenta trocar pelas ether dos clientes e a ether pública.

  12. #32

    Padrão

    FIZ O PROCEDIMENTO MAS DA ERRO AO COPIAR O ARQUIVO QUANDO ENTRO EM FILE E TENTO COPIAR O ARQUIVO PARA ABRIR COM O BLOCO DE NOTAS



  13. #33

    Padrão

    DEPOIS DE MUITAS TENTATIVAS CONSEGUI EXPORTAR DA UMA ANALIZADA NESSAS REGRAS POR FAVOR... CONTO COM SUA EXPERIENCIA AMIGO PARA PODER ME DAR UMA MAOZINHA

    / ip firewall mangle
    add chain=forward p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p_conn passthrough=yes comment="Marcar Todo Trafego \
    p2p" disabled=no
    add chain=forward connection-mark=p2p_conn action=mark-packet \
    new-packet-mark=p2p passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=msn action=mark-packet \
    new-packet-mark=msn passthrough=yes comment="MSN" disabled=no
    add chain=prerouting protocol=tcp src-port=1024-65535 dst-port=1863 \
    action=mark-packet new-packet-mark=msn passthrough=yes comment="" \
    disabled=no
    add chain=prerouting packet-mark=pop3 action=mark-packet new-packet-mark=pop3 \
    passthrough=yes comment="Controle POP3" disabled=no
    add chain=prerouting protocol=tcp src-port=1024-65535 dst-port=110 \
    action=mark-connection new-connection-mark=pop3 passthrough=yes comment="" \
    disabled=no
    add chain=output protocol=tcp src-port=3122 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=Squid-Connection \
    passthrough=yes comment="Cache full" disabled=no
    add chain=output connection-mark=Squid-Connection action=mark-packet \
    new-packet-mark=squid-paket passthrough=yes comment="" disabled=no
    add chain=output protocol=tcp src-port=3122 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=Squid-Connection \
    passthrough=yes comment="Cache full" disabled=yes
    add chain=output connection-mark=Squid-Connection action=mark-packet \
    new-packet-mark=squid-paket passthrough=yes comment="" disabled=yes
    add chain=forward p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p_conn passthrough=yes comment="Marcar Todo Trafego \
    p2p" disabled=yes
    add chain=forward connection-mark=p2p_conn action=mark-packet \
    new-packet-mark=p2p passthrough=yes comment="" disabled=yes
    add chain=prerouting connection-mark=msn action=mark-packet \
    new-packet-mark=msn passthrough=yes comment="MSN" disabled=yes
    add chain=prerouting protocol=tcp src-port=1024-65535 dst-port=1863 \
    action=mark-packet new-packet-mark=msn passthrough=yes comment="" \
    disabled=yes
    add chain=prerouting packet-mark=pop3 action=mark-packet new-packet-mark=pop3 \
    passthrough=yes comment="Controle POP3" disabled=yes
    add chain=prerouting protocol=tcp src-port=1024-65535 dst-port=110 \
    action=mark-connection new-connection-mark=pop3 passthrough=yes comment="" \
    disabled=yes
    add chain=output protocol=tcp src-port=3122 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=Squid-Connection \
    passthrough=yes comment="Cache full" disabled=yes
    add chain=output connection-mark=Squid-Connection action=mark-packet \
    new-packet-mark=squid-paket passthrough=yes comment="" disabled=yes
    add chain=output protocol=tcp src-port=8291 action=mark-connection \
    new-connection-mark=WINBOX_FULL passthrough=yes comment="WINBOX" \
    disabled=no
    add chain=output connection-mark=WINBOX_FULL action=mark-packet \
    new-packet-mark=Winbox_Full passthrough=yes comment="" disabled=no
    add chain=output connection-mark=WINBOX_FULL action=return comment="" \
    disabled=no