+ Responder ao Tópico



  1. #1

    Padrão Redirecionar de uma site para outro

    Pesquisei bastante e não encontrei nada especificamente para mikrotik, preciso que quando um cliente acessar um determinado site www.site-xxx.com ele seja redirecionado para o site www.YYY.com, não se trata de um bloqueio e sim um redirecionamento de um determinado site para outro site determinado nas configurações, não sei se é possível, caso alguem tenha uma solução eu agradeço!

  2. #2

    Padrão

    quando uso web-proxy faço assim:


    /ip proxy access
    add action=deny comment="" disabled=no dst-host=www.site1.com.br redirect-to=site2.com.br
    Última edição por allstrit; 08-03-2009 às 21:50.



  3. #3

    Padrão

    Citação Postado originalmente por allstrit Ver Post
    quando uso web-proxy faço assim:


    /ip proxy access
    add action=deny comment="" disabled=no dst-host=www.site1.com.br redirect-to=site2.com.br

    Tem algo errado nesse script ai!
    eu acho, pois lá ñ tem esse campo redirect-to

  4. #4

    Thumbs up

    Olá Amigos!

    AllSTRIT está correto !

    A Regra Para MK 3.XX é a seguinte, não esquecendo que o Web Proxy tem que estar rodando !

    /ip proxy access
    add action=deny comment="redirecionamento de sites" disabled=no dst-host=www.google.com.br redirect-to=www.terra.com.br


    Isso não é script, é uma regra!!!

    Você deve ta usando uma versão pirata ou outra anterior a 3.XX

    Para Versão pirata ou anterior a 3.XX a regra é diferente !

    Procure configurar corretamente seu Web Proxy e Usar a regra certa para a versão certa!!!

    No fórum tem bastante material sobre este assunto então e só ter tempo para garimpar!

    Abraços a todos!
    Última edição por Giovani.couto; 09-03-2009 às 00:14.



  5. #5

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Olá Amigos!

    AllSTRIT está correto !

    A Regra Para MK 3.XX é a seguinte, não esquecendo que o Web Proxy tem que estar rodando !

    /ip proxy access
    add action=deny comment="redirecionamento de sites" disabled=no dst-host=www.google.com.br redirect-to=www.terra.com.br


    Isso não é script, é uma regra!!!

    Você deve ta usando uma versão pirata ou outra anterior a 3.XX

    Para Versão pirata ou anterior a 3.XX a regra é diferente !

    Procure configurar corretamente seu Web Proxy e Usar a regra certa para a versão certa!!!

    No fórum tem bastante material sobre este assunto então e só ter tempo para garimpar!

    Abraços a todos!
    Obrigado pelo esclarecimento, a versão do meu MK é anterior a 3.xx (2.9.27), já dei uma garimpada pelo forum mas ainda ñ encontrei nada tratando especificamente desse caso!... vou continuar procurado!

  6. #6

    Padrão

    Use o DNS do mikrotik para fazer isto.
    Coloque o nome do site que será redirecionado e o ip do site para onde será redirecionado.
    Name: exemplo.com (ip: 198.65.23.5)
    Address: 198.56.4.85 (www.site.com.br)



  7. #7

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Use o DNS do mikrotik para fazer isto.
    Coloque o nome do site que será redirecionado e o ip do site para onde será redirecionado.
    Name: exemplo.com (ip: 198.65.23.5)
    Address: 198.56.4.85 (www.site.com.br)

    Sinceramente, ñ entendi... fiz assim:
    ip > DNS > Static
    em ADD só tenho a opção DNS Static Entry <>
    e os campos
    NAME:
    Anddress:
    TTL:

  8. #8

    Thumbs up

    Olá Amigo!

    Não tenho como testar o que você quer pois não tenho essa versão rodando no meu sistema, mas.......
    Tive olhando com calma o seu caso e vi que e meio complicado de fazer na versão 2.9.27!

    Mas achei uma maneira de redirecionar um site para outro!
    Só tem um inconveniente que vou comentar depois !


    Primeiro descubra os endereços ips dos sites!

    ping -->Google = 74.125.77.103

    ping -->Terra - Notícias, vídeos, esportes, economia, diversão, música, moda, fotolog, blog, chat = 200.176.3.142

    Agora vamos ao winbox em IP / Firewall / Nat

    E coloca esta regra acima do Mascaramento de sua rede!
    Coloque esta regra pelo winbox manualmente! Não tente ir pelo terminal, pois pode não dar certo por causa das versões!

    chain=dstnat dst-address=74.125.77.103 protocol=tcp dst-port=80 action=dst-nat to-addresses=200.176.3.142 to-ports=80


    Talvez possa digitar o endereço WWW.yyy.com.br do site direto no address e talvez o mikrotik faça a conversão do endereço! Como foi no meu!

    O inconveniente!

    O Cliente verá o site do terra mas na barra do endereço estará o Google ! Testei aqui e ficou desta maneira!
    Até Mais!!!
    Última edição por Giovani.couto; 09-03-2009 às 20:56.



  9. #9

    Thumbs up

    To bom La em cima não sei por que saiu o endereço da propaganda do terra e também não saiu o WWW e também o com.br !

    Acho que deu pra entender!

    Até mais!!!

  10. #10

    Padrão

    O que falei foi o seguinte:
    Temos o site www.site1.com.br que atende pelo ip: 192.168.2.5, por exemplo e o site www.site2.com.br que atende pelo ip 172.16.2.4
    O que faremos no mikrotik é apenas uma troca destes sites. Se eu quiser que o site1 seje redirecionado para o site2 eu coloco no dns o nome do site1 e o ip do site2 e vice-versa.



  11. #11

    Padrão

    Realmente funcionou q foi uma beleza, exatamente como vc falou, ficou o endereço de um site e o conteúdo de outro, mas ta ótimo...
    Obrigado pela atenção!!

  12. #12

    Padrão

    Qualquer coisa... estamos por ae.