+ Responder ao Tópico



  1. #1

    Padrão DDNS através do MK

    1 - Criei uma página , no NO-IP estou tentando abrir;
    2 - Ai Abre a página do MIKROTIK, ou seja a tela do webbox 2.9.27 ao invés da abrir a página que hospedei na web!
    3 - Se tiver alguma mudança que possa fazer no servidor MK, para resolver este problema eu agradeço muito.

    Se Alguém poderia me ajudar????

    Agradeço.

    horfew
    Última edição por Horfew; 08-03-2009 às 18:39.

  2. #2

    Padrão

    Aguarda alguma alternativa!!
    Última edição por Horfew; 08-03-2009 às 18:40.



  3. #3

    Padrão

    Não sei pq um SO do porte do MK não tem suporte a DDNS!!

    Qualquer firmware tem, no BrazilFW tem...

  4. #4

    Padrão

    pois é!!
    eu até consegui um scrip mas não funcionou!

    :global ddnsuser horfew
    :global ddnspass 250785
    :global ddnshost consultoriarb.dns-dns.com
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("CHANGEIP: NENHUM IP PRESENTE PARA SER ENVIADO NA INTERFACE" . $ddnsinterface . ", VERIFIQUE POR FAVOR!")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "CHANGEIP: IP ATUALIZADO COM SUCESSO!"
    :log info [ : put [/tool dns-update name=$ddnshost address=[: pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    }
    }

    este ai é o scrip!! esta desse jeito no server



  5. #5

    Padrão

    Você usa modem em Bridge? ou Roteado/Link?

    Se for no modo roteado, basta redirecionar a porta 80 do modem para a maquina onde você vai usar o No-IP para ter acesso a pagina na qual quer hospedar (Essa configuração você faz no proprio modem).

    Se for no modo Bridge você pode tentar trocar a porta que o MK usar para a internet em IP/Services de "www - porta 80" para "www - porta 8080" deixando livre a porta 80 para sua pagina que deseja hospedar. Nunca testei isso no modo bridge.

    Citação Postado originalmente por Horfew Ver Post
    1 - Criei uma página , no NO-IP estou tentando abrir;
    2 - Ai Abre a página do MIKROTIK, ou seja a tela do webbox 2.9.27 ao invés da abrir a página que hospedei na web!
    3 - Se tiver alguma mudança que possa fazer no servidor MK, para resolver este problema eu agradeço muito.

    Se Alguém poderia me ajudar????

    Agradeço.

    horfew

  6. #6

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    Você usa modem em Bridge? ou Roteado/Link?

    Se for no modo roteado, basta redirecionar a porta 80 do modem para a maquina onde você vai usar o No-IP para ter acesso a pagina na qual quer hospedar (Essa configuração você faz no proprio modem).

    Se for no modo Bridge você pode tentar trocar a porta que o MK usar para a internet em IP/Services de "www - porta 80" para "www - porta 8080" deixando livre a porta 80 para sua pagina que deseja hospedar. Nunca testei isso no modo bridge.
    tentei mas não foi!!



  7. #7

    Thumbs up DDNS no MKT 2.9.27

    Use esse script, tenho certeza que funciona. Crie um novo script com o nome de DDNS e copie e cole o codigo abaixo.


    Código :
    :log info "DDNS: Begin"
    :global ddns-user "username"
    :global ddns-pass "password"
    :global ddns-host "username.dns1.us"
    :global ddns-interface "interfacedolinkdeinternet"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={ 
    :log info "DDNS: No change" 
    }
    }
    :log info "DDNS: End"

    adicione tambem um scheduler com o nome de RUN DDNS, com um intervalo de 5 minutos e em On event coloque DDNS


    ****** preste atenção nas aspas, elas tem que estar no texto. Esse script funciona muito bem no mkt. Agora, se você hospedou uma página em um host na rede interna, você tera que criar um dst nat para a porta 80, ou a porta que você escolheu, neste ip.

  8. #8

    Padrão

    Citação Postado originalmente por douglasesmeriz Ver Post
    Use esse script, tenho certeza que funciona. Crie um novo script com o nome de DDNS e copie e cole o codigo abaixo.


    Código :
    :log info "DDNS: Begin"
    :global ddns-user "username"
    :global ddns-pass "password"
    :global ddns-host "username.dns1.us"
    :global ddns-interface "interfacedolinkdeinternet"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={ 
    :log info "DDNS: No change" 
    }
    }
    :log info "DDNS: End"
    adicione tambem um scheduler com o nome de RUN DDNS, com um intervalo de 5 minutos e em On event coloque DDNS


    ****** preste atenção nas aspas, elas tem que estar no texto. Esse script funciona muito bem no mkt. Agora, se você hospedou uma página em um host na rede interna, você tera que criar um dst nat para a porta 80, ou a porta que você escolheu, neste ip.
    --------> E COMO SE FAZ ISSO??Sou novo no assunto! (( interfacedolinkdeinternet)) coloco o que aqui??
    Última edição por Horfew; 09-03-2009 às 15:04.



  9. #9

    Padrão

    Citação Postado originalmente por Horfew Ver Post
    --------> E COMO SE FAZ ISSO??Sou novo no assunto! (( interfacedolinkdeinternet)) coloco o que aqui??
    Ai vc coloca o nome da placa que ta recebendo o link.

    Ex.: ether1, ether2...

  10. #10

    Padrão

    Citação Postado originalmente por lipeiori Ver Post
    Ai vc coloca o nome da placa que ta recebendo o link.

    Ex.: ether1, ether2...
    lipeiori, testei este script com um cable modem da net e funcionou legal, mas com o adsl da telefonica não funciona, com o cable ele pega ip público na ether1 via dhcp client, mas e o adsl, como faço ? a ether1 fica sem ip e se coloco no lugar o nome da interface pppoe client ele também não funciona.
    Grato,

    Aroldo



  11. #11

    Padrão

    Com adsl é melhor usar o DDNS no modem roteado e redirecionar as portar 80 e 8291 para o IP do MK.