+ Responder ao Tópico



  1. Muito bom cara!!
    E o link de calculo também!!
    Abraços,

  2. Antes de mais nada, parabéns ao CATV pelo tópico e pela grande dica! Parabéns também ao Ir.'. Minelli pelo aprimoramento, este fórum é o que é por conta da presença de pessoas como vocês aqui.

    Pessoal, uso um porxy Ubuntu em paralelo com meu MK 3.24, tenho Thunder-Cache ativo e rodando perfeitamente há mais de 3 meses, na verdade uso-o desde que ele se chamava Ecache.

    Porém não estou conseguindo fazer essa regra abaixo funcionar com os objetos do Thunder, e antes que pergunte, eu já fiz a marcação no header(THUNDER: THUNDER) pelo apache2 sim, já tentei usando as chains 'output', "foward", "prerouting", e "posrouting" também.

    Já inclusive marquei o content como "THUNDER: THUNDER" bem como com "thunder/", porém ambos sem sucesso.

    As regras chegam a contar algumas coisas, mas nada comparado ao tamanho real dos arquivos que estou puxando. Vi no site da PCRAM que o amigo M4d3 conseguiu fazer, algum de você também conseguiu a mesma proeza e está disposto à compartilhá-la?

    Agradeço antecipadamente as respostas.

    TFA.'.

    Citação Postado originalmente por minelli Ver Post
    Bom vou postar aqui algumas correções que tive de fazer para as regras postadas anteriormente funcionarem corretamente no meu servidor de teste:

    1 - Link para calculo de tamanhos:
    Código :
    [URL="http://www.gwebtools.com.br/converter-bit"]Converter bit, byte, kilobit, kilobyte, megabit, megabyte, gigabit, gigabyte[/URL]
    Correções que foram feitas aqui:
    1 - Tamanho de Arquivos
    Código :
     4M = 4194304 byte
     8M = 8388608 byte
    12M = 12582912 bytes
    2 - Mangle / PassthRough
    Tive de seleciona o PassthRough na marcação dos Pacotes, fazendo isso as regras ao atingirem o valor em MB começaram a repassarem para a próxima.

    No Manual em PDF, pagina 325 do do MK 3.x em Mangle / Descrição
    Código :
    Inglês:
    passthrough - ignore this rule go on to the next one
    Português:
    passthrough - Ignore está regra e vá para proxima.
    Regras Corrigidas (Para evitar problemas deixei Disabled=yes):
    Mikrotik versão 3.25
    /IP FIREWALL MANGLE
    Código :
    /ip firewall mangle
    add action=mark-connection chain=output comment="PROXYFULL 0-4M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=0-4194304 disabled=yes dscp=4 \
        new-connection-mark=Proxy_Full_4Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_4Mb_Conn disabled=yes new-packet-mark=Proxy_Full_4Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 4-8M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=4194304-8388608 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_8Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_8Mb_Conn disabled=yes new-packet-mark=Proxy_Full_8Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 8-12M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=8388608-12582912 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_12Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_12Mb_Conn disabled=yes new-packet-mark=Proxy_Full_12Mb_Packet passthrough=yes
    Queue Tree:
    /QUEUE TREE
    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=4M name=Proxy_Full_4Mb packet-mark=Proxy_Full_4Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3M name=Proxy_Full_8Mb packet-mark=Proxy_Full_8Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=2M name=Proxy_Full_12Mb packet-mark=Proxy_Full_12Mb_Packet parent=\
        global-out priority=2 queue=default
    Lembrando que as regras são de autoria do CATV_BRASIL e foram adaptadas pra melhor funcionamento por mim.
    Por Favor se for util agradeça.
    OBS.: Caros Moderadores, fiz questão de ler e imprimir todos os itens da regras deste forum e num vi nenhuma irregularidade neste post por isso gostaria que não o removessem se necessário move-lo.
    Por garantia como meus postes teem sumido de vez em quando tirei um PrintScreen caso precise recoloca-lo no forum.

    Desde ja Agradeço a todos.



  3. Citação Postado originalmente por xnetinho Ver Post
    Antes de mais nada, parabéns ao CATV pelo tópico e pela grande dica! Parabéns também ao Ir.'. Minelli pelo aprimoramento, este fórum é o que é por conta da presença de pessoas como vocês aqui.

    Pessoal, uso um porxy Ubuntu em paralelo com meu MK 3.24, tenho Thunder-Cache ativo e rodando perfeitamente há mais de 3 meses, na verdade uso-o desde que ele se chamava Ecache.

    Porém não estou conseguindo fazer essa regra abaixo funcionar com os objetos do Thunder, e antes que pergunte, eu já fiz a marcação no header(THUNDER: THUNDER) pelo apache2 sim, já tentei usando as chains 'output', "foward", "prerouting", e "posrouting" também.

    Já inclusive marquei o content como "THUNDER: THUNDER" bem como com "thunder/", porém ambos sem sucesso.

    As regras chegam a contar algumas coisas, mas nada comparado ao tamanho real dos arquivos que estou puxando. Vi no site da PCRAM que o amigo M4d3 conseguiu fazer, algum de você também conseguiu a mesma proeza e está disposto à compartilhá-la?

    Agradeço antecipadamente as respostas.

    TFA.'.
    Bom dia Ir.'. Netinho
    Nunca tentei usar dessa forma mas as regras continuam a mesma com pequenas alteracoes.
    Farei os testes e posto aqui a regra para funcionar da forma que necessita.
    Mas estarei fora a servico e so devo voltar dia 15/08, somente apos essa data poderei estar postando.

  4. Boa tarde a todos... sou novo e nao estou conseguindo utilizar esta grande dica.

    Utilize as regras acima do catv e a regra de drop nao esta funcionando, alguem poderia me ajudar? realmente estou precisando.. obrigado



  5. #55
    Luiz Paulo
    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    fala ai pessoal, beleza... parabenizar a todos que contribuem aqui no forum, dizer que sou novissimo no mikrotik e tenho aprendido muito aki.
    seguinte,

    a regra mangle foi de boa, mas a queue simples nao consegui.
    entao fiz o seguinte (manual)

    general

    Name= PACKFULL

    Max limit= 10M

    Advanced

    Packet mark= PackFullMARK

    Interface= ether2 Local

    funcionou, ele ta liberando o link inteiro para a navegação e tambem para download, mas ele nao volta para a regra queue do cliente apos ter ultrapassado os 500k, continua baixando com todo o link.

    gostaria da ajuda de voces para saber no que estou errando
    desde ja agradeço

    mk 2.9.27
    modem bridge
    webproxy desativado
    cache full desativado






Tópicos Similares

  1. Limitando tamanho de downloads
    Por ejcNet no fórum Redes
    Respostas: 9
    Último Post: 23-07-2009, 13:03
  2. Respostas: 2
    Último Post: 25-07-2005, 08:40
  3. limitando o tamanho da banda para download
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 15-07-2005, 17:12
  4. Limitar Tamanho de Download ....
    Por pssgyn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-10-2004, 08:23
  5. Limitar tamanho de download no squid. É possível?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 09-07-2003, 18:38

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L