+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por mktguaruja Ver Post
    CATV e todos do forum..

    so um poko leigo no mikrotik (por um bom tempo, pois tem gente com muita experiencia aki)

    eu implantei com um poco de dificultades o proxy paralelo, e agora estou tentando configura da seguinte maneira o mikrotik.

    arquivos de 0mb a 4mb ir a 4mbps compartilhada
    arquivos de 4mb a 8mb ir a 3mbps compartilhada
    arquivos de 8mb a 12mb ir a 2mbps compartilhada

    e > que 12mb ir a 1mbps compartilhando pelo numero de conexao simultaneas.

    ai eu tava pensando para fazer dessa forma eu teria q marca a porta padrao do squid correto ?
    para min fazer a mesma coisa com thundercache seria a mesma logica q no squid ??

    porque c eu jogar sem esse controle os radinho não vai aguentar vai travar muiito...

    estou tentando fazer.. logo logo posto as regras..

    espero a ajuda de vc´s obrigado.
    Todos vocês não me levem a mal, mas vamos pensar um pouquinho???

    Primeira coisa você terá que ter 3 pares de regras marcando os pacotes do mangle (nesse caso vou mostrar como faz no MK):

    /ip fir man
    add action=mark-connection chain=output comment=\
    "PROXYFULL 0-4M (CATVBRASIL)" connection-bytes=0-4000000 disabled=no \
    dscp=4 new-connection-mark=proxyfull_4m passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=proxyfull_4m \
    disabled=no new-packet-mark=proxyfull4m passthrough=no
    add action=mark-connection chain=output comment=\
    "PROXYFULL 4M-8M (CATVBRASIL)" connection-bytes=4000000-8000000 \
    disabled=no dscp=4 new-connection-mark=proxyfull_8m passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=proxyfull_8m \
    disabled=no new-packet-mark=proxyfull8m passthrough=no
    add action=mark-connection chain=output comment=\
    "PROXYFULL 8M-12M (CATVBRASIL)" connection-bytes=8000000-12000000 \
    disabled=no dscp=4 new-connection-mark=proxyfull_12m passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=proxyfull_12m \
    disabled=no new-packet-mark=proxyfull12m passthrough=no



    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=4000000 name=proxyfull_4m packet-mark=proxyfull4m parent=\
    global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=3000000 name=proxyfull_8m packet-mark=proxyfull8m parent=\
    global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=2000000 name=proxyfull_12m packet-mark=proxyfull8m parent=\
    global-out priority=8 queue=default


    Lembrando que as regras acima são para a versão 3.xx... Viram como é fácil?? Não tem mistério nenhum. O pessoal que desenvolve esses tipos de regras, nem precisa conhecer muito para desenvolver regras "avançadas" no Mikrotik, basta ter um conceito mínimo.


  2. #42

    Padrão

    Boa Catv.. dá pra fazer uma série de coisas, mangles, etc... marcar pacotes..

    Bem lembrado...

    You´re the MAN !!!!

    Abraços



  3. #43

    Padrão

    Citação Postado originalmente por alamdias Ver Post
    Boa Catv.. dá pra fazer uma série de coisas, mangles, etc... marcar pacotes..

    Bem lembrado...

    You´re the MAN !!!!

    Abraços

    Thanks you my brother!!

    Today Brazil, tomorrow Latvia!!

    Coming soon!

  4. #44

    Padrão

    eu uso aqui mk 3.x squid thunder paralelo e add essas regras nao teve trafego em nenhuma das 3



  5. #45

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Se você usar as 2 regras que coloquei no exemplo sim, vai dropar tudo acima de 500k.
    na v3.24 com hotspot coloquei elas e naum dropol
    /ip firewall filter rules
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

    Versão 3.xx

    add chain=forward protocol=tcp dst-port=80 connection-bytes=500000-0 \
    action=drop comment="" disabled=no

  6. #46

    Padrão

    Estou com problemas aqui.

    Tenho duas faixas de IP na mesma interface e gostaria que em uma tivesse o controle descrito no tópico, mas não estou conseguindo mesmo utilizando a address list para a faixa de IP especificada.

    OBS.: tentei na versão 2.27.9(MK de teste) e na 3.13(MK em produção)

    Podem me ajudar???

    Abraços



  7. #47
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Parabéns, regras de mta ajuda!

  8. #48



  9. #49

    Padrão

    Alguém efetivamente usa as regras, pois tenho tentado fazê-la funcionar , mas não consigo

  10. #50
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Divisão por Tamanho de Downloads

    Bom vou postar aqui algumas correções que tive de fazer para as regras postadas anteriormente funcionarem corretamente no meu servidor de teste:

    1 - Link para calculo de tamanhos:
    Código :
    [url=http://www.gwebtools.com.br/converter-bit]Converter bit, byte, kilobit, kilobyte, megabit, megabyte, gigabit, gigabyte[/url]

    Correções que foram feitas aqui:
    1 - Tamanho de Arquivos
    Código :
     4M = 4194304 byte
     8M = 8388608 byte
    12M = 12582912 bytes

    2 - Mangle / PassthRough
    Tive de seleciona o PassthRough na marcação dos Pacotes, fazendo isso as regras ao atingirem o valor em MB começaram a repassarem para a próxima.

    No Manual em PDF, pagina 325 do do MK 3.x em Mangle / Descrição
    Código :
    Inglês:
    passthrough - ignore this rule go on to the next one
    Português:
    passthrough - Ignore está regra e vá para proxima.

    Regras Corrigidas (Para evitar problemas deixei Disabled=yes):
    Mikrotik versão 3.25
    /IP FIREWALL MANGLE
    Código :
    /ip firewall mangle
    add action=mark-connection chain=output comment="PROXYFULL 0-4M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=0-4194304 disabled=yes dscp=4 \
        new-connection-mark=Proxy_Full_4Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_4Mb_Conn disabled=yes new-packet-mark=Proxy_Full_4Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 4-8M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=4194304-8388608 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_8Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_8Mb_Conn disabled=yes new-packet-mark=Proxy_Full_8Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 8-12M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=8388608-12582912 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_12Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_12Mb_Conn disabled=yes new-packet-mark=Proxy_Full_12Mb_Packet passthrough=yes

    Queue Tree:
    /QUEUE TREE
    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=4M name=Proxy_Full_4Mb packet-mark=Proxy_Full_4Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3M name=Proxy_Full_8Mb packet-mark=Proxy_Full_8Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=2M name=Proxy_Full_12Mb packet-mark=Proxy_Full_12Mb_Packet parent=\
        global-out priority=2 queue=default

    Lembrando que as regras são de autoria do CATV_BRASIL e foram adaptadas pra melhor funcionamento por mim.
    Por Favor se for util agradeça.
    OBS.: Caros Moderadores, fiz questão de ler e imprimir todos os itens da regras deste forum e num vi nenhuma irregularidade neste post por isso gostaria que não o removessem se necessário move-lo.
    Por garantia como meus postes teem sumido de vez em quando tirei um PrintScreen caso precise recoloca-lo no forum.

    Desde ja Agradeço a todos.
    Última edição por minelli; 25-06-2009 às 15:23. Razão: Adicionar versão do MK. / Alterado Comments / Correção Ortográfica



  11. #51
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Muito bom cara!!
    E o link de calculo também!!
    Abraços,

  12. #52

    Padrão

    Antes de mais nada, parabéns ao CATV pelo tópico e pela grande dica! Parabéns também ao Ir.'. Minelli pelo aprimoramento, este fórum é o que é por conta da presença de pessoas como vocês aqui.

    Pessoal, uso um porxy Ubuntu em paralelo com meu MK 3.24, tenho Thunder-Cache ativo e rodando perfeitamente há mais de 3 meses, na verdade uso-o desde que ele se chamava Ecache.

    Porém não estou conseguindo fazer essa regra abaixo funcionar com os objetos do Thunder, e antes que pergunte, eu já fiz a marcação no header(THUNDER: THUNDER) pelo apache2 sim, já tentei usando as chains 'output', "foward", "prerouting", e "posrouting" também.

    Já inclusive marquei o content como "THUNDER: THUNDER" bem como com "thunder/", porém ambos sem sucesso.

    As regras chegam a contar algumas coisas, mas nada comparado ao tamanho real dos arquivos que estou puxando. Vi no site da PCRAM que o amigo M4d3 conseguiu fazer, algum de você também conseguiu a mesma proeza e está disposto à compartilhá-la?

    Agradeço antecipadamente as respostas.

    TFA.'.

    Citação Postado originalmente por minelli Ver Post
    Bom vou postar aqui algumas correções que tive de fazer para as regras postadas anteriormente funcionarem corretamente no meu servidor de teste:

    1 - Link para calculo de tamanhos:
    Código :
    [URL="http://www.gwebtools.com.br/converter-bit"]Converter bit, byte, kilobit, kilobyte, megabit, megabyte, gigabit, gigabyte[/URL]
    Correções que foram feitas aqui:
    1 - Tamanho de Arquivos
    Código :
     4M = 4194304 byte
     8M = 8388608 byte
    12M = 12582912 bytes
    2 - Mangle / PassthRough
    Tive de seleciona o PassthRough na marcação dos Pacotes, fazendo isso as regras ao atingirem o valor em MB começaram a repassarem para a próxima.

    No Manual em PDF, pagina 325 do do MK 3.x em Mangle / Descrição
    Código :
    Inglês:
    passthrough - ignore this rule go on to the next one
    Português:
    passthrough - Ignore está regra e vá para proxima.
    Regras Corrigidas (Para evitar problemas deixei Disabled=yes):
    Mikrotik versão 3.25
    /IP FIREWALL MANGLE
    Código :
    /ip firewall mangle
    add action=mark-connection chain=output comment="PROXYFULL 0-4M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=0-4194304 disabled=yes dscp=4 \
        new-connection-mark=Proxy_Full_4Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_4Mb_Conn disabled=yes new-packet-mark=Proxy_Full_4Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 4-8M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=4194304-8388608 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_8Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_8Mb_Conn disabled=yes new-packet-mark=Proxy_Full_8Mb_Packet passthrough=yes
    add action=mark-connection chain=output comment="PROXYFULL 8-12M (CATVBRASIL_Editada por Rodrigo_Minelli.'.)" connection-bytes=8388608-12582912 disabled=yes \
        dscp=4 new-connection-mark=Proxy_Full_12Mb_Conn passthrough=yes protocol=tcp
    add action=mark-packet chain=output comment="" connection-mark=Proxy_Full_12Mb_Conn disabled=yes new-packet-mark=Proxy_Full_12Mb_Packet passthrough=yes
    Queue Tree:
    /QUEUE TREE
    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=4M name=Proxy_Full_4Mb packet-mark=Proxy_Full_4Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=3M name=Proxy_Full_8Mb packet-mark=Proxy_Full_8Mb_Packet parent=\
        global-out priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=2M name=Proxy_Full_12Mb packet-mark=Proxy_Full_12Mb_Packet parent=\
        global-out priority=2 queue=default
    Lembrando que as regras são de autoria do CATV_BRASIL e foram adaptadas pra melhor funcionamento por mim.
    Por Favor se for util agradeça.
    OBS.: Caros Moderadores, fiz questão de ler e imprimir todos os itens da regras deste forum e num vi nenhuma irregularidade neste post por isso gostaria que não o removessem se necessário move-lo.
    Por garantia como meus postes teem sumido de vez em quando tirei um PrintScreen caso precise recoloca-lo no forum.

    Desde ja Agradeço a todos.



  13. #53
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por xnetinho Ver Post
    Antes de mais nada, parabéns ao CATV pelo tópico e pela grande dica! Parabéns também ao Ir.'. Minelli pelo aprimoramento, este fórum é o que é por conta da presença de pessoas como vocês aqui.

    Pessoal, uso um porxy Ubuntu em paralelo com meu MK 3.24, tenho Thunder-Cache ativo e rodando perfeitamente há mais de 3 meses, na verdade uso-o desde que ele se chamava Ecache.

    Porém não estou conseguindo fazer essa regra abaixo funcionar com os objetos do Thunder, e antes que pergunte, eu já fiz a marcação no header(THUNDER: THUNDER) pelo apache2 sim, já tentei usando as chains 'output', "foward", "prerouting", e "posrouting" também.

    Já inclusive marquei o content como "THUNDER: THUNDER" bem como com "thunder/", porém ambos sem sucesso.

    As regras chegam a contar algumas coisas, mas nada comparado ao tamanho real dos arquivos que estou puxando. Vi no site da PCRAM que o amigo M4d3 conseguiu fazer, algum de você também conseguiu a mesma proeza e está disposto à compartilhá-la?

    Agradeço antecipadamente as respostas.

    TFA.'.
    Bom dia Ir.'. Netinho
    Nunca tentei usar dessa forma mas as regras continuam a mesma com pequenas alteracoes.
    Farei os testes e posto aqui a regra para funcionar da forma que necessita.
    Mas estarei fora a servico e so devo voltar dia 15/08, somente apos essa data poderei estar postando.

  14. #54

    Padrão

    Boa tarde a todos... sou novo e nao estou conseguindo utilizar esta grande dica.

    Utilize as regras acima do catv e a regra de drop nao esta funcionando, alguem poderia me ajudar? realmente estou precisando.. obrigado



  15. #55
    Luiz Paulo
    Visitante

    Padrão dow limitado x navegação liberado

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    fala ai pessoal, beleza... parabenizar a todos que contribuem aqui no forum, dizer que sou novissimo no mikrotik e tenho aprendido muito aki.
    seguinte,

    a regra mangle foi de boa, mas a queue simples nao consegui.
    entao fiz o seguinte (manual)

    general

    Name= PACKFULL

    Max limit= 10M

    Advanced

    Packet mark= PackFullMARK

    Interface= ether2 Local

    funcionou, ele ta liberando o link inteiro para a navegação e tambem para download, mas ele nao volta para a regra queue do cliente apos ter ultrapassado os 500k, continua baixando com todo o link.

    gostaria da ajuda de voces para saber no que estou errando
    desde ja agradeço

    mk 2.9.27
    modem bridge
    webproxy desativado
    cache full desativado

  16. #56
    Luiz Paulo
    Visitante

    Padrão navegação ilimitada x download limitado

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    fala ai pessoal, beleza... parabenizar a todos que contribuem aqui no forum, dizer que sou novissimo no mikrotik e tenho aprendido muito aki.
    seguinte,

    a regra mangle foi de boa, mas a queue simples nao consegui.
    entao fiz o seguinte (manual)

    general

    Name= PACKFULL

    Max limit= 10M

    Advanced

    Packet mark= PackFullMARK

    Interface= ether2 Local

    funcionou, ele ta liberando o link inteiro para a navegação e tambem para download, mas ele nao volta para a regra queue do cliente apos ter ultrapassado os 500k, continua baixando com todo o link.

    gostaria da ajuda de voces para saber no que estou errando
    desde ja agradeço

    mk 2.9.27
    modem bridge
    webproxy desativado
    cache full desativado



  17. #57

    Padrão down lilitado x navegação ilimitada

    boa tarde pessoal, sou novo no forum e mais ainda no mikrotik, preciso da ajuda de voces.

    configuração::

    mk 2.9.27 / modem bridge / link velox de 8mb / cache full / webproxy / filtro youtube (nao vai pro cache) / 1gb ram / 40gb hd ide / só nao posto as regras porque nao sei faze-lo...rsrsr

    minha duvida é o seguinte:

    consegui fazer a dica do amigo (j34nsch) até certo ponto, a regra mangle foi de boa, mas a queue simple nao consegui, nao roda o script e nao achei onde colocar a opção (direction=both )
    entao fui tentar fazer manual e coloquei assim:

    na aba general

    Name= PACKFULL
    Max limit= 10M/10M

    na aba advanced

    Packet mark= PackFullMARK
    Interface= ether2 Local (dos clientes)

    realmente naveguei com toda a banda e fiz down de até 800k, porem, ele deveria baixar a velocidade do down quando baixasse 500k (não é isso?) ex: arquivo de 2M de 0 á 500k ele baixaraia a full e de 501k á 2M ele baixaria na velocidade configurada na queue simple do cliente ja configurada no meu caso de 150k, estou certo ?

    pois é, nao consegui... gostaria muito da ajuda de voces.
    desde ja agradeço
    Última edição por LuizPaulo; 10-10-2009 às 13:23.

  18. #58
    Avatar de renatocostas
    Ingresso
    Dec 2007
    Localização
    Av. Santos Dumont 119, centro -Montes Claros MG
    Posts
    288

    Padrão

    Citação Postado originalmente por j34nsch Ver Post
    então amigo eu fiz diferente, os arquivos pequenos de até 500k liberei velocidade extra, porem os maiores deixei cair na queues do cliente, assim a nevegação fica muito rapida, e os cliente que estão fazendo download fica na velocidade contratada.

    assim dou privilegio a porta 80 e resolução de dns

    marca os pacote no queues, OBS deixei encima das outras queues

    e pronto fica show de bola, cliente fica feliz e não aumenta em muito o consumo de link, vou marcar mais tarde os https tb

    agora como o amigo disse é só trocar onde esta connection-bytes=0-500000 por connection-bytes=1024000-0, ai vc vai liberar os pacotes para os pacotes maiores que 1mega

    Bem o brigado a todos os amigo que nos ajudaram, 1929 espero que o meu post tenho lhe ajudado t+
    Eu to fazendo o teste desta regra mas implementando no queue tree e utilizando o PCQ, por enquanto ta funciondo direito, mas estou esperando a hora de pico para testar 100%.

    Att,

    Renato Costa.



  19. #59

    Padrão

    Uma dúvida:

    Vamos ver se eu entendi.
    O controle de banda seria todo feito com base no tamanho de arquivos.? Algum tempo atrás eu já havia postado indagando desta possibilidade. Veja o link abaixo.

    https://under-linux.org/f106102-cont...anda-diferente

    Mas logo surgiu um impedimento. A partição do arquivo original.

    Nesta regra que o Luiz Paulo postou, pode acontecer que um gerenciador de download venha a burlar a regra, dividindo o arquivo em vários pedaços. O Igetter por exemplo pode partir em 14 pedaços, assim, uma arquivo de 14 MB não teria o controle da banda.
    E acho que os mais experientes podem achar um jeito de dividir em mais pedaços.

    Mas vamos debatendo o assunto, pois de repente aparece uma solução.

  20. #60

    Padrão pcq

    Citação Postado originalmente por renatocostas Ver Post
    Eu to fazendo o teste desta regra mas implementando no queue tree e utilizando o PCQ, por enquanto ta funciondo direito, mas estou esperando a hora de pico para testar 100%.

    Att,

    Renato Costa.

    beleza renato, caso funcione, poste os scripts que voce usou pra ajudar a gente.

    e uma duvida!!! caso funcione, tambem funciona para quem nao usa o pcq ?
    Última edição por LuizPaulo; 11-10-2009 às 13:41.