Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #7

    Padrão

    marconipcd, eu fiz da seguinte maneira e deu certo,
    LINK <> MK(NAT) <> CLIENTES (Portas !21,!80, NAT para o LINK)
    ___________\/ (Requisições das 21,80 vão para a porta 3128 do Debian)
    Debian (Squid+Sarg) (Debian ligado na ether2 da RB e utilizando NAT)

    Todos os clientes passam por um controle (Queue e QOS), sendo que os pacotes que são priorizados são os das portas 80(www), ICMP(ping), 53(dns).
    Última edição por agpnet; 23-03-2009 às 19:20.

  2. #8

    Padrão

    amigo, meu esquema é o mesmo que vocë me descreveu,com uma unica diferença que nÃO utilizava ip valido no squid, re-configurei e até agora esta normal(claro que não é horario de pico) vouobservar o dia inteiro e se der certo ou errado eu posto aqui pra galera



  3. #9

    Padrão

    amigo, mais ou menos 1 hora esta estavel sem problemas algum notei que quando começou horario de pico a partir de uns 20 minutos atraz começou o mesmo problema, tou pensando uma coisa aqui defini um ip valido para o squid tudo bem, porém utilizo dois links de 2 megas que chegam no meu swthi e um cabo do swthi para o linux-squid então definir como interface eth1 e eth1:1 e também definir dois gatways agora minha pergunta é será que todos os dois links estão sendo utilizados??

  4. #10

    Smile rota estática

    Amigo tenta isso aqui... tinha o mesmo problema que vc mais agora está tuuudo ok ^^
    Abraço!

    Proxy Pararelo ao Mikrotik Através de Rota Estática



  5. #11

    Padrão

    Amigo minha versão do mikrotik é a 2.9.27 o seu ultimo passo (5º)

    Por fim crie a ultima regra que será responsável pela a rota "clientes[TCP80]<-->webproxy":
    /ip firewall nat add comment="Rota Estática para o Proxy Pararelo[TCP80] - clientes" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.100.100.2 routing-mark=proxy-clientes scope=255 target-scope=255

    não consegui encontrar opção de configurar o gateway, então adicionei um novo gateway e marquei e tentei criar um nat para redirecionar, mais ele não redireciona

    e agora o que faço?

  6. #12

    Padrão

    Citação Postado originalmente por marconipcd Ver Post
    Amigo minha versão do mikrotik é a 2.9.27 o seu ultimo passo (5º)

    Por fim crie a ultima regra que será responsável pela a rota "clientes[TCP80]<-->webproxy":
    /ip firewall nat add comment="Rota Estática para o Proxy Pararelo[TCP80] - clientes" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.100.100.2 routing-mark=proxy-clientes scope=255 target-scope=255

    não consegui encontrar opção de configurar o gateway, então adicionei um novo gateway e marquei e tentei criar um nat para redirecionar, mais ele não redireciona

    e agora o que faço?
    marconipcd,
    vc fez o quarto passo em mangle marcou em routing-mark? na rota vc deve usar o mesmo routing-mark se não o fizer não funciona, e o gateway na rota a ser criada é o ip do seu web-proxy...
    outra coisa importante com essa configuração que te passei não é pra ser usada com o webproxy do mikrotik como um parent proxy, se o mesmo estiver ativado desative-o e tbm desativa a regra nat de redirect para ele...
    passa pra gente as suas configurações de rota, nat e mangle pra gente dar uma olhada...
    ficamos no aguardo!
    Última edição por animetaldeath; 24-03-2009 às 18:05.