Página 9 de 9 PrimeiroPrimeiro ... 456789
+ Responder ao Tópico



  1. Citação Postado originalmente por horusosbourne Ver Post
    Voltando para comentar.
    Estava errando a regra de iptables para compartilhar a internet. Agora eu consigo navegar, porém o servidor debian nao faz o cache...
    Vou tentar mexer aqui um pouco para ver o que fazer.
    A regra de nat para redirecionamento pro servidor debian deve vir antes da regra de nat global? Tentei fazer isso, mas sem sucesso. Ele navega um pouco mais lento, mas ainda assim não faz o cache. Isso me leva a crer que o problema possa ser o squid.
    Vou rever as regras aqui, mas se algum colega do fórum passou por isso e quiser compartilhar a experiencia, fico imensamente agradecido...

    Abraços
    Olá amigo, já verificou se seu squid está como transparente?? criou essa regra(iptables)??? vc deve redirecionar todas as requisições vindas da porta 80 para a porta 3128(tcp) e configurar seu squid.conf para trabalhar como proxy transparente, já o fez? esse deve ser o problema de não estar fazendo o cache, e se não o fez faça e quando fizer monitore as requisições dos clientes no access.log com um:
    tail -f /var/log/squid/access.log
    e veja se está tendo cache, aguardo retorno!

  2. Citação Postado originalmente por rogeriodj Ver Post
    Como fazer a regra de mascaramento para 3 faixas de ips, pois uso 3 faixas nos clientes...
    Opa, vc quer fazer mascaramento de NAT no linux ou no mk?

    Exemplo - Linux
    iptables -t nat -A POSTROUTING -o ethx -s 10.0.0.0/8 -j MASQUERADE
    iptables -t nat -A POSTROUTING -o ethx -s 172.16.0.0/12 -j MASQUERADE
    iptables -t nat -A POSTROUTING -o ethx -s 192.168.0.0/16 -j MASQUERADE

    Exemplo - MikroTik
    /ip firewall nat add chain=srcnat action=masquerade src-address=10.0.0.0/8 out-interface=internet
    /ip firewall nat add chain=srcnat action=masquerade src-address=172.16.0.0/12 out-interface=internet
    /ip firewall nat add chain=srcnat action=masquerade src-address=192.168.0.0/16 out-interface=internet



  3. Citação Postado originalmente por magrock Ver Post
    Amigo, Parabéns pelo tutorial !

    Agora eu queria perguntar a voce se o squid tem que estar em uma outra interface separada ou na mesma interface que estão os clientes. pois como esse lance não utiliza o parent proxy fiquei meio em duvida !

    Obrigado

    Não é necessário mais recomendo para afim de você eventualmente querer fazer controle de banda no mikrotik você necessitará de uma interface de rede exclusiva para o proxy, agora caso você faça o controle de banda pelo o linux entaum não necessitará de uma interface exclusiva para o proxy.

  4. Citação Postado originalmente por rjardim Ver Post
    bom, fiz tudo conforme o tutorial e esta funcionando perfeitamente.

    cenário:

    clientes - dhcp com mascara /30 e conexão por pppoe, visto que alguns clientes se conectar sempre com o mesmo ip

    ex: cliente: joao - ip 10.0.0.10 - ip valido para web: 189.1.1.99

    proxy cache no ubuntu server em paralelo ao mk na interface clientes

    antes de habilitar o proxy, utilizava netmap para fazer com que alguns clientes utilizassem ip valido, mas agora com o proxy estas regras se tornaram inuteis e estou tendo dificuldade para solucionar a questao, caso algum possa ajudar ficarei grato.

    rafael.
    Está usando o proxy numa mesma interface de rede onde estão conectados os clientes se sim lhe aconselho colocar o proxy numa interface separada para evitar problemas.






Tópicos Similares

  1. Respostas: 2
    Último Post: 01-04-2015, 08:00
  2. Respostas: 3
    Último Post: 04-09-2009, 08:51
  3. squid através de outro proxy
    Por void_main_void no fórum Servidores de Rede
    Respostas: 4
    Último Post: 01-09-2004, 10:53
  4. Errors de Acesso ao Servidor Linux através de estações Win
    Por helpdesk no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-07-2004, 13:54
  5. Usar Squid atraves de outro Proxy
    Por lucianotome no fórum Servidores de Rede
    Respostas: 4
    Último Post: 20-05-2003, 10:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L