+ Responder ao Tópico



  1. #1

    Padrão PPPoE + mppe

    Lí muitas recomendações aqui no fórum sobre a implementação de pppoe-server + mppe para segurança do cliente (dados criptografados) e do servidor (resolve clonagem ip x mac).

    O melhor que encontrei foi esse(clique) mas trata-se de um trexo do arquivo de configuração em que o usuário diz conseguir conexão com cliente Linux(stateless) mas não com Windows (statefull).

    Gostaria que os colegas indicassem algum material sobre essa implementação do Linux quanto sem Radius (para teste inicial) quando com. Aqui uso AP em Brindge e controlo tudo por um server Linux.

    Grato.

  2. #2

    Padrão UPDATE

    Opa. Conseguir implementar o pppoe+mppe, o problema é que o cliente Windows não navega. Quando fui verificar ele não obtem o gateway padrão. Mas se desativo o mppe funciona perfeitamente.

    No windows desativei a opção "usar gateway padrão em rede remota" mas nada.

    Eis o pppoe-server-options:

    Código :
    #require-chap
    #refuse-pap
    #refuse-chap
    #refuse-mschap
    asyncmap 0
    mru 1480
    mtu 1480
    require-mschap-v2
    lcp-echo-interval 10
    lcp-echo-failure 2
    require-mppe
    mppe-stateful
     
    login
    lcp-echo-interval 10
    lcp-echo-failure 2
    ms-dns 172.23.57.62
    ms-dns 172.23.57.62
    netmask 255.255.255.224
    #defaultroute # troquei esse pelo próximo e não resolveu
    nodefaultroute 
    noipdefault
    usepeerdns



  3. #3

    Padrão Upload

    Dá uma força aê galera.
    Em um modo o cliente windows não pega o gateway, noutro ele configura o próprio ip como gateway. Não ví como configurar o gateway manualmente. Só funciona 100% pppoe + chap, pppoe + mppe, não está funcionando. Será que só funciona bem com Radius? Alguém já passou por isso?

    Grato.

  4. #4



  5. #5

    Unhappy

    Citação Postado originalmente por alexandrecorrea Ver Post
    defaultroute
    #nodefaultroute
    Eu já essa inversão mas não obtive exito.

  6. #6

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    defaultroute
    #nodefaultroute
    Alexandre se puderes faz um teste aí num PC windows conecte à rede e verifique o gateway padrão com ipconfig /all - não sei se há outro modo. Aqui conseguir usar pppoe+freeradius \o/ (users pois não encontra modulo para mysql) porém o PC continua obtendo como gateway o próprio IP.
    Não pude testar navegação pois esse server esta numa VM mas após a conexão consigo acessar uma página do apache que está configurado.

    Grato.



  7. #7

    Padrão

    tenho isso rodando aqui sem problemas...

    so que o concetrador pppoe é mikrotik !!

  8. #8

    Padrão

    Blz, vou fazer o nat para ver funciona aqui assim mesmo.



  9. #9

    Padrão

    uuuhhhhhuuuu \o/. Conseguiiii!!!
    Uma dica: Em muito tutoriais em português vc encontrará orientação para configurar o freeradius versão 1.x+ a partir da versão 2.x+ alguns itens vão para no arquivo default dentro de sites-enabled.

    Agora partir pra autentição EAP. heheheh.

    Obs: Ainda não verifiquei o possível problema do gateway padrão.