Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por bjaraujo Ver Post
    Creio que está correto. Você reiniciou seu squid?
    Código :
    squid -k reconfigure
    No lugar desse arquivo com ips coloque os ips separados por espaço e ponha a máscara de rede tb. Ex.: 192.168.254.6/255.255.255.0 vc pode usar 192.168.254.6/24
    Reiniciei, dai o bloqueio funciona, so a pagina de erro que não...

  2. #22

    Padrão

    Citação Postado originalmente por danieluramg Ver Post
    bom o bind ja ta instalado, instalei o resolvconf e fiz o que vc disse
    so que não tem resposta de ping

    q será?
    Dá uma olhada da dica do colega.
    Dicas para proteger seu servidor DNS (BIND) - Parte 01 | Under-Linux.Org



  3. #23

    Padrão

    Citação Postado originalmente por bjaraujo Ver Post
    estranhamente não existe o named.conf no meu sistema, o proprio bind ou o resolvconf cria esse arquivo??

  4. #24

    Padrão

    Os arquivos de configuracao são criados na instalacao.

    cd /etc/bind

    named-checkconf

    Se retornar erro você está com problemas.



  5. #25

    Padrão

    depois que mudei a fonte do apt-get para o Lenny e fiz atualização meu servidor ficou um lixo
    pra conectar por SSH é 5 min so pra pedir a senha
    o NX server da ate time out de tanto que espera...
    as paginas demoram uns 10 seg so pra comessar a carregar.
    agora depois de tantar instalar o resolvconf danou tudo, nem navega mais!
    vou formatar tudo aqui ta bixado demais .........
    bom depois posto aki qual foi o resultado!

    valew gente.........

  6. #26

    Padrão E volto a estaca zero....

    Bom galera o FDS se foi e voltei pro meu passa-tempo (dor-de-cabeça).......

    bom estão no sabado depois de minha ultima postagem formatei a maquina e reinstalei o Kurumin 7 comessando tuudo denovo.
    dai fiz tudo pra compartilhar a internet norlamente la nos scripts do Kurumin, dai instalei o Squid tambem por lá, dai tudo OK perfeito, (como estava antes, sem cache full)
    ai instalei por cima o Squid que já imbuti o ZPH (dpkg -i squid*) da pasta onde deixei a instalação (os 4 DEBs) dai ele deu o erro que sempre da pedindo o Apache, dai instalei o Apache com apt-get dai voltei ao (dpkg -i squid*)ai deu que foi tudo instalado.
    so que continua sem funcionar o cache full... eu baixo um arquivo em uma maquina que etá sem limite, dai baixo em outra maquina que esta com controle de banda e continua limitando a velocidade do arquivo que já esta em cache
    a instalação como fiz por cima não funciona?
    bom tinha funcionado quando segui a dica do braraujo para atualizar para o Lenny ai instalou o Squid 2.7 porém ficou orrivel o desempenho do micro depois disso, dai tentei instalar apenas o Squid 2.7 mudando os repositorios do apt-get, so que na hora que mando instalar o Squid ele diz que tem que substituir uma porrada de outros, dai acho q ia votar a ficar uma merda então não fiz.

    o que fazer??



  7. #27

    Padrão

    Citação Postado originalmente por darklinux3 Ver Post
    Os pacotes estao corretos é isso mesmo.
    O que te faz pensar que nao está fazendo cache? se seu proxy é transparente e quando desativa o serviço a navegacao pára. Passou pelo proxy tá fazendo o cache! ou sua configuracao nao esta de acordo
    Verifique a linha do "access log" no squid.conf coloque /var/log/squid/access.log, depois restarte o squid monitore o acesso ao cache com tail -f /var/log/squid/access.log e veja os HIT e MISS do cache estao ocorrendo.

    Cada acesso deve aparecer uma linha no cache. Também verifique o diretorio onde está o cache se foram criados os arquivos realmente.

    Abs!
    Darklinux3 cara o negocio ta foda aqui...
    novamente não está fazendo cache! certeza que não, ja fiz todos os testes possiveis
    e fazendo o que vc falou vela o erro que da em meu log
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line 238: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.



    e o estranho é que existe a ACL all, e mesmo que eu comente a linha http_access deny all e comente a http_access allow all ele continua dando o MESMO erro...
    bom então o controle das delay pools esta funcionando, entao o squid esta funcionando, porem não faz cache, ja tentei desinstalar e reinstalar.
    anexei meu access.log e o squid.conf completo se vc puder dar uma olhada pra ver se acha o erro!
    https://under-linux.org/forums/images/attach/txt.gif access.txt (33.1 KB)

    https://under-linux.org/forums/images/attach/txt.gif squid.conf.txt (4.5 KB)




    valew
    Arquivos Anexos Arquivos Anexos

  8. #28

    Padrão

    Citação Postado originalmente por danieluramg Ver Post
    Darklinux3 cara o negocio ta foda aqui...
    novamente não está fazendo cache! certeza que não, ja fiz todos os testes possiveis
    e fazendo o que vc falou vela o erro que da em meu log
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line 238: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.



    e o estranho é que existe a ACL all, e mesmo que eu comente a linha http_access deny all e comente a http_access allow all ele continua dando o MESMO erro...
    bom então o controle das delay pools esta funcionando, entao o squid esta funcionando, porem não faz cache, ja tentei desinstalar e reinstalar.
    anexei meu access.log e o squid.conf completo se vc puder dar uma olhada pra ver se acha o erro!
    https://under-linux.org/forums/images/attach/txt.gif access.txt (33.1 KB)

    https://under-linux.org/forums/images/attach/txt.gif squid.conf.txt (4.5 KB)




    valew
    Você editou o arquivo antes de enviar? Se não o fez procure por outro squid.conf nesse server e trabalhe nele. O log aponta erro na linha 238 mas seu arquivo só tem 145 linhas.

    Cada NONE do teu access.log diz que o navegador ou baixou no cache ou não baixou nada (bloqueado).
    Última edição por bjaraujo; 13-04-2009 às 18:23.



  9. #29

    Padrão

    Citação Postado originalmente por bjaraujo Ver Post
    Você editou o arquivo antes de enviar? Se não o fez procure por outro squid.conf nesse server e trabalhe nele. O log aponta erro na linha 238 mas seu arquivo só tem 145 linhas.

    Cada NONE do teu access.log diz que o navegador ou baixou no cache ou não baixou nada (bloqueado).
    como assim antes de enviar? esse squid.conf é o que está na pasta "/etc/squid/"
    é o LOG agora que vi que faltou pedaço, é que estava conectado por SSH e não copiou o texto todo.

    Eu ja tentei reinstalar o Squid,e mesmo com o squid.conf que o proprio kurumin ja instala pre-configurado ele da o mesmo erro quando "squid -f /var/log/squid/access.log"
    ai ele demora um pouco e da o mesmo erro
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line x: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.

    modando apenas o numero da linha

    o mais estranho é qua a linha http_access deny all esta comentada!

  10. #30

    Padrão mais um dia que se passa.....

    bom hoje resolvi tentar novamente instalar o Squid do Lenny, então fiz tudo na seguinte ordem:

    • apt-get update

    dai editei a sources.list do apt e editei os repositorios para os do Lenny.

    • apt-get update
    • apt-get upgrade -y

    ai atualizou uma porrada de pacotes.
    dai instalei o Squid (atualizou mais um monte)
    ai iniciou o serviço, e tal
    dei um squid -v e realmente, esta agora com a versão 2.7 Stable3
    novamente esta fazendo o controle de banda, editei o squid.conf conforme minhas configurações, etc.
    e novamente fiz um download em uma estação, limpei a cache do navegador, apaguei o arquivo baixado e baixei o mesmo arquivo novamente, que foi novamente baixado do servidor (o squid não fez cache)

    ai dei um squid -f /var/log/access.log
    que estranhamente, mas já me acostumei deu o mesmo erro
    2009/04/14 10:24:06| ACL name 'all' not defined!
    FATAL: Bungled (null) line 180: http_access deny all
    Squid Cache (Version 2.7.STABLE3): Terminated abnormally.

    terminando com o processo. apontando para a linha 180
    bom agora sim vem o que achei muito estranho mesmo, abri o access.log, cache.log e store.log e limpei todos, e novamente acessei um pouco via proxy, e depois voltei a rodar o comando squif -f /var/log/squid/access.log, que novamente deu o MESMO erro apontando para a MESMA linha 180, sendo que o arquivo não tem nem esse tanto de linhas!

    cara tem alguma parte do meu squid que ta bixada/travada, não sei mais o que fazer...

    aguardo uma luz de uma alma bendita, acredito que so um power user no squid pra desvendar esse mistério.........



  11. #31

    Padrão

    Derrube seu squid, como root:
    Código :
    killall -s9 squid
    Teste o arquivo de configuração:
    Código :
    squid -f /etc/squid/squid.conf -f check
    Rode teu squid com o seguinte comando, como root:
    Código :
    squid -f /etc/squid/squid.conf -d2
    Qualquer coisa me manda um mp com teu msn.

  12. #32

    Padrão

    Citação Postado originalmente por bjaraujo Ver Post
    Derrube seu squid, como root:
    Código :
    killall -s9 squid
    Teste o arquivo de configuração:
    Código :
    squid -f /etc/squid/squid.conf -f check
    Rode teu squid com o seguinte comando, como root:
    Código :
    squid -f /etc/squid/squid.conf -d2
    Qualquer coisa me manda um mp com teu msn.
    Fiz tudo deu isso:

    [email protected]:/etc/squid# killall -s9 squid
    [email protected]:/etc/squid# squid -f /etc/squid/squid.conf -f check
    FATAL: Unable to open configuration file: check: (2) No such file or directory
    Squid Cache (Version 2.7.STABLE3): Terminated abnormally.
    CPU Usage: 0.008 seconds = 0.004 user + 0.004 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    Abortado
    [email protected]:/etc/squid# squid -f /etc/squid/squid.conf -d2
    [email protected]:/etc/squid# 2009/04/14 11:22:19| Starting Squid Cache version 2.7.STABLE3 for i386-debian-linux-gnu...
    2009/04/14 11:22:19| Process ID 8011
    2009/04/14 11:22:19| With 1024 file descriptors available
    2009/04/14 11:22:19| Using epoll for the IO loop
    2009/04/14 11:22:19| Performing DNS Tests...
    2009/04/14 11:22:19| Successful DNS name lookup tests...
    2009/04/14 11:22:19| DNS Socket created at 0.0.0.0, port 1167, FD 6
    2009/04/14 11:22:19| Adding nameserver 208.67.222.222 from /etc/resolv.conf
    2009/04/14 11:22:19| Adding nameserver 208.67.220.220 from /etc/resolv.conf
    2009/04/14 11:22:19| User-Agent logging is disabled.
    2009/04/14 11:22:19| Referer logging is disabled.
    2009/04/14 11:22:19| logfileOpen: opening log /var/log/squid/access.log
    2009/04/14 11:22:19| Unlinkd pipe opened on FD 11
    2009/04/14 11:22:19| Swap maxSize 15360000 KB, estimated 1181538 objects
    2009/04/14 11:22:19| Target number of buckets: 59076
    2009/04/14 11:22:19| Using 65536 Store buckets
    2009/04/14 11:22:19| Max Mem size: 262144 KB
    2009/04/14 11:22:19| Max Swap size: 15360000 KB
    2009/04/14 11:22:19| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    2009/04/14 11:22:19| logfileOpen: opening log /var/log/squid/store.log
    2009/04/14 11:22:19| Rebuilding storage in /var/spool/squid (DIRTY)
    2009/04/14 11:22:19| Using Least Load store dir selection
    2009/04/14 11:22:19| Current Directory is /etc/squid
    2009/04/14 11:22:19| Loaded Icons.
    2009/04/14 11:22:19| Accepting proxy HTTP connections at 0.0.0.0, port 3128, FD 13.
    2009/04/14 11:22:19| Accepting ICP messages at 0.0.0.0, port 3130, FD 14.
    2009/04/14 11:22:19| HTCP Disabled.
    2009/04/14 11:22:19| WCCP Disabled.
    2009/04/14 11:22:19| Ready to serve requests.
    2009/04/14 11:22:19| Store rebuilding is 19.4% complete
    2009/04/14 11:22:20| Done reading /var/spool/squid swaplog (21118 entries)
    2009/04/14 11:22:20| Finished rebuilding storage from disk.
    2009/04/14 11:22:20| 20910 Entries scanned
    2009/04/14 11:22:20| 0 Invalid entries.
    2009/04/14 11:22:20| 0 With invalid flags.
    2009/04/14 11:22:20| 20910 Objects loaded.
    2009/04/14 11:22:20| 0 Objects expired.
    2009/04/14 11:22:20| 204 Objects cancelled.
    2009/04/14 11:22:20| 0 Duplicate URLs purged.
    2009/04/14 11:22:20| 0 Swapfile clashes avoided.
    2009/04/14 11:22:20| Took 0.8 seconds (27124.6 objects/sec).
    2009/04/14 11:22:20| Beginning Validation Procedure
    2009/04/14 11:22:20| Completed Validation Procedure
    2009/04/14 11:22:20| Validated 20706 Entries
    2009/04/14 11:22:20| store_swap_size = 435740k
    2009/04/14 11:22:20| storeLateRelease: released 0 objects



  13. #33

    Padrão

    Olá amigo seu arquivo de configuracao esta com problemas, quando vc instalou o squid ele ja deveria estar rodando normalmente e fazendo cache das paginas a acl all ja viria inclusa. Aqui eu uso debian apenas o sistema basico e instalo apenas os pacotes do bind9, squid e squid-common(2.6).
    Eu ainda nao utilizei esse squid 2.7 pode ser que existe alguma diferença de configuracao uma vez passei por isso quando utilizava a versao 2.5 e lançaram a 2.6.
    Em eu conf. tem muitas acl de bloqueios, uma dica: rode primeiro o básico default que vem com a sua distro vá refinando seu serviço para adapta-lo as suas necessidades.

    Faz o teste e posta o resultado!
    Abs!

  14. #34

    Padrão

    Citação Postado originalmente por darklinux3 Ver Post
    Olá amigo seu arquivo de configuracao esta com problemas, quando vc instalou o squid ele ja deveria estar rodando normalmente e fazendo cache das paginas a acl all ja viria inclusa. Aqui eu uso debian apenas o sistema basico e instalo apenas os pacotes do bind9, squid e squid-common(2.6).
    Eu ainda nao utilizei esse squid 2.7 pode ser que existe alguma diferença de configuracao uma vez passei por isso quando utilizava a versao 2.5 e lançaram a 2.6.
    Em eu conf. tem muitas acl de bloqueios, uma dica: rode primeiro o básico default que vem com a sua distro vá refinando seu serviço para adapta-lo as suas necessidades.

    Faz o teste e posta o resultado!
    Abs!
    Opa blz brother
    cara o bjaraujo me ajudou aqui, fizemos varias tentativas que ele foi me passando pelo MSN, dai tava dando varios erros estranhos e tal, ai ate rodou, dai entrou em meu server por SSH e conseguiu fazer rodar blzinha .
    so que como da vez anterior que mudei os repositorios para os do Lenny a estabilidade da internet ficou horrivel, demora pra responder ao requisitar uma pagina, ate o SSH fica lento, dai revotei e formatei denovo!
    dai fiz tudo direitinho: 1º intalei o kurumin, fiz as atualizações do apt-get, instalei o compartilhamento, firewall, depois o Squid pelos scripts, dai me sertifiquei de que estava rodando mesmo, reiniciei a maquina e tava redondinho novamente.
    dai parei o Squid, instalei o Apache (que sempre q vou atualizar para o meu Squid com ZPH ele reclama, entao ja instalei antes) dai sim instalei o Squid com ZPH que compilei, ai sim ficou perfect!
    ta fazendo o controle de banda, cache full, etc.
    bom mas ainda estou com ideia de instalar o HTB ou CBQ, pois nao estou gostando da maneira que as delay pools funcionam, e tambem não consigo fazer a pagina de erros personalizada para nao pagantes funcionar, se puder veja meu squid.conf
    dai la no fim esta as regras que criei, no arquivo "naopagou" coloco o IP dos inadimplentes
    e o arquivo "SUSPENSO" esta na pasta de erros, que tambem informei no squid.conf
    quando adiciono o IP do usuario a lista o squid bloqueia o acesso, porem não é exibida a pagina de erros escolhida, da "a pagina nao pode ser exibida" tradicional....
    Seguei squid.conf em anexo!
    valew.......
    Arquivos Anexos Arquivos Anexos



  15. #35

    Padrão

    Ola a todos, sou daqueles iniciantes..
    atualizei meu squid para o 3, segui um squid.conf aqui do forum mesmo, deu erro na hora de executar, pois seguindo informacoes do forum o squid tava rodando na outra versao quando atulizei ou executei a nova conf, em fim... como n'ao tenho conhecimento muito em linux, exclui as pastas squid e squid3, tanto na pasta /etc com /var /log...


    Como posso sair destas confusoes e comecar novamente, instalando o squid3, remover essas sujeiras para uma nova reinstalacao do squid3

    obrigado....

  16. #36
    Não Registrado
    Visitante

    Padrão

    Citação Postado originalmente por fullproxy Ver Post
    Ola a todos, sou daqueles iniciantes..
    atualizei meu squid para o 3, segui um squid.conf aqui do forum mesmo, deu erro na hora de executar, pois seguindo informacoes do forum o squid tava rodando na outra versao quando atulizei ou executei a nova conf, em fim... como n'ao tenho conhecimento muito em linux, exclui as pastas squid e squid3, tanto na pasta /etc com /var /log...


    Como posso sair destas confusoes e comecar novamente, instalando o squid3, remover essas sujeiras para uma nova reinstalacao do squid3

    obrigado....
    BrazilFW Firewall and Router está é a solução.