Página 6 de 8 PrimeiroPrimeiro ... 2345678 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom galera o FDS se foi e voltei pro meu passa-tempo (dor-de-cabeça).......

    bom estão no sabado depois de minha ultima postagem formatei a maquina e reinstalei o Kurumin 7 comessando tuudo denovo.
    dai fiz tudo pra compartilhar a internet norlamente la nos scripts do Kurumin, dai instalei o Squid tambem por lá, dai tudo OK perfeito, (como estava antes, sem cache full)
    ai instalei por cima o Squid que já imbuti o ZPH (dpkg -i squid*) da pasta onde deixei a instalação (os 4 DEBs) dai ele deu o erro que sempre da pedindo o Apache, dai instalei o Apache com apt-get dai voltei ao (dpkg -i squid*)ai deu que foi tudo instalado.
    so que continua sem funcionar o cache full... eu baixo um arquivo em uma maquina que etá sem limite, dai baixo em outra maquina que esta com controle de banda e continua limitando a velocidade do arquivo que já esta em cache
    a instalação como fiz por cima não funciona?
    bom tinha funcionado quando segui a dica do braraujo para atualizar para o Lenny ai instalou o Squid 2.7 porém ficou orrivel o desempenho do micro depois disso, dai tentei instalar apenas o Squid 2.7 mudando os repositorios do apt-get, so que na hora que mando instalar o Squid ele diz que tem que substituir uma porrada de outros, dai acho q ia votar a ficar uma merda então não fiz.

    o que fazer??

  2. Citação Postado originalmente por darklinux3 Ver Post
    Os pacotes estao corretos é isso mesmo.
    O que te faz pensar que nao está fazendo cache? se seu proxy é transparente e quando desativa o serviço a navegacao pára. Passou pelo proxy tá fazendo o cache! ou sua configuracao nao esta de acordo
    Verifique a linha do "access log" no squid.conf coloque /var/log/squid/access.log, depois restarte o squid monitore o acesso ao cache com tail -f /var/log/squid/access.log e veja os HIT e MISS do cache estao ocorrendo.

    Cada acesso deve aparecer uma linha no cache. Também verifique o diretorio onde está o cache se foram criados os arquivos realmente.

    Abs!
    Darklinux3 cara o negocio ta foda aqui...
    novamente não está fazendo cache! certeza que não, ja fiz todos os testes possiveis
    e fazendo o que vc falou vela o erro que da em meu log
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line 238: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.



    e o estranho é que existe a ACL all, e mesmo que eu comente a linha http_access deny all e comente a http_access allow all ele continua dando o MESMO erro...
    bom então o controle das delay pools esta funcionando, entao o squid esta funcionando, porem não faz cache, ja tentei desinstalar e reinstalar.
    anexei meu access.log e o squid.conf completo se vc puder dar uma olhada pra ver se acha o erro!
    https://under-linux.org/forums/images/attach/txt.gif access.txt (33.1 KB)

    https://under-linux.org/forums/images/attach/txt.gif squid.conf.txt (4.5 KB)




    valew
    Arquivos Anexos Arquivos Anexos



  3. Citação Postado originalmente por danieluramg Ver Post
    Darklinux3 cara o negocio ta foda aqui...
    novamente não está fazendo cache! certeza que não, ja fiz todos os testes possiveis
    e fazendo o que vc falou vela o erro que da em meu log
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line 238: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.



    e o estranho é que existe a ACL all, e mesmo que eu comente a linha http_access deny all e comente a http_access allow all ele continua dando o MESMO erro...
    bom então o controle das delay pools esta funcionando, entao o squid esta funcionando, porem não faz cache, ja tentei desinstalar e reinstalar.
    anexei meu access.log e o squid.conf completo se vc puder dar uma olhada pra ver se acha o erro!
    https://under-linux.org/forums/images/attach/txt.gif access.txt (33.1 KB)

    https://under-linux.org/forums/images/attach/txt.gif squid.conf.txt (4.5 KB)




    valew
    Você editou o arquivo antes de enviar? Se não o fez procure por outro squid.conf nesse server e trabalhe nele. O log aponta erro na linha 238 mas seu arquivo só tem 145 linhas.

    Cada NONE do teu access.log diz que o navegador ou baixou no cache ou não baixou nada (bloqueado).
    Última edição por bjaraujo; 13-04-2009 às 17:23.

  4. Citação Postado originalmente por bjaraujo Ver Post
    Você editou o arquivo antes de enviar? Se não o fez procure por outro squid.conf nesse server e trabalhe nele. O log aponta erro na linha 238 mas seu arquivo só tem 145 linhas.

    Cada NONE do teu access.log diz que o navegador ou baixou no cache ou não baixou nada (bloqueado).
    como assim antes de enviar? esse squid.conf é o que está na pasta "/etc/squid/"
    é o LOG agora que vi que faltou pedaço, é que estava conectado por SSH e não copiou o texto todo.

    Eu ja tentei reinstalar o Squid,e mesmo com o squid.conf que o proprio kurumin ja instala pre-configurado ele da o mesmo erro quando "squid -f /var/log/squid/access.log"
    ai ele demora um pouco e da o mesmo erro
    2009/04/13 15:38:41| ACL name 'all' not defined!
    FATAL: Bungled access.log line x: http_access deny all
    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.

    modando apenas o numero da linha

    o mais estranho é qua a linha http_access deny all esta comentada!



  5. bom hoje resolvi tentar novamente instalar o Squid do Lenny, então fiz tudo na seguinte ordem:

    • apt-get update

    dai editei a sources.list do apt e editei os repositorios para os do Lenny.

    • apt-get update
    • apt-get upgrade -y

    ai atualizou uma porrada de pacotes.
    dai instalei o Squid (atualizou mais um monte)
    ai iniciou o serviço, e tal
    dei um squid -v e realmente, esta agora com a versão 2.7 Stable3
    novamente esta fazendo o controle de banda, editei o squid.conf conforme minhas configurações, etc.
    e novamente fiz um download em uma estação, limpei a cache do navegador, apaguei o arquivo baixado e baixei o mesmo arquivo novamente, que foi novamente baixado do servidor (o squid não fez cache)

    ai dei um squid -f /var/log/access.log
    que estranhamente, mas já me acostumei deu o mesmo erro
    2009/04/14 10:24:06| ACL name 'all' not defined!
    FATAL: Bungled (null) line 180: http_access deny all
    Squid Cache (Version 2.7.STABLE3): Terminated abnormally.

    terminando com o processo. apontando para a linha 180
    bom agora sim vem o que achei muito estranho mesmo, abri o access.log, cache.log e store.log e limpei todos, e novamente acessei um pouco via proxy, e depois voltei a rodar o comando squif -f /var/log/squid/access.log, que novamente deu o MESMO erro apontando para a MESMA linha 180, sendo que o arquivo não tem nem esse tanto de linhas!

    cara tem alguma parte do meu squid que ta bixada/travada, não sei mais o que fazer...

    aguardo uma luz de uma alma bendita, acredito que so um power user no squid pra desvendar esse mistério.........






Tópicos Similares

  1. Duvida sobre Web-proxy cache full
    Por maxwellsousa no fórum Servidores de Rede
    Respostas: 10
    Último Post: 31-12-2008, 11:51
  2. Dúvidas sobre tamanho do cache para Squid
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 5
    Último Post: 18-05-2006, 16:36
  3. Duvidas Iptables + Squid -----Help-----
    Por A-Marcio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 29-03-2003, 10:26
  4. Squid sem cache
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-11-2002, 20:14
  5. DÚVIDA NO SQUID!!!!!!!!!!!!!!!!!!!!
    Por BrunoPiaui no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-11-2002, 17:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L