Página 7 de 8 PrimeiroPrimeiro ... 2345678 ÚltimoÚltimo
+ Responder ao Tópico



  1. Derrube seu squid, como root:
    Código :
    killall -s9 squid
    Teste o arquivo de configuração:
    Código :
    squid -f /etc/squid/squid.conf -f check
    Rode teu squid com o seguinte comando, como root:
    Código :
    squid -f /etc/squid/squid.conf -d2
    Qualquer coisa me manda um mp com teu msn.

  2. Citação Postado originalmente por bjaraujo Ver Post
    Derrube seu squid, como root:
    Código :
    killall -s9 squid
    Teste o arquivo de configuração:
    Código :
    squid -f /etc/squid/squid.conf -f check
    Rode teu squid com o seguinte comando, como root:
    Código :
    squid -f /etc/squid/squid.conf -d2
    Qualquer coisa me manda um mp com teu msn.
    Fiz tudo deu isso:

    root@squidserver:/etc/squid# killall -s9 squid
    root@squidserver:/etc/squid# squid -f /etc/squid/squid.conf -f check
    FATAL: Unable to open configuration file: check: (2) No such file or directory
    Squid Cache (Version 2.7.STABLE3): Terminated abnormally.
    CPU Usage: 0.008 seconds = 0.004 user + 0.004 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    Abortado
    root@squidserver:/etc/squid# squid -f /etc/squid/squid.conf -d2
    root@squidserver:/etc/squid# 2009/04/14 11:22:19| Starting Squid Cache version 2.7.STABLE3 for i386-debian-linux-gnu...
    2009/04/14 11:22:19| Process ID 8011
    2009/04/14 11:22:19| With 1024 file descriptors available
    2009/04/14 11:22:19| Using epoll for the IO loop
    2009/04/14 11:22:19| Performing DNS Tests...
    2009/04/14 11:22:19| Successful DNS name lookup tests...
    2009/04/14 11:22:19| DNS Socket created at 0.0.0.0, port 1167, FD 6
    2009/04/14 11:22:19| Adding nameserver 208.67.222.222 from /etc/resolv.conf
    2009/04/14 11:22:19| Adding nameserver 208.67.220.220 from /etc/resolv.conf
    2009/04/14 11:22:19| User-Agent logging is disabled.
    2009/04/14 11:22:19| Referer logging is disabled.
    2009/04/14 11:22:19| logfileOpen: opening log /var/log/squid/access.log
    2009/04/14 11:22:19| Unlinkd pipe opened on FD 11
    2009/04/14 11:22:19| Swap maxSize 15360000 KB, estimated 1181538 objects
    2009/04/14 11:22:19| Target number of buckets: 59076
    2009/04/14 11:22:19| Using 65536 Store buckets
    2009/04/14 11:22:19| Max Mem size: 262144 KB
    2009/04/14 11:22:19| Max Swap size: 15360000 KB
    2009/04/14 11:22:19| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    2009/04/14 11:22:19| logfileOpen: opening log /var/log/squid/store.log
    2009/04/14 11:22:19| Rebuilding storage in /var/spool/squid (DIRTY)
    2009/04/14 11:22:19| Using Least Load store dir selection
    2009/04/14 11:22:19| Current Directory is /etc/squid
    2009/04/14 11:22:19| Loaded Icons.
    2009/04/14 11:22:19| Accepting proxy HTTP connections at 0.0.0.0, port 3128, FD 13.
    2009/04/14 11:22:19| Accepting ICP messages at 0.0.0.0, port 3130, FD 14.
    2009/04/14 11:22:19| HTCP Disabled.
    2009/04/14 11:22:19| WCCP Disabled.
    2009/04/14 11:22:19| Ready to serve requests.
    2009/04/14 11:22:19| Store rebuilding is 19.4% complete
    2009/04/14 11:22:20| Done reading /var/spool/squid swaplog (21118 entries)
    2009/04/14 11:22:20| Finished rebuilding storage from disk.
    2009/04/14 11:22:20| 20910 Entries scanned
    2009/04/14 11:22:20| 0 Invalid entries.
    2009/04/14 11:22:20| 0 With invalid flags.
    2009/04/14 11:22:20| 20910 Objects loaded.
    2009/04/14 11:22:20| 0 Objects expired.
    2009/04/14 11:22:20| 204 Objects cancelled.
    2009/04/14 11:22:20| 0 Duplicate URLs purged.
    2009/04/14 11:22:20| 0 Swapfile clashes avoided.
    2009/04/14 11:22:20| Took 0.8 seconds (27124.6 objects/sec).
    2009/04/14 11:22:20| Beginning Validation Procedure
    2009/04/14 11:22:20| Completed Validation Procedure
    2009/04/14 11:22:20| Validated 20706 Entries
    2009/04/14 11:22:20| store_swap_size = 435740k
    2009/04/14 11:22:20| storeLateRelease: released 0 objects



  3. Olá amigo seu arquivo de configuracao esta com problemas, quando vc instalou o squid ele ja deveria estar rodando normalmente e fazendo cache das paginas a acl all ja viria inclusa. Aqui eu uso debian apenas o sistema basico e instalo apenas os pacotes do bind9, squid e squid-common(2.6).
    Eu ainda nao utilizei esse squid 2.7 pode ser que existe alguma diferença de configuracao uma vez passei por isso quando utilizava a versao 2.5 e lançaram a 2.6.
    Em eu conf. tem muitas acl de bloqueios, uma dica: rode primeiro o básico default que vem com a sua distro vá refinando seu serviço para adapta-lo as suas necessidades.

    Faz o teste e posta o resultado!
    Abs!

  4. Citação Postado originalmente por darklinux3 Ver Post
    Olá amigo seu arquivo de configuracao esta com problemas, quando vc instalou o squid ele ja deveria estar rodando normalmente e fazendo cache das paginas a acl all ja viria inclusa. Aqui eu uso debian apenas o sistema basico e instalo apenas os pacotes do bind9, squid e squid-common(2.6).
    Eu ainda nao utilizei esse squid 2.7 pode ser que existe alguma diferença de configuracao uma vez passei por isso quando utilizava a versao 2.5 e lançaram a 2.6.
    Em eu conf. tem muitas acl de bloqueios, uma dica: rode primeiro o básico default que vem com a sua distro vá refinando seu serviço para adapta-lo as suas necessidades.

    Faz o teste e posta o resultado!
    Abs!
    Opa blz brother
    cara o bjaraujo me ajudou aqui, fizemos varias tentativas que ele foi me passando pelo MSN, dai tava dando varios erros estranhos e tal, ai ate rodou, dai entrou em meu server por SSH e conseguiu fazer rodar blzinha .
    so que como da vez anterior que mudei os repositorios para os do Lenny a estabilidade da internet ficou horrivel, demora pra responder ao requisitar uma pagina, ate o SSH fica lento, dai revotei e formatei denovo!
    dai fiz tudo direitinho: 1º intalei o kurumin, fiz as atualizações do apt-get, instalei o compartilhamento, firewall, depois o Squid pelos scripts, dai me sertifiquei de que estava rodando mesmo, reiniciei a maquina e tava redondinho novamente.
    dai parei o Squid, instalei o Apache (que sempre q vou atualizar para o meu Squid com ZPH ele reclama, entao ja instalei antes) dai sim instalei o Squid com ZPH que compilei, ai sim ficou perfect!
    ta fazendo o controle de banda, cache full, etc.
    bom mas ainda estou com ideia de instalar o HTB ou CBQ, pois nao estou gostando da maneira que as delay pools funcionam, e tambem não consigo fazer a pagina de erros personalizada para nao pagantes funcionar, se puder veja meu squid.conf
    dai la no fim esta as regras que criei, no arquivo "naopagou" coloco o IP dos inadimplentes
    e o arquivo "SUSPENSO" esta na pasta de erros, que tambem informei no squid.conf
    quando adiciono o IP do usuario a lista o squid bloqueia o acesso, porem não é exibida a pagina de erros escolhida, da "a pagina nao pode ser exibida" tradicional....
    Seguei squid.conf em anexo!
    valew.......
    Arquivos Anexos Arquivos Anexos



  5. Ola a todos, sou daqueles iniciantes..
    atualizei meu squid para o 3, segui um squid.conf aqui do forum mesmo, deu erro na hora de executar, pois seguindo informacoes do forum o squid tava rodando na outra versao quando atulizei ou executei a nova conf, em fim... como n'ao tenho conhecimento muito em linux, exclui as pastas squid e squid3, tanto na pasta /etc com /var /log...


    Como posso sair destas confusoes e comecar novamente, instalando o squid3, remover essas sujeiras para uma nova reinstalacao do squid3

    obrigado....






Tópicos Similares

  1. Duvida sobre Web-proxy cache full
    Por maxwellsousa no fórum Servidores de Rede
    Respostas: 10
    Último Post: 31-12-2008, 11:51
  2. Dúvidas sobre tamanho do cache para Squid
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 5
    Último Post: 18-05-2006, 16:36
  3. Duvidas Iptables + Squid -----Help-----
    Por A-Marcio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 29-03-2003, 10:26
  4. Squid sem cache
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-11-2002, 20:14
  5. DÚVIDA NO SQUID!!!!!!!!!!!!!!!!!!!!
    Por BrunoPiaui no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-11-2002, 17:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L