+ Responder ao Tópico



  1. #181
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão DE ACORDO

    Sérgio mais uma vez estou de acordo com você. O pessoal precisa se dedicar mais um pouco em estudar.

    Citação Postado originalmente por sergio Ver Post
    Acredito que não seja isso. Eu sou totalmente contra receita de bolo, pois não traz conhecimento para ninguém e ainda incentiva os "preguiçosos".

    O que foi postado pelo Luciano (m4d3) é que não adianta vir no tópico e encher de telinha de Mikrotik, configurações do squid.conf ou iptables se o cidadão não sabe como é que funciona cada um desses.

    Se não sabe, pesquise e aprenda, se não tem tempo para isso, contrate alguém que saiba implementar ou leve mais tempo para estudar e entender.

    O intuito do tópico é que usem o script, debugem o mesmo, encontrem falhas, se puder colaborem reportando bugs e enviando melhorias, mas para isso o cidadão tem que saber como funciona "a coisa" em nível conceitual e prático.

  2. #182

    Padrão

    amigos,

    Tudo que vem fácil vai fácil, ou seja, todo conhecimento que adquirimos com muita facilidade como vocês estão querendo, vai acabar no esquecimento facilmente. Tenho certeza que muitos não vão nem querer saber o que estão colocando no mk deles, só vão querer ver funcionando, ai se der pau, como faz???

    Digo pra vocês comecei a montar meu proxy paralelo na sexta anoite, fiquei ontem até as 2 da manhã adivinhem o que aconteceu????

    Depois de varias tentativas (instalei o debian umas 5 vezes no meu server) consegui colocar tudo pra funcionar, só não consegui colocar ainda o SARG pra gravar o ip do cliente e não do MK, fora isso ta filé.

    Tem vários posts ai no underlinux falando de proxy paralelo, tentem comparar, corram atrás e nunca pensem em desistir. As regras são parecidas. Vai depender da estrutura de cada um, as regras que coloquei no meu talves não funcione no de vocês, por isso que vocês teem que correr atrás, para saber o que estão fazendo.

    Deem uma olhada no script do luciano, depois que dei uma lida no script dele ganhei uma noção de como funcionava o programa dele.

    Abraços a todos



  3. #183

    Padrão Sobre o sarg

    Caro amigo tb tive este problema no sarg,e so consegui fazer funcionar rodando na mao o crontab.
    Nossos amigos ai tem experiencia para detalhar o processo.
    E posteriormente rodando o ./gera_rel.sh ( que ira gerar o relatorio do sarg do DIA ).

  4. #184
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão SARG

    Bruno bom dia,
    me diz uma coisa vc ñ está conseguindo que apareça os ip´s dos clientes no SARG é isso?
    Se for basta vc colocar um ! na frente do ip do servidor linux no nat.
    Citação Postado originalmente por brunocabrini Ver Post
    amigos,

    Tudo que vem fácil vai fácil, ou seja, todo conhecimento que adquirimos com muita facilidade como vocês estão querendo, vai acabar no esquecimento facilmente. Tenho certeza que muitos não vão nem querer saber o que estão colocando no mk deles, só vão querer ver funcionando, ai se der pau, como faz???

    Digo pra vocês comecei a montar meu proxy paralelo na sexta anoite, fiquei ontem até as 2 da manhã adivinhem o que aconteceu????

    Depois de varias tentativas (instalei o debian umas 5 vezes no meu server) consegui colocar tudo pra funcionar, só não consegui colocar ainda o SARG pra gravar o ip do cliente e não do MK, fora isso ta filé.

    Tem vários posts ai no underlinux falando de proxy paralelo, tentem comparar, corram atrás e nunca pensem em desistir. As regras são parecidas. Vai depender da estrutura de cada um, as regras que coloquei no meu talves não funcione no de vocês, por isso que vocês teem que correr atrás, para saber o que estão fazendo.

    Deem uma olhada no script do luciano, depois que dei uma lida no script dele ganhei uma noção de como funcionava o programa dele.

    Abraços a todos



  5. #185

    Padrão SARG

    Seria minha proxima busca pois no meu so aparece o ip do MK....Vamos ao teste...
    Thanks....

  6. #186

    Padrão RELATORIO SARG

    Bom Exatamente como foi relatado.
    Eu uso o nat por IP e nao por interface...
    No relatorio aparece os 2 ips ( MK+CLIENTE ).
    Isso e normal Segue um Screenshot do sarg.

    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         sarg.JPG
Visualizações:	137
Tamanho: 	32,6 KB
ID:      	4120  



  7. #187

    Padrão

    ..........
    Última edição por Roberto21; 05-05-2009 às 00:44.

  8. #188
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Por favor sem agressões, senão a única alternativa é fechar o tópico.



  9. #189
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão

    Roberto a forma que vc me explicou assim eu compreendo sim, a sua ideia é pesquisar, e aprender, o que eu não acho legal é cobrar caro, e falar, assim ta tudo pronto, ai quando irmos atraz fala tem que fazer muita coisa, ontem conversei com vc, sobre isso, no msn, inclusive garanti a vc que não iria postar de forma alguma, so que se continuar assim irei postar o que deu certo aki
    nada contra vc, muito menos sem contra o luciando, e sim contra atitudes e hipocrisia

  10. #190

    Padrão

    Olá a todos,

    Já fiz de tudo ao alcance do meu pequenissimo conhecimento e ñ consegui rodar o proxy paralelo, por este motivo pergunto a vcs, este proxy funciona tanto em pppoe e hotspot, ou tem alguma diferença entre as configurações.

    Obs.: Atualmente eu utilizo pppoe

    Obrigado pela atenção.



  11. #191

    Padrão

    Citação Postado originalmente por ssn129 Ver Post
    Olá a todos,

    Já fiz de tudo ao alcance do meu pequenissimo conhecimento e ñ consegui rodar o proxy paralelo, por este motivo pergunto a vcs, este proxy funciona tanto em pppoe e hotspot, ou tem alguma diferença entre as configurações.

    Obs.: Atualmente eu utilizo pppoe

    Obrigado pela atenção.
    Sim, funciona tanto em pppoe quanto em hotspot. Consegue do seu mikrotik pingar o ip do linux por padrão 192.168.10.250 ? se sim crie uma regra em ip firewall nat
    dst-nat
    src-address !192.168.10.250
    dst-port 80
    action
    dst-nat 192.168.10.250
    to-ports 3128

    antes do mascaramento e depois das demais regras
    isso deve desviar o trafego da porta 80 para o servidor squid do conlinux.

    Qualquer dificuldade volte a nos procurar.

    Sucesso amigo.

    M4D3

  12. #192

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Sim, funciona tanto em pppoe quanto em hotspot. Consegue do seu mikrotik pingar o ip do linux por padrão 192.168.10.250 ? se sim crie uma regra em ip firewall nat
    dst-nat
    src-address !192.168.10.250
    dst-port 80
    action
    dst-nat 192.168.10.250
    to-ports 3128

    antes do mascaramento e depois das demais regras
    isso deve desviar o trafego da porta 80 para o servidor squid do conlinux.

    Qualquer dificuldade volte a nos procurar.

    Sucesso amigo.

    M4D3
    Parabens Luciano, parece ate que voce escutou meu comentario entre amigos do under.



  13. #193

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Sim, funciona tanto em pppoe quanto em hotspot. Consegue do seu mikrotik pingar o ip do linux por padrão 192.168.10.250 ? se sim crie uma regra em ip firewall nat
    dst-nat
    src-address !192.168.10.250
    dst-port 80
    action
    dst-nat 192.168.10.250
    to-ports 3128

    antes do mascaramento e depois das demais regras
    isso deve desviar o trafego da porta 80 para o servidor squid do conlinux.

    Qualquer dificuldade volte a nos procurar.

    Sucesso amigo.

    M4D3
    Obrigado, depois de tantas lutas, descobri q o prxy esta funcionando, o problema está no fato de q o mesmo ñ se conecta ao link de internet.

  14. #194

    Padrão

    Citação Postado originalmente por ssn129 Ver Post
    Obrigado, depois de tantas lutas, descobri q o prxy esta funcionando, o problema está no fato de q o mesmo ñ se conecta ao link de internet.
    Se vc consegue pingar do mikrotik no linux então já é meio caminho, verifica se o gateway do linux é o ip da placa de rede (/etc/network/interfaces) do mikrotik e acerta o dns do linux (/etc/resolv.conf).

    Sucesso

    M4D3



  15. #195

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Se vc consegue pingar do mikrotik no linux então já é meio caminho, verifica se o gateway do linux é o ip da placa de rede (/etc/network/interfaces) do mikrotik e acerta o dns do linux (/etc/resolv.conf).

    Sucesso

    M4D3
    Olá,

    Está tudo ok, eu pingo no servidor 192.168.10.250 e dentro do servidor pingo qualquer pagina na Web.
    Última edição por ssn129; 30-04-2009 às 20:00.

  16. #196
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Boa noite...

    Pessoal é o seguinte, aqui esta quase tudo normal a nao ser os videos do youtube globo, outros sites como uol abre o video mais nao espera reproduzir e ja passa pra outro video ai eu volto a pagina e ele abre a pagina rapidamente e o video ja esta no cache do linux, mais o do youtube e globo nao abre nem a pau fica só uma tela preta no lugar do video.

    os arquivos que baixo tambem percebi que esta fazendo cache de alguns e outros nao

    As unicas regras que coloquei no mk para o linux foi a masquerade com ip na faixa do linux e a regra de ds-nat com ! no ip do linux em scr adress

    E tbm o link da dica do Luciano para ver os logs http://192.168.10.250/squid-reports/...r11-2020Apr04/ que nao abre tambem

    Ah tbm coloquei aquele index que o Luciano fez, mais depois tirei nao sei se fiz certo nao tinha a o diretorio youtube dentro do diretorio /var/www/thunder ai criei o diretorio youtube e dentro dele o index.php com o codigo do luciano

    Se alguem puder me dar uma dica eu agradeço

    Falow abraços a todos
    Última edição por edcomrocha; 30-04-2009 às 18:47. Razão: editar texto



  17. #197

    Padrão

    Olá,

    Esta é a minha situação, em anexo

    Porfavor, me deêm uma solução.


    Obrigado.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         novo-2.jpg
Visualizações:	122
Tamanho: 	193,6 KB
ID:      	4143   Clique na imagem para uma versão maior

Nome:	         novo-3.jpg
Visualizações:	92
Tamanho: 	24,8 KB
ID:      	4144  

    Clique na imagem para uma versão maior

Nome:	         novo-1.jpg
Visualizações:	122
Tamanho: 	527,2 KB
ID:      	4145  

  18. #198

    Padrão

    Citação Postado originalmente por edcomrocha Ver Post
    Veja o seu arquivo de configuração do sarg, talvez o diretório padrão não seja este.



  19. #199

    Padrão

    Citação Postado originalmente por ssn129 Ver Post
    ...
    Porfavor, me deêm uma solução...
    Você já instalou e configurou o squid? E ele tá em execução?

  20. #200

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Você já instalou e configurou o squid? E ele tá em execução?
    Sim, e se vc reparar nos anexos verá q ele esta rodando, só ñ esta repassando as requisições dos usuarios.


    Obrigado