+ Responder ao Tópico



  1. Olá,

    Já fiz de tudo no mikrotik para acessar o debian, e não consegui, pesso a alguem que mi ajude a configurar o mikrotik.

    Tenho um mikrotik com pppoe.

    obrigado

  2. boa tarde

    aqui utilizo hotspot mas creio que não tem influência nas regras de comunicação do mk-debian para o proxy em paralelo ao mikrotik vamos lá

    1º Vc vai adicionar duas regras no seu mk, vai em Ip/Firewall/NAt:

    a) Esta regra abastece o debian com link sem limitação de banda.
    chain=srcnat, src. address: 192.168.10.0/30(classe ip debian ), action=masquerede;

    b) Esta regra redireciona todos os pedidos destinados a porta 80(http) vindos dos clientes para o debian.
    chain=dstnat, src. address: 192.168.168.0/24(classe de ip da interface clientes que vai para users), protocol=6 tcp, dst. port=80, in. interface: clientes(sua interface que ai para os clientes), action=redirect, to port=3128(esta porta deve ser comentada em web proxy setting)

    Seguindo agora vc altera em Ip/Web proxy/botão settings os seguintes detalhes:

    port: 3128
    hostname: proxy
    transparent proxy=yes
    parent proxy:192.168.10.2
    parent proxy port: 5128

    o resto normal

    Obs: É obvio que vc tem que adequar estes dados a sua realidade e não esquecer de adequar os ips tanto na placa que liga no debian quanto as demais.

    Continuando...

    Agora no debian partindo do presuposto que vc tem o debian instalado basta configurar o squid.conf conforme sua realidade de hardware memoria, hd etc

    se tiver duvidas quanto a configuração do squid é so perguntar

    abraços



  3. Muito obrigado jean.

    Uma pergunta, esta mesma regra serviu para o conlinuxZ4?

    Aqui eu uso a seguinte configuração:

    IP => Firewall => Filter Rules:
    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no \
    dst-port=3128 protocol=tcp
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    Ip => Firewall => Nat
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=!Clientes protocol=tcp src-address=\
    172.10.20.0/24 to-ports=3128
    Ip => firewall => Mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    Queue => Tree
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="[CACHE-FULL] - Download" packet-mark=\
    pacotes_squid-down parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5000000 name="[CACHE-FULL] - Upload" packet-mark=\
    pacotes_squid-up parent=global-out priority=1 queue=default

    IP => Proxy
    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=400000000KiB \
    max-client-connections=600 max-fresh-time=4w2d max-server-connections=\
    600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow comment="" disabled=no src-address=172.10.20.0/24
    Última edição por ssn129; 21-04-2009 às 20:22.

  4. Citação Postado originalmente por ssn129 Ver Post
    Muito obrigado jean.

    Uma pergunta, esta mesma regra serviu para o conlinuxZ4?

    Aqui eu uso a seguinte configuração:

    IP => Firewall => Filter Rules:
    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no \
    dst-port=3128 protocol=tcp
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    Ip => Firewall => Nat
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=!Clientes protocol=tcp src-address=\
    172.10.20.0/24 to-ports=3128
    Ip => firewall => Mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    Queue => Tree
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="[CACHE-FULL] - Download" packet-mark=\
    pacotes_squid-down parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5000000 name="[CACHE-FULL] - Upload" packet-mark=\
    pacotes_squid-up parent=global-out priority=1 queue=default

    IP => Proxy
    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=400000000KiB \
    max-client-connections=600 max-fresh-time=4w2d max-server-connections=\
    600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow comment="" disabled=no src-address=172.10.20.0/24
    Boa noite a todos

    ssn129

    Não testei ainda o script do m4d3 no meu cenário mas creio que não tem influencia no maximo alteração de classe de ip que o debian vai trabalhar ja que o script altera para uma classe de ip especifica, estou trocando meu server mk por um mais novo e estou revisando todas as regras de firewall, balanceamento, criptografia, autenticação, paginas de aviso, classes de ip, servidor dhcp, radius enfim estou usando a versão 2.9.50 e vou passar pra versão 3.20 então esta meio enrolado aqui pra min, mas quando terminar quero voltar minhas atenções pro debian...mas se precisar de alguma dica e eu puder ajudar beleza

    abraços



  5. ............
    Última edição por Roberto21; 04-05-2009 às 23:37.






Tópicos Similares

  1. Regras Speedr para Integração com Mikrotik e Cache Full
    Por rodolfostayne no fórum Servidores de Rede
    Respostas: 23
    Último Post: 11-11-2015, 13:00
  2. Respostas: 17
    Último Post: 29-10-2012, 11:52
  3. Servidor para escritório com Mikrotik
    Por davijhon no fórum Sistemas Operacionais
    Respostas: 12
    Último Post: 18-12-2010, 09:13
  4. Respostas: 11
    Último Post: 19-10-2008, 02:23
  5. Shell Script para integração com Mikrotik
    Por Kandango no fórum Redes
    Respostas: 3
    Último Post: 19-03-2008, 19:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L