+ Responder ao Tópico



  1. #81

    Arrow Para quem esta com problema de lentidão após um certo tempo

    Olá estou usando o Thunder desde o inicio, desde quando se chamava ecache. O projeto é excelente o problema é que quando ele é utilizado em provedores o mesmo sofre um número muito grande de requisições.

    Antes o problema maior era o mysql que no meu caso sempre ficava usando 100% de cpu. Hj na versão 2.1 foi retirada o mysql mas o problema de lentidão continua para quem tem muitas requisições.

    No meu caso tive esse problema cheguei a deixar o meu cache uma semana desativado até encontrar a solução. Pesquisando muito descobri q o erro era de WARNING! Your cache is running out of filedescriptors analizando o log do squid.

    Para resolver tinha visto uma dica de mudar o n. máximo de arquivos do squid em /etc/default/squid para SQUID_MAXFD=4096

    Somente isso não resolveu ai encontrei uma outra dica de mudar o n. máximo de arquivos abertos pelo kernel em /proc/sys/fs/file-max

    Lembrando q essas conf são para o ubuntu.

    Essa semana um outro usuário do forum do Thunder descobriu uma configuração no squid.conf q estava gerando muito trafego desnecessário.

    Para resolver
    É só mudar na linha do squid.conf
    acl store_rewrite_list url_regex -i "/etc/squid/thunder/thunder.lst" para
    acl store_rewrite_list dstdomain -i "/etc/squid/thunder/thunder.lst"

    Tai as dicas para mim resolveu espero que resolva para vcs também.

  2. #82

    Padrão

    ............
    Última edição por Roberto21; 05-05-2009 às 00:35.



  3. #83

    Padrão

    Olá brother!


    Também já alterei aqui mas não resolveu, já almentei as requisições do squid para 4096, já olhei no forum do thunder, já fiz algumas dicas que o pessoal passou por lá e nada resolveu.

    tenho P4/LGA775/3.0---4G/667 de ram/500G de hd...vou aguaradar para amanhã (domingo) alguém dar uma luz...por que são 2 horas da manhã e não consegui resolver((((o dia todo))))).


    Mas amanhã conseguirei...

    Quanto ao full marque no mangle com a TOS 48 ( somente) e em forward, se for a versão 2 do MK, que ai o mangle começa a marcar e as outras regras fluem normalmente, aqui fiz assim e quando o server não para os vídeos saem que é uma beleza.
    __________________
    Roberto.
    Email: [email protected]
    De que adianta a banda larga se a mente é estreita ?

    www.porque2012.com



    Roberto, como te disse meu cache ta rodando que é uma maravilha!!! nao deu nenhum pau mais...
    mas ainda nao consegui fazer o full no mk, uso a versao 3.20, sera q vc nao poderia, me detalhar essas regras, por favor se possivel.....
    to errando em alguma coisa....
    os pacotes marcam com tos 12
    ve o q pode fazer por favor se possivel, desde ja agradecido e um abraço...

  4. #84

    Padrão

    Citação Postado originalmente por multlink Ver Post
    ae o erro completo!

    cache:/home/multlink# ./conlinuxZ4.sh

    Ign cdrom://[Debian GNU/Linux 4.0 r4a _Etch_ - Official i386 CD Binary-1 20080803-21:07] etch Release.gpg
    Ign cdrom://[Debian GNU/Linux 4.0 r4a _Etch_ - Official i386 CD Binary-1 20080803-21:07] etch Release
    Ign cdrom://[Debian GNU/Linux 4.0 r4a _Etch_ - Official i386 CD Binary-1 20080803-21:07] etch/contrib Packages/DiffIndex
    Ign cdrom://[Debian GNU/Linux 4.0 r4a _Etch_ - Official i386 CD Binary-1 20080803-21:07] etch/main Packages/DiffIndex
    Obtendo:1 Debian -- Security Information etch/updates Release.gpg [197B]
    Atingido Debian -- Security Information etch/updates Release
    Ign Debian -- Security Information etch/updates/main Packages/DiffIndex
    Ign Debian -- Security Information etch/updates/contrib Packages/DiffIndex
    Ign Debian -- Security Information etch/updates/main Sources/DiffIndex
    Ign Debian -- Security Information etch/updates/contrib Sources/DiffIndex
    Atingido Debian -- Security Information etch/updates/main Packages
    Atingido Debian -- Security Information etch/updates/contrib Packages
    Atingido Debian -- Security Information etch/updates/main Sources
    Atingido Debian -- Security Information etch/updates/contrib Sources
    Baixados 197B em 11s (18B/s)
    Lendo lista de pacotes... Pronto
    Lendo lista de pacotes... Pronto
    Construindo árvore de dependências... Pronto
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
    Lendo lista de pacotes... Pronto
    Construindo árvore de dependências... Pronto
    squid já é a versão mais nova.
    Nota, selecionando apache2-mpm-prefork ao invés de apache2
    apache2-mpm-prefork já é a versão mais nova.
    O pacote lynx não está disponível, mas é referenciado por outro pacote.
    Isso pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte
    E: O pacote lynx não tem candidato para instalação
    Criando variaveis de configuracao
    Configurando SARG...
    Baixando Thunder Cache 2.1
    --19:49:52-- http://ecache.svn.sourceforge.net/vi...ar.gz?view=tar
    => `v2.1.tar.gz?view=tar'
    Resolvendo ecache.svn.sourceforge.net... 216.34.181.65
    Connecting to ecache.svn.sourceforge.net|216.34.181.65|:80... conectado!
    HTTP requisição enviada, aguardando resposta... 200 OK
    Tamanho: nao especificado [application/octet-stream]

    [ <=> ] 11,628 53.58K/s

    19:49:53 (53.34 KB/s) - `v2.1.tar.gz?view=tar' saved [11628]

    Configurando Thunder Cache 2.1
    ln: criando link simbólico `/etc/squid/googlevideo.com.php' to `/etc/squid/youtube.com.php': Arquivo existe
    ln: criando link simbólico `/etc/squid/grisoft.com.php' to `/etc/squid/avg.com.php': Arquivo existe
    ln: criando link simbólico `/var/www/thunder.php' to `/etc/squid/thunder.php': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/thunder': Arquivo existe
    Configurando interface eth0...
    Configurando Apache 2.0
    mkdir: não é possível criar o diretório `/var/www/conprove': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/conprove/aviso': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/conprove/corte': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/conprove/pendencia': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/conprove/manutencao': Arquivo existe
    mkdir: não é possível criar o diretório `/var/www/conprove/aguarde': Arquivo existe
    Configurando SQUID...
    Forcing reload of web server (apache2)...Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

    diminui para caber o texto(muda somente as portas)

    [Sat Apr 18 19:49:57 2009] [warn] VirtualHost 192.168.10.250:81 overlaps with VirtualHost 192.168.10.250:81, the first has precedence, perhaps you need a NameVirtualHost directive
    httpd (no pid file) not running
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    Warning: DocumentRoot [/var/www/squid-reports/] does not exist
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

    diminui para caber o texto(muda somente as portas)

    [Sat Apr 18 19:49:57 2009] [warn] VirtualHost 192.168.10.250:81 overlaps with VirtualHost 192.168.10.250:81, the first has precedence, perhaps you need a NameVirtualHost directive
    (98)Address already in use: make_sock: could not bind to address [::]:81
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:81
    no listening sockets available, shutting down
    Unable to open logs
    failed!
    Olá, pelo seu log acredito que esteja utilizando debian 4, o scritp é para o 5, você pode corrigir os erros fazendo a instalação guiada pelo tutorial da primeira página deste post ou em
    PC RAM Informática | O mundo mais perto de você! na aba 'serviços', onde o conteúdo esta constantemente sendo atualizado e o tutorial já possui um adicional. Em breve novo script melhorado e mais videos.

    Abraço

    M4D3



  5. #85

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Ola pessoal, depois de tantos tutoriais que já vi na net, muitas vezes utilizando do conhecimento dos amigos para aprimorar as soluções que utilizo, compilando uma série de informações resolvi fazer um video mostrando como instalar o debian como preparação para servidor cache dentre outros serviços, este tutorial permite imediata integração com super cache full pelo mikrotik, segue o link do video de instalação do Debian:








    Para maiores detalhes preparei página fixa de download em PC RAM Informática | O mundo mais perto de você! acesso o menu serviços.


    Dentre os recursos do script:


    - Squid 2.7 com ZPH integrado para uso com cache full

    - Apache 2.0 configurado com hosts virtuais para uso no envio de mensagem aos clientes (Ex: débito, bloqueio, atraso, comunicação de manutenção, avisos...)

    - Sarg geração de relatório de acessos do squid com agendamento

    - ThunderCache para cache de videos do Youtube/Uol/Terra/Outros... e atualizações da Microsoft/Antivirus/Outros...

    - Publicidade via MSN, alterando o banner padrão do MSN para banner do provedor/evento/vendendo anuncio via msn

    - Publicidade via YOUTUBE, através da configuração do próprio ThunderCache

    - Configuração da interface de rede eth0




    CONHEÇA O DEBIAN


    Debian 5.01 - download x64:
    < Versão 64bits


    Debian 5.01 - download i386 : < Versão 32bits utilizado no video tutorial



    DICAS:
    Ao instalar, mantenha o micro conectado a um servidor DHCP (veja abaixo) para que seja possível baixar os pacotes necessários e proceder as atualizações, estou terminando de testar o script que irá automatizar as configurações do servidor, estarei postando aqui assim que concluído (em até 2 dias).

    Adicione em uma placa de rede do seu servidor mikrotik (não de link nem de clientes) o ip 192.168.10.253 será o gateway do seu Debian:
    / ip address
    add address=192.168.10.253/24 network=192.168.10.0 broadcast=192.168.10.255 \
    interface=EthIntranet comment="" disabled=no

    O ip configurado no Debian depois de rodar o script será:
    IP: 192.168.10.250
    MSK: 255.255.255.0
    GAT: 192.168.10.253
    DNS: 192.168.10.253 < quem irá resolver nomes será o Mikrotik

    VALOS LÁ PESSOAL, AGORA TA PRONTO:

    PC RAM Informática | O mundo mais perto de você! e acesse o menu serviços, verá o tutorial atualizado com maquina virtual pra baixar e script incluso.

    E pra quem quiser baixar o script direto no seu linux debian já instalado conforme o video o comando é:

    Código :
    [COLOR=red][B]wget [URL="http://www.pcram.com.br/conlinux/conlinuxZ4.sh"][COLOR=#0000ff]http://www.pcram.com.br/conlinux/conlinuxZ4.sh[/COLOR][/URL][/B][/COLOR]
    [B][COLOR=red]chmod +x conlinuxZ4.sh[/COLOR][/B]
    [B][COLOR=red]./conlinuxZ4.sh[/COLOR][/B]



    Crie o arquivo /var/www/thunder/youtube/index.php com o código abaixo para listar e tocar os videos do diretório diretamente no youtube.
    Código :
    [B][COLOR=red]<?php
    #ADAPTADO DA WEB POR LUCIANO RAMPANELLI / M4D3
    $diretorio = getcwd();
    $ponteiro  = opendir($diretorio);
    while ($nome_itens = readdir($ponteiro)) {
        $tipos = array("flv", "flx", "fla");
        $itens[] = $nome_itens;
    }
     
    sort($itens);
    foreach ($itens as $listar) {
       if ($listar!="." && $listar!=".."){
                    if (is_dir($listar)) {
                            $pastas[]=$listar;
                    } else{
    if (in_array(strtolower(end(explode(".",$listar))), $tipos)) { $arquivos[]=$listar; }
                    }
       }
    }
     
     
    #if ($pastas != "" ) {
    #foreach($pastas as $listar){
    #   print "Pasta: <a href='$listar'>$listar</a><br>";}
    #   }
     
    if ($arquivos != "") {
    foreach($arquivos as $listar){
     $listar="echo $listar |cut -c 1-11";
     $listar=system($listar);
     print "<a href='http://www.youtube.com/watch?v=$listar'>ver no youtube</a><br>";}
       }
    ?>
    [/COLOR][/B]

    Dúvidas ou sugestões, poste aqui.


    Abraço a todos

    M4D3
    msn e telefones só para serviços, dicas e ajuda use o fórum
    Atualizado com o segundo video e complementação do primeiro.

  6. #86

    Padrão

    .............
    Última edição por Roberto21; 05-05-2009 às 00:35.



  7. #87

    Question Luciano

    Só tenho uma duvida aqui ! não problema ^^

    pelo que eu vi no seu script ele configura o squid.conf automaticamente, sendo que lá no thundercache as linhas de comando são diferentes das que estão script, pelo visto voce não está usando o acl store_rewrite_list dstdomain -i "/etc/squid/thunder.lst" e sim o acl store_rewrite_list dstdomain com o nome dos dominios 1 a 1 e não pela lista.
    (Obs: Eles retiraram o url_regex e voltaram para o dstdomain)

    pelo seu script está melhor ou é alguma modificação pra ficar condizente ao script.

    Att:

    Cristiano Bernardo

  8. #88

    Padrão

    ...........
    Última edição por Roberto21; 05-05-2009 às 00:36.



  9. #89

    Padrão

    Citação Postado originalmente por multlink Ver Post
    O pacote lynx não está disponível, mas é referenciado por outro pacote.
    Isso pode significar que o pacote está faltando, ficou obsoleto ou
    está disponível somente a partir de outra fonte
    E: O pacote lynx não tem candidato para instalação


    como resolver esse erro que da em meu debian?
    Se você seguir o tutorial em video não terá problemas, também o lynx não é nada que vá afetar o seu desempenho, apenas um navegador para o shell que uso para fazer alguns testes, pode deixar sem ele se for só isso mesmo.

    Abraço M4D3

  10. #90

    Padrão

    Citação Postado originalmente por Johnat Ver Post
    consegui acessar o squid.conf editei as regras, porem na hora de salvar eu aperto o esc como vc disse digito ;qw aparece recording la em baixo no fim do script e fika la durante muito tempo e naum faz mas nada alem disso.

    não é ;qw e sim :wq, ok?? tenta ai



  11. #91

    Padrão

    QUOTE=Roberto21]
    Citação Postado originalmente por popovi
    Citação Postado originalmente por Roberto21
    Citação Postado originalmente por popovi
    Roberto, como te disse meu cache ta rodando que é uma maravilha!!! nao deu nenhum pau mais...mas ainda nao consegui fazer o full no mk, uso a versao 3.20, sera q vc nao poderia, me detalhar essas regras, por favor se possivel.....
    to errando em alguma coisa....
    os pacotes marcam com tos 12
    ve o q pode fazer por favor se possivel, desde ja agradecido e um abraço...

    Olá!


    Aqui também está 100%!!!


    Faça a marcação com a TOS 12 a tac X CACHE HIT não existe mais nesse caso.

    Se você fez um DSTNAT ao invés do redirecionamento então terá que azer a marcação em postruning.

    Se seu firewall for ''afinadinho'' cuidaddo com as regras que bloqueiam o 127.0.0.0/8, ela fica limitando o thunder, libere tudo, vou postar aqui pra vc a minha regra de marcação no mangle, se você manteve até os endereços como eu é só mudar a TOS para 12 no seu caso.



    add chain=postrouting action=mark-connection new-connection-mark=HIT \
    passthrough=yes src-address=192.168.10.250 src-port=3128 protocol=tcp \
    tos=48 comment="HIT'S DO PROXY" disabled=no

    add chain=postrouting action=mark-packet new-packet-mark="hit's do proxy" \
    passthrough=yes connection-mark=HIT comment="" disabled=no


    Depois é só fazer a queue tree, ou queue simple como vc achar melhor


    Essa leitura aqui vai fazer vc compreender:



    Se o destino de um pacote gerado localmente é alterado (pela chain OUTPUT), e isso leva o pacote a passar por uma interface diferente, e então o endereço de origem também é alterado para o endereço da interface de saída. Por exemplo, mudando o destino de um pacote loopback para sair por eth0 irá resultar na mudança do endereço de origem de 127.0.0.1 para o endereço de eth0; ao contrário dos outros mapeamentos de origem (que são feitos depois de tudo, na chain POSTROUNTING) esse é realizado imediatamente. Naturalmente, todos esses mapeamentos são revertidos no momento que os pacotes de resposta chegam.

    Roberto, o cache full agora ta funcionando, para dowloads, e demais arquivos, porem para videos nao esta cache full, quando vou la e retiro o limite de banda de um cliente o video vai full, isto e o proxy continua perfeito, porem nao fica cache full com os videos
    tem algo errado, lembrando meu firewall esta totalmente desbloqueado, e uso hotspot, sera q pode ser isso?

  12. #92

    Padrão

    ..........
    Última edição por Roberto21; 05-05-2009 às 00:36.



  13. #93

    Padrão

    Bem no debian 4 n consegui, baixei o lenny e instalei tudo 100%,mas notei que o processamento está alto d+.
    Coloquei um pc que estava ak parado,celeron 1.8ghz 775, 4giga ddr 667, sata2 320g, essa pc daria para suportar uam rede com 150 pcs até 200???
    Tentei instalar num atlon_x2 4.2ghz, e não instala nem a pau o linux, será pq a placa mãe uma asus com chipset nvidia?????

    Ahhh coloquei placa de rede intel pro 100,ela melhor que a 3com???

  14. #94

    Arrow

    Citação Postado originalmente por multlink Ver Post
    Bem no debian 4 n consegui, baixei o lenny e instalei tudo 100%,mas notei que o processamento está alto d+.
    Coloquei um pc que estava ak parado,celeron 1.8ghz 775, 4giga ddr 667, sata2 320g, essa pc daria para suportar uam rede com 150 pcs até 200???
    Tentei instalar num atlon_x2 4.2ghz, e não instala nem a pau o linux, será pq a placa mãe uma asus com chipset nvidia?????

    Ahhh coloquei placa de rede intel pro 100,ela melhor que a 3com???
    Pode ser o pacote binario que está errado, se voce está utilizando o mesmo cd que voce instalou no celeron não funciona pois ele é I386, para o AMD 64 é outro cd de instalação. voce pode pegar ele nesse link aki:

    Debian 5.01 - download x64: < Versão 64bits



  15. #95

    Padrão

    ok vou baixar e verificar se instala direito, pq até o unbutu também não passa!!!

  16. #96

    Padrão Ajuda

    Olá,

    Já fiz de tudo no mikrotik para acessar o debian, e não consegui, pesso a alguem que mi ajude a configurar o mikrotik.

    Tenho um mikrotik com pppoe.

    obrigado



  17. #97

    Smile Integração Mk - Debian

    boa tarde

    aqui utilizo hotspot mas creio que não tem influência nas regras de comunicação do mk-debian para o proxy em paralelo ao mikrotik vamos lá

    1º Vc vai adicionar duas regras no seu mk, vai em Ip/Firewall/NAt:

    a) Esta regra abastece o debian com link sem limitação de banda.
    chain=srcnat, src. address: 192.168.10.0/30(classe ip debian ), action=masquerede;

    b) Esta regra redireciona todos os pedidos destinados a porta 80(http) vindos dos clientes para o debian.
    chain=dstnat, src. address: 192.168.168.0/24(classe de ip da interface clientes que vai para users), protocol=6 tcp, dst. port=80, in. interface: clientes(sua interface que ai para os clientes), action=redirect, to port=3128(esta porta deve ser comentada em web proxy setting)

    Seguindo agora vc altera em Ip/Web proxy/botão settings os seguintes detalhes:

    port: 3128
    hostname: proxy
    transparent proxy=yes
    parent proxy:192.168.10.2
    parent proxy port: 5128

    o resto normal

    Obs: É obvio que vc tem que adequar estes dados a sua realidade e não esquecer de adequar os ips tanto na placa que liga no debian quanto as demais.

    Continuando...

    Agora no debian partindo do presuposto que vc tem o debian instalado basta configurar o squid.conf conforme sua realidade de hardware memoria, hd etc

    se tiver duvidas quanto a configuração do squid é so perguntar

    abraços

  18. #98

    Padrão duvida

    Muito obrigado jean.

    Uma pergunta, esta mesma regra serviu para o conlinuxZ4?

    Aqui eu uso a seguinte configuração:

    IP => Firewall => Filter Rules:
    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no \
    dst-port=3128 protocol=tcp
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    Ip => Firewall => Nat
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=!Clientes protocol=tcp src-address=\
    172.10.20.0/24 to-ports=3128
    Ip => firewall => Mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    Queue => Tree
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="[CACHE-FULL] - Download" packet-mark=\
    pacotes_squid-down parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5000000 name="[CACHE-FULL] - Upload" packet-mark=\
    pacotes_squid-up parent=global-out priority=1 queue=default

    IP => Proxy
    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=400000000KiB \
    max-client-connections=600 max-fresh-time=4w2d max-server-connections=\
    600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow comment="" disabled=no src-address=172.10.20.0/24
    Última edição por ssn129; 21-04-2009 às 21:22.



  19. #99

    Wink Falta de tempo pra testar

    Citação Postado originalmente por ssn129 Ver Post
    Muito obrigado jean.

    Uma pergunta, esta mesma regra serviu para o conlinuxZ4?

    Aqui eu uso a seguinte configuração:

    IP => Firewall => Filter Rules:
    /ip firewall filter
    add action=accept chain=input comment="ACEITAR CONEXOES PROXY" disabled=no \
    dst-port=3128 protocol=tcp
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    Ip => Firewall => Nat
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Link
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no \
    dst-port=80 in-interface=!Clientes protocol=tcp src-address=\
    172.10.20.0/24 to-ports=3128
    Ip => firewall => Mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    Queue => Tree
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="[CACHE-FULL] - Download" packet-mark=\
    pacotes_squid-down parent=global-in priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5000000 name="[CACHE-FULL] - Upload" packet-mark=\
    pacotes_squid-up parent=global-out priority=1 queue=default

    IP => Proxy
    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=400000000KiB \
    max-client-connections=600 max-fresh-time=4w2d max-server-connections=\
    600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=allow comment="" disabled=no src-address=172.10.20.0/24
    Boa noite a todos

    ssn129

    Não testei ainda o script do m4d3 no meu cenário mas creio que não tem influencia no maximo alteração de classe de ip que o debian vai trabalhar ja que o script altera para uma classe de ip especifica, estou trocando meu server mk por um mais novo e estou revisando todas as regras de firewall, balanceamento, criptografia, autenticação, paginas de aviso, classes de ip, servidor dhcp, radius enfim estou usando a versão 2.9.50 e vou passar pra versão 3.20 então esta meio enrolado aqui pra min, mas quando terminar quero voltar minhas atenções pro debian...mas se precisar de alguma dica e eu puder ajudar beleza

    abraços

  20. #100

    Padrão

    ............
    Última edição por Roberto21; 05-05-2009 às 00:37.