+ Responder ao Tópico



  1. #1

    Padrão Ajuda portas / servicos range ips

    Boas pessoal, desta vez estou com outra duvida ah cerca da abertura de portas para p2p e outros programas...

    eu tenho isso a funcionar...como ta no wiki da mikrotik, mas porem tenho que abrir a porta para cada IP/cliente, e isso torna-se chato...dava muito mais jeito só uma regra que abrisse essa porta, para toda a range de uma gama de ips. ex.192.168.1.xxx

    eu ja tentei no dst-address fazer 192.168.1.2-192.168.1.254 por exemplo, mas ae ele não abre porta para nenhum ip....

    alguma soluçao?

  2. #2
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Não consegui entender o que vc quer. Abrir porta? Explica pausadamente para ver se consigo ajudar.



  3. #3

    Padrão

    pelo o q eu entedi. vc que liberar uma determinada porta para um range de ips e bloquear as demais. vc faz uma regra accept para um range de ips antes da que ta fazendo o bloqueio.

  4. #4

    Padrão

    Citação Postado originalmente por interhome Ver Post
    Não consegui entender o que vc quer. Abrir porta? Explica pausadamente para ver se consigo ajudar.
    é simples...

    voce tem um cliente de emule por exemplo, que tem um IP 192.168.1.100 por exemplo.
    então voce abre portas tcp e udp para o cliente, para ele ter high ID, mas dps aparece outro cliente que quer...e este cliente não tem IP estatico, então vou ter que fazer um binding, e se eu tiver para toda a gama de ips 192.168.1.xxx posso por na pagina online, as mesmas portas tcp e udp para toda a gente.



  5. #5

  6. #6

    Padrão

    Pronto, porque uma imagem vale mais que 1000 palavras, segue em anexo, a descrição...

    como podem ver na imagem em anexo está um IP "192.168.200.26" com a determinada porta no protocolo TCP.

    E o que eu quero, é, em vez de tar a criar uma regra para cada IP "192.168.200.xxx" visto que a porta é a mesma, criar só uma para o range completo. já tentei onde tenho lá IP, meter o range normal que normalmente funciona no mikrotik "192.168.200.2-192.168.200.254" mas assim não abre a porta para nenhum IP.

    há solução???
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         prtscr_tik.JPG
Visualizações:	62
Tamanho: 	87,6 KB
ID:      	3978  



  7. #7
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    Cara to tentando mais esta dificil entender. Deixa eu te explicar uma coisa basica. Quando se tem um serviço funcionando por exemplo http = a porta tcp 80. O que isso quer disser é que um host irá se comunicar com ele na porta destino 80, a porta origem é qualquer uma diferente acima 1024. Assim bloquear a porta 36275 não quer disser nada. Quando o mikrotik faz nat na verdade ele esta fazendo PAT. Estude sobre o assunto e reformule o que vc realmente precisa.

    PAT
    Port Address Translation (PAT) é uma característica de um dispositivo de rede que traduz TCP ou UDP comunicações efectuadas entre os anfitriões em uma rede privada e anfitriões em uma rede pública. Ela permite que um único endereço IP público a ser usado por muitos anfitriões em uma rede privada, que normalmente é uma rede de área local ou LAN.

    Um dispositivo transparente PAT modifica pacotes IP como elas passam por ela. As modificações fazem todos os pacotes que ele envia para a rede pública a partir de múltiplos hosts na rede privada parece que originam de um único anfitrião, (o dispositivo PAT) na rede pública. Port Address Translation (PAT) é uma característica de um dispositivo de rede que traduz TCP ou UDP comunicações efectuadas entre os anfitriões em uma rede privada e anfitriões em uma rede pública. Ela permite que um único endereço IP público a ser usado por muitos anfitriões em uma rede privada, que normalmente é uma rede de área local ou LAN. Um dispositivo PAT modifica pacotes IP como elas passam por ela. As modificações fazem todos os pacotes que ele envia para a rede pública a partir de múltiplos hosts na rede privada parece que originam de um único anfitrião, (o dispositivo PAT) na rede pública


    Leie e reflita um pouco: Link:

    NAT, DNAT, PAT suas definições | Vivência em Tecnologia

  8. #8

    Padrão

    Citação Postado originalmente por interhome Ver Post
    Cara to tentando mais esta dificil entender. Deixa eu te explicar uma coisa basica. Quando se tem um serviço funcionando por exemplo http = a porta tcp 80. O que isso quer disser é que um host irá se comunicar com ele na porta destino 80, a porta origem é qualquer uma diferente acima 1024. Assim bloquear a porta 36275 não quer disser nada. Quando o mikrotik faz nat na verdade ele esta fazendo PAT. Estude sobre o assunto e reformule o que vc realmente precisa.

    PAT
    Port Address Translation (PAT) é uma característica de um dispositivo de rede que traduz TCP ou UDP comunicações efectuadas entre os anfitriões em uma rede privada e anfitriões em uma rede pública. Ela permite que um único endereço IP público a ser usado por muitos anfitriões em uma rede privada, que normalmente é uma rede de área local ou LAN.

    Um dispositivo transparente PAT modifica pacotes IP como elas passam por ela. As modificações fazem todos os pacotes que ele envia para a rede pública a partir de múltiplos hosts na rede privada parece que originam de um único anfitrião, (o dispositivo PAT) na rede pública. Port Address Translation (PAT) é uma característica de um dispositivo de rede que traduz TCP ou UDP comunicações efectuadas entre os anfitriões em uma rede privada e anfitriões em uma rede pública. Ela permite que um único endereço IP público a ser usado por muitos anfitriões em uma rede privada, que normalmente é uma rede de área local ou LAN. Um dispositivo PAT modifica pacotes IP como elas passam por ela. As modificações fazem todos os pacotes que ele envia para a rede pública a partir de múltiplos hosts na rede privada parece que originam de um único anfitrião, (o dispositivo PAT) na rede pública


    Leie e reflita um pouco: Link:

    NAT, DNAT, PAT suas definições | Vivência em Tecnologia
    ok, ja estou percebendo voce, mas realmente voce não tá percebendo a "utilidade" que eu quero empregar...

    vamos por partes...

    1º, voce tem 1 cliente que quer aceder ao emule com HIGH ID, logo voce vai ter que abrir portas no IP dele (as mesmas portas que ele tem configurado no programa) porque ao que parece, o mikrotik vem com elas fexadas por predefinição, e nesse caso o cliente não tem HIGHID.

    2º, O prtsrc que postei é de uma regra que tenho para um cliente. Mas na verdade, o que quero é aplicar esta regra para cada IP na minha rede, então para não estar dizendo ao pessoal para cada um usar IP estático, é preferivel criar a mesma regra para toda a gente....mas assim, teria que criar 253 regras (desde o 192.168.200.2 até ao 192.168.200.254) só para abrir o serviço do emule.
    o que queria era mesmo uma maneira de aplicar a todos os clientes esta regra, sem ter que criar 253 regras...

    3º, Uma ajudinha sff , não percebo nada disto, ou está escapando algo...

    PS:brigadao pelo apoio que estão dando até agora



  9. #9

    Padrão

    Você quer repassar o tráfego do emule para determinados ips sem ter que colocar toda a rede dentre este controle, certo?
    Você pode fazer isto criando a regra para uma source address list e depois ir add os ips que quer a esta address list.
    Se for isto, tá aí uma maneira de fazer.

  10. #10

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Você quer repassar o tráfego do emule para determinados ips sem ter que colocar toda a rede dentre este controle, certo?
    Você pode fazer isto criando a regra para uma source address list e depois ir add os ips que quer a esta address list.
    Se for isto, tá aí uma maneira de fazer.
    não, nada disso. eu não sei porque está tão dificil de perceber...eu apenas dar ao cliente HIGHID.
    não quero controlar, marcar, não, nada disso, apenas quero dar um HIGHID ao cliente de emule, porque se não fizer ele fica com a notificação "debaixo de firewall".

    e para conseguir fazer isso, até agora, só consegui com o chain em "dst-nat".

    se ajudar, imagina que tem um router linksys ligado sozinho a uma ligação ADSL, e para ter o emule com HIGH ID, tem que redirecionar as portas, certo? é isso que estou fazendo no tik...



  11. #11

    Padrão

    Mas é isto mesmo, você quer fazer este dnat para vários clientes, não quer? Fazendo este dnat para uma address list, você poderá liberar qualquer ip para o highid.

  12. #12

    Padrão

    Agora se quiser liberar toda a rede, você pode usar a faixa 192.168.1.0/24 no lugar do 192.168.1.1-192.168.1.254. E se quiser deixar o ip do servidor de fora, basta indicar o ip do servidor e colocar uma
    Código :
    !
    que o resto fica liberado.



  13. #13

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Agora se quiser liberar toda a rede, você pode usar a faixa 192.168.1.0/24 no lugar do 192.168.1.1-192.168.1.254. E se quiser deixar o ip do servidor de fora, basta indicar o ip do servidor e colocar uma
    Código :
    !
    que o resto fica liberado.
    ae, não funciona, isso tambem ja tinha tentado... a porta continua fexada...

    tenho assim....olha no prtscr
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         prtscr_tik.JPG
Visualizações:	47
Tamanho: 	88,5 KB
ID:      	3980  

  14. #14

    Padrão

    Você já usou a address list?



  15. #15

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Você já usou a address list?
    não, como faço isso :O ????

  16. #16

    Padrão

    Address list é uma forma de você não utilizar a mesma regra várias vezes apenas mudando uma informação, com ela você pode usar apenas uma regra para vários ips.
    Aqui está uma forma de você usar um address-list:

    Código :
    /ip firewall nat add chain=dstnat dst-port="emulepor" src-address-list="HIGHID" action=dst-nat to-addresses="ipdedestino" to-ports="portadedestino" comment="Redir HIGHID - emule"

    Para add os ips na address-list:
    Código :
    /ip firewall address-list add list="HIGHDI" address=192.168.1.6 disabled=no
    Desta forma terá menos trabalho e pode add o ip que quiser.



  17. #17

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Address list é uma forma de você não utilizar a mesma regra várias vezes apenas mudando uma informação, com ela você pode usar apenas uma regra para vários ips.
    Aqui está uma forma de você usar um address-list:

    Código :
    /ip firewall nat add chain=dstnat dst-port="emulepor" src-address-list="HIGHID" action=dst-nat to-addresses="ipdedestino" to-ports="portadedestino" comment="Redir HIGHID - emule"
    Para add os ips na address-list:
    Código :
    /ip firewall address-list add list="HIGHDI" address=192.168.1.6 disabled=no
    Desta forma terá menos trabalho e pode add o ip que quiser.
    aeee, é isso mesmo, assim já deve dar...vo testar e dps posto aqui resultados...

    ABRAÇÃO...