Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão Thunder redirect

    Poste a regra de como vc esta empurrando pra o thunder pra ver se eu te ejudo, o meu ta direiti
    nho.

  2. #22

    Padrão

    Testem com estas rotas para youtube, nesta data funcionando perfeito:

    208.65.0.0/16
    64.233.0.0/16
    189.73.192.0/24
    74.125.0.0/16
    64.15.0.0/16
    Última edição por m4d3; 15-05-2009 às 11:35.



  3. #23

    Padrão

    eu acho q tem uns videos no 64.15.0.0/16 tb....
    acho q o negocio é ir testando os videos e olhando no torch do mk....

  4. #24

    Padrão

    Eu faço isso pelo próprio squid:

    #Desviar Site
    acl desvia-site url_regex ".youtube.com"
    tcp_outgoing_address 192.168.0.1 desvia-sites
    http_access allow desvia-sites

    Uso isso na minha rede já tem um bom tempo.



  5. #25

    Padrão

    Citação Postado originalmente por ijr Ver Post
    Eu faço isso pelo próprio squid:

    #Desviar Site
    acl desvia-site url_regex ".youtube.com"
    tcp_outgoing_address 192.168.0.1 desvia-sites
    http_access allow desvia-sites

    Uso isso na minha rede já tem um bom tempo.
    Seu proxy deve ser em série antes do mk ou então seu linux deve ter acesso a outros gateways e não somete ao mikrotik.
    Última edição por m4d3; 14-05-2009 às 15:40.

  6. #26

    Padrão RESOLVIDO!!!

    Bom pessoal, resolvi meu problema. Vou tentar explicar aqui o que fiz, porém, minha topologia tem características bem peculiares... então se não ficar muito claro alguma parte, por favor, perguntem:
    - faço a autenticação atrabés de PPPo no MK;
    - o MK possui saída por 2 links, um da Telefônia e outro da CTBC;
    - o Link da Telefonica passa por um Server com Conectiva 10, onde é feito o cache;
    - o Link da CTBC passa por um server com o Ubuntu + Thunder Cache;
    - separo meus clientes em duas redes e marco os pacotes de cada uma delas, fazendo com que os clientes da REDE1 saiam pelo link da Telefonica e os da REDE2 pelo link da CTBC;
    Ainda não quis mexer no server com o Conectiva pq ele já tem 4 anos em funcionamento, várias regras e detalhes... então para impantar o Thunder nele vou precisar de um "tempinho".. pq sempre pode acontecer algo errado..rs.. a opção que fiz então foi mexer no meu server Ubuntu, que é mais recente e pelo qual passam menos clientes ainda... Instalei o Thunder Cache nele e ficou show! Muito bom mesmo. A questão para mim é que só os clientes da REDE2 usufruem do Thunder, pois só eles passam pelo Ubuntu. O que quis fazer então é pegar só os pacotes direcionados para o youtube vindos da REDE1 e direcioná-los para o Ubuntu, fazendo com que esses clientes que não passariam pelo Thunder passem nesse caso. A princípio, criei as Rotas para as redes 208.0.0.0/8 e 74.0.0.0/8..mas não funcionou.. Bom, o erro está no seguinte ponto.. essas rotas estão corretas, a questão é que o Thunder funciona da seguinte forma: vc faz a requisição do vídeo, mas o carregamento é feito a partir do apache que está rodando junto com o Thunder... por exemplo, se o IP externo do seu servidor que está rodando o Thunder for "xxx.yyy.aa.bb" quando vc acessa o vídeo do youtube, ele aparece na barra de status do navegador "Recebendo dados de xxx.yyy.aa.bb".. então a SOLUÇÃO FOI CRIAR UMA ROTA TAMBÉM PARA XXX.YYY.AA.BB juntamente com as rotas para 74.0.0.0/8 e 208.0.0.0/8 no MK colocando em todas elas como GW o Ubuntu... aí BINGO! Não importa seo cliente é da REDE1 ou REDE2.. youtube sai sempre no Thunder!
    Pessoal, agradeço a todos que tentaram ajudar!
    E disponho-me a esclarecer melhor as dúvidas que surgirem!
    Abraços!
    Ricardo



  7. #27

    Padrão

    Citação Postado originalmente por ijr Ver Post
    Eu faço isso pelo próprio squid:

    #Desviar Site
    acl desvia-site url_regex ".youtube.com"
    tcp_outgoing_address 192.168.0.1 desvia-sites
    http_access allow desvia-sites

    Uso isso na minha rede já tem um bom tempo.
    Amigo, como ficou as coonfigurações de NAT e rota default ai? Estou a procura de soluções como a sua, já uso servidor CentOS rodando squid a tempos.Você só fez no squid, ou tem mais alguma coisa?

  8. #28

    Padrão

    q bom q conseguiu!

    pode dizer como organizou as rotas, ja q uma faz rota para a outra(rota de entrada e saida)?

    XXX.YYY.AA.BB
    74.0.0.0/8
    208.0.0.0/8


    Citação Postado originalmente por ricardofjayme Ver Post
    Bom pessoal, resolvi meu problema. Vou tentar explicar aqui o que fiz, porém, minha topologia tem características bem peculiares... então se não ficar muito claro alguma parte, por favor, perguntem:
    - faço a autenticação atrabés de PPPo no MK;
    - o MK possui saída por 2 links, um da Telefônia e outro da CTBC;
    - o Link da Telefonica passa por um Server com Conectiva 10, onde é feito o cache;
    - o Link da CTBC passa por um server com o Ubuntu + Thunder Cache;
    - separo meus clientes em duas redes e marco os pacotes de cada uma delas, fazendo com que os clientes da REDE1 saiam pelo link da Telefonica e os da REDE2 pelo link da CTBC;
    Ainda não quis mexer no server com o Conectiva pq ele já tem 4 anos em funcionamento, várias regras e detalhes... então para impantar o Thunder nele vou precisar de um "tempinho".. pq sempre pode acontecer algo errado..rs.. a opção que fiz então foi mexer no meu server Ubuntu, que é mais recente e pelo qual passam menos clientes ainda... Instalei o Thunder Cache nele e ficou show! Muito bom mesmo. A questão para mim é que só os clientes da REDE2 usufruem do Thunder, pois só eles passam pelo Ubuntu. O que quis fazer então é pegar só os pacotes direcionados para o youtube vindos da REDE1 e direcioná-los para o Ubuntu, fazendo com que esses clientes que não passariam pelo Thunder passem nesse caso. A princípio, criei as Rotas para as redes 208.0.0.0/8 e 74.0.0.0/8..mas não funcionou.. Bom, o erro está no seguinte ponto.. essas rotas estão corretas, a questão é que o Thunder funciona da seguinte forma: vc faz a requisição do vídeo, mas o carregamento é feito a partir do apache que está rodando junto com o Thunder... por exemplo, se o IP externo do seu servidor que está rodando o Thunder for "xxx.yyy.aa.bb" quando vc acessa o vídeo do youtube, ele aparece na barra de status do navegador "Recebendo dados de xxx.yyy.aa.bb".. então a SOLUÇÃO FOI CRIAR UMA ROTA TAMBÉM PARA XXX.YYY.AA.BB juntamente com as rotas para 74.0.0.0/8 e 208.0.0.0/8 no MK colocando em todas elas como GW o Ubuntu... aí BINGO! Não importa seo cliente é da REDE1 ou REDE2.. youtube sai sempre no Thunder!
    Pessoal, agradeço a todos que tentaram ajudar!
    E disponho-me a esclarecer melhor as dúvidas que surgirem!
    Abraços!
    Ricardo



  9. #29

    Padrão

    Wesley,

    Como te disse, na verdade a solução foi só criar as rotas... por exemplo, no caso do youtube, tudo que é 74.0.0.0/8 e 208.0.0.0/8 vai para o thunder, porém, o thunder irá, através do apache, entregar o vídeo para o cliente... então o player começará a carregar a partir do Ip do thunder e não mais do servidor do youtube.. por isso criei uma rota tb para meu ip externo do thunder, entendeu?

  10. #30

    Padrão

    Ah sim!!
    bom bolado!!
    vlw

    Citação Postado originalmente por ricardofjayme Ver Post
    Wesley,

    Como te disse, na verdade a solução foi só criar as rotas... por exemplo, no caso do youtube, tudo que é 74.0.0.0/8 e 208.0.0.0/8 vai para o thunder, porém, o thunder irá, através do apache, entregar o vídeo para o cliente... então o player começará a carregar a partir do Ip do thunder e não mais do servidor do youtube.. por isso criei uma rota tb para meu ip externo do thunder, entendeu?