Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por fernandofiorentinn Ver Post
    rapaz se nao soubermos qual a disponibilidade da tua rede nao podemos ajuda-lo configuraçoes proprias ninguem vai por aqui nao

    Certo vamo lá então para as minhas configurações!

    Interfaces:

    0 R ;;; Interface do Roteador 2
    LINK2 ether 1500
    1 R ;;; Interface do Roteador 1
    LINK1 ether 1500
    2 R ;;; Interface de Clientes Wirelless
    RADIO ether 1500
    3 R ;;; Interface de Clientes via Cabo
    CABO ether 1500
    4 R ;;; Interface do Linux Proxy
    PROXY ether 1500

    Utilizo hotspot para controlar os clientes das interfaces Radio e Cabo, pela interface Proxy faço um proxy externo ao debian e nas interfaces Link2 e Link1 são onde entram os links cada um de 2 megas da embratel(dedicado)

    lembrando que já tentei :

    ip firewall mangle:
    ====================
    add action=mark-connection chain=prerouting comment="LOAD BALANCE" \
    connection-state=new disabled=yes new-connection-mark=odd nth=1,0 \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=yes new-connection-mark=even nth=2,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=odd \
    disabled=yes new-routing-mark=odd passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=even \
    disabled=yes new-routing-mark=even passthrough=no


    ip firewall nat:
    ====================

    add action=src-nat chain=srcnat comment="" connection-mark=odd disabled=yes dst-port=0-65535 protocol=tcp to-addresses=\
    201.39.xxx.xxx to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=even disabled=yes dst-port=0-65535 protocol=tcp to-addresses=\
    189.43.xxx.xxx to-ports=0-65535

    ip route:
    ====================

    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx routing-mark=odd scope=30 \
    target-scope=10
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=189.43.xxx.xxx routing-mark=even scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx \
    scope=255 target-scope=10


    já tentei passar um cliente só por um link só, marcando a conexão dele pelo mangle e mesmo assim, não passa ele não repassa para outro link, atualmente estou usando assim:

    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx, 189.43.xxx.xxx \
    scope=255 target-scope=10

    mais quando um link satura e o cliente esta no meio de um download o downloa cai, esse é meu maior problema, se eu conseguisse passar um cliente por um unico link, já resolveria 90% dos problemas

    obrigado!

  2. ok amigo, acho que tenho a solução dos seus problemas aqui, vou postar pra vc ja já.



  3. este cenário se aplica a dois gateways de entrada, por exemplo: radio >192.168.1.0/24 e cabo> 192.168.0.0/24, isso se usar /24 é uma marcação de por rotas, se usar subredes terá que fazer uma marcação dessa por cliente.
    Citação Postado originalmente por fernandofiorentinn Ver Post
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="rota1" disabled=no \
    new-routing-mark=gw1 passthrough=yes src-address=xxx.xxx.xxx.xxx/24 <----------usaremos 192.168.1.0/24
    add action=mark-routing chain=prerouting comment="rota2" disabled=no \
    new-routing-mark=gw2 passthrough=yes src-address=xxx.xxx.xxx.xxx/24 <---------usaremos 192.168.0.0/24 atente ao campo new-routing-mark é muito importante..
    pronto fizemos a marcação das redes...

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    192.168.1.0/24

    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    192.168.0.0/24


    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    xxx.xxx.xxx.xxx routing-mark=gw1 scope=255 target-scope=10 <aqui vc vai marcar por qual gateway vai sai a rota1(gw1) exemplo:201.39.xxx.xxx


    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    xxx.xxx.xxx.xxx routing-mark=gw2 scope=255 target-scope=10 < aqui vc marca por qual gateway sai a rota2(gw2) exemplo: 189.43.xxx.xxx

    obs: em routes lembre-se de retirar qualquer regra que tenha flag AS (static) os DAC sao dinamicos recomedo fazer isso em um mikrotik 0 primeiro depois vc adequa as suas necessidades

  4. fernando,

    fiz o teste no tracert -d UOL - O melhor conteúdo
    e ele estava passando por um só getway, mais pra navegar tive que desabilitar o proxy externo
    tem alguma solução para eu não precisar desabilitar meu proxy pra esses clientes?



  5. Citação Postado originalmente por marconipcd Ver Post
    fernando,

    fiz o teste no tracert -d UOL - O melhor conteúdo
    e ele estava passando por um só getway, mais pra navegar tive que desabilitar o proxy externo
    tem alguma solução para eu não precisar desabilitar meu proxy pra esses clientes?
    como vc usa seu proxy?






Tópicos Similares

  1. Como se monta web proxy na versao 3.13
    Por mpsnet no fórum Redes
    Respostas: 1
    Último Post: 05-12-2009, 15:07
  2. Possível BUG na versão 3.13
    Por andhy no fórum Redes
    Respostas: 3
    Último Post: 06-09-2009, 01:10
  3. LB NTH NA VERSAO 3.X
    Por shalom_rm no fórum Redes
    Respostas: 3
    Último Post: 04-05-2009, 17:13
  4. Ativar Web Proxy Na Versao 2.8
    Por socrateschalkidis no fórum Redes
    Respostas: 2
    Último Post: 29-03-2007, 00:29
  5. bug na versao 9.3 suse
    Por albertoreboucas no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-06-2005, 09:23

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L