+ Responder ao Tópico



  1. #1

    Padrão LB na versão 3.13!!

    Pessoal, tou passando por uma serie de problemas com algumas versões do mikrotik, adquiri uma licença recentemente, e instalei o MK 3.22(só dor de cabeça) e que fique bem claro pra quem quiser instalar a tal versão, claro que toda regra tem sua exceção, mais se eu tivesse pesquisado iria achar outros relatos de problemas com a versão, instalei a versão 3.13 resolveu praticamente todos os problemas...e apareceu outro....

    não consigo de forma alguma fazer Load Balancing, já tentei nth, por rotas, por serviços, setando no prorpio hotspot, e nada, não repassa para o segundo link, o que aconteceu foi que eu acabei tendo que colocar os dois getways como default só que quando um link satura ele muda pra outro fazendo algumas conexões cair, como páginas de banco, msn, orkut, jogos online..


    já tentei de tudo que encontrei aqui no forum, e abro esse post pra saber se alguem já conseguiu configurar um load balance no MK 3.13 se consegui pediria que me disesse como por favor, e assim iremos contribuir com o crescimento do forum..

    um abraço a todos

  2. #2
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão

    O loadbalance funciona, mas fique bem claro que é balanceamnto e não soma de link. Com o LB voce terá alguns problemas que deveram ser tratatos individualmente. Como por exemplo, Bancos....



  3. #3

  4. #4

    Padrão

    se possivel posta ai tuas configurações, porque eu não consegui... obrigado



  5. #5

    Padrão

    rapaz se nao soubermos qual a disponibilidade da tua rede nao podemos ajuda-lo configuraçoes proprias ninguem vai por aqui nao

  6. #6

    Padrão

    Citação Postado originalmente por fernandofiorentinn Ver Post
    rapaz se nao soubermos qual a disponibilidade da tua rede nao podemos ajuda-lo configuraçoes proprias ninguem vai por aqui nao

    Certo vamo lá então para as minhas configurações!

    Interfaces:

    0 R ;;; Interface do Roteador 2
    LINK2 ether 1500
    1 R ;;; Interface do Roteador 1
    LINK1 ether 1500
    2 R ;;; Interface de Clientes Wirelless
    RADIO ether 1500
    3 R ;;; Interface de Clientes via Cabo
    CABO ether 1500
    4 R ;;; Interface do Linux Proxy
    PROXY ether 1500

    Utilizo hotspot para controlar os clientes das interfaces Radio e Cabo, pela interface Proxy faço um proxy externo ao debian e nas interfaces Link2 e Link1 são onde entram os links cada um de 2 megas da embratel(dedicado)

    lembrando que já tentei :

    ip firewall mangle:
    ====================
    add action=mark-connection chain=prerouting comment="LOAD BALANCE" \
    connection-state=new disabled=yes new-connection-mark=odd nth=1,0 \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=yes new-connection-mark=even nth=2,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=odd \
    disabled=yes new-routing-mark=odd passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=even \
    disabled=yes new-routing-mark=even passthrough=no


    ip firewall nat:
    ====================

    add action=src-nat chain=srcnat comment="" connection-mark=odd disabled=yes dst-port=0-65535 protocol=tcp to-addresses=\
    201.39.xxx.xxx to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=even disabled=yes dst-port=0-65535 protocol=tcp to-addresses=\
    189.43.xxx.xxx to-ports=0-65535

    ip route:
    ====================

    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx routing-mark=odd scope=30 \
    target-scope=10
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=189.43.xxx.xxx routing-mark=even scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx \
    scope=255 target-scope=10


    já tentei passar um cliente só por um link só, marcando a conexão dele pelo mangle e mesmo assim, não passa ele não repassa para outro link, atualmente estou usando assim:

    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.39.xxx.xxx, 189.43.xxx.xxx \
    scope=255 target-scope=10

    mais quando um link satura e o cliente esta no meio de um download o downloa cai, esse é meu maior problema, se eu conseguisse passar um cliente por um unico link, já resolveria 90% dos problemas

    obrigado!



  7. #7

    Padrão

    ok amigo, acho que tenho a solução dos seus problemas aqui, vou postar pra vc ja já.

  8. #8

    Padrão

    este cenário se aplica a dois gateways de entrada, por exemplo: radio >192.168.1.0/24 e cabo> 192.168.0.0/24, isso se usar /24 é uma marcação de por rotas, se usar subredes terá que fazer uma marcação dessa por cliente.
    Citação Postado originalmente por fernandofiorentinn Ver Post
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="rota1" disabled=no \
    new-routing-mark=gw1 passthrough=yes src-address=xxx.xxx.xxx.xxx/24 <----------usaremos 192.168.1.0/24
    add action=mark-routing chain=prerouting comment="rota2" disabled=no \
    new-routing-mark=gw2 passthrough=yes src-address=xxx.xxx.xxx.xxx/24 <---------usaremos 192.168.0.0/24 atente ao campo new-routing-mark é muito importante..
    pronto fizemos a marcação das redes...

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    192.168.1.0/24

    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    192.168.0.0/24


    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    xxx.xxx.xxx.xxx routing-mark=gw1 scope=255 target-scope=10 <aqui vc vai marcar por qual gateway vai sai a rota1(gw1) exemplo:201.39.xxx.xxx


    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    xxx.xxx.xxx.xxx routing-mark=gw2 scope=255 target-scope=10 < aqui vc marca por qual gateway sai a rota2(gw2) exemplo: 189.43.xxx.xxx

    obs: em routes lembre-se de retirar qualquer regra que tenha flag AS (static) os DAC sao dinamicos recomedo fazer isso em um mikrotik 0 primeiro depois vc adequa as suas necessidades



  9. #9

    Padrão

    fernando,

    fiz o teste no tracert -d UOL - O melhor conteúdo
    e ele estava passando por um só getway, mais pra navegar tive que desabilitar o proxy externo
    tem alguma solução para eu não precisar desabilitar meu proxy pra esses clientes?

  10. #10

    Padrão

    Citação Postado originalmente por marconipcd Ver Post
    fernando,

    fiz o teste no tracert -d UOL - O melhor conteúdo
    e ele estava passando por um só getway, mais pra navegar tive que desabilitar o proxy externo
    tem alguma solução para eu não precisar desabilitar meu proxy pra esses clientes?
    como vc usa seu proxy?



  11. #11

    Padrão

    add action=dst-nat chain=dstnat comment="Redirect - Proxy para Rede Interna" \
    disabled=no dst-address-list=!Sem_Proxy dst-port=80 in-interface=LOJA \
    protocol=tcp src-address=!15.15.0.2 to-addresses=15.15.0.2 to-ports=5128

    add action=dst-nat chain=pre-hotspot comment=\
    "Redirect - Proxy Clientes via Wireless" disabled=no dst-address-list=\
    !Sem_Proxy dst-port=80 hotspot=auth in-interface=RADIO protocol=tcp \
    src-address=!15.15.0.2 to-addresses=15.15.0.2 to-ports=5128

    add action=dst-nat chain=pre-hotspot comment=\
    "Redirect - Proxy Clientes via Cabo" disabled=no dst-address-list=\
    !Sem_Proxy dst-port=80 hotspot=auth in-interface=CABO protocol=tcp \
    src-address=!15.15.0.2 to-addresses=15.15.0.2 to-ports=5128

  12. #12

    Padrão

    seguinte, aqui tive que desabilitar meu proxy, alguns clientes tava dando problema, mas no caso como duas redes distintas o ideal seriam dois proxys, vc usa cache full ou só http?



  13. #13

  14. #14

    Padrão

    ok , vou te passar algumas regras que talvez ajudem.. me diz quantos ips validos sobram pra vc?



  15. #15

  16. #16

    Padrão

    olha agora que lembrei, eu nao uso hotspot, as regras do hotspot sao dinamicas, mas vamos lá,(porra 125 ips validos é muita coisa), eu usava da seguinte forma, retirei ele do mikrotik e coloquei no roteador, usei essas regras
    ip firewall nat
    add action=dst-nat chain=dstnat comment=redir_nat1 disabled=yes dst-port=80 \
    in-interface="clientes 1" protocol=tcp src-address=!192.168.0.xxx \
    to-addresses=200.xxx.xxx.xxx to-ports=?128


    ip firewall filter
    add action=accept chain=forward comment="redir filter" disabled=yes \
    dst-address=
    200.xxx.xxx.xxx dst-port=?128 in-interface="clientes 1" \
    out-interface=etherX protocol=tcp src-address=192.168.x.0/24




  17. #17

    Padrão LoadBalance

    vejão se esse TUTOR pode ajudar ....



    somente leitura..
    Arquivos Anexos Arquivos Anexos

  18. #18

    Padrão

    Citação Postado originalmente por InfinityWifi Ver Post
    vejão se esse TUTOR pode ajudar ....



    somente leitura..
    Arquivo protegido por senha