Página 6 de 6 PrimeiroPrimeiro ... 23456
+ Responder ao Tópico



  1. #101
    Pedro Silva
    Visitante

    Padrão Blanceando a carga

    Olá pessoal eu fiz aqui um balancenamento de um link full e outro ADSL ambos de megas por nth, só que agora houve uma promoção do adsl e então assinei os 8 megas do ADSL, quero saber como dividir essa carga já que tenho duas velocidades diferentes do jeito que estou fazendo aqui o link full sempre fica lotado e ADSL só ocupa os dois megas. Sei que tenho que somar a banda total e dividir pelo menor link para ter a quantidade de marcaçao do NTH. Tentei fazer aqui e não deu certo algué, ai pode me da um luz?

    /ip address
    add address=200.249.152.140/29 broadcast=200.249.152.135 comment=Server \
    disabled=no interface=link01 network=200.249.152.128
    add address=199.198.111.1/24 broadcast=199.198.111.255 comment=hotspot \
    disabled=no interface=clientes network=199.198.111.0
    add address=192.168.1.240/24 broadcast=192.168.1.255 comment="" disabled=no \
    interface=link02 network=192.168.1.0
    add address=200.249.152.133/29 broadcast=200.249.152.135 comment=Embratel \
    disabled=no interface=link01 network=200.249.152.128

    /ip firewall Mangle
    add action=mark-connection chain=prerouting comment="Load Balance" disabled=no in-interface=clientes \
    new-connection-mark=odd passthrough=yes src-address-list=odd
    add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clientes new-routing-mark=odd passthrough=\
    no src-address-list=odd
    add action=mark-connection chain=prerouting comment="" disabled=no in-interface=clientes new-connection-mark=even \
    passthrough=yes src-address-list=even
    add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clientes new-routing-mark=even passthrough=\
    no src-address-list=even
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes \
    new-connection-mark=odd nth=5,1 passthrough=yes
    add action=add-src-to-address-list address-list=odd address-list-timeout=1d chain=prerouting comment="" disabled=no \
    in-interface=clientes
    add action=mark-routing chain=prerouting comment="" connection-mark=odd disabled=no in-interface=clientes \
    new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes \
    new-connection-mark=even nth=5,2 passthrough=yes
    add action=add-src-to-address-list address-list=even address-list-timeout=1d chain=prerouting comment="" \
    connection-mark=even disabled=no in-interface=clientes
    add action=mark-routing chain=prerouting comment="" connection-mark=even disabled=no in-interface=clientes \
    new-routing-mark=even passthrough=no
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes \
    new-connection-mark=even nth=2,2 passthrough=yes src-address-list=odd

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    link01
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    link02

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    200.249.152.129 scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    200.249.152.129 routing-mark=odd scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.248 routing-mark=even scope=255 target-scope=10


    Abraços

  2. #102

    Talking

    parabéns pelo post. muito bom..



  3. #103

    Padrão

    Galera nao sei oq pode ser . . . mas só estou "saindo" por um UNICO gateway... o outro nao esta indo.. o que pode ser?

    OBS: Como funciona a regra NTH?

  4. #104

    Padrão

    Duvida, to com com idea de montar um servidor com 2 RB44gv apenas para fazer o balanceamento dos link usando a regra do autor modificando apenas para 6 link de 2.5m adsl....e outro servidor para controle dos clientes e firewal e banda etc.. ficaria bom???
    a estrutura seria mais ou menoas assim...
    Links > servidor Mk configurardo com a regra do autor > servidor que vai gerenciar os clientes >switch > torre...



  5. #105

    Padrão

    Muito bem amigo, agora, como faço que determinado cliente se logue em determinado link.Ex:

    cliente: fulano ----> link1
    ciclano ---> link2

  6. #106

    Padrão

    Para eu conseguir configurar este balancemento preciso instalar uma placa de rede para cada link?

    É pq já estou a tempo tentanto fazer funcionar o NTH usando 2 address lists mas percebo que a prioridade tem sido sempre muito maior para o primeiro link. Estou até agora testando só com uma placa de rede para os dois links que estao num HUB.



  7. #107

    Padrão Load Balance apenas para dois links

    Citação Postado originalmente por jeanfrank Ver Post
    Bom dia a todos

    Testei vários balanceamentos e tive muitos problemas com msn, bancos conectividade social etc
    Então pesquisando implementei um load balance por nth + permanent conection e ficou muito bom, aqui estou utilizando 5 links de velocidade iguais e mesma operadora e detalhe os links tem que estar bons pra dar tudo certo no meu caso tenho 2 links locais na sede da empresa e 3 links remotos vindo de outras partes da cidade não entrarei em detalhes esta parte somente o balanceamento mas se alguem tiver duvida é só postar e ajudamos no que puder. Segue:

    Comece criando faixas de ip pras interfaces dos links no server mk tenho 7 interfaces lan;
    Minha interface que distribui o sinal chama-se clientes.

    ip/address list

    Link1 = 192.168.4.253/24
    Link2 = 192.168.2.253/24
    Link3 = 192.168.3.253/24
    Link4 = 192.168.1.253/24
    Link5 = 192.168.9.253/24

    Agora vamos criar 5 address list uma pra cada link

    ip/firewall/address list

    +/name:Link1 / 192.168.4.253/ok
    +/name:Link2 / 192.168.2.253/ok
    +/name:Link3 / 192.168.3.253/ok
    +/name:Link4 / 192.168.1.253/ok
    +/name:Link5 / 192.168.9.253/ok

    Continuando vamos criar todas as regras de mangle

    ip/firewall/mangle

    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link1#Action/Action: mark connection/New connection mark:Link1/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link1#Action/Action: mark routing/New routing mark:Link1/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link2#Action/Action: mark connection/New connection mark:Link2/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link2#Action/Action: mark routing/New routing mark:Link2/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link3#Action/Action: mark connection/New connection mark:Link3/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link3#Action/Action: mark routing/New routing mark:Link3/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link4#Action/Action: mark connection/New connection mark:Link4/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link4#Action/Action: mark routing/New routing mark:Link4/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link5#Action/Action: mark connection/New connection mark:Link5/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link5#Action/Action: mark routing/New routing mark:Link5/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=0/Action/Action: mark connection/New connection mark:Link1/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link1#Action/Action: add src to address list/address list:Link1/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link1#Action/Action: mark routing/New routing mark:Link1/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=1/Action/Action: mark connection/New connection mark:Link2/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link2#Action/Action: add src to address list/address list:Link2/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link2#Action/Action: mark routing/New routing mark:Link2/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=2/Action/Action: mark connection/New connection mark:Link3/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link3#Action/Action: add src to address list/address list:Link3/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link3#Action/Action: mark routing/New routing mark:Link3/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=3/Action/Action: mark connection/New connection mark:Link4/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link4#Action/Action: add src to address list/address list:Link4/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link4#Action/Action: mark routing/New routing mark:Link4/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=4/Action/Action: mark connection/New connection mark:Link5/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link5#Action/Action: add src to address list/address list:Link5/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link5#Action/Action: mark routing/New routing mark:Link5/passthrough=no
    ---------------------------------------------------------------------------------------------
    Bom ufa...finalizado as regras de mangle vamos pra regras de nat...

    General#chain:srcnat/Connection mark: Link1#Action/Action: src-nat/to addresses:192.168.4.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link2#Action/Action: src-nat/to addresses:192.168.2.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link3#Action/Action: src-nat/to addresses:192.168.3.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link4#Action/Action: src-nat/to addresses:192.168.1.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link5#Action/Action: src-nat/to addresses:192.168.9.253/to ports: 0-65535

    ----------------------------------------------------------------------------------------------
    Finalmente as regras de ip/route list...vamos lá

    Destination: 0.0.0.0/0
    gateway: 192.168.4.254
    Mark: Link1

    Destination: 0.0.0.0/0
    gateway: 192.168.2.254
    Mark: Link2

    Destination: 0.0.0.0/0
    gateway: 192.168.3.254
    Mark: Link3

    Destination: 0.0.0.0/0
    gateway: 192.168.1.254
    Mark: Link4

    Destination: 0.0.0.0/0
    gateway: 192.168.9.254
    Mark: Link5

    Este funciona como meu link principal
    Destination: 0.0.0.0/0
    gateway: 192.168.4.254

    Então pessoal é isto se esqueci de algo pode cobrar e espero que ajude vcs, por que batalhei bastante pra chegar a este cenário e quero deixar claro que não é o balanceamento difinitivo e tem seus pros e contras mas acredito que é um excelente começo pra quem quer balancear links sem ter problemas com bancos e msn, pra aqueles que utilizam hotspot como eu e utiliza o conectividade social tem outras regras complementares pra resolver o problema se alguem tiver duvida pode perguntar... e se ajudou alguem este post por favor agradeça... Pois é o meu salario rs rs rs rs rs....

    Abraços e até a proxima.

    Felicidades pra todos!!!!!!!!!!!!


    Boa noite amigo, desde ja agradeço pelas explições no post. Sou amador no MK, mas ja conseguir configurar meu Server MK, numa boa, até ja montei um PC-AP blz! É claro!! Tudo com ajuda dos caros amigos deste Forum espetacular!!
    Agora estou necessitando configurar um Load Balance, só que para apenas 2 links, ja bati cabeça, não só com o seu mas com outros post de caros participantes deste Fórum, como Pro2, CATV, HDFuture, Isacloko....

    Suas regras me chamaram atenção por ter algumas de minhas necessidades, citando as regras de "/ tool netwatch"

    Ficaria imensamente agradecido se vc pudesse me auxiliar a aplicar suas regras apenas para dois links, peço por obséquio não só a voce, mas como a todos que estiverem lendo esse post.

    Não compreendi as questões dos DNS`s das conexões.
    Achei muito interessante no Tutorial passo-a-passo do David - CATV as regras de Load Balance por TRATAMENTO DE PORTAS, link: Mikrotik - UnderLinux Wiki.
    Não conseguir colocar pra rodar.
    Última edição por rasonline; 07-10-2009 às 03:37.

  8. #108

    Smile Adapatação da regra para 2 links

    rasonline boa tarde

    Então se vc quiser utilizar este balance tranquilo, basta vc reduzir os contadores nth pra 2 links não tem segredo, observe que tem uma mudança da versão 2.9 para 3.x então sugiro que informe a sua versão pra poder te passar melhor, mas basicamente é assim se for 2.9 é estes ai mas com redução pra 2 links ex1,2,0 e 1,2,1) e se for 3.x ex: (2,1 e 2,2) o resto não tem segredo é so aplicar a logica tipo: 3 faixas de ip sendo 2 para os links, 2 address list e assim vai.
    Mas deixa falar hoje faço um balance por rotas estaticas que considero superior a este ai se quiser mais detalhes pode falar... estou fazendo um curso administrador redes linux e juntamente com meu serviço o tempo tá curto mas tamos ai...

    falou



  9. #109

    Padrão Implementando Load Balance

    Citação Postado originalmente por jeanfrank Ver Post
    rasonline boa tarde

    Então se vc quiser utilizar este balance tranquilo, basta vc reduzir os contadores nth pra 2 links não tem segredo, observe que tem uma mudança da versão 2.9 para 3.x então sugiro que informe a sua versão pra poder te passar melhor, mas basicamente é assim se for 2.9 é estes ai mas com redução pra 2 links ex1,2,0 e 1,2,1) e se for 3.x ex: (2,1 e 2,2) o resto não tem segredo é so aplicar a logica tipo: 3 faixas de ip sendo 2 para os links, 2 address list e assim vai.
    Mas deixa falar hoje faço um balance por rotas estaticas que considero superior a este ai se quiser mais detalhes pode falar... estou fazendo um curso administrador redes linux e juntamente com meu serviço o tempo tá curto mas tamos ai...

    falou
    Opa amigo, bom dia!!!

    Obrigado por sua atenção, a versão do meu MK é 2.9.27 (crackeada), uso para estudo.
    Achei muito interessante o código de LB da Wiki do CATV Brasil, aonde os serviços são distribuidos nos links, não conseguir fazer funcionar, vc poderia me dar uma ajuda? O balanciamento por rotas estáticas, que vc usa agora é no mesmo padrão ???

    Meus Links:

    LInk1: 128k - ISP Wieless
    Link2: 150k - StarOne - Via satélite.

  10. #110
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.925
    Posts de Blog
    1

    Padrão Re: Duvida sobre o balanceamento

    boa noite
    primeiramente parabens pelo post
    amigo não tenho muita esperiencia com balance em mikrotik uso mais em linux porem estou com problemas nos download eles cai e muito
    gostaria de saber se pelo mk vcs tiveram este problemas ????
    e para um balance de 4 link seria o caso eu de remover o link5 do seu post ????



  11. #111

    Padrão Re: Balanceamento 5 links Perfeito !!!!!

    qual versao funciona esse load... 2.9.27? essa e a q eu uso

  12. #112

    Padrão Re: Balanceamento 5 links Perfeito !!!!!

    Citação Postado originalmente por jeanfrank Ver Post
    Bom dia a todos

    Testei vários balanceamentos e tive muitos problemas com msn, bancos conectividade social etc
    Então pesquisando implementei um load balance por nth + permanent conection e ficou muito bom, aqui estou utilizando 5 links de velocidade iguais e mesma operadora e detalhe os links tem que estar bons pra dar tudo certo no meu caso tenho 2 links locais na sede da empresa e 3 links remotos vindo de outras partes da cidade não entrarei em detalhes esta parte somente o balanceamento mas se alguem tiver duvida é só postar e ajudamos no que puder. Segue:

    Comece criando faixas de ip pras interfaces dos links no server mk tenho 7 interfaces lan;
    Minha interface que distribui o sinal chama-se clientes.

    ip/address list

    Link1 = 192.168.4.253/24
    Link2 = 192.168.2.253/24
    Link3 = 192.168.3.253/24
    Link4 = 192.168.1.253/24
    Link5 = 192.168.9.253/24

    Agora vamos criar 5 address list uma pra cada link

    ip/firewall/address list

    +/name:Link1 / 192.168.4.253/ok
    +/name:Link2 / 192.168.2.253/ok
    +/name:Link3 / 192.168.3.253/ok
    +/name:Link4 / 192.168.1.253/ok
    +/name:Link5 / 192.168.9.253/ok

    Continuando vamos criar todas as regras de mangle

    ip/firewall/mangle

    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link1#Action/Action: mark connection/New connection mark:Link1/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link1#Action/Action: mark routing/New routing mark:Link1/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link2#Action/Action: mark connection/New connection mark:Link2/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link2#Action/Action: mark routing/New routing mark:Link2/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link3#Action/Action: mark connection/New connection mark:Link3/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link3#Action/Action: mark routing/New routing mark:Link3/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link4#Action/Action: mark connection/New connection mark:Link4/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link4#Action/Action: mark routing/New routing mark:Link4/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link5#Action/Action: mark connection/New connection mark:Link5/passthrough=yes
    General#chain-prerouting/In. interface: Clientes#Advanced/Src. address list: Link5#Action/Action: mark routing/New routing mark:Link5/passthrough=no

    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=0/Action/Action: mark connection/New connection mark:Link1/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link1#Action/Action: add src to address list/address list:Link1/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link1#Action/Action: mark routing/New routing mark:Link1/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=1/Action/Action: mark connection/New connection mark:Link2/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link2#Action/Action: add src to address list/address list:Link2/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link2#Action/Action: mark routing/New routing mark:Link2/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=2/Action/Action: mark connection/New connection mark:Link3/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link3#Action/Action: add src to address list/address list:Link3/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link3#Action/Action: mark routing/New routing mark:Link3/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=3/Action/Action: mark connection/New connection mark:Link4/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link4#Action/Action: add src to address list/address list:Link4/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link4#Action/Action: mark routing/New routing mark:Link4/passthrough=no
    ---------------------------------------------------------------------------------------------
    General#chain-prerouting/In. interface: Clientes/Connection State: new#Extra: nth every=4, Counter=4, Packet=4/Action/Action: mark connection/New connection mark:Link5/passthrough=yes
    General#chain-prerouting/In. interface: Clientes/Connect mark:Link5#Action/Action: add src to address list/address list:Link5/timeout: 1d 00:00:00
    General#chain-prerouting/In. interface: Clientes/Connection mark: Link5#Action/Action: mark routing/New routing mark:Link5/passthrough=no
    ---------------------------------------------------------------------------------------------
    Bom ufa...finalizado as regras de mangle vamos pra regras de nat...

    General#chain:srcnat/Connection mark: Link1#Action/Action: src-nat/to addresses:192.168.4.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link2#Action/Action: src-nat/to addresses:192.168.2.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link3#Action/Action: src-nat/to addresses:192.168.3.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link4#Action/Action: src-nat/to addresses:192.168.1.253/to ports: 0-65535

    General#chain:srcnat/Connection mark: Link5#Action/Action: src-nat/to addresses:192.168.9.253/to ports: 0-65535

    ----------------------------------------------------------------------------------------------
    Finalmente as regras de ip/route list...vamos lá

    Destination: 0.0.0.0/0
    gateway: 192.168.4.254
    Mark: Link1

    Destination: 0.0.0.0/0
    gateway: 192.168.2.254
    Mark: Link2

    Destination: 0.0.0.0/0
    gateway: 192.168.3.254
    Mark: Link3

    Destination: 0.0.0.0/0
    gateway: 192.168.1.254
    Mark: Link4

    Destination: 0.0.0.0/0
    gateway: 192.168.9.254
    Mark: Link5

    Este funciona como meu link principal
    Destination: 0.0.0.0/0
    gateway: 192.168.4.254

    Então pessoal é isto se esqueci de algo pode cobrar e espero que ajude vcs, por que batalhei bastante pra chegar a este cenário e quero deixar claro que não é o balanceamento difinitivo e tem seus pros e contras mas acredito que é um excelente começo pra quem quer balancear links sem ter problemas com bancos e msn, pra aqueles que utilizam hotspot como eu e utiliza o conectividade social tem outras regras complementares pra resolver o problema se alguem tiver duvida pode perguntar... e se ajudou alguem este post por favor agradeça... Pois é o meu salario rs rs rs rs rs....

    Abraços e até a proxima.

    Felicidades pra todos!!!!!!!!!!!!
    Olá Jean, desculpe tomar seu tempo, mas ainda sou muito leigo em MK estou precisando fazer um load entre duas adsl da mesma operadora, porém não sei como fasso, pra usar essas regras eu teria que deixar os modems em router?
    Será que teria como me explicar as modificações que tenho que fazer na sua regra para utilixar aqui?
    Meu MK é 2.9.27.

    Ip modens
    adsl 1 10.0.0.2
    adsl 2 10.2.2.2

    Desde ja agradeço e novemente desculpas por tomar seu tempo!



  13. #113

    Padrão Re: Balanceamento 5 links Perfeito !!!!!

    Valterterabyte,

    Boa noite
    Seguinte quando configurei este load balance estava já testando outras formas de balance, hoje eu indicaria pra vc por rotas estaticas ou pcc, no meu caso hoje não uso mais por que recentemente compras um boa quantidade de link dedicado full e como é um circuito unico de link não tenho necessidade de fazer balanceamento, mas voltando ao balance vc pode fazer um bem facil que é o por rotas estaticas, não dá problema nenhum com bancos ou msn é muito facil de configurar.
    Basicamente vc vai pegar determinadas rotas e fazer elas passarem por uma dsl e outras rotas passarem pelo outro link.
    Ex: em ip routes adicione uma nova rota assim

    address= 200.0.0.0/8 interface gateway = dsl1
    address= 201.0.0.0/8 interface gateway = dsl2
    address= 202.0.0.0/8 interface gateway= dsl1

    e assim por diante ou ideal dependendo da quantidade de clientes é começar com pelo menos 5 dsl ai vc vai dividir assim por exemplo:
    rotas default (0.0.0.0/0)= dsl1 * tudo que não for declarado passa por aqui
    rotas msn (64.0.0.0/8)= dsl2
    rotas orkut e youtube (74.0.0.0/8) = dsl3
    rotas altas partir de (202.0.0.0/8) = dsl4
    demais rotas dsl5

    Lembrando que isto é só uma ideia inicial, na verdade vc tem que fazer um estudo de consumo da sua rede pra determinar qual a melhor divisão para seus links , antes de desativar minhas dsl cheguei a ter 8 dsl com 123 rotas diferentes ficou muito bom, no meu caso deixei um link só pra orkut e outro só pra youtube, outro só msn e etc.
    Outro detalhe importante é configurar os modens em bridge por que ai eles não travam o mk disca a conexão fica show

    valeu duvidas estamos ai

    abraço

    jeanfrank

  14. #114

    Padrão Re: Balanceamento 5 links Perfeito !!!!!

    Funciona nesta tambem, mas indico a versão 4.6 muito boa

    valeu



  15. #115

    Padrão Re: Balanceamento 5 links Perfeito !!!!!

    Boa noite, bom post estarei testando nos meus servidores para ver se acabara com o problema que estou tendo com relação ao msn.
    Obrigado