+ Responder ao Tópico



  1. #13

    Padrão

    Citação Postado originalmente por cleciorodrigo Ver Post
    Amigo faça o seguinte, altere o MTU e o MRU teste com os seguintes valores:

    Max MTU 1480
    Max MRU 1492

    Abraços

    Clecio Rodrigo
    Pessoal muito obrigado pela atenção de todos, isso que diferencia o esse forum dos outros, mas vamus lá.

    Depois de muito pesquizar, lento o manual (infelismente so tem do 2.9), uso o MK 3.23 acabei encontranto um dados inportante.

    "max-mru (integer; default: 1480) - Maximum Receive Unit. The optimal value is the MTU of the interface the tunnel is working over decreased by 20 (so, for 1500-byte Ethernet link, set the MTU to 1480 to avoid fragmentation of packets)
    max-mtu (integer; default: 1480) - Maximum Transmission Unit. The optimal value is the MTU of the interface the tunnel is working over decreased by 20 (so, for 1500-byte Ethernet link, set the MTU to 1480 to avoid fragmentation of packets)"

    Ele pede para mudar o valor de 20 em 20 é isso mesmo?

    mais na frente em soluçoes de problemas tem,


    • I can get through the PPPoE link only small packets (eg. pings)
      You need to change mss of all the packets passing through the PPPoE link to the value of PPPoE link's MTU-40 at least on one of the peers. So for PPPoE link with MTU of 1480:
      [[email protected]] interface pppoe-server server> set 0 max-mtu=1440 max-mru=1440
      [[email protected]] interface pppoe-server server> print
      Flags: X - disabled
      0 service-name="mt" interface=wlan1 max-mtu=1440 max-mru=1440
      authentication=pap,chap,mschap1,mschap2 keepalive-timeout=10
      one-session-per-host=yes max-sessions=0 default-profile=default
      [[email protected]MT] interface pppoe-server server>

    no meu caso não passa nada.

    enthaum resolvi mudar os valor mtu e mru para 1440, aparentemente resolveu o problema so falta verificar em um cliente, que nao esta no momento.

    Quaquer coisa me avisem ai.

  2. #14
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    1440 é muito baixo. Provavelmente continuará a ter problemas. 1452 (MTU e MRU) é o ideal para quem usa links ruins, especialmente ADSL.



  3. #15

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    1440 é muito baixo. Provavelmente continuará a ter problemas. 1452 (MTU e MRU) é o ideal para quem usa links ruins, especialmente ADSL.
    .

    Marcelão, ja que tocou no assunto, explica ai a questão do MTU e MRU, aqui uso em 1488, mais tento faz por 1452, 1500, 1480. Fica super estavel... Mais mesmo assim, eu não sei o que isso faz, gostaria de uma opinão de quem entende do assunto ai. O que é o MTU e MRU, e como utilizar em diferentes ocasioes.

  4. #16

    Padrão

    recomendo criar uma regra de MSS GERAL pra todos... ocupa menos recurso do servidor... (recomendacoes no manual do mikrotik)



  5. #17

    Padrão

    Alexandre no caso o mikrotik cria duas regras pra cada conexão pppoe, cada uma com um valor diferente, como as do print do meu mikrotik

    D chain=forward in-interface=<pppoe-luciacristina> protocol=tcp tcp-flags=syn action=change-mss new-mss=1440
    D chain=forward out-interface=<pppoe-luciacristina> protocol=tcp tcp-flags=syn action=change-mss new-mss=1452

    Como vc faz ae, usa somente um valor???

    Abraços

    Clecio

    Citação Postado originalmente por alexandrecorrea Ver Post
    recomendo criar uma regra de MSS GERAL pra todos... ocupa menos recurso do servidor... (recomendacoes no manual do mikrotik)

  6. #18

    Padrão

    / ip firewall mangle
    add action=change-mss chain=forward comment="Regra GERAL - Altera MSS para 1440" disabled=no new-mss=1440 protocol=tcp tcp-flags=syn tcp-mss=1441-65535