+ Responder ao Tópico



  1. #1

    Padrão Squid paralelo pega somente IP do mk

    Pessoal

    tenho um squid paralelo (sem usar o proxy do mk) assim:

    link --> mk --> clientes
    ............|
    ............|
    ............V
    .........squid

    no mk so uso a regra de redir pro squid :

    ;;; PROXYCLIENTES
    chain=dstnat action=dst-nat to-addresses=172.16.2.2 to-ports=5128 src-address=192.168.0.0/16
    src-address-list=!hotspotgateway dst-address-list=!semproxy in-interface=Rede_Eth4_CLIENTES dst-port=80 protocol=tcp

    nos logs do meu squid, so aparece o ip do mk 172.16.2.1

    como faço pra logar os ips da rede 192.168.0.0/16???

    tem q habilitar algo na arp da interface???

    tks

  2. #2

    Padrão

    Citação Postado originalmente por ThunderBRZ Ver Post
    Pessoal

    tenho um squid paralelo (sem usar o proxy do mk) assim:

    link --> mk --> clientes
    ............|
    ............|
    ............V
    .........squid

    no mk so uso a regra de redir pro squid :

    ;;; PROXYCLIENTES
    chain=dstnat action=dst-nat to-addresses=172.16.2.2 to-ports=5128 src-address=192.168.0.0/16
    src-address-list=!hotspotgateway dst-address-list=!semproxy in-interface=Rede_Eth4_CLIENTES dst-port=80 protocol=tcp

    nos logs do meu squid, so aparece o ip do mk 172.16.2.1

    como faço pra logar os ips da rede 192.168.0.0/16???

    tem q habilitar algo na arp da interface???

    tks

    Olá amigo,


    para resolver isto é necessário que vc faça duas coisas:

    a primeira é criar um novo gateway no seu mk com a faixa de ip do seu squid e dá nome a essa rota;

    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark=nova comment="" disabled=no

    a segunda é em firewal mangle desviar as conexões da página as conexões a porta 80 para a rota específicada

    add chain=prerouting protocol=tcp dst-port=80 src-address-list=!desmarcar \
    action=mark-routing new-routing-mark=nova passthrough=no comment="regra do \


    a regra em vermelho poderá ser utilizada para excluir determinado endereço de entrada de forma que não passe pelo proxy e será util se o gateway do linux for seu MK, pois terá que deixar o ip de retorno do linux fora do proxy para não criar reduntância;


    Feito isso vc precisa entrar na maquina linux que está com o squid e configurar a rota de retorno para os ips dos cliente, por exemplo:

    imagine que vc criou a sua rede com esse ip que citei no exemplo de forma que o servidor linux se interaja com o mikrotik pelo ip 10.100.100.2 com gateway 10.100.100.1 e que a faixa do seu clientes é 192.168.0.0/24

    vc precisar criar no linux uma rota que diga que rota de saida para esses ips é através da interface 10.100.100.2 com gw 10.100.100.1, pois caso contrário o linux não saberá a quem devolver as requisicoes;

    para resolver o problema acima em azul de uma forma mais fácil vc pode fazer com que o gateway do linux também seja o MK de forma que todas as requisicoes seriam devolvidas para gateway



  3. #3

    Padrão

    amigo vc tambem precisa desativar o nat para a interface que esta o seu squid

  4. #4

    Padrão

    se vc adicionar uma rota.. e tirar a rede de destino do mascaramento...



  5. #5

    Padrão

    No seu squid.conf você tem que liberar a faixa de rede dos clientes também.
    Código :
    acl redeC src 192.168.0.0/24
    http_access allow redeC

  6. #6

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    se vc adicionar uma rota.. e tirar a rede de destino do mascaramento...
    Demorou mais a ficha caiu moleque!!!!!! uhauahuah consegui aqui



  7. #7

    Padrão

    Citação Postado originalmente por numlock Ver Post
    Demorou mais a ficha caiu moleque!!!!!! uhauahuah consegui aqui
    a minha ainda nao caiu... :P
    detalha ai pra mim plz!
    grato!

  8. #8

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    a minha ainda nao caiu... :P
    detalha ai pra mim plz!
    grato!
    Cabra na rede que eu consegui é assim link---ubuntu---mikrotik--clientes bastou eu remover as regras snat, masquerade e dstnat do mikrotik q esta em ap bridge e adicionar a rota no linux para a faixa de ip dos clientes (precisa de rota pra o linux saber de onde vem os clientes) do router mikrotik no meu caso. no caso mostrado no primeiro post ele marca as coneção na porta 80 e roteia os pacotes marcadas para o linux coloca ai a tua rede q eu tento fazer algo



  9. #9

    Padrão

    olha eu nao entendi ate agora

    minha rede ta assim :


    MK -->192.168.0.1/24 -> clientes
    ..|
    ..|
    ..v
    172.18.0.1
    ..|
    ..|
    ..|
    ..V
    UBUNTU SQUID
    172.18.0.2


    tem como alguem dar 1 ajuda, olha q eu nao sou mowbrow mas bixo num tendi nda

    eu uso um maskarade pro ubuntu e outro pros clientes

    e uma dstnat pra porta 80 na 3128 do squid

    so isso

    tks

  10. #10

    Padrão

    1)vc tera que remover a regra dstnat ela marca os pacote com o ip do mikrotik ai ja era
    2)para tranferir o trafego da porta 80 para squid vc marca os pacotes da porta 80 vindo dos clientes e
    3)adiciona uma rota no mikrotik para o linux para os os pacotes marcados veja Proxy Pararelo ao Mikrotik Através de Rota Estática
    4)terá ainda que criar uma rota no linux para que ele saiba que o router que envia pros clientes é o mikrotik pra tu acho q seria route add -net 192.168.0.0 netmask 255.255.255.0 gw 172.18.0.1 e 5)teria que adicionar uma regra no iptalbles do linux para transferir os dados da porta 80 para a sua porta do squid da uma olhada aqui Servidores Linux, Guia Prático: Configurando um proxy transparente



  11. #11

    Padrão

    Citação Postado originalmente por ThunderBRZ Ver Post
    olha eu nao entendi ate agora

    minha rede ta assim :


    MK -->192.168.0.1/24 -> clientes
    ..|
    ..|
    ..v
    172.18.0.1
    ..|
    ..|
    ..|
    ..V
    UBUNTU SQUID
    172.18.0.2


    tem como alguem dar 1 ajuda, olha q eu nao sou mowbrow mas bixo num tendi nda

    eu uso um maskarade pro ubuntu e outro pros clientes

    e uma dstnat pra porta 80 na 3128 do squid

    so isso

    tks
    iae broder, meu esquema eh igual ao seu ai.

    / ip address
    add address=172.16.6.1/30 network=172.16.6.0 broadcast=172.16.6.3 \
    interface=proxy comment="proxy" disabled=no

    / ip firewall nat
    add chain=srcnat out-interface=LINK src-address=172.16.6.2 action=masquerade comment="NAT proxy server" disabled=no
    add chain=dstnat dst-address=!172.16.6.2 protocol=tcp dst-port=80 src-address-list=clientes dst-address-list=!semproxy action=dst-nat to-addresses=172.16.6.2 to-ports=3128 \
    comment="dst_proxy" disabled=no
    add chain=srcnat src-address-list=clientes action=masquerade comment="NAT" disabled=no


    uso squid2.7 com zph e thunder cache

    tentei oq o amigo disse mais nao tive sucecsso : /
    tentei outro esquema de um outro post de outro amigo, e nada,,
    ajuda nois ae galera, nois é noob! =]
    grato!

  12. #12



  13. #13

    Padrão

    Citação Postado originalmente por numlock Ver Post
    1)vc tera que remover a regra dstnat ela marca os pacote com o ip do mikrotik ai ja era
    2)para tranferir o trafego da porta 80 para squid vc marca os pacotes da porta 80 vindo dos clientes e
    3)adiciona uma rota no mikrotik para o linux para os os pacotes marcados veja Proxy Pararelo ao Mikrotik Através de Rota Estática
    4)terá ainda que criar uma rota no linux para que ele saiba que o router que envia pros clientes é o mikrotik pra tu acho q seria route add -net 192.168.0.0 netmask 255.255.255.0 gw 172.18.0.1 e 5)teria que adicionar uma regra no iptalbles do linux para transferir os dados da porta 80 para a sua porta do squid da uma olhada aqui Servidores Linux, Guia Prático: Configurando um proxy transparente

    Mandou bem, é disso que eu falo, nada de colar regrinhas, isso é ensinar a pensar, parabéns numlock.

  14. #14

    Padrão

    se vc adicionar uma rota.. e tirar a rede de destino do mascaramento... (2)